User Guide Cancel

Recover InDesign documents

  1. InDesign User Guide
  2. Get to know InDesign
    1. Introduction to InDesign
      1. What's New in InDesign
      2. System requirements
      3. Common questions
      4. Use Creative Cloud libraries
    2. Workspace
      1. Workspace basics
      2. Toolbox
      3. Set preferences
      4. Touch workspace
      5. Default keyboard shortcuts
      6. Document recovery and undo
      7. Capture extension
  3. Create and lay out documents
    1. Documents and pages
      1. Create documents
      2. Work with parent pages
      3. Work with document pages
      4. Set page size, margins, and bleed
      5. Work with files and templates
      6. Create book files
      7. Add basic page numbering
      8. Number pages, chapters, and sections
      9. Convert QuarkXPress and PageMaker documents
      10. Share content
      11. Understand a basic managed-file workflow
      12. Save documents
    2. Grids
      1. Grids
      2. Format grids
    3. Layout aids
      1. Rulers
  4. Add content
    1. Text
      1. Add text to frames
      2. Threading text
      3. Arabic and Hebrew features in InDesign
      4. Create type on a path
      5. Bullets and numbering
      6. Glyphs and special characters
      7. Text composition
      8. Text variables
      9. Generate QR codes
      10. Edit text
      11. Align text
      12. Wrap text around objects
      13. Anchored objects
      14. Linked content
      15. Format paragraphs
      16. Format characters
      17. Find/Change
      18. Spell check and language dictionaries
    2. Typography
      1. Using fonts in InDesign
      2. Kerning and tracking
    3. Format text
      1. Format text
      2. Work with Style Packs
      3. Tabs and indents
    4. Review text
      1. Track and review changes
      2. Add editorial notes in InDesign
      3. Import PDF comments
    5. Add references
      1. Create a table of contents
      2. Footnotes
      3. Create an index
      4. Endnotes
      5. Captions
    6. Styles
      1. Paragraph and character styles
      2. Map, export, and manage styles
      3. Object styles
      4. Drop caps and nested styles
      5. Work with styles
      6. Leading
    7. Tables
      1. Format tables
      2. Create tables
      3. Table and Cell styles
      4. Select and edit tables
      5. Table strokes and fills
    8. Interactivity
      1. Hyperlinks
      2. Dynamic PDF documents
      3. Bookmarks
      4. Buttons
      5. Forms
      6. Animation
      7. Cross-references
      8. Structure PDFs
      9. Page transitions
      10. Movies and sounds
      11. Forms
    9. Graphics
      1. Understand paths and shapes
      2. Draw with the Pencil tool
      3. Draw with the Pen tool
      4. Apply line (stroke) settings 
      5. Compound paths and shapes
      6. Edit paths
      7. Clipping paths
      8. Change corner appearance
      9. Align and distribute objects
      10. Linked and embedded graphics
      11. Integrate AEM assets
    10. Color and transparency
      1. Apply color
      2. Use colors from imported graphics
      3. Work with swatches
      4. Mix inks
      5. Tints
      6. Undertand spot and process colors
      7. Blend colors
      8. Gradients
      9. Flatten transparent artwork
      10. Add transparency effects
  5. Share
    1. Work with InDesign Cloud documents
    2. InDesign cloud documents | Common questions
    3. Share and collaborate        
    4. Share for Review
    5. Review a shared InDesign document
    6. Manage feedback 
  6. Publish
    1. Place, export, and publish
      1. Publish Online
      2. Copy, insert graphics
      3. Export content for EPUB
      4. Adobe PDF options
      5. Export content to HTML
      6. Export to Adobe PDF
      7. Export to JPEG format
      8. Export HTML
      9. DPS and AEM Mobile overview
      10. Supported File Formats
    2. Printing
      1. Print booklets
      2. Printer's marks and bleeds
      3. Print documents
      4. Inks, separation, and screen frequency
      5. Overprinting
      6. Create PostScript and EPS files
      7. Preflight files before handoff
      8. Print thumbnails and oversized documents
      9. Prepare PDFs for service providers
      10. Prepare to print separations
  7. Extend InDesign
    1. Automation
      1. Data merge
      2. Plug-ins
      3. Capture extension in InDesign
      4. Scripting
  8. Troubleshooting
    1. Fixed issues
    2. Crash on launch
    3. Preference folder read-only issue
    4. Troubleshoot file issues
    5. Unable to export PDF
    6. InDesign document recovery

Learn how to recover documents if InDesign shuts down unexpectedly.

If InDesign shuts down unexpectedly due to system errors, power outages, or other problems, then any unsaved changes made to InDesign documents you were working on may be lost. The InDesign automatic recovery feature can help you retrieve these documents.  

While you make changes to an InDesign document, InDesign performs a mini-save of the changes once every minute. InDesign stores these changes in temporary files in the InDesign Recovery folder, adds the changes to the document, and then deletes the temporary files every time you choose File > Save. If InDesign shuts down unexpectedly, InDesign attempts to use these temporary files to recover unsaved changes to the document.

InDesign Recovery folder contents

Each user account has a separate InDesign Recovery folder. If InDesign can't locate the InDesign Recovery folder during startup, it re-creates the folder.

  •  dbt [random alphanumeric character]: A temporary file with mini-saved information for every open InDesign document. The names of these temporary files always begin with "dbt" and, on Windows, end with "tmp."
  •  Default settings: A temporary file that stores default settings. It is the first temp file listed when you view the contents of the InDesign Recovery folder by name.
  • RecoveryData: An index for all open InDesign documents and crashed documents, including their complete path names. The list of open documents contains paths not aliases, which means InDesign is not able to recover files you move or rename after a crash.
  • ProtectiveShutdownLog: A log file generated if InDesign crashes due to an access violation. This log file is helpful for identifying a specific plug-in that may have caused the error.

 If you take the document in need of recovery to another system and open it there, InDesign will be unable to search the RecoveryData file and you'll lose the opportunity to recover data that may have been stored before the crash. Therefore, try to recover documents immediately after a crash by starting InDesign and saving any recovered documents.

InDesign Recovery folder locations

  • macOS: Users/[User Name]/Library/Cache/Adobe InDesign/Version[#.0]/InDesign Recovery
  • Windows: C:\Users\[User Name]\AppData\Local\Adobe\InDesign\Version [#].0\en_US\Caches\InDesign Recovery

 The information contained in the above folders is in an encrypted format. You can't use it to recover the document using a third-party tool or force InDesign to recover the data.

Recover an InDesign document

  1. Restart InDesign to begin the automatic document recovery process.

    InDesign checks the InDesign Recovery folder for information on documents that were open when it shut down, and then attempts to open these documents and incorporate any mini-saved data into them.

  2. Save the recovered document, or revert to the last saved version of the document.

    If InDesign successfully opens a document and incorporates mini-saved data into the document, the filename appears as follows: "[My Original Filename] Recovered".

    • To save the recovered document, choose File > Save or File > Save As. When prompted, click Yes to overwrite the original file and incorporate the recovered, previously unsaved information.
    • Alternatively, choose File > Revert to revert to the last saved version of the document. This version won't include the unsaved changes you made to the document before InDesign quit unexpectedly.

    If a recovered document is too damaged to open, InDesign could quit again or display an error message.

  3. (Optional) Check the ProtectiveShutdownLog file to determine if a third-party plug-in caused InDesign to crash.

    Open the file in a text editor to view the time, date, error, and plug-ins that were loaded in InDesign when the crash occurred. See Troubleshoot InDesign third-party plug-ins.

Messages during automatic recovery

While InDesign tries to recover your document, you might see one of the messages in the table below.

Some messages ask you how to proceed. Under some circumstances, you can click the following buttons:

  • Click Yes to continue the recovery of the remaining documents but leave the document listed in the alert on the list of documents in the RecoveryData file. The next time you start InDesign, it will try to recover this document again.
  • Click No to continue the recovery of any remaining documents but remove the document listed in the alert from the list of documents in the RecoveryData file. InDesign won't try to recover this file again.
  • Click Cancel to stop the recovery process for all documents. The next time you start InDesign, it will try to recover all documents again.
  • Click Save As to save the repaired document as a new document.
  • Click Continue to work on the new untitled repaired document.

Message

What does it mean?

Do you want to start automatic recovery?

At least one of the documents requiring recovery is damaged (even though the message doesn't mention damage). See Troubleshoot file issues.

[File name] could not be found. Do you want to postpone its recovery?

InDesign couldn't locate the document because it has been deleted, moved, or renamed. Or, the volume (server) on which the document is located may be currently unavailable.

[File name] could not be recovered because it had been changed.

The document has already been recovered and saved over a network, so the document's contents no longer match the local file containing the mini-saved information. To locate the file, choose File > Open.  

Cannot open 'unknown document.' Database error information not available.

The document's temporary file is damaged or can't be found. You can still open the last saved version of the document.

[File name] is damaged beyond any possibility of recovery.

The document is unrecoverable because it is damaged. See Troubleshoot file issues.

[File name] may be damaged. Do you want to open it anyway?

The document contains inconsistencies that could cause InDesign to crash. If you open the document, copy and paste its contents into a new document. See Troubleshoot file issues.

InDesign detected that the file [File name] is damaged. We have repaired the file, but some content may be missing.

(Recommended) Click "Save As" to save the repaired file with a new name.

The original file was corrupt and a new file has been created with the recovered content. You can save the file or continue to work on the new untitled document.

InDesign detected that the file [File name] is damaged.

We have repaired the file, but some content may be missing. Your original file is intact and the repaired file is a duplicate of it

The original file was corrupt and a new file has been created with the recovered content.  


Related resources

Talk to us

We would love to hear from you. Share your thoughts with the Adobe InDesign Community

Adobe logo

Sign in to your account