This document describes how to install and use the supplemental OpenEXR Alpha plug-in.

The supplemental OpenEXR Alpha plug-in provides an alternate method for handling ‘A’ channel data when opening an OpenEXR file. Instead of directly converting ‘A’ channel data to transparency (as the old OpenEXR plug-in does), OpenEXR Alpha opens ‘A’ channel data as an alpha channel.


Photoshop CS2 did not generally support transparency in 32-bit mode. In that version, a workaround was implemented that allowed you to read in transparency data to an alpha channel. In Photoshop CS3, transparency support was implemented for 32-bit mode, ensuring compliance with the OpenEXR specification. Transparency was therefore no longer read into an alpha channel during straight channel compositing.

Before you begin

Installing the OpenEXR Alpha plug-in requires local administration rights. If you use Mac OS, Windows Vista, or Windows 7, the operating system prompts you to enter the name and password of an administrator user account. If you use Windows XP, log in to your computer using a local administrator account before you begin.

Windows users: Some of the steps in this TechNote list files by their full filename, which includes filename extensions (for example, OpenEXR Alpha.8bi). On Windows, filename extensions for known file types are not visible by default. To make filename extensions visible, do the following:

  1. In Windows Explorer, choose Tools > Folder Options (Windows XP) or Organize > Folder And Search Options (Windows 7 and Vista).
  2. Select the View tab near the top of the Folder Options window.
  3. In the Advanced Settings area of the View tab, deselect Hide Extensions For Known File Types.
  4. Click OK.

Windows users: Some of the steps in this document require that you determine whether you are using a 32-bit or 64-bit edition of Windows. To determine which system type you have, see Determine whether your computer is running a 32-bit or a 64-bit edition of Windows.


On Windows, the OpenEXR Alpha plug-in is not compatible with versions of Photoshop earlier than Photoshop CS5. It does not load in Photoshop CS3 or CS4.

On Mac OS, the OpenEXR Alpha plug-in does not load on PPC machines.

Install the OpenEXR Alpha plug-in for Photoshop CS5 on Mac or Windows (download update from the Adobe website)

To install the OpenEXR Alpha plug-in by downloading an update from the Adobe website:

  1. Download the zipped plug-in:

  2. Exit Photoshop CS5.
  3. Unzip the downloaded file.
  4. Drag the plug-in to the Photoshop Plug-ins folder.
    • Windows 32-bit: Drag OpenEXR Alpha.8bi from the Win32 folder to /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats folder.
    • Windows 64-bit/Photoshop 64-bit: Drag OpenEXR Alpha.8bi from the Win64 folder to /Program Files/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats folder.
    • Windows 64-bit/Photoshop 32-bit: Drag OpenEXR Alpha.8bi from the Win32 folder to /Program Files (x86)/Adobe/Adobe Photoshop CS5/Plug-ins/File Formats folder.
    • Mac OS: Drag OpenEXR.plugin to /Applications/Adobe Photoshop CS5/Plug-ins/File Formats folder.
  5. Launch Photoshop CS5.

Use the OpenEXR Alpha plug-in

To open an EXR file:

  1. Launch Photoshop CS5.
  2. Choose File > Open.
  3. Browse to the EXR file you want to open. In the file formats list, choose OpenEXR Alpha. Photoshop treats the ‘A’ channel data as an alpha channel instead of transparency.

To export an EXR file:

  1. Choose File > Save As.
  2. In the file formats list, choose OpenEXR Alpha.

  3. Select the Save: Alpha Channels option. This setting preserves the alpha channel data.

Note: Transparency added after the file was opened is flattened.

Note: Even after installing the OpenEXR Alpha plug-in, you still have the option to choose the old OpenEXR in the file formats list. This plug-in still handles data in the ‘A’ channel as transparency. This behavior has been the default in Photoshop since Photoshop CS3 (Version 10.0).

Additional notes

Some other noteworthy behavior when using the supplemental plug-in:

  • Premultiplied compositing is not supported.
  • If you double-click a file to open it, Photoshop CS5 always uses OpenEXR Alpha rather than OpenEXR.
  • If you open a file with two or more alpha channels, OpenEXR Alpha does not preserve any of the alpha channels. They are entirely dropped.
  • (Mac OS): In the Save dialog, OpenEXR Alpha is the top item. It does not display alphabetically next to Open EXR.
  • (Windows): To get the old OpenEXR behavior, choose File > Open As, then select OpenEXR.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy