Note:

In Photoshop CS6, 3D functionality was part of Photoshop Extended. All features in Photoshop Extended are part of Photoshop CC. Photoshop CC does not have a separate Extended offering.

Beginning with Photoshop CS6, Photoshop has a more intuitive 3D workflow, with consolidated tools and contextual on-image controls. For a quick description of these new features, see What's New in Photoshop CC | 3D imaging and What's New in CS6.

3D features | Creative Cloud-only

For users who are new to Creative Cloud, the following features have been updated and added.

  • 32-bit color pickers can now be used when specifying colors for materials, lines, surfaces, or lights in the Properties panel.
  • Normal maps can be generated from Diffuse maps. In the 3D panel, select the 3D object you want to affect and then, click the Filter By Materials icon in the top area of the panel. Then, in the Properties panel, click the folder icon next to Normal: and choose Generate Normals From Diffuse from the menu.
  • If you pause a rendering and make one or more selections, resuming the rendering will be applied to the selections. Resuming a rendering also works even after saving your document as a PSD.
  • Cross Section now works with reflective surfaces and other surface styles such as Constant, Cartoon, and Sketch.
  • By default, an Image-Based Light (IBL) is added your 3D environment. Adobe offers other IBLs for download from Adobe® Photoshop® Extended 3D Content.
  • You can change the Ray Trace rendering tile size from its default, which is set based on how many cores are in your computer. Choose Edit > Preferences > 3D (Windows) or Photoshop > Preferences > 3D (Mac OS) and then, choose a size from the Render Tile Size menu in the Ray Tracer section of the Preferences dialog box.
  • During rendering, both the time remaining and percentage rendered are displayed in the Status Bar at the bottom of the document window.
  • Photoshop now offers better OpenGL shadows. To specify the shadow quality that works best with your computer, choose Edit > Preferences > 3D (Windows) or Photoshop > Preferences > 3D (Mac OS). Then, choose an option from the Shadow Quality menu in the Interactive Rendering section of the Preferences dialog box.

Click the following link to view a video of Photoshop Senior Product Manager, Zorana Gee, presenting the new 3D features in the Creative Cloud version of Photoshop.

Note:

A minimum of 512 MB of VRAM is required for the 3D features in the Creative Cloud version of Photoshop.

3D panel targets scene elements

In the streamlined 3D panel, select specific elements you want to edit:

  1. At the top of the 3D panel, select Scene , Meshes , Materials , or Lights
  2. Select an individual element (such as Current View in the Scene section). Or select multiple elements to apply uniform properties.
  3. Adjust settings in the Properties panel, or drag in the document window. (If you drag a specific object or light, the 3D panel then selects that element.)

Note: To add new lights, click the document icon at the bottom of the Scene and Lights sections. Or click the panel menu to save and load groups of lights as a preset.

Properties panel provides contextual settings

After you select individual elements in the 3D panel or document window, the Properties panel displays related settings. When you finish adjusting, click the Render icon at the bottom of the panel.

Note: Click the Coordinates icon at the top of the panel to enter precise numerical locations for objects, cameras, and lights. To quickly cycle between properties and coordinates, press the V key.

Environment settings include global ambient and image-based lights, and ground plane shadows and reflections.

Scene settings include render presets such as Bounding Box and Wireframe, and custom render options for cross-sections, surfaces, and points.

Camera settings include field of view (FOV), depth of field, and stereo options for anaglyph, lenticular, or side-by-side viewing.

Mesh settings let you catch and cast shadows, adjust 3D extrusions, and edit source text and paths.


Note: To hide an object, but retain its shadows for compositing with 2D images, select Invisible.

Materials settings include texture and bump map settings such as the new Roughness option.

Light settings let you choose from infinite, spot, and point types, and adjust color, intensity, and shadows.

Move tool consolidates object and camera adjustments

The Move tool lets you adjust the placement of objects and camera:

  • In the options bar, choose between Rotate , Roll , Drag , Slide , and Scale modes.
  • To quickly cycle through these modes, press Shift+V.
  • To quickly switch between camera and Environment controls, click away from 3D objects.

Note: In the document window, a gold document border indicates camera control, a blue border Environment control, a green border Scene control, and no border Mesh control.

On-image controls directly edit elements

With on-image controls, you can often edit an entire 3D scene without accessing any workspace panels. To maximize your view, press the F key to cycle between full screen and standard screen modes.

In the document window, you can directly interact with the following elements:

Scene, Mesh, and Light settings  To quickly access Scene properties in the document window, right-click the canvas away from 3D objects. Or right-click meshes and lights to access their properties.

Shadows Shift-click them, and then drag to reposition the related light.

Object bounding box controls Click an object once to activate, and then position the mouse pointer over various planes; when a plane is shaded yellow, drag to adjust the object along that axis. Or drag corners to rotate on the X or Y axis.

Create and adjust 3D extrusions

3D extrusion lets you extend type, selections, closed paths, shapes, and image layers into three dimensions.

  1. Select a path, shape layer, type layer, image layer, or specific pixel areas.
  2. Choose 3D > New 3D Extrusion From Selected Path, Layer, or Current Selection.
  3. Note: To quickly extrude type while editing with the Type tool, click the 3D button in the options bar.

  4. With the mesh selected in the 3D panel, select the Deform or Cap icons at the top of the Properties panel.
  5. Edit numerical settings in the Properties panel, or drag the interactive extrusion controls in the document window.

To edit the original path, type, or image layer, select the related mesh in the 3D panel, and click Edit Source in the Properties panel.

Define ground planes for imported objects

Quickly create perspective planes with the Vanishing Point filter, and snap an imported object to them.

  1. Select an image layer, and choose Filter > Vanishing Point.
  2. Using the Create Plane and Edit Plane tools, create a grid to define a ground plane. Then click OK.
  3. Choose 3D > New 3D Layer from File.

The imported object is placed on the ground plane you defined.

Make paths from 3D layers


Choose 3D > Make Work Path from 3D Layer to convert the current rendering into a Work Path. This command traces a path over the alpha channel of the layer.

If you render in wireframe mode and adjust the crease threshold value to eliminate some unnecessary lines, you can create a rendering that looks hand drawn when stroked with a Photoshop brush.

Merge multiple 3D layers

To improve performance and interact shadows and reflections for multiple objects, merge as many 3D layers as you need.

Before merging 3D layers, use the Orthographic camera view to position meshes with maximum precision:

  1. At the top of the 3D panel, click the Scene icon , and select Current View.
  2. In the Properties panel, select Orthographic.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy