Video tutorial: Linked Smart Objects

Video tutorial: Linked Smart Objects
Infinite Skills

Understand Smart Objects

Smart Objects are layers that contain image data from raster or vector images, such as Photoshop or Illustrator files. Smart Objects preserve an image’s source content with all its original characteristics, enabling you to perform nondestructive editing to the layer.

In Photoshop CC and CS6, you can embed the contents of an image into a Photoshop document. In Photoshop CC, you can also create Linked Smart Objects whose contents are referenced from external image files. The contents of a Linked Smart Object are updated when its source image file changes.

Linked Smart Objects are distinct from duplicated instances of a Smart Object within a Photoshop document. With Linked Smart Objects, you can use a shared source file across multiple Photoshop documents which is a familiar and welcome concept for web designers.

Smart Object benefits

With Smart Objects, you can:

  • Perform nondestructive transforms. You can scale, rotate, skew, distort, perspective transform, or warp a layer without losing original image data or quality because the transforms don’t affect the original data.

  • Work with vector data, such as vector artwork from Illustrator, that otherwise would be rasterized in Photoshop.

  • Perform nondestructive filtering. You can edit filters applied to Smart Objects at any time.

  • Edit one Smart Object and automatically update all its linked instances.

  • Apply a layer mask that’s either linked or unlinked to the Smart Object layer.

  • Try various designs with low-resolution placeholder images that you later replace with final versions.

You can’t perform operations that alter pixel data—such as painting, dodging, burning, or cloning—directly to a Smart Object layer, unless it is first converted into a regular layer, which will be rasterized. To perform operations that alter pixel data, you can edit the contents of a Smart Object, clone a new layer above the Smart Object layer, edit duplicates of the Smart Object, or create a new layer.

Note:

When you transform a Smart Object that has a Smart Filter applied to it, Photoshop turns off filter effects while the transform is being performed. Filter effects are applied again after the transform is complete. See Apply Smart Filters.

Photoshop smart object benefits
Regular layer and a Smart Object in the Layers panel. The icon in the lower-right corner of the thumbnail indicates a Smart Object.

Photoshop Smart Object in the Layers panel
(Photoshop CC) A linked Smart Object in the Layers panel

Create embedded Smart Objects

You can create embedded Smart Objects using several methods: by using the Open As Smart Object command; placing a file (CS6) or placing a file as embedded (CC, CS6), pasting data from Illustrator; or converting one or more Photoshop layers to Smart Objects.

  • Do any of the following:
    • (CC) Choose File > Place Embedded to import files as Smart Objects into an open Photoshop document.
    • Choose File > Open As Smart Object, select a file, and click Open.
    • (CS6) Choose File> Place to import files as Smart Objects into an open Photoshop document.

    Note:

    Although you can place JPEG files, it's better to place PSD, TIFF, or PSB files because you can add layers, modify pixels, and resave the file without loss. (Saving a modified JPEG file requires you to flatten new layers and recompress the image, causing image quality degradation).

    • Choose Layer > Smart Object > Convert to Smart Object to convert a selected layer into a Smart Object.
    • In Bridge, choose File > Place > In Photoshop to import a file as a Smart Object into an open Photoshop document.

    Note:

    An easy way to work with camera raw files is to open them as Smart Objects. You can double-click the Smart Object layer containing the raw file at any time to adjust the Camera Raw settings.

    See the video Open an image as a Smart Object to learn how.

    • Select one or more layers and choose Layer > Smart Objects > Convert To Smart Object. The layers are bundled into one Smart Object.

    • Drag PDF or Adobe Illustrator layers or objects into a Photoshop document.

    • Paste artwork from Illustrator into a Photoshop document, and choose Smart Object in the Paste dialog box. For the greatest flexibility, enable both PDF and AICB (No Transparency Support) in the File Handling & Clipboard section of the Preferences dialog box in Adobe Illustrator.

Create Linked Smart Objects | Photoshop CC

Note:

The Linked Smart Object feature is available in Photoshop versions 14.2 (Photoshop CC | January 2014) and later.

In Photoshop CC, you can create Linked Smart Objects. The contents of Linked Smart Objects are updated when the source image file changes. Linked Smart Objects are particularly useful for teams or in cases where assets must be reused across designs.

Follow these steps to create a Linked Smart Object:

  1. Choose File > Place Linked.
  2. Select an appropriate file and click Place.

The Linked Smart Object is created and is displayed in the Layers panel with a link icon ().

Note:

You can also create a Linked Smart Object in an open document by dragging and dropping the appropriate file while keeping the following key pressed:

(Windows) Alt key
(Mac OS) Option key

To change this default behavior, turn off Preferences > General > Always Create Smart Objects While Placing.

File size savings using Linked Smart Objects

Since Linked Smart Objects maintain a dependency on an external file rather than embedding a source file within the containing document, they often result in significantly smaller file sizes. While Linked Smart Objects do not store the original file in the containing document, they still store a flattened and scaled version of the image data from the original file. In some cases, the size of this data may be much larger than the size of the original file, making the file size savings seem negligible.

Update Linked Smart Objects

If an external source file changes while a Photoshop document referencing it is open, the relevant Linked Smart Object is automatically updated. However, when you open a Photoshop document containing out-of-synch Linked Smart Objects, you can update the Smart Objects:

  • Right-click a Linked Smart Object layer and choose Update Modified Content.
  • Choose Layer > Smart Objects > Update Modified Content.

Linked Smart Objects whose source images have changed are visually highlighted in the Layers panel:

Photoshop Out-of-sync Linked Smart Objects highlighted in the Layers panel
Out-of-sync Linked Smart Objects are highlighted in the Layers panel.

Note:

You can update all linked Smart Objects in the current Photoshop document by choosing Layer > Smart Objects > Update All Modified Content.

Photoshop Linked Smart Objects with missing external source files highlighted in the Layers panel
Linked Smart Objects with missing external source files are highlighted in the Layers panel.

Note:

While detecting changes to Linked Smart Objects or updating a Linked Smart Object, Photoshop looks only at the immediate linked file. Links nested inside Smart Objects are not updated.

To resolve a Linked Smart Object with a missing external source, follow these steps:

  1. Right-click the Linked Smart Object layer icon and choose Resolve Broken Link.
  2. Navigate to the new location of the missing object.
  3. Click Place.

View Linked Smart Object properties

With a Linked Smart Object layer selected in the Layers panel, choose Window > Properties.

The following properties are displayed:

  • The path of the external source file for the Linked Smart Object
  • The Linked Smart Object size and positional coordinates (X, Y)

You can perform the following actions directly from within the Properties panel:

  • Edit the contents of the external image file. If necessary, Photoshop opens an external application that can handle the source image file. For example, Photoshop opens Adobe Illustrator if the external source image is a .ai file.
  • Embed the Linked Smart Object within the current document.

Embed Linked Smart Objects

Do one of the following:

  • Right-click a Linked Smart Object layer in the Layers panel and choose Embed Linked.
  • Choose Layer > Smart Objects > Embed Linked.
  • In the Properties panel, click Embed.

Note:

Choose Layer > Smart Objects > Embed All Linked to embed all Linked Smart Objects in the Photoshop document.

Package Linked Smart Objects

You can package the Linked Smart Objects in a Photoshop document, such that their source files are saved to a folder on your computer. A copy of the Photoshop document is saved along with the source files in the folder.

  1. Choose File > Package.
  2. Select a location where you want to place the source files and a copy of the Photoshop document.

Any audio or video Linked Smart Objects in the document are packaged as well.

Note:

You must save a file before packaging the Linked Smart Objects that it contains.

How Photoshop locates linked files

Photoshop always looks for linked files in the last-known relative location. If the linked file is not found in that location, Photoshop looks for it:

  • In the last-known absolute location
  • Using a saved alias (Mac OS only)
  • In the same folder as the containing document

This behavior allows you to move, copy, and share project folders and files with minimal risk of encountering broken links.

Note:

The Resolve Missing Assets dialog always displays the last-known absolute path of missing source files.

Convert an embedded Smart Object to a Linked Smart Object

You can convert an embedded Smart Object to a Linked Smart Object. Transforms, filters, and other effects applied to the embedded Smart Object are preserved when it is converted.

Do the following:

  1. Select an embedded Smart Object layer in the Photoshop document.
  2. Choose Layer > Smart Object > Convert To Linked.
  3. Select the location on your computer where you want to save the source file. Enter a name for the file, including a supported extension. For example, link_file.jpg.

Filter the Layers panel by Smart Objects | Photoshop CC

  1. In the Layers panel, select Smart Object from the filtering pop-up menu.
Photoshop Filter layers by Smart Objects
Filter layers by Smart Objects

  1. Click one of the following icons:
  •     Filter for up-to-date Linked Smart Objects
  •     Filter for out-of-synch Linked Smart Objects
  •     Filter for missing Linked Smart Objects
  •     Filter for embedded Smart Objects

Note:

You can use the toggle switch () to turn off layer filtering.

Duplicate an embedded Smart Object

  • In the Layers panel, select a Smart Object layer, and do one of the following:
    • To create a duplicate Smart Object that is linked to the original, choose Layer > New > Layer Via Copy, or drag the Smart Object layer to the Create A New Layer icon at the bottom of the Layers panel. Edits you make to the original affect the copy and vice versa.

    • To create a duplicate Smart Object that isn’t linked to the original, choose Layer > Smart Objects > New Smart Object Via Copy. Edits you make to the original don’t affect the copy.

    A new Smart Object appears in the Layers panel with the same name as the original and “copy” as a suffix.

Edit the contents of a Smart Object

When you edit a Smart Object, the source content is opened in either Photoshop (if the content is raster data or a camera raw file) or the application that handles the placed format by default (for example, Adobe Illustrator or Adobe Acrobat). When you save changes to the source content, the edits appear in all linked instances of the Smart Object in the Photoshop document.

  1. Select the Smart Object from the Layers panel, and do one of the following:
    • Choose Layer > Smart Objects > Edit Contents.
    • Double-click the Smart Objects thumbnail in the Layers panel.
    • In the Properties panel, click Edit Contents.
  2. Click OK to close the dialog box.
  3. Make edits to the source content file, then choose File > Save.

    Photoshop updates the Smart Object to reflect the changes you made. (If you don’t see the changes, make the Photoshop document containing the Smart Object active.)

Replace the contents of a Smart Object

You can replace the image data in one Smart Object or multiple linked instances. This feature lets you quickly update a visual design, or replace low-resolution placeholder images with final versions.

Note:

When you replace a Smart Object, any scaling, warping, or effects that you applied to the first Smart Object are maintained.

  1. Select the Smart Object, and choose Layer > Smart Objects > Replace Contents.
  2. Navigate to the file you want to use, and click Place.
  3. Click OK.

    The new content is placed in the Smart Object.

Convert an embedded or linked Smart Object to a layer

Converting a Smart Object to a regular layer rasterizes the content at the current size. Convert a Smart Object to a regular layer only if you no longer need to edit the Smart Object data. Transforms, warps, and filters applied to a Smart Object are no longer editable after the Smart Object is rasterized.

  • Select the Smart Object, and choose Layer > Smart Objects > Rasterize.  

Note:

If you want to re-create the Smart Object, reselect its original layers and start from scratch. The new Smart Object won’t retain transforms you applied to the original Smart Object.

Export the contents of an embedded Smart Object

  1. Select the Smart Object from the Layers panel, and choose Layer > Smart Objects > Export Contents.
  2. Choose a location for the contents of the Smart Object, then click Save.

    Photoshop exports the Smart Object in its original placed format (JPEG, AI, TIF, PDF, or other formats). If the Smart Object was created from layers, it is exported in PSB format.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy