Video | Walk through a video project

Video | Walk through a video project
In this video, Adobe certified Photoshop expert and author Jeff Sengstack demonstrates the range of animation and video editing features available in Photoshop.
Jeff Sengstack

Timeline video creation

The redesigned, clip-based Timeline panel reflects video editors like Adobe Premiere, including transitions and effects that give finished videos professional polish.

Video tutorials:

Intuitive video Workflow: How to add video clips, trim video clips, add a music track, and render your movie for playback by your audience. By RC Conception (8:18)

How to edit video in Photoshop. By Matthew Gore (10:42)

Slip editing to adjust the in and out points of a video without changing the clip duration. By Meredith Payne-Stotzner (1:20)

Frame skipping and caching to improve playback performance. By Meredith Payne-Stotzner (2:07)

Changing clip speed: Slow and Fast Motion. By Jeff Sengstack (9:45). How to put clips into slow motion or speed them up. By Jeff Sengstack (9:45)

Video Groups

Video Groups combine multiple video clips and other content such as text, images, and shapes on a single track in the Timeline.

Create a Video Group

  • Import a video file; it's automatically added as a new Video Group.
  • To create an empty group for adding content to, click a filmstrip icon on the left of the Timeline panel, and choose New Video Group from the pop-up menu.

Edit a Video Group

  • To reposition clips, drag them in the Timeline.
  • To change in and out points, drag clip borders in the Timeline.
  • To move items from one group to another, drag them up or down in the Timeline or Layers panel.
  • To divide a selected clip and edit the resulting parts separately, position the Timeline playhead where you want to split the clip. Then click the Split At Playhead button in the upper-left corner of the Timeline panel.

Audio tracks and controls

Separate audio tracks in the Timeline allow for easy editing and adjusting.

Adjust audio in clips

  • Right-click audio clips to mute them, adjust volume, or fade in and out.
  • Right-click video clips, and click the musical notes to adjust audio they contain.

Adjusting audio: Video tutorial by Richard Harrington. (3:31)

Create or delete audio tracks

  • To the right of audio track names in the Timeline, click the musical notes , and select either New Audio Track or Delete Track.

Add, duplicate, delete, or replace audio clips

  • To the right of audio track names in the Timeline, click the musical notes . Then select Add Audio to place another clip on the track.
  • Select an audio clip in the Timeline, and click the musical notes to the right of the track name. Then select Duplicate, Delete, or Replace Audio Clip.

Video transitions

Transitions create professional fade and cross-fade effects. Click the transitions icon in the upper left of the Timeline panel. Then choose a duration, and drag a transition type to the start or end of clips. (Place the transition between clips to cross-fade.) Drag the edges of the transition preview in the Timeline to precisely set in and out points.


Right-click transitions in the Timeline to replace them with another transition type or specify a precise numeric duration.

Change video clip duration and speed

Right-click video clips to access Duration and Speed sliders. These controls interact; for example, a Speed of 400% limits the maximum duration to one-quarter of the original.

Apply filters to video layers

To apply filters across all frames in a video layer, first convert the layer into a Smart Object. Any subsequent filters you apply become Smart Filters, which provide total flexibility, letting you readjust filter settings at any time.

  1. Select the video layer in the Timeline or Layers panel.
  2. Choose Layer > Smart Objects > Convert to Smart Object.
  3. Apply filters from the Filter menu. To later readjust settings, view the Layers panel, and double-click the filter in the Smart Filters list for the video layer.

For more information, see Nondestructive editing.

Apply motion effects to text, still images, and Smart Objects

Right-click text, still-image, and Smart Object clips to access pan, zoom, and rotate presets, quickly applying sophisticated animation. Drag the resulting Transform keyframes in the Timeline to fine-tune the results.


To create dramatic effects as you pan, scale, and rotate clips over time, convert your clip to a Smart Object and use Transform keyframes with the Free Transform tool.

Video tutorials:

Transforming Layers over time. Julieanne Kost (3:52)

Creating masks to move over time. Julieanne Kost (3:17)

How to pan and zoom video in Photoshop. Julieanne Kost (18:06)

Create animations with audio. Tutorial article by Rafiq Elmansy.

Import a wider range of file formats

With a redesigned video engine, you can import a wider range of video, audio, and image sequence files. Easily work with file types such as 3GP, 3G2, AVI, DV, FLV and  F4V, MPEG-1, MPEG-4, QuickTime MOV (in Windows, full support requires separate QuickTime installation).

For the complete list, see Supported file formats.

Export final video with the Adobe Media Encoder

Choose File > Export > Render Video. From the first pop-up menu, select Adobe Media Encoder to choose from the following Format options:

  • DPX (Digital Picture Exchange) format is designed primarily for frame sequences that you plan to incorporate into professional video projects using an editor such as Adobe Premiere Pro.
  • H.264 (MPEG-4) format is the most versatile, including presets for high-definition and widescreen video, and output optimized for tablet devices or web delivery.
  • QuickTime (MOV) format is required for export of alpha channels and uncompressed video. The Preset menu provides additional compression options.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy