Adobe Acrobat PDFMaker (przycisk Konwertuj na Adobe PDF na pasku narzędzi/karcie PDFMaker) jest dodatkiem, który umożliwia tworzenie plików PDF w aplikacjach Microsoft Office. Ta funkcja jest instalowana z wersją Acrobat Professional i Standard.

  • W pakiecie Microsoft Office w wersji 2003 i starszych moduł PDFMaker wykorzystuje drukarkę Adobe PDF do tworzenia pliku PostScript. Następnie drukarka Adobe PDF wykorzystuje aplikację Adobe Acrobat Distiller, aby utworzyć plik PDF.
  • W pakiecie Microsoft Office 2007, 2010, 2016365 moduł PDFMaker wykorzystuje bibliotekę AdobePDF do konwersji dokumentów Microsoft Office na PDF.
  • Aplikacji Acrobat Distiller lub drukarki Adobe PDF można też używać niezależnie, aby tworzyć pliki PDF.

W tym dokumencie opisano rozwiązywanie problemów występujących podczas próby tworzenia plików PDF z aplikacji Office za pomocą modułu Acrobat PDFMaker. Mimo że dokument oparto na programie Microsoft Word, większość procedur rozwiązywania problemów dotyczy również programów Microsoft PowerPoint i Microsoft Excel.

 

Wstążka Acrobat jest niedostępna w aplikacjach Office 2016 i Office 365 w systemie Windows

Stosuje się do wersji Office 2016 lub Office 365 programów Word, Excel i PowerPoint

Spróbuj wykonać następujące kroki, aby rozwiązać problem:  

  1. Kliknij ikonę programu Word prawym przyciskiem myszy i wybierz polecenie Uruchom jako administrator.

    Jeśli pojawi się monit Kontrola konta użytkownika, kliknij przycisk Tak.

  2. Otwórz pusty dokument – wybierz szablon Pusty dokument. Można również otworzyć istniejący dokument programu Word.

  3. W menu Plik wybierz Opcje. Wyświetlone zostanie okno dialogowe Opcje programu Word.

  4. Wybierz opcję Dodatki z listy opcji. W rozwijanym menu Zarządzaj wybierz Dodatki COM, a następnie przycisk IDŹ.

    Dodatki Word
  5. W oknie dialogowym Dodatki COM zaznacz pole wyboru Dodatek COM Acrobat PDFmaker Office, jeśli nie jest jeszcze zaznaczone i kliknij przycisk OK

    Dodatek COM Adobe PDFmaker Office

Moduł PDFMaker ulega awarii podczas pracy z pakietem Office 2016 i Office 365 w systemie Windows

Acrobat PDFMaker ulega awarii podczas pracy z pakietem Office 2016 i Office 365 w systemie Windows po zainstalowaniu lutowej aktualizacji pakietu Office 2016.

Firma Adobe analizuje problem i wraz z firmą Microsoft stara się znaleźć rozwiązanie najszybciej, jak to możliwe. Dopóki problem nie zostanie rozwiązany, do tworzenia plików PDF można użyć rozwiązania zastępczego opisanego tutaj.

Sprawdzanie zgodności programu Acrobat z pakietem Microsoft Office

Przed przystąpieniem do rozwiązywania problemów upewnij się, że wersja używanego programu Acrobat jest zgodna z wersją używanego pakietu Office. Więcej informacji można znaleźć w artykule Zgodne przeglądarki internetowe i aplikacje modułu PDFMaker | Acrobat, Reader.

Rozwiązywanie problemów związanych z aplikacją Acrobat Distiller i drukarką Adobe PDF (dotyczy tylko modułu PDFMaker dla pakietu Microsoft Office w wersji 2003 i starszej)

Do konwertowania dokumentów Word moduł Acrobat PDFMaker (dla pakietu Microsoft Office w wersji 2003 i starszej) wykorzystuje drukarkę Adobe PDF, która z kolei wykorzystuje aplikację Acrobat Distiller. W związku z tym pierwszym etapem rozwiązywania problemów jest określenie, czy aplikacja Acrobat Distiller działa prawidłowo:

Próba utworzenia pliku PDF z dokumentu Word za pomocą drukarki Adobe PDF

  1. W programie Word otwórz dokument i wybierz polecenia Plik > Drukuj.
  2. Z listy Nazwa drukarki wybierz Adobe PDF, a następnie kliknij przycisk OK.

Próba utworzenia pliku PDF za pomocą aplikacji Acrobat Distiller

Uwaga: w tej metodzie zaawansowane funkcje modułu PDFMaker, takie jak zachowywanie łączy i struktury dokumentu, nie są obsługiwane.

  1. Otwórz dokument Word, a następnie wybierz polecenia Plik > Drukuj.
  2. W oknie dialogowym Drukowanie wybierz drukarkę PostScript (na przykład drukarkę Adobe PDF), zaznacz opcję Drukuj do pliku, a następnie kliknij przycisk OK.

    Zostanie utworzony plik PostScript (.ps lub .prn).

    Uwaga: jeśli nie masz drukarki PostScript, możesz pobrać sterownik drukarki PostScript z witryny firmy Adobe. Po instalacji sterownika wykonaj czynność z punktu 2. Jeśli zostanie wybrana drukarka Adobe PDF, usuń zaznaczenie opcji „Nie wysyłaj czcionek do drukarki Adobe PDF”, aby utworzyć plik PostScript.

  3. W programie Acrobat wybierz polecenia Zaawansowane > Acrobat Distiller.
  4. Z listy Ustawienia domyślne wybierz żądaną pozycję (lub zostaw wartość domyślną).
  5. Wybierz polecenia Plik > Otwórz, a następnie z listy Pliki typu wybierz pozycję Wszystkie pliki, zaznacz utworzony plik PS lub PRN, a następnie kliknij przycisk Otwórz.
  6. Określ nazwę i położenie dla pliku PDF, a następnie kliknij przycisk Zapisz.
    • Jeśli utworzenie pliku PDF w aplikacji Acrobat Distiller powiedzie się, przejdź do części Rozwiązywanie problemów z modułem PDFMaker.
    • Jeśli utworzenie pliku PDF w aplikacji Acrobat Distiller nie powiedzie się, przejdź do następnego punktu.
  7. Otwarcie pliku messages.log z następującego folderu systemu Windows (NT, 2000, XP, Vista, 7): %AppData%\Adobe\Acrobat\Distiller [numer wersji]

  8. Przejrzyj plik messages.log w poszukiwaniu informacji ułatwiających rozwiązywanie problemów:

    • Jeśli w pliku jest informacja, dlaczego nie można było utworzyć pliku PDF w aplikacji Acrobat Distiller, użyj pola wyszukiwania w pomocy programu Acrobat i pomocy technicznej, aby znaleźć powiązane dokumenty. Na przykład, jeśli w pliku dziennika jest wskazany błąd PostScript, rozwiąż problem zgodnie z zaleceniami w artykule Rozwiązywanie problemów z błędami PostScript.
    • Jeśli w pliku nie ma informacji o błędzie utworzenia pliku PDF przez aplikację Acrobat Distiller, utwórz dokument Word, który zawiera tylko kilka słów. Następnie spróbuj utworzyć plik PDF z tego dokumentu, używając drukarki Adobe PDF i aplikacji Acrobat Distiller:
    • Jeśli można utworzyć plik PDF na podstawie nowego dokumentu, problem może być powiązany z modułem PDFMaker. Przejdź do części Rozwiązywanie problemów z modułem Acrobat PDFMaker.
    • Jeśli nie można utworzyć pliku PDF z nowego dokumentu, użyj pliku w innej aplikacji. Spróbuj utworzyć plik PDF za pomocą aplikacji Acrobat Distiller. Jeśli problem wystąpi podczas tworzenia pliku w innej aplikacji, ponownie zainstaluj aplikację Acrobat Distiller. Jeśli problem nie wystąpi podczas tworzenia pliku w innej aplikacji, rozwiąż problemy związane z konkretnym zachowaniem, używając dokumentów wymienionych w części Zawartość pokrewna. Lub wyszukaj w pomocy programu Acrobat. Aby uzyskać pomoc, skontaktuj się z pomocą techniczną programu Acrobat.

Rozwiązywanie problemów z modułem Acrobat PDFMaker

Jeśli można utworzyć plik za pomocą drukarki Adobe PDF lub Acrobat Distiller, ale nie można za pomocą modułu Acrobat PDFMaker, problem może być związany z funkcją modułu Acrobat PDFMaker. Aby określić, czy dowolna z tych funkcji powoduje problem, wyłącz je. Potem spróbuj utworzyć plik PDF:

  1. W programie Word wybierz polecenia Adobe PDF > Zmień ustawienia konwersji.
  2. Z listy Ustawienia konwersji wybierz pozycję Najmniejszy rozmiar pliku.
  3. Kliknij kartę Word, a następnie usuń zaznaczenie wszystkich opcji.
  4. Kliknij kartę Zakładki, a następnie usuń zaznaczenie wszystkich opcji zakładek.
  5. Kliknij kartę Zabezpieczenia, a następnie usuń zaznaczenie wszystkich opcji zabezpieczeń.
  6. Kliknij przycisk OK.
  7. Spróbuj utworzyć plik PDF:
  • Jeśli nie można utworzyć pliku PDF, przejdź do części Rozwiązywanie problemów dotyczących dokumentów.
  • Jeśli można utworzyć plik PDF, określ, które funkcje powodują problem: włączaj po jednej funkcji i próbuj utworzyć plik PDF. Powtarzaj ten proces do wystąpienia problemu. Następnie utwórz dokument Word z tylko kilkoma wyrazami. Spróbuj utworzyć plik PDF na podstawie tego dokumentu, używając takich samych ustawień modułu Acrobat PDFMaker:
  • Jeśli można utworzyć plik PDF z nowego dokumentu, problem dotyczy dokumentu. Przejdź do części Rozwiązywanie problemów dotyczących dokumentów.
  • Jeśli nie można utworzyć pliku PDF na podstawie nowego dokumentu, oznacza to, że ostatnio włączona funkcja powoduje problem. Ponownie zainstaluj moduł Acrobat PDFMaker. Jeśli problem się powtarza, skontaktuj się z pomocą techniczną programu Acrobat.

Rozwiązywanie problemów dotyczących dokumentów

Jeśli problem dotyczy konkretnego dokumentu, rozwiąż problem wykonując następujące czynności.

Włączanie tylko funkcji modułu Acrobat PDFMaker używanych przez dokument

Przykładowo, jeśli dokument zawiera wyłącznie style nagłówka Nagłówek 1 i Nagłówek 2, wyłącz inne style nagłówka w oknie dialogowym Acrobat PDFMaker.

Przełączenie na widok Normalny w programie Word i utworzenie pliku PDF za pomocą modułu Acrobat PDFMaker

Ponowne tworzenie dokumentu Word w celu wyeliminowania wszelkich uszkodzeń

Wykonaj co najmniej jedną z następujących czynności:

  • Skopiuj zawartość dokumentu Word i wklej ja w nowym dokumencie, a następnie utwórz plik PDF.
  • Zaznacz cały tekst w dokumencie, zmień jego czcionkę, a następnie zapisz dokument z nową nazwą. Dokument zostanie zapisany ponownie, co może wyeliminować elementy powodujące konflikty z modułem Acrobat PDFMaker. Po zapisaniu dokumentu można ponownie sformatować go, używając żądanej czcionki.
  • Jeśli dokument został utworzony w programie Word w wersji innej niż używana do tworzenia plików PDF, wprowadź niewielką zmianę w dokumencie. Po zmianie dokumentu zapisz go z nową nazwą. Ta procedura wymusza ponowne zapisanie dokumentu, co może wyeliminować elementy powodujące konflikty z modułem Acrobat PDFMaker.

Odtworzenie niestandardowych stylów nagłówków w dokumencie i utworzenie pliku PDF

Określanie elementów dokumentu powodujących konflikty

  1. Utwórz dokument Word.
  2. Skopiuj połowę oryginalnego dokumentu Word do nowego dokumentu Word.
  3. Skonwertuj nowy dokument Word na plik PDF za pomocą modułu Acrobat PDFMaker.
  • Jeśli problem wystąpi ponownie, elementy powodujące konflikty są w nowym dokumencie Word. Aby określić element powodujący konflikty, powtórz czynności z punktów 1–3 i skopiuj połowę drugiego dokumentu do kolejnego nowego dokumentu Word.
  • Jeśli problem nie wystąpi, element powodujący konflikty jest w oryginalnym dokumencie Word. Aby wyizolować problem, powtórz czynności z punktów 1–3 i skopiuj drugą połowę oryginalnego dokumentu Word do kolejnego nowego dokumentu Word. Jeśli obie połowy dokumentu można skonwertować prawidłowo, zamknij inne uruchomione programy, w tym aplikację Office. Usuń pliki .tmp (zwykle są w folderze Windows/Temp).

Ponowne instalowanie programów

Odinstaluj zarówno program Acrobat, jak i pakiet Office lub konkretną aplikację Office (Word, PowerPoint lub Excel). Ponownie zainstaluj pakiet Office lub konkretną aplikację Office, a następnie ponownie zainstaluj program Acrobat.

Aby usunąć program Acrobat, użyj funkcji Dodaj/usuń programu w oknie Panel sterowania. Więcej informacji o odinstalowywaniu pakietu Office można znaleźć w dokumentacji pakietu Office. Można je też uzyskać, kontaktując się z pomocą firmy Microsoft.

Wyłączanie ochrony dokumentu Word, jeśli dokument jest chroniony

Więcej informacji o wyłączaniu ochrony, można znaleźć w dokumentacji pakietu Office. Można je też uzyskać, kontaktując się z pomocą firmy Microsoft. 

Rozwiązywanie problemów z innymi makrami w programie Microsoft Word

Moduł PDFMaker może powodować konflikty z innymi makrami, takimi jak oprogramowanie antywirusowe lub oprogramowanie do obsługi faksów. Jeśli inne zadania rozwiązywania problemów nie powiodą się lub występują problemy z modułem PDFMaker po zainstalowaniu makra innej firmy, rozwiąż problemy konfliktów z innymi makrami. Znane makra powodujące konflikty z modułem to: Duden Korrektor Plus 2.0, ViaVoice 10 i starsze wersje, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus oraz GoldMine Link to Word.

Aby określić, czy moduł PDFMaker powoduje konflikty z innymi makrami, usuń lub wyłącz kolejno inne makra (patrz odpowiednie łącze poniżej). Spróbuj ponownie skonwertować dokument na plik PDF za pomocą modułu PDFMaker. Jeśli problem nie wystąpi, skontaktuj się z producentem tego makro.

Rozwiązywanie problemów z programem Microsoft Word

Poniższe czynności oparto na następujących artykułach z bazy wiedzy firmy Microsoft:

Więcej informacji o rozwiązywaniu problemów z programem Microsoft Word można uzyskać, wyszukując odpowiedni artykuł w witrynie firmy Microsoft.

Uruchamianie programu Word z przełącznikiem /a i ręczne dodawanie modułu PDFMaker

Przełącznik /a powoduje uruchomienie programu Word z wyłączonym automatycznym ładowaniem dodatków i szablonów globalnych (w tym szablonu Normal). Przełącznik /a powoduje też zablokowanie plików ustawień. Oznacza to, że nie można odczytać ani modyfikować plików ustawień, jeśli ten przełącznik został użyty.

Uwaga: zmiany preferencji, niestandardowych ustawień lub makr w trakcie sesji programu Word uruchomionego z przełącznikiem /a zostaną utracone po zamknięciu programu Word.

Aby uruchomić program Word z przełącznikiem /a:

  1. Zamknij wszystkie programy.
  2. Wybierz polecenia Start > Uruchom.
  3. W oknie dialogowym Uruchamianie wpisz polecenie winword.exe /a.
  4. Kliknij przycisk OK. Okno dialogowe Uruchamianie zostanie zamknięte. Zostanie uruchomiony program Word.

Aby ręcznie załadować moduł PDFMaker (tylko Acrobat 6.x):

  1. Zamknij wszystkie programy.
  2. Wybierz polecenia Narzędzia > Szablony i dodatki.
  3. Zaznacz szablon PDFMaker.dot (nie PDFMakerA.dot) i kliknij przycisk OK.

    Pojawi się ikona modułu PDFMaker.

Tylko wersje Acrobat 7.x, 8.x, 9.x, X (jeśli dotyczy) 

Aby ręcznie załadować moduł PDFMaker (program Microsoft Word w wersji 2003 lub starszej):

  1. Zamknij wszystkie programy.
  2. Wybierz polecenia Narzędzia > Dostosuj, a następnie kliknij kartę Polecenia.
  3. W panelu Kategorie kliknij pozycję Narzędzia.
  4. Przeciągnij pozycję Dodatki COM z panelu Polecenia do menu Narzędzia, przytrzymując przycisk myszy. Po wyświetleniu poleceń menu Narzędzia przeciągnij pozycję Dodatki COM poniżej polecenia Dostosuj, a następnie puść przycisk myszy.
  5. Kliknij przycisk Zamknij.
  6. Kliknij polecenie Dodatki COM w menu Narzędzia.
  7. Kliknij przycisk Dodaj, znajdź dodatek (PDFMaker jest w folderze [ścieżka instalacyjna programu Acrobat]\PDFMaker\Office\PDFMOfficeAddIn.dll) i kliknij przycisk OK.

  8. Naciśnij kombinację klawiszy Alt+F11, aby uruchomić program Visual Basic Editor.
  9. Naciśnij kombinację Ctrl+G, aby wyświetlić okienko Immediate programu Visual Basic Editor.
  10. Aby uruchomić moduł PDFMaker w programie Word, wpisz ciąg Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True. Zamknij program Visual Basic Editor.
  11. Sprawdź, czy na pasku menu programu Microsoft Word po prawej stronie menu Pomoc jest widoczne menu Adobe PDF.

Ręczne ładowanie modułu PDFMaker (program Microsoft Word w wersji 2007 i 2010):

  1. Zamknij wszystkie programy.
  2. Kliknij przycisk Microsoft Office, a następnie kliknij Opcje programu Word.

  3. Kliknij pozycję Dodatki.

  4. Na liście Zarządzaj kliknij pozycję Dodatki COM, a następnie przycisk Idź.

  5. Jeśli dodatek Acrobat PDFMaker COM jest wyświetlany na liście i zaznaczony w oknie dialogowym Dodatki COM, wykonaj następujące czynności. W przeciwnym razie przejdź do punktu 6.

  6. Kliknij pole wyboru dodatku Acrobat PDFMaker COM, aby usunąć jego zaznaczenie.

  7. Kliknij przycisk OK, aby zamknąć okno dialogowe Dodatki COM.

  8. Powtórz czynności z punktów 1–3, a następnie zaznacz pole wyboru Acrobat PDFMaker COM w oknie dialogowym Dodatki COM.

  9. Sprawdź, czy karta Acrobat wyświetla się na wstążce programu Microsoft Word.

  10. Jeśli dodatku Acrobat PDFMaker COM NIE ma na liście w oknie dialogowym Dodatki COM, wykonaj czynności z punktów 7–10 w części Aby ręcznie załadować moduł PDFMaker (program Microsoft Word w wersji 2003 lub starszej).

Utwórz testowy dokument Word i uruchom moduł PDFMaker: 

  1. Wpisz jakiś tekst w dokumencie Word.
  2. Wybierz polecenia Plik > Zapisz, a następnie zapisz dokument testowy na pulpicie.
  3. Kliknij polecenie Konwertuj na Adobe PDF.

Jeśli problem nie występuje po użyciu przełącznika /a podczas uruchamiania programu Word, usuń poszczególne składniki ładowane podczas uruchamiania programu Word. Usuwaj je pojedynczo w kolejności, w jakiej są widoczne w programie Word. Podczas uruchamiania programu Word ładowane są następujące składniki:

  • Automatyczne makra programu Word
  • Szablon globalny (Normal.dot)
  • Dodatki (WLL)
  • Szablony z folderu Word Startup i Office Startup
  • Dodatki COM
  • Klucz danych programu Word z rejestru systemu Windows
  • Klucz opcji programu Word z rejestru systemu Windows
  • Automatyczne makra programu Word

Uwaga: więcej informacji o rozwiązywaniu problemów z uruchamianiem programu Word można uzyskać w następujących usługach pomocy technicznej produktów firmy Microsoft.

Zmiana nazwy pliku szablonu Normal.dot

Więcej informacji o zmianie nazwy pliku szablonu globalnego można znaleźć w części „Szablon globalny (Normal.dotm lub Normal.dot)” w artykule pomocy technicznej firmy Microsoft pt. Resetowanie opcji użytkownika i ustawień rejestru w programie Word. Przewiń w dół strony, aby uzyskać dostęp do artykułu.

Ważne: Nie używaj przełącznika /a podczas ponownego uruchamiania programu Word po zakończeniu tych czynności.

Jeśli zmiana nazwy szablonu globalnego pozwoliła rozwiązać problem, oznacza to, że problem powoduje uszkodzony szablon Normal.dot. Czasami trzeba zmienić kilka ustawień, aby przywrócić swoje opcje. Jeśli w pliku Normal.dot, którego nazwa została zmieniona, są ustawienia własne użytkownika, np. style, makra lub wpisy autotekstu, których nie można łatwo odtworzyć, spróbuj użyć narzędzia Organizer, aby skopiować te ustawienia ze starego pliku Normal.dot do nowego pliku Normal.dot.

Więcej informacji o używaniu narzędzia Organizer można uzyskać, wykonując następujące czynności:

  1. Uruchom program Word.
  2. Wybierz polecenia Pomoc > Pomoc programu Microsoft Word.
  3. W narzędziu Asystent pakietu Office lub kreatorze odpowiedzi wpisz Organizer.

  4. Kliknij przycisk Szukaj, aby znaleźć powiązane tematy.

Jeśli problem nie został rozwiązany, możesz używać starego szablonu globalnego (Normal.dot) zamiast nowego szablonu globalnego. Aby używać starego szablonu Normal.dot, zmień jego nazwę ponownie na Normal.dot. Jeśli mimo wykonania czynności przedstawionych w tym dokumencie nadal występują problemy z modułem PDFMaker, skontaktuj się z pomocą techniczną programu Acrobat.

Ta zawartość jest licencjonowana na warunkach licencji Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Posty z serwisów Twitter™ i Facebook nie są objęte licencją Creative Commons.

Informacje prawne   |   Zasady prywatności online