Błąd platformy Adobe Print Engine w programie InDesign

Problem

Podczas próby drukowania program InDesign zwraca następujący błąd:

„Błąd drukowania: platforma Adobe Print Engine nie może wydrukować danych z powodu nieznanego problemu”.

Rozwiązania

Wykonaj co najmniej jedną z następujących czynności:

Rozwiązanie 1: Ponownie utwórz plik preferencji programu InDesign.

  1. Zamknij program InDesign.
  2. Zmień nazwę pliku InDesign SavedData i pliku InDesign Defaults (na przykład na InDesign SavedData.old, InDesign Defaults.old) w następującej lokalizacji:
    • Windows XP: C:/Documents and Settings/[nazwa użytkownika]/Application Data/Adobe/InDesign/[wersja]
    • Windows 7 / Vista: C:/Users/[nazwa użytkownika]/AppData/Roaming/Adobe/InDesign/[wersja]
    • Mac OS: /Users/[nazwa użytkownika]/Library/Preferences/Adobe InDesign/[wersja]
  3. Uruchom program InDesign. Program InDesign tworzy pliki preferencji.
  4. Jeśli problem nadal występuje, można przywrócić oryginalne preferencje, usuwając nowe pliki i zmieniając nazwy starych plików preferencji na oryginalne.

Rozwiązanie 2: Ponownie utwórz gradient, aby kolory dodatkowe pochodziły z tej samej przestrzeni kolorów.

Jeśli drukujesz plik EPS wyeksportowany z dokumentu InDesign z gradientem, upewnij się, że kolory dodatkowe w gradiencie pochodzą z tej samej przestrzeni kolorów, a następnie ponownie wyeksportuj plik EPS. (Na przykład upewnij się, że gradient nie zawiera jednego koloru dodatkowego RGB i jednego koloru dodatkowego LAB).

Rozwiązanie 3: Zmień opcje drukowania w oknie dialogowym Drukuj.

Zmień ustawienia w oknie dialogowym Drukuj w następujący sposób:

  • W przypadku drukowania sekcji zawierającej tylko jedną stronę nieparzystą należy usunąć zaznaczenie opcji Tylko strony parzyste.
  • W przypadku drukowania sekcji zawierającej tylko jedną stronę parzystą należy usunąć zaznaczenie opcji Tylko strony nieparzyste.

Rozwiązanie 4: Zastąp kolory spoza zakresu kolorami, które znajdują się w zakresie.

W przypadku drukowania dokumentu InDesign zawierającego zaimportowany tekst ze znacznikami, należy sprawdzić, czy plik z tekstem ze znacznikami nie zawiera koloru spoza zakresu. Kolory spoza zakresu są wyświetlane na palecie Próbki z dołączoną wartością, taką jak „+5”, która wskazuje najbliższą wartość w zakresie.

Aby zastąpić kolor spoza zakresu kolorem, który znajduje się w zakresie, wykonaj następujące czynności:

  • Zdefiniuj nową próbkę koloru w programie InDesign, a następnie użyj funkcji Znajdź/Zmień, aby zastąpić kolor w oznaczonym pliku tekstowym nowym kolorem.
  • Przedefiniuj wartość koloru w oznaczonym pliku tekstowym, a następnie ponownie zaimportuj plik do programu InDesign. Wartości kolorów są definiowane za pomocą znacznika tabeli kolorów (<Tabela kolorów>). Więcej informacji na temat definicji kolorów w tekstach ze znacznikami można znaleźć w pliku PDF tekstu ze znacznikami na płycie CD-ROM z programem InDesign.

Rozwiązanie 5: Wyeksportuj plik do formatu PDF, a następnie wydrukuj go w programie Adobe Acrobat 5 lub nowszym.

Wyeksportuj plik do formatu PDF, a następnie wydrukuj plik PDF z programu Adobe Acrobat 5 lub nowszego albo Adobe Acrobat Reader 5.0 lub nowszego.

Rozwiązanie 6: Usuń komentarze OPI 2.0 z pliku PDF.

Usuń komentarze OPI 2.0 z pliku PDF, umieść plik PDF w programie InDesign, a następnie wydrukuj dokument.

Aby usunąć komentarze OPI 2.0, wykonaj jedną z następujących czynności:

  • W programie Adobe Acrobat ręcznie usuń komentarze OPI 2.0, a następnie ponownie utwórz plik PDF.
  • W programie Acrobat użyj programu Enfocus Pitstop, aby usunąć komentarze OPI 2.0.
  • Użyj komentarzy OPI 1.3.
  • W programie Acrobat Distiller wybierz opcję Ustawienia > Edytuj ustawienia Adobe PDF, kliknij kartę Zaawansowane, usuń zaznaczenie opcji Zachowaj komentarze OPI, a następnie oczyść plik PDF.
  • Użyj obiegu pracy proxy OPI i osadzaj proxy w pliku PDF (bez pomijania).
  • W programie InDesign zaznacz plik PDF i zastosuj opcję przezroczystości. Instrukcje znajdują się w sekcji „Określanie przezroczystości” w pomocy programu InDesign.

Rozwiązanie 7: Zastąp plik PDF obrazem EPS.

Użyj aplikacji do edycji obrazów, takiej jak Adobe Photoshop, aby zapisać plik PDF jako obraz EPS. Następnie umieść obraz EPS w dokumencie InDesign.

Rozwiązanie 8: Użyj Menedżera farb, aby przekonwertować wszystkie kolory dodatkowe na kolory podstawowe.

Aby zweryfikować liczbę używanych kolorów dodatkowych, otwórz paletę Próbki. Nazwy próbek, obok których występuje kwadrat z szarym kółkiem, to kolory dodatkowe.

Aby przekonwertować wszystkie kolory na kolory podstawowe za pomocą aplikacji Menedżer farb, wykonaj następujące czynności:

  1. Otwórz paletę Próbki.
  2. Wybierz Menedżer farb z menu.
  3. Wybierz opcję Wszystkie dodatkowe na podstawowe w lewym dolnym rogu okna dialogowego i kliknij OK.

Po wybraniu strony wynikowej w oknie dialogowym Drukuj w sekcji Tusze wyświetlane będą tylko tusze: cyjan, magenta, żółty i czarny.

Uwaga: ten problem występuje tylko w przypadku drukowania na drukarce PostScript. Jeśli masz dostęp do drukarki innej niż PostScript, możesz jej użyć do wydrukowania kompozycji pliku.

Rozwiązanie 9: Zapisz plik źródłowy w innym formacie

Otwórz plik źródłowy w aplikacji, w której go utworzono, i zapisz go w formacie innym niż PDF. Więcej informacji można znaleźć w dokumentacji dołączonej do aplikacji.

Rozwiązanie 10: Wyeksportuj dokument do formatu InDesign Interchange (.inx), a następnie sprawdź informacje o czcionkach.

  1. W programie InDesign CS wybierz opcję Plik > Eksportuj i wybierz InDesign Interchange z menu Zapisz jako typ.
  2. Kliknij przycisk Zapisz.

Rozwiązanie 11: Wyeksportuj plik PDF z programu InDesign jako plik JPEG.

Umieść plik PDF w nowym dokumencie InDesign. Wyeksportuj plik PDF jako plik JPEG, a następnie umieść plik JPEG w oryginalnym dokumencie InDesign.

  1. Utwórz dokument InDesign.
  2. Wybierz opcję Plik > Umieść, wybierz plik PDF i kliknij Otwórz.
  3. Kliknij stronę, aby umieścić plik PDF.
  4. Po zaznaczeniu pliku PDF wybierz opcję Plik > Eksportuj.
  5. Wybierz opcję JPEG z menu Format, nadaj plikowi nazwę, a następnie kliknij przycisk Zapisz.
  6. Wybierz odpowiednie opcje eksportu, a następnie kliknij przycisk Eksportuj.
  7. Otwórz oryginalny dokument InDesign, który nie został wydrukowany.
  8. Wybierz opcję Plik > Umieść, wybierz plik JPEG zapisany w kroku 5 i kliknij Otwórz.
  9. Kliknij stronę, aby umieścić plik JPEG.

Rozwiązanie 12: Użyj narzędzia Konwertuj do PDF w pakiecie Microsoft Office, aby utworzyć plik PDF.

  1. Otwórz dokument w programie Microsoft Excel, Microsoft PowerPoint lub Microsoft Word.
  2. Kliknij opcję Konwertuj na Adobe PDF na pasku narzędzi.
  3. Nadaj nazwę plikowi i zapisz go jako PDF.

Rozwiązanie 13: Utwórz plik PostScript i przekonwertuj go do formatu PDF za pomocą programu Adobe Acrobat Distiller.

Aby utworzyć plik PostScript w aplikacji źródłowej, zapoznaj się z dokumentacją dołączoną do aplikacji.

Aby przekonwertować plik PostScript na plik PDF, wykonaj następujące czynności:

  1. Uruchom aplikację Acrobat Distiller.
  2. Wybierz ustawienie z menu Ustawienia domyślne.
  3. Wybierz opcję Plik > Otwórz.
  4. Zaznacz plik PostScript i wybierz Otwórz. Plik PDF pojawia się w tej samej lokalizacji co plik PostScript.

Rozwiązanie 14: Sprawdź, czy czcionka nie jest uszkodzona.

Aby ustalić, czy problem dotyczy uszkodzonej czcionki, spróbuj przełączyć wszystkie czcionki używane w dokumencie na czcionkę standardową. (Na przykład zmień na Arial lub Times New Roman).

Jeśli problem pojawia się ponownie po zmianie czcionki, to nie jest on związany z czcionką. Jeśli problem się nie powtórzy, oryginalna czcionka może być uszkodzona lub przestarzała (tj. utworzona przed 1992 r.). Spróbuj ponownie zainstalować czcionkę lub uzyskać zaktualizowaną wersję od producenta czcionki.

Rozwiązanie 15: Utwórz ponownie pliki listy czcionek Adobe.

W systemie Windows:

  1. Zakończ działanie wszystkich aplikacji firmy Adobe.
  2. Wybierz opcję Start > Wyszukaj > Dla plików lub folderów.
  3. Wyszukaj pliki z listą czcionek:
  • W systemach Windows XP i Windows Vista wpisz "Adobefnt*.lst" (łącznie z cudzysłowami) w polu „Cała nazwa pliku lub jej część”, a następnie kliknij przycisk Wyszukaj.
  • W systemie Windows 2000 wpisz "Adobefnt*.lst" (łącznie z cudzysłowami) w polu Nazwa, a następnie kliknij przycisk Znajdź teraz.
  1. Zaznacz wszystkie pliki na liście i wybierz Plik > Usuń. (W przypadku usunięcia pliku listy czcionek dla innej aplikacji Adobe plik zostanie ponownie utworzony przy następnym uruchomieniu aplikacji Adobe).
  2. Uruchom ponownie program InCopy lub InDesign. Pliki listy czcionek są ponownie tworzone podczas uruchamiania.

W systemie Mac OS X:

  1. Zakończ działanie wszystkich aplikacji firmy Adobe.
  2. Wybierz opcję Plik > Znajdź i wykonaj jedną z następujących czynności:
  • W systemie Mac OS X w wersji 10.4.x kliknij przycisk Komputer, wpisz Adobefnt w polu tekstowym obok parametru „Nazwa pliku to”, a następnie kliknij Enter.
  • W systemach Mac OS X w wersjach 10.2.x–10.3.x wybierz opcję Dyski lokalne z menu Wyszukaj w, wpisz Adobefnt w polu obok parametru „Nazwa pliku to”, a następnie kliknij przycisk Wyszukaj.
  1. Zaznacz plik i wybierz polecenie Plik > Przenieś do kosza.
  2. Powtórz kroki 2–3 dla plików Adobefnt05.lst i Adobefnt06.lst.
  3. Uruchom ponownie program InCopy lub InDesign. Pliki listy czcionek są ponownie tworzone podczas uruchamiania.

Uwaga: w przypadku systemu Mac OS w wersji 10.5x, jeśli nie znaleziono pliku adobefnt.lst, należy dodać pliki systemowe do kryteriów wyszukiwania w oknie dialogowym Plik > Znajdź.

  1. Wybierz pozycję Inne z menu podręcznego Rodzaj i poczekaj na wyświetlenie okna dialogowego Wybierz atrybut wyszukiwania.
  2. Wpisz „system”.
  3. Wybierz Pliki systemowe z listy i kliknij OK.
  4. Zaznacz także pole wyboru W menu, jeśli chcesz, aby pliki systemowe pojawiały się w kryteriach w przyszłości.
  1. Wydrukuj jedną stronę na raz.

  2. Zlokalizuj uszkodzoną stronę lub łącze w dokumencie.

Rozwiązanie 17: Zainstaluj ponownie sterowniki drukarki

Skontaktuj się z producentem drukarki, aby uzyskać najnowszą wersję sterownika drukarki. Jeśli używasz najnowszej wersji sterownika drukarki, a problem nadal występuje, usuń sterownik, a następnie zainstaluj go ponownie z oryginalnego dysku instalacyjnego lub płyty CD-ROM.

Rozwiązanie 18: Przenieś dokument do nowego pliku

  1. Przenieś strony za pomocą polecenia Przenieś strony
    Wybierz opcję Układ > Strony > Przenieś strony lub wybierz polecenie Przenieś strony z menu panelu Strony.

  2. Wskaż stronę lub strony do przeniesienia.

  3. Następnie w sekcji Cel wybierz miejsce, do którego mają zostać przeniesione strony. W razie potrzeby określ stronę. 

  4. Kliknij przycisk OK.

Dodatkowe informacje

Ten błąd ma kilka potencjalnych przyczyn. Ponowne utworzenie plików preferencji koryguje najczęstsze przyczyny, takie jak:

  • Drukowanie na drukarce innej niż PostScript natychmiast po wydrukowaniu na drukarce PostScript z wybraną opcją Skaluj, aby dopasować.
  • Anulowanie zadania drukowania podczas procesu drukowania lub buforowania.
  • Drukowanie z uszkodzonymi plikami preferencji.

Inne potencjalne przyczyny to m.in.:

  • Drukowanie pliku PDF zawierającego komentarze OPI 2.0.
  • Drukowanie gradientu zawierającego kolory dodatkowe z różnych przestrzeni kolorów.
  • Drukowanie oznaczonego pliku tekstowego, który używa kolorów spoza zakresu.
  • Drukowanie bez wybrania drukarki w module wybierania.
  • Drukowanie z otwartym modułem wybierania po dokonaniu wyboru drukarki.

W niektórych przypadkach wydruk pliku w formacie PDF stanowi obejście problemu. Błąd nie zawsze występuje w programie InDesign 1.5 lub nowszym, ponieważ wersje te zawierają wiele ulepszeń drukowania.

Program InDesign zwraca błąd podczas próby wydrukowania komentarzy OPI 2.0. Błąd może wystąpić po umieszczeniu plików PDF utworzonych w programie QuarkXPress 5.x w dokumencie programu InDesign. Problem nie występuje w przypadku komentarzy OPI 1.3. Większość serwerów proxy nie zawiera komentarzy OPI 2.0.

Adobe

Pomoc dostępna szybciej i łatwiej

Nowy użytkownik?