Adobe Acrobat PDFMaker (кнопка «Преобразовать в Adobe PDF» на панели инструментов) — это надстройка для создания файлов PDF из приложений Microsoft Office. Эта функция устанавливается вместе с Acrobat Professional и Standard.

  • В MS Office 2003 и более ранних версий, PDFMaker использует принтер Adobe PDF для создания файла PostScript. Затем принтер Adobe PDF взаимодействует с приложением Adobe Acrobat Distiller, чтобы создать файл PDF.
  • В MS Office 2007, 2010, 2016 и 365 PDFMaker использует библиотеку AdobePDF для преобразования документа Microsoft Office в PDF.
  • Принтер Acrobat Distiller или Adobe PDF также можно использовать отдельно для создания файлов PDF.

В этом документе содержатся рекомендации по устранению неполадок, которые возникают при попытке создать файлы PDF из офисных приложений с помощью Acrobat PDFMaker. Хотя этот документ ссылается на Microsoft Word, большинство способов устранения неполадок также применимы к Microsoft PowerPoint и Microsoft Excel.

 

Лента Acrobat недоступна в приложениях Office 2016 или Office 365 в Windows

Применимо к версиям Office 2016 или Office 365 Word, Excel и PowerPoint

Попробуйте выполнить следующие действия, чтобы устранить эту проблему:  

  1. Щелкните правой кнопкой мыши по значку Word и выберите «Запустить от имени администратора».

    Если появится запрос контроля учетных записей, выберите Да.

  2. Откройте пустой документ - выберите шаблон Пустой документ. Кроме того, вы можете открыть существующий документ Word.

  3. В меню Файл выберите Параметры. Откроется диалоговое окно «Параметры Word».

  4. Выберите пункт Надстройки в списке параметров. В раскрывающемся списке Управление выберите Надстройки COM, а затем нажмите Перейти.

    Надстройки Word
  5. В диалоговом окне «Надстройки COM» установите флажок надстройки Acrobat PDFMaker Office COM, если он не установлен, и нажмите ОК.

    Надстройка PDFMaker Office COM

Сбои в работе PDFMaker с Office 2016 и Office 365 для Windows

После февральского обновления Office 2016 Acrobat PDFMaker аварийно завершает работу с Office 2016 и Office 365 для Windows.

Adobe исследует причины проблемы и работает с Microsoft, чтобы устранить проблему как можно скорее. Временные решения по созданию документов PDF см. здесь.

Проверка совместимости Acrobat с Microsoft Office

Прежде чем приступить к процедуре устранения неполадок, убедитесь, что версия Acrobat, с которой вы работаете, совместима с вашей версией Office. Дополнительные сведения см. в разделе «Совместимые веб-браузеры и PDFMaker-совместимые приложения | Acrobat, Reader».

Устранение проблем, связанных с Acrobat Distiller и принтером Adobe PDF (применимо только к PDFMaker для MS Office 2003 и более ранних версий)

Acrobat PDFMaker (для MS Office 2003 и более ранних версий) использует принтер Adobe PDF, который в свою очередь использует приложение Acrobat Distiller, чтобы преобразовывать документы Word. Таким образом, первый шаг к устранении неполадок — определить, работает ли Acrobat Distiller правильно:

Попробуйте создать PDF-файл из Word с принтером Adobe PDF 

  1. Откройте документ в приложении Цщкв и выберите пункт меню «Файл» > «Печать».
  2. Выберите Adobe PDF из списка имен принтеров, а затем нажмите кнопку «ОК».

Попробуйте создать PDF с приложением Acrobat Distiller

Примечание. Этот метод не поддерживает расширенные функции PDFMaker, такие как поддержка ссылок и структуры документа.

  1. Откройте документ Word, а затем выберите пункт меню «Файл» > «Печать».
  2. В диалоговом окне «Печать» выберите принтер PostScript (например, принтер Adobe PDF), выберите параметр «Печатать в файл», а затем нажмите кнопку «ОК».

    Создан файл PostScript (.PS или .PRN).

    Примечание. Если вы не используете принтер PostScript, вы можете загрузить драйвер принтера PostScript с сайта Adobe. После установки драйвера выполните шаг 2. При выборе принтера Adobe PDF, снимите флажок «Не отправлять шрифты на Adobe PDF, чтобы создать файл PostScript.

  3. В Acrobat выберите «Дополнительно» > «Acrobat Distiller».
  4. Выберите нужный вариант в списке настроек по умолчанию (или оставьте как есть).
  5. Выберите «Файл» > «Открыть», выберите все файлы в меню «Типы файлов», выберите тип создаваемого файла «PS» или «PRN», а затем нажмите кнопку «Открыть».
  6. Введите имя, укажите расположение для PDF-файла и нажмите кнопку «Сохранить».
  7. Откройте файл messages.log в следующей папке (для Windows (NT, 2000, XP, Vista, 7): %AppData%\Adobe\Acrobat\Distiller [номер версии]

  8. Проверьте файл messages.log на предмет наличия информации для устранения неполадок:

    • Если в файле есть указания, почему Acrobat Distiller не может создать файл PDF, используйте функцию поиска по документу «Справка и техподдержка Acrobat» для поиска соответствующих документов. Например, если в файле перечислены ошибка PostScript, устраните эту неполадку в соответствии с рекомендациями в разделе «Устранение неполадок PostScript».
    • Если в файле нет никаких указаний на то, почему Acrobat Distiller не может создать файл PDF, создайте документ Word, который содержит лишь несколько слов. Затем попробуйте создать файл PDF из этого документа, используя принтер Adobe PDF и приложение Acrobat Distiller:
    • Если вы можете создать PDF-файл из нового документа, то проблема может быть связана с PDFMaker. Продолжить «Устранение неполадок Acrobat PDFMaker».
    • Если вы не можете создать PDF-файл из нового документа, используйте файл из другого приложения. Затем попробуйте создать файл PDF с помощью Acrobat Distiller. Если проблема возникает и с файлом из другого приложения, переустановите Acrobat Distiller. Если с файлом из другого приложения проблем не возникает, изучите поведение в каждом конкретном случае использования по документам, перечисленным в разделе «Дополнительная информация». Или найдите поиском «Справка Acrobat». Если вам нужна дополнительная помощь, обратитесь в службу технической поддержки Acrobat.

Устранение проблем, связанных с Acrobat PDFMaker

Если вы можете создать файл PDF с принтером Adobe PDF или в Acrobat Distiller, но не можете с Acrobat PDFMaker, то проблема может быть связана именно с Acrobat PDFMaker. Чтобы определить, вызывают ли проблемы ли какие-либо из функций этой программы, отключите их. Затем попробуйте создать файл PDF:

  1. В программе Word, выберите «Adobe PDF» > «Изменить параметры преобразования».
  2. Выберите «Наименьший размер файла» из меню «Параметры преобразования».
  3. Щелкните вкладку «Word», затем отмените выбор всех параметров.
  4. Щелкните вкладку «Закладки», затем отмените выбор всех параметров закладок.
  5. Щелкните вкладку «Безопасность», затем отмените выбор всех параметров безопасности.
  6. Нажмите кнопку «ОК».
  7. Попробуйте создать файл PDF:
  • Если вы не можете создать файл PDF, то перейдите к пункту «Устранение проблем для конкретного документа».
  • Если вы можете создать файл PDF, то выясните, какие функции вызвают проблему: включите одну функцию и попробуйте создать файл PDF. Повторяйте эту процедуру до тех пор, пока проблема не повторится. Затем создайте документ Word, который содержит лишь несколько слов. Попробуйте создать файл PDF из этого документа, используя те же настройки Acrobat PDFMaker:
  • Если вы можете создать файл PDF из нового документа, то проблема заключается в конкретном документе. Перейдите к разделу «Устранение проблем конкретного документа».
  • Если вы не можете создать файл PDF из нового документа, то причиной проблемы может быть последняя включенная функция. Переустановите Acrobat PDFMaker. Если проблема так и не решится, свяжитесь со Службой поддержки Acrobat

Устранение проблем для конкретного документа

Если вы обнаружили, что проблема заключается в конкретном документе, устранить неполадки можно следующим образом.

Включите только те функции Acrobat PDFMaker, которые используются в документе

Например, если документ содержит только стили заголовков «Заголовок 1» и «Заголовок 2», отключите другие стили заголовков в диалоговом окне Acrobat PDFMaker.

Переключитесь в режим просмотра обычного документа в программе Word, а затем создайте файл PDF с помощью Acrobat PDFMaker

Повторно создайте документ Word, чтобы исключить любые повреждения

Выполните одно из или несколько следующих действий.

  • Скопируйте содержимое документа Word и вставьте его в новый документ, а затем создайте файл PDF.
  • Выделите весь текст в документе, измените шрифт, а затем сохраните документ под новым именем. Word перезапишет документ, который поможет исключить элементы, конфликтующие с Acrobat PDFMaker. После сохранения документа можно изменить в нем шрифт на желаемый.
  • Если документ был создан в версии Word отличной от той, которую вы используете для создания файла PDF, внесите в документ небольшие изменения. Затем сохраните его под новым именем. В результате этой процедуры Word перепишет документ, возможно, исключив все элементы, которые конфликтуют с Acrobat PDFMaker.

Восстановите в документе все пользовательские стили заголовков, а затем создайте файл PDF

Выявите конфликтующие элементы в документе

  1. Создайте новый документ Word.
  2. Скопируйте половину исходного документа Word в новый документ Word.
  3. Преобразуйте новый документ Word в формат PDF с помощью Acrobat PDFMaker
  • Если проблема возникает снова, значит конфликтующий элемент находится в новом документе Word. Для дальнейшего выявления конфликтующего элемента повторите шаги 1-3 и скопируйте половину второго документа Word в новый документ Word.
  • Если проблема не возникает, значит конфликтующий элемент находится в исходном документе Word. Для дальнейшего выявления конфликтующего элемента повторите шаги 1-3 и скопируйте вторую половину исходного документа Word в новый документ Word. Если обе половины документа преобразуются правильно, закройте другие работающие программы, включая приложение Office. Удалите файлы .TMP (они часто находятся в папке Windows/Temp).

Переустановите программы

Удалите Acrobat и Office или конкретное приложение Office (Word, PowerPoint или Excel). Переустановите Office или конкретное приложение Office, а затем переустановите Acrobat.

Чтобы удалить Acrobat используйте вкладку «Установка и удаление программ» на Панели управления. Для получения инструкций по удалению Office, см. документацию по Office или обратитесь в службу технической поддержки Microsoft.

Если документ Word защищен, снимите защиту

Для получения инструкций по удалению защиты, см. документацию Word или обратитесь в службу технической поддержки Microsoft. 

Устранение неполадок, связанных с конфликтами с другими макросами в Microsoft Word

PDFMaker может конфликтовать с другими макросами, например, антивирусами или программным обеспечением для факса. Если другие действия по устранению неполадок завершаются ошибкой или если в PDFMaker наблюдаются неполадки после установки макроса стороннего разработчика, устраните конфликты с другими макросами. Макросы, о которых известно, что они вызывают несовместимость, включают Duden Korrektor Plus 2.0, ViaVoice 10 и более ранние версии, Personal Translator 2002 Office Plus, OfficeReady Stuffit, Leuchter Informatic AG WordPlus и GoldMine Link для Word.

Чтобы определить, не конфликтует ли PDFMaker с другим макросом, удаляйте или отключайте другие макросы по отдельности (см. соответствующую ссылку ниже). После этого повторите попытку преобразования документа в формат PDF с помощью PDFMaker. Если неполадка больше не возникает, обратитесь к производителю этого макроса.

Устранение проблем при работе с Microsoft Word

Перечисленные ниже действия основаны на статьях из базы знаний Microsoft:

Более подробную информацию об устранении неполадок при работе с Microsoft Word см. на сайте Microsoft и ищите соответствующую статью.

Запустите Word с ключом /a и добавьте PDFMaker вручную

Ключ/a запускает Word без встраиваемых элементов и глобальных шаблонов (включая шаблон Normal), исключая их автоматический запуск.Ключ /a также блокирует файлы настройки; то есть, при использовании этого ключа, файлы настройки невозможно читать или изменять.

Примечание.  Все изменения в настройках, поьзовательские предпочтениях или макрокомандах, выполненные при работе с ключом /a при выходе из программы Word будут потеряны.

Для запуска Word используйте ключ /a:

  1. Выйдите из всех программ.
  2. Выберите «Пуск» > «Выполнить».
  3. В диалоговом окне «Запустить» введитеwinword.exe /a.
  4. Нажмите кнопку «OK». Диалоговое окно «Выполнить» закроется, и запустится Word.

Чтобы загрузить PDFMaker вручную (только для Acrobat 6.x):

  1. Выйдите из всех программ.
  2. Выберите «Инструменты» > «Шаблоны и надстройки».
  3. Выберите PDFMaker.dot (не PDFMakerA.dot) и нажмите «ОК».

    Появятся значки PDFMaker.

Для Acrobat 7.x, 8.x, 9.x, X (в зависимости от ситуации) 

Чтобы загрузить PDFMaker вручную (MS Word 2003 или более ранней версии):

  1. Выйдите из всех программ.
  2. Выберите «Инструменты» > «Настройки» и нажмите вкладку «Команды».
  3. Нажмите «Инструменты» на панели «Категории».
  4. Перетащите надстройку COM из панели «Команды» в меню «Инструменты», удерживая кнопку мыши нажатой. Когда меню «Инструменты» отобразит меню команд, перетащите надстройку COM непосредственно под функцию «Настройка», а затем отпустите кнопку мыши.
  5. Нажмите «Закрыть».
  6. Нажмите пункт «Надстройка COM» в меню «Инструменты».
  7. Нажмите «Добавить», найдите надстройку (надстройка PDFMaker находится в [путь-установки-Acrobat]\PDFMaker\Office\PDFMOfficeAddIn.dll) и нажмите «ОК».

  8. Нажмите комбинацию клавиш Alt+F11, чтобы запустить редактор Visual Basic.
  9. Нажмите Ctrl+G, чтобы запустить Immediate Window Visual Basic.
  10. Чтобы запустить PDFMaker в программе Word, введите Application.COMAddIns("PDFMaker.OfficeAddin").Connect = True Закройте диалоговое окно редактора Visual Basic.
  11. Убедитесь, что меню Adobe PDF теперь отображается справа от пункта «Справка» на панели меню Microsoft Word.

Загрузките PDFMaker вручную (MS Word 2007 и 2010).

  1. Выйдите из всех программ.
  2. Нажмите кнопку «Microsoft Office», а затем нажмите «Параметры Word».

  3. Нажмите «Надстройки».

  4. В списке управления нажмите «Надстройки COM», а затем нажмите «Перейти».

  5. Если надстройка «Acrobat PDFMaker COM» отображается и выбрана в диалоговом окне «Надстройки COM», выполните следующие действия. В противном случае перейдите к шагу 6.

  6. Снимите флажок «Надстройки Acrobat PDFMaker COM».

  7. Нажмите «ОК», чтобы закрыть диалоговое окно «Надстройки COM».

  8. Повторите шаги с 1 по 3, а затем установите флажок «Надстройки Acrobat PDFMaker COM» в диалоговом окне «Надстройки COM».

  9. Убедитесь, вкладка «Acrobat» отображается на панели MS Word.

  10. Если надстройка «Acrobat PDFMaker COM» НЕ отображается в диалоговом окне «Надстройки COM», выполните шаги 7-10 в разделе Загрузка PDFMaker вручную (MS Word 2003 или более ранние версии)

Создание тестового документа Word и запуск PDFMaker: 

  1. Наберите какой-нибудь текст в документе Word.
  2. Выберите «Файл» > «Сохранить» и сохраните тестовый документ на рабочем столе.
  3. Нажмите «Преобразовать в Adobe PDF».

Если вы решили свою проблему при запуске Word с ключом /a, то теперь удаляйте каждый из компонентов, загружаемых при запуске Word. Удалите эти компоненты по одному в том порядке, в котором они показаны в Word. Во время запуска Word загружаются следующие компоненты:

  • Автоматические макросы Word
  • Глобальный шаблон (Normal.dot)
  • Надстройки (WLL)
  • Шаблоны из папки автозагрузки Word и папки запуска Office
  • Надстройки COM
  • Ключ Word Data в реестре Windows
  • Ключ Word Options в реестре Windows
  • Автоматические макросы Word

Примечание. Для поиска дополнительных способов устранения неполадок при запуске Word обратитесь в следующие службы технической поддержки Microsoft:

Переименовать файл шаблонов Normal.dot

Для получения подробных инструкций о переименовании файла глобального шаблона, см. раздел «Глобальный шаблон (Normal.dotm или Normal.dot)» в справочной статье Microsoft «Сброс параметров пользователя и настроек реестра в Word». Прокрутите страницу вниз, чтобы получить доступ к статье.

Важно!  Не используйте ключ /a для перезапустка Word после того, как выполните все шаги.

Если вы решили свою проблему путем переименования глобального шаблона, значит, проблема была в поврежденном шаблоне Normal.dot. В ряде случаев требуется изменить некоторые настройки, чтобы восстановить ваши параметры. Если файл Normal.dot, переименованный вами, содержит настройки, например, стили, макросы или автотекст, которые будет сложно восстанавливать, попробуйте использовать Organizer для копирования этих настроек из старого файла Normal.dot. в новый.

Для получения дополнительной информации об использовании приложения Organizer, выполните следующие действия:

  1. Запустите Word.
  2. Выберите «Справка» > «Справка Microsoft Word».
  3. В Office Assistant или Answer wizard введите Organizer.

  4. Нажмите «Поиск», чтобы просмотреть разделы.

Если вы не решили свою проблему, попробуйте использовать старый глобальный шаблон (Normal.dot) вместо нового глобального шаблона. Чтобы использовать старый шаблон Normal.dot, переименуйте новый шаблон Normal.dot обратно в Normal.dot. Если проблема с PDFMaker после работы с этим документом не исчезнет, свяжитесь со службой поддержки Acrobat.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет