Узнайте, что делать, если замедляется вставка графического объекта или вы обнаружили непредвиденные данные в файлах Illustrator.

Проблема

Вставка иллюстраций в файл Illustrator выполняется значительно медленнее, чем предполагалось, или в целевом документе присутствуют непредвиденные глобальные объекты (например, палитры, символы и кисти).

Решения

Попробуйте одно или несколько из следующих решений, в зависимости от используемой версии приложения Illustrator.

Выберите свою версию Illustrator:

Исправьте неправильные имена внешних глобальных объектов (Mac и Windows; CS6 и CC)

  1. Убедитесь, что вы используете последнюю версию приложения Illustrator. Перейдите в раздел «Справка» > «Обновления» или обновите Illustrator через приложение Creative Cloud для настольных ПК.

  2. Загрузите прилагаемый ZIP-файл и извлеките содержащийся в нем сценарий (файл JSX).

    Загрузить

  3. Запустите Illustrator и выполните сценарий, выбрав меню «Файл» > «Сценарии» > «Другие сценарии» или перетащив его в программу. Появляется сообщение: «Установки fixBadPluginGlobalObjectNames включены».

  4. Если появляется сообщение «Установки fixBadPluginGlobalObjectNames отключены», выполните сценарий еще раз.

  5. Выйдите из Illustrator и снова запустите его, а затем откройте и сохраните затронутый файл Illustrator, чтобы убедиться, что он исправлен.

Решения для CS5 и более ранних версий

Чтобы устранить проблему в Illustrator CS5 и более ранних версиях, воспользуйтесь одним из двух решений, описанных ниже. Если с помощью первого решения проблему устранить не удалось, попробуйте второе.

Решение 1 (CS5 и более ранние версии): включите режим восстановления содержимого 

  1. Закройте приложение Illustrator.

  2. Найдите файл установок Adobe Illustrator. Например, файлы установок для Illustrator CS5 находятся здесь:

    • Mac OS: /[пользователь]/Library/Preferences/Adobe Illustrator CS5/[язык]
    • Windows 7/Vista: Users/[пользователь]/AppData/Roaming/Adobe/Adobe Illustrator CS5 Settings/[язык]/AIPrefs
    • Windows XP: Documents and Settings/[пользователь]/Application Data/Adobe/Adobe Illustrator CS5 Settings/AIPrefs

    Примечание.

    В ОС Windows файлы в папках Application и AppData по умолчанию скрыты. Если вам требуется помощь, чтобы отобразить скрытые файлы, см. раздел Отображение скрытых файлов.

  3. Откройте файл установок в редакторе неформатированного текста, например TextWrangler (Mac OS) или «Блокнот» (Windows). (Также можно использовать более привычную программу для обработки текста. В этом случае файл следует сохранить как неформатированный текст без возможности скрытого расширения .txt).

  4. В файле установок найдите раздел, который выглядит следующим образом:

    /aiFileFormat {

    /PDFCompatibility 1

    /enableATEReadRecovery 0

    /enableContentRecovery 0

    /enableATEWriteRecovery 0

    /clipboardPSLevel 3

    }

  5. Измените значение enableContentRecovery с 0 на 1. Если в разделе /aiFileFormat не существует строки enableContentRecovery, добавьте ее. После редактирования она должна выглядеть следующим образом:

    /enableContentRecovery 1

  6. Сохраните файл установок без возможности изменения имени или расширения.

Решение 2 (CS5 и более ранние версии): отредактируйте восстановленный файл 

  1. Запустите Illustrator.
  2. Чтобы открыть документ, выберите «Файл» > «Открыть» или нажмите сочетание клавиш Command + O.

    Не открывайте документ, используя двойной щелчок мыши на файле, список последних файлов или перетаскивание файла на значок программы Illustrator.  

  3. В диалоговом окне навигации по файловой системе выберите файл, который необходимо восстановить.

  4. Нажмите клавиши Command + Option + Shift (Mac OS) или Ctrl + Alt + Shift (Windows), а затем нажмите кнопку «Открыть» в диалоговом окне «Открыть».

  5. Закройте открывшееся пустое окно без сохранения.

  6. Через программу Finder (Mac OS) или Проводник Windows (Windows) в том же каталоге, где содержался исходный файл, вы найдете его дубликат с символом подчеркивания в начале названия. Например, при открытии «BrokenFile.ai» новый файл получит имя «_BrokenFile.ai».

  7. Откройте файл с подчеркиванием в редакторе неформатированного текста, например в TextWrangler (Mac OS) или UltraEdit (Windows). (Пользователи Windows могут также использовать WordPad или Notepad). Открытие большого нерабочего файла может занять некоторое время. Если ваш текстовый редактор имеет ограничение на максимальный размер открываемых файлов, используйте другую программу.

  8. В подчеркнутом файле найдите все случаи употребления следующего комментария:

    %AI8_BeginPluginObject

  9. Проверьте следующую строку на соответствие одной из перечисленных ниже строк:
    (Adobe Calligraphic Brush Tool)
    (Adobe Scatter Brush Tool)
    (Adobe ArtOnPath Brush Tool)
    (Adobe Pattern Brush Tool)

  10. Если такая строка не соответствует одной из этих 4 строк в точности (включая регистр), выделите весь текст внутри комментария %AI8_BeginPluginObject и первого последующего комментария %AI8_EndPluginObject. Затем удалите сами комментарии и выделение.

  11. Повторите действия 9 и 10 для каждого случая употребления комментария %AI8_BeginPluginObject в данном файле.

  12. Сохраните файл.
  13. Откройте файл в Illustrator.
  14. Удалите сначала все символы, а затем все кисти. При подозрении, что в файле содержатся необходимые символы или мазки кисти, запустите действие «Удалить неиспользуемые элементы панели» (выберите «Операции»> «Удалить неиспользуемые элементы палитры», а затем нажмите «Выполнить выделенную команду»).  

  15. Сохраните файл под новым именем (например, «Fixed File.ai»).

  16. (Обязательно) Закройте файл.

  17. Откройте файл в Illustrator. Чтобы убедиться в исправности файла, выделите любой объект, скопируйте его и вставьте в новый пустой файл.

Дополнительная информация

Непредвиденное содержимое возникает из-за проблем, которые уже исправлены в текущей версии программы Illustrator, но существуют в документах, сохраненных в предыдущих версиях. При работе с документом, сохраненным в предыдущей версии Illustrator, его открытие в текущей версии не всегда позволяет устранить проблему.

Непредвиденные глобальные объекты могут отображаться или не отображаться на соответствующих панелях. Попытки удалить непредвиденные глобальные объекты могут не увенчаться успехом. Также они могут привести к нестабильности и внезапному отключению Illustrator.

При сохранении документа значительное увеличение его размера свидетельствует о добавлении большого количества глобальных объектов. Прежде чем эти некорректные данные будут замечены, они могут уже долгое время существовать в документе, поэтому возврат к предыдущим версиям не всегда позволяет устранить проблему. Некорректные данные могут распространяться при копировании иллюстраций из одного документа в другой.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет