Узнайте, как ускорить и оптимизировать работу приложения Illustrator в macOS.

На скорость и эффективность работы Adobe Illustrator влияют несколько факторов. Например, операционная система и конфигурация оборудования, рабочий процесс, выбранные параметры. Если приложение Illustrator работает медленнее, чем обычно, существует несколько методов, которые помогут оптимизировать производительность не только программы Illustrator, но и других приложений.

Повышение производительности заметнее во время работы с большими файлами.

Приступая к работе

Перед тем как выполнить описанные ниже шаги, убедитесь, что вы используете последнюю версию Illustrator и что установлены все обновления для используемой версии. Обновление программного обеспечения часто включают исправления и улучшения, связанные с производительностью.

Если вы используете Illustrator CC, вы можете обновить его с помощью приложения Creative Cloud для настольных ПК.

Оптимизация macOS

Настройка и эффективное использование операционной системы позволяют увеличить объем доступной памяти для приложений, что помогает оптимизировать их работу. Попробуйте описанные ниже методы оптимизации macOS, чтобы повысить производительность приложения Illustrator.

Управляйте шрифтами

Каждый из установленных шрифтов увеличивает объем оперативной памяти, используемой системой macOS. Устанавливайте только необходимые шрифты. Это повысит производительность системы и приложений, которые их используют. Используйте служебную программу управления шрифтами для управления большим количеством шрифтов.

Используйте драйвер принтера PostScript

Драйверы других принтеров могут конфликтовать с приложением Illustrator. Поэтому компания Adobe рекомендует установить драйвер принтера PostScript в качестве принтера по умолчанию в macOS.

Шаг 1. Задайте принтер PostScript в качестве принтера по умолчанию

Примечание.

Чтобы завершить эту процедуру, убедитесь, что принтер PostScript подключен к компьютеру напрямую или через сеть.

  1. В меню Apple выберите System Preferences («Системные настройки»), а затем нажмите значок Printers & Scanners («Принтеры и сканнеры»).

  2. Если принтер PostScript не отображается в списке, нажмите значок +, выберите принтер PostScript и нажмите Add («Добавить»).

  3. Выберите принтер PostScript во всплывающем меню Default printer («Принтер по умолчанию»).

Шаг 2. Настройте Illustrator для печати на принтере, не заданном по умолчанию.

  1. Откройте любой документ в приложении Illustrator и выберите меню «Файл» > «Печать».

  2. В диалоговом окне «Печать» выберите «Файл Adobe PostScript» или имя принтера в меню «Принтер».

  3. Нажмите кнопку «Сохранить».

Оптимизируйте конфигурацию оборудования

Используемое оборудование влияет на производительность приложения Illustrator: чем мощнее процессор или чем выше производительность жесткого диска, тем быстрее Illustrator обрабатывает информацию. Такие улучшения оборудования, как установка дополнительного объема ОЗУ, использование многопроцессорной системы или оптимизация и дефрагментация дисков, также могут повысить производительность. Попробуйте описанные ниже методы оптимизации конфигурации оборудования для повышения производительности приложения Illustrator.

Используйте более мощный процессор

Скорость центрального процессора (ЦП) компьютера влияет на скорость работы приложения Illustrator. Поскольку Illustrator управляет большим количеством данных и выполняет многочисленные вычисления, скорость его работы во многом зависит от скорости процессора. Подумайте об использовании компьютера с более быстрым процессором.

Установите дополнительные модули ОЗУ

Если объема ОЗУ недостаточно для работы приложения Illustrator, оно использует место на жестком диске (например, рабочий диск) для обработки информации. Максимальной скорости работы приложения Illustrator можно достичь, если информация обрабатывается в памяти без использования места на жестком диске.

Оптимизируйте свободное место на жестком диске

Ниже приведены несколько способов оптимизации места на диске:

  • Проверьте свой жесткий диск на наличие ошибок или дефрагментированных файлов с помощью служебной программы для работы с дисками стороннего производителя (например, Norton Utilities). В macOS дефрагментацию выполнять не нужно, но может потребоваться восстановление с помощью служебной программы для работы с дисками стороннего производителя.
  • Сохраняйте файлы на дисках с высокой скоростью чтения/записи. Например, лучше использовать внутренний жесткий диск компьютера, чем сетевой сервер (сетевой диск) или внешний диск.

Эффективно используйте функции приложения Illustrator

Производительность приложения Illustrator зависит от способа работы с ним, особенно от режима просмотра графических объектов. Ниже описаны функции приложения Illustrator, которые помогут оптимизировать скорость его работы.

Работайте в режиме просмотра «Контуры»

В режиме «Контуры» скрываются атрибуты цвета, и отображаются только внешние очертания графического объекта на иллюстрации. Работа в режиме Показа контура позволяет ускорить отображение сложного изображения, например, объектов, содержащих градиенты и узоры. Режим Показа контура упрощает редактирование объектов, скрытых за другими объектами с заливкой.

Для отображения документа Illustrator в режиме показа контура выберите «Вид» > «Контур».

Создавайте пользовательские представления

Вы можете создавать пользовательские представления документа. Пользовательские представления позволяют быстро изменить режим просмотра, масштаб, позицию прокрутки и параметры слоя.

Для создания пользовательского представления документа Illustrator, задайте атрибуты представления, которые необходимо сохранить. Затем выберите «Вид» > «Создать вид» и введите имя в диалоговом окне «Создать вид». Пользовательский вид появится в меню «Вид».

Измените настройки растровых эффектов

Чтобы оптимизировать производительность приложения Illustrator, можно изменить разрешение растровых эффектов.

Чтобы изменить разрешение растровых эффектов, выберите «Эффекты» > «Параметры растровых эффектов в документе» и выберите одно из следующих значений в раскрывающемся списке «Разрешение» :

  • При редактировании файлов выберите «Экран». Illustrator использует разрешение 72-ppi для растровых эффектов, повышая скорость отображения.
  • Для печати файлов выберите «Высокое». Illustrator использует разрешение 300-ppi для растровых эффектов, снижая скорость печати, но повышая ее качество.

Затем нажмите ОК.

Скройте слои и удалите миниатюры

Illustrator перерисовывает экран быстрее, если скрыть слои, содержащие сложные графические объекты или растровые изображения высокого разрешения.

Чтобы скрыть слой, щелкните значок с изображением глаза слева от имени слоя, отмените выбор параметра «Показать слои» и нажмите кнопку ОК. Чтобы скрыть все слои, кроме выделенного, нажмите значок с изображением глаза, удерживая нажатой клавишу Alt.

Палитра «Слои» может отображать миниатюры для слоев верхнего уровня, вложенных слоев, групп и объектов. Для ускорения перерисовки экрана в приложении Illustrator уменьшите количество миниатюр, выбрав пункт «Параметры палитры» в меню палитры «Слои», и уменьшите количество миниатюр.

  • Чтобы удалить все миниатюры в палитре «Слои», выберите«Маленькие» в разделе «Размер строк» и нажмите кнопку ОК.
  • Чтобы удалить миниатюры для конкретных элементов в палитре «Слои», отмените выбор параметра «Слои», «Группы» или «Объекты» в разделе «Миниатюры» и нажмите кнопку ОК.

Отключите режим просмотра наложения цветов

Режим наложения позволяет увидеть, как приблизительно будут выглядеть эффекты перехода, прозрачности и наложения красок при выводе с использованием цветоделения. Чтобы улучшить производительность, старайтесь не использовать режим просмотра наложения.

Для включения или отключения просмотра наложения цветов выберите «Вид» > «Просмотр наложения цветов».

Удалите неиспользуемую монтажную область

Монтажные области представляют собой области, которые могут содержать печатаемые графические объекты. Оптимизировать производительность можно, удалив неиспользуемые или ненужные монтажные области.

Для управления монтажными областями выберите «Окно» > «Монтажные области». Затем выберите монтажную область, которую нужно удалить, и нажмите кнопку «Удалить».

Измените установки рабочего диска

Если во время работы со встроенным растровым изображением системе не хватает ОЗУ, приложение Illustrator использует в качестве рабочего диска место на жестком диске. Получение информации из жесткого диска занимает больше времени, чем из памяти. Поэтому использование части жесткого диска как виртуальной памяти может привести к снижению производительности. Если вам требуется больше памяти для работы в Illustrator, попробуйте увеличить объем ОЗУ.

По умолчанию Illustrator использует системный диск в качестве основного рабочего диска. Выберите для рабочего диска Illustrator самый быстрый жесткий диск.

Чтобы изменить установки рабочего диска, выполните следующие действия:

  1. Выберите Illustrator > «Установки» > «Подключаемые модули и рабочий диск».

  2. Выберите жесткий диск из главного всплывающего меню. Если планируется работа с большими изображениями и имеется более чем один жесткий диск, выберите другой диск из дополнительного всплывающего меню.
  3. Нажмите кнопку ОК и перезапустите Illustrator.

Удалите неиспользуемые элементы из профилей документов

Профили документов Illustrator содержат узоры, градиенты, модели диаграмм, цвета, библиотеки цветов и кисти по умолчанию, которые отображаются в новых документах Illustrator. Эти файлы также определяют масштаб, размер окна, параметры просмотра и положение прокрутки для новых документов. Уменьшите размер новых документов, удалив ненужные цветовые образцы и кисти из профилей новых документов Illustrator.

Подробнее о создании пользовательских профилей документов см.Профили запуска – удобный инструмент для настройки новых документов.

Удалите неиспользуемые элементы из шаблонов

Шаблоны позволяют создавать документы с общими параметрами и элементами дизайна. Можно уменьшить размер файла новых документов путем удаления из шаблонов ненужных образцов, символов, стилей графики и кистей.

Подробнее о создании шаблонов файлов см. в разделе Файлы и шаблоны.

Используйте функцию связи для изображений

Встроенные растровые изображения (например, TIFF, BMP или Photoshop EPS) могут значительно увеличить размер документа Illustrator, снижая общую производительность. Чтобы повысить производительность, включите параметр «Ссылка» при размещении растрового изображения. Будет установлена связь с файлом, размещенном на жестком диске.

  • Выберите команду «Файл» > «Поместить». В диалоговом окне «Поместить» установите флажок «Связь».

Если для бюро допечатной подготовки требуется наличие встроенных изображений, сохраните копию файлов. Выберите пункт «Включить связанные файлы» в диалоговом окне «Параметры исходных форматов Illustrator» или «Параметры формата EPS».

Используйте для просмотра файлов EPS режим с низким разрешением

Если документ содержит связанные файлы EPS с изображениями предварительного просмотра с высоким разрешением, Illustrator обновляет экран медленнее при редактировании иллюстрации. Для ускорения обновления экрана приложением Illustrator используйте изображения предварительного просмотра EPS с низким разрешением. Выполните следующие действия:

  1. Выберите Illustrator > «Установки» > «Обработка файлов и буфер обмена».

  2. Выберите «Использовать прокси с низким разрешением для связанных файлов EPS» и нажмите ОК.

Отмените выбор параметра «Показать взаимодействие прозрачных областей DCS»

Диалоговое окно «Параметры палитры» меню «Связи» содержит пункт «Показать взаимодействие прозрачных областей DCS». Если выбран этот параметр, на палитре «Связи» отображается желтый значок, который указывает на связанные графические объекты DCS или EPS, которые являются прозрачными или наложены на прозрачные объекты. Поскольку при использовании этого параметра постоянно проверяется взаимодействие связанных файлов EPS с прозрачными областями, это может привести к снижению производительности приложения Illustrator.

Чтобы отключить параметр «Показать взаимодействие прозрачных областей DCS», выполните следующие действия:

  1. Выберите команду «Окно» > «Связи». В меню палитры «Связи» выберите «Параметры палитры».

  2. Удалите флажок «Показать взаимодействие прозрачных областей DCS» и нажмите ОК.

Скройте палитру «Навигатор»

Для удобства навигации в палитре «Навигатор» отображается миниатюра текущего графического объекта. Количество времени, необходимое для обновления миниатюры при изменении документа, зависит от сложности графического объекта. Чтобы повысить скорость перерисовки экрана и производительность при работе со сложным документом, скройте палитру «Навигатор».

  • В меню «Окно» удалите флажок «Навигатор».

Можно настроить пользовательские виды для более эффективного масштабирования отдельных областей документа.

Отмените выбор параметра «Сглаживание графических объектов»

Параметр «Сглаживание графических объектов» выравнивает текст и графику путем смешивания цвета крайних пикселей объекта с цветом соседних пикселей. Однако этот процесс может замедлить перерисовку экрана. Чтобы отключить этот параметр, выполните следующие действия:

  1. Выберите Illustrator > «Установки» > «Общие».

  2. Отмените выбор параметра «Сглаживание графических объектов» и нажмите кнопку ОК.

Примените команду «Упростить»

Команда «Упростить» уменьшает количество опорных точек в контурах и формах контура, уменьшая размер файла и увеличивая производительность. Чтобы применить команду «Упростить», выберите необходимый контур или объект, а затем выберите команду «Объект» > «Контур» > «Упростить».

Дополнительные сведения о команде «Упростить» см. в разделе Редактирование контуров.

Выключите «быстрые» направляющие

«Быстрые» направляющие помогают создать, выровнять, отредактировать и трансформировать объекты Illustrator по отношению к другим объектам. Если на иллюстрации имеется много объектов, приложению Illustrator нужно больше времени для отображения «быстрых» направляющих.

  • Чтобы отключить быстрые направляющие, выберите меню «Просмотр» и удалите флажок «Быстрые направляющие».

Получите более подробную информацию о «быстрых» направляющих.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет