Узнайте о том, как заставить Illustrator работать быстро и эффективно в ОС Windows.

На скорость и эффективность работы Adobe Illustrator влияют несколько факторов, таких как операционная система, конфигурация оборудования, рабочий процесс и выбранные параметры. Если вы заметили, что Illustrator работает медленнее, чем обычно, попробуйте эти методы для оптимизации производительности не только Illustrator, но и других приложений.(Улучшение производительности более заметно при работе с большими файлами.)

Приступая к работе

Перед выполнением описанных ниже задач установите последнюю версию Illustrator или все обновления к версии, которую вы используете. Обновление программного обеспечения часто включают исправления и улучшения, связанные с производительностью. 

Если вы используете Illustrator CC, вы можете обновить Illustrator через приложение Creative Cloud для настольных ПК.

Примечание.

Процедуры в этом документе основаны на настройках интерфейса. Если интерфейс изменен, некоторые процедуры могут отличаться. Например, путь для перехода к Панели управления может отличаться. Выберите Пуск > Параметры > Панель управления или Пуск > Панель управления в зависимости от версии Windows.Для получения советов по устранению неисправностей и общих сведений о Windows, свяжитесь со Службой поддержки Adobe, а также службой поддержки Microsoft.

Оптимизация Windows

Настраивая операционную систему для эффективной работы, вы можете увеличить объем памяти, доступной для приложений, что позволит им работать плавнее. Вот несколько способов оптимизации Windows и повышения быстродействия Illustrator.

Увеличить объем доступной памяти

Виртуальная память позволяет использовать жесткий диск для хранения информации, которая обычно хранится в оперативной памяти. Но доступ к информации на жестком диске занимает больше времени, чем доступ к информации в памяти. Таким образом, если система слишком сильно зависит от виртуальной памяти, производительность может снизиться.

Для увеличения производительности выберите подходящий размер файла подкачки (области жесткого диска, который хранит виртуальную память). Для изменения размера файла подкачки требуются права администратора. Illustrator работает лучше всего, если максимальный размер файла подкачки приблизительно в три раза превышает объем оперативной памяти.

  1. Закройте все приложения.

  2. Выберите «Пуск» > «Панель управления» > «Система» > «Дополнительные параметры системы».

  3. В диалоговом окне «Свойства системы» выберите вкладку «Дополнительно».

  4. Щелкните «Параметры» в разделе «Быстродействие», а затем выберите вкладку «Дополнительно».

  5. В разделе «Виртуальная память» нажмите « Изменить».

  6. Снимите флажок «Автоматически управлять размером файла подкачки для всех дисков».

  7. Выберите из списка жесткий диск, объем свободного места на котором не менее трех раз превышает объем установленной оперативной памяти компьютера. Например, если на компьютере установлено 64 МБ оперативной памяти, выберите жесткий диск, на котором есть не менее 192 МБ свободного места. Для лучшей производительности выберите жесткий диск, который не используется как рабочий диск Illustrator.

Отключить функции драйвера

Драйверы некоторых видеоадаптеров обеспечивают дополнительные параметры для ускорения или изменения отображения графики. Иногда эти параметры могут отрицательно повлиять на перерисовку экрана в Illustrator. Попробуйте отключить специфические функции драйвера, чтобы определить оптимальные настройки для использования с Illustrator. Дополнительные сведения см. в документации к видеоадаптеру.

Управляйте шрифтами

Каждый из установленных шрифтов увеличивает объем оперативной памяти, используемой ОС Windows. Для повышения производительности системы и приложений, использующих шрифты, устанавливайте только необходимые шрифты. Используйте служебную программу управления шрифтами для управления большим количеством шрифтов.

Ограничьте приложения, которые запускаются при старте системы

Приложения, которые запускаются автоматически с Windows конкурируют с Illustrator за доступную оперативную память. Чтобы отключить автоматический запуск приложений выполните следующие действия:

  1. Закройте все приложения.

  2. Запустите Проводник Windows.
  3. Отключите автозапуск приложений для текущего пользователя, переместив все значки и ярлыки из папки Автозагрузка (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) в другую папку.

  4. Перезагрузите Windows.

Для закрытия приложений, автозапуск которых прописан в реестре, выполните следующие действия:

  1. Перезагрузите Windows.
  2. Нажмите Ctrl+Shift+Esc.

  3. Перейдите на вкладку «Процессы».

  4. Щелкните по имени приложения, а затем нажмите Снять задачу.

  5. Перезапустите illustrator. Если производительность Illustrator повысилась, обратитесь к производителю приложения с просьбой помочь отключить его автозапуск. Повторите шаги 2–5 для всех остальных приложений, загружающихся автоматически.

Восстановите значки и ярлыки

Если после перезапуска производительность Illustrator не повысилась, верните значки и ярлыки в папку Автозагрузка.

Если производительность Illustrator повысилась, определите основные причины проблемы с производительностью, поочередно возвращая значки и ярлыки приложений в папку Автозагрузка.

Перезапустите компьютер после восстановления нескольких значков и ярлыков и проверьте производительность Illustrator.

Повторяйте эту процедуру до тех пор, пока производительность Illustrator не снизится. Обнаружив значок или ярлык приложения, которое является причиной проблемы с производительностью, удалите его снова. Обратитесь к производителю приложения, чтобы проверить наличие обновлений.

Оптимизация оборудования

Используемое вами оборудование влияет на производительность Illustrator: чем быстрее процессор или жесткий диск, тем быстрое Illustrator может обрабатывать данные. Другие улучшения оборудования, как например, установка дополнительного объема оперативной памяти, использование многопроцессорной системы, оптимизация и дефрагментация дисков, также могут повысить производительность. Попробуйте эти методы повышения быстродействия.

Используйте более быстрый процессор

Скорость центрального процессора вашего компьютера влияет на скорость работы Illustrator. Поскольку Illustrator обрабатывает большое количество данных и выполняет множество вычислений, скорость его работы зависит от скорости процессора. Подумайте об использовании компьютера с более быстрым процессором.

Установите дополнительные модули ОЗУ

Если приложению Illustrator недостаточно оперативной памяти, оно использует жесткий диск (виртуальную память, рабочий диск или и то, и другое) для обработки данных. Быстрее всего Illustrator работает, если может обрабатывать данные в памяти, не используя жесткий диск.

Оптимизируйте свободное место на жестком диске

Ниже приведены несколько способов оптимизации места на диске:

  • Проверьте жесткий диск на наличие ошибок, дефрагментируйте файлы и с оптимально используйте свободное место на жестком диске с помощью программ CHKDSK.exe и Дефрагментация диска. Дополнительные сведения см. в документации Windows или в разделе Повышение производительности Windows.
  • Сохраните файлы на диски с более высокой скоростью доступа. Например, можно использовать внутренний жесткий диск компьютера, а не сетевой сервер (сетевой диск) или внешний диск.
  • Если необходимо сохранить файл в сети или на внешний диск, сначала сохраните файл на внутренний жесткий диск компьютера. Затем закройте файл и используйте Проводник Windows, чтобы скопировать его в сеть или на внешний диск.

Использование принтера PostScript

Для получения наилучших результатов печати из Illustrator используйте принтер PostScript. Большинству не-PostScript принтеров необходима информация об отображении, ресурсы компьютера и специализированные драйверы принтера для передачи данных печати на принтер. Поэтому печать на них может выполняться гораздо медленнее, чем на принтере PostScript.

Эффективно используйте возможности Illustrator

То, как вы работаете в Illustrator — особенно способ просмотра графических объектов — может влиять на быстродействие Illustrator. Ниже описаны способы использования возможностей Illustrator более эффективно.

Работайте в режиме Показа контура

Режим Показа контура позволяет скрыть атрибуты заливки, отображая графический объект как незаполненные контуры. Работа в режиме Показа контура позволяет ускорить отображение сложного изображения, например, объектов, содержащих градиенты и узоры. Режим Показа контура упрощает редактирование объектов, скрытых за другими объектами с заливкой.

Для отображения документа Illustrator в режиме Показа контура выберите Вид > Контур.

Создавайте пользовательские представления

Вы можете создавать пользовательские представления документа. Пользовательские представления позволяют быстро изменить режим просмотра, масштаб, позицию прокрутки и параметры слоя.

Для создания пользовательского представления документа Illustrator, задайте атрибуты представления, которые необходимо сохранить. Затем выберите Вид > Создать вид и введите имя в диалоговом окне «Создать вид». Пользовательский вид появится в меню «Вид».

Измените параметры растровых эффектов

Для оптимизации производительности Illustrator вы можете изменить разрешение растровых эффектов.

Для изменения растровых эффектов выберите Эффект» > Параметры растровых эффектов в документе. Во всплывающем меню «Разрешение» выполните одно из следующих действий:

  • Выберите Экран, если вы редактируете файлы. Illustrator использует разрешение 72 пикселя/дюйм для растровых эффектов, увеличивая скорость отображения.
  • Выберите Высокое, если вы печатаете файлы. Illustrator использует разрешение 300 пикселей/дюйм для растровых эффектов, снижая скорость печати, но повышая качество печати.

Затем нажмите ОК.

Скрывайте слои и удаляйте эскизы

Используйте панель «Слои» для организации и изменения графических объектов. Если скрыть слои, которые содержат сложные графические объекты или растровые изображения высокого разрешения, Illustrator обновляет экран быстрее.

Чтобы скрыть слой, щелкните по значку с изображением глаза слева от имени слоя. Чтобы скрыть все слои, кроме выделенного, щелкните по значку с изображением глаза, удерживая нажатой клавишу Alt (Option в Mac OS).

Панель «Слои» может отображать эскизы слоев верхнего уровня, вложенных слоев, групп и объектов. Для уменьшения количества эскизов и ускорения отрисовки экрана в Illustrator выберите «Параметры панели» в меню панели «Слои», а затем уменьшите количество эскизов.

Панель параметров

Отключите просмотр наложения

Режим наложения позволяет увидеть, как приблизительно будут выглядеть эффекты перехода, прозрачности и наложения красок при выводе с использованием цветоделения. Чтобы улучшить производительность, старайтесь не использовать режим просмотра наложения.

Для включения или отключения просмотра наложения цветов выберите Вид > Просмотр наложения цветов.

Удалите неиспользуемые монтажные области

Монтажные области представляют собой области, которые могут содержать печатаемые графические объекты. Для оптимизации производительности подумайте об удалении неиспользуемых или ненужных монтажных областей.

Для управления монтажными областями выберите Окно > Монтажные области. Выберите монтажную область, которую хотите удалить и нажмите Удалить.

Изменение параметров рабочего диска

При работе со встроенным растровым изображением на системе с недостаточным количеством оперативной памяти Illustrator использует дисковое пространство в качестве рабочего диска. Доступ к информации на жестком диске занимает больше времени, чем доступ к информации в памяти. Таким образом, использование жесткого диска в качестве виртуальной памяти может привести к снижению производительности. Если вам требуется больше памяти для работы в Illustrator, Adobe рекомендует установить дополнительный модуль ОЗУ.

По умолчанию Illustrator использует системный диск в качестве основного рабочего диска. Выберите для рабочего диска Illustrator самый быстрый жесткий диск.

Чтобы изменить установки рабочего диска, выполните следующие действия:

  1. Выберите «Правка» > «Установки» > «Подключаемые модули и рабочий диск».

  2. Выберите жесткий диск во всплывающем меню «Вторичный». Если вы работаете с крупными изображениями, и в компьютере имеется более одного жесткого диска, выберите другой диск во всплывающем меню «Вторичный».

  3. Нажмите кнопку ОК и перезапустите Illustrator.

Удалите неиспользуемые элементы из профилей документов

Профили документов Illustrator содержат узоры, градиенты, модели диаграмм, цвета, библиотеки цветов и кисти по умолчанию, которые отображаются в новых документах Illustrator. Эти файлы также определяют масштаб, размер окна, параметры просмотра и положение прокрутки для новых документов. Уменьшите размер новых документов, удалив ненужные цветовые образцы и кисти из профилей новых документов Illustrator.

Подробности о создании пользовательских профилей документа в Illustrator приведены в разделе «Профили запуска: Удобный инструмент для настройки новых документов».

Удалите неиспользуемые элементы из шаблонов

Шаблоны позволяют создавать документы с общими параметрами и элементами дизайна. Можно уменьшить размер файла новых документов путем удаления из шаблонов ненужных образцов, символов, стилей графики и кистей.

Подробнее о создании файлов шаблонов см. раздел «Файлы и шаблоны».

Включите ссылки на изображения

Встроенное растровое изображение (например, TIFF, BMP или Photoshop EPS) может значительно увеличить размер документа Illustrator, снижая общую производительность. Чтобы повысить производительность, включите параметр «Ссылка» при размещении растрового изображения. Будет установлена связь с файлом, размещенном на жестком диске.

  • Выберите «Файл» > «Разместить». В диалоговом окне «Поместить» установите флажок «Связь».

Если для бюро допечатной подготовки требуется наличие встроенных изображений, сохраните копию файлов. Выберите пункт «Включить связанные файлы» в диалоговом окне «Параметры исходных форматов Illustrator» или «Параметры формата EPS» .

Используйте для просмотра файлов EPS режим с низким разрешением

Если документ содержит связанные файлы EPS с изображениями предварительного просмотра с высоким разрешением, Illustrator обновляет экран медленнее при редактировании иллюстрации. Для ускорения обновления экрана приложением Illustrator используйте изображения предварительного просмотра EPS с низким разрешением. Выполните следующие действия:

  1. Выберите «Правка» > «Установки» > «Обработка файлов и буфер обмена».

  2. Выберите «Использовать прокси с низким разрешением для связанных файлов EPS» и нажмите ОК.

Показать взаимодействие прозрачных областей DCS

Диалоговое окно «Параметры панели ссылок» содержит параметр «Показать взаимодействие прозрачных областей DCS». Если этот параметр выбран, на панели «Ссылки» отображается желтый значок, указывающий на наличие прозрачной связанной графики DCS EPS, или объектов, перекрывающих другие прозрачные объекты. Поскольку этот параметр заставляет Illustrator регулярно проверять взаимодействие связанных файлов EPS с прозрачными областями, это может привести к снижению производительности.

Чтобы отключить параметр «Показать взаимодействие прозрачных областей» выполните следующие действия:

  1. Выберите «Окно» > «Ссылки». В меню панели «Ссылки» выберите «Параметры панели».

  2. Снимите флажок «Показать взаимодействие прозрачных областей DCS» и нажмите ОК.

Скройте панель «Навигатор»

Панель «Навигатор» отображает в виде эскизов текущий графический объект для удобства навигации. Время обработки, необходимое для обновления эскизов при каждом изменении документа зависит от сложности графических объектов. Чтобы повысить скорость обновления экрана в сложных документах, скройте панель «Навигатор». В меню «Окно» снимите флажок «Навигатор.

Можно настроить пользовательские виды для более эффективного масштабирования отдельных областей документа.

Отключите сглаживание объектов

Параметр «Сглаживание объектов» выравнивает текст и графику путем смешивания цвета пикселей по краям объекта с цветом смежных пикселей. Однако этот процесс может снизить скорость обновления экрана. Чтобы отключить этот параметр, выполните следующие действия:

  1. Выберите «Правка» > «Установки» > «Общие».

  2. Отмените выбор параметра «Сглаживание графических объектов» и нажмите кнопку ОК.

Примените команду «Упростить»

Команда «Упростить» уменьшает количество опорных точек в контурах и формах контура, уменьшая размер файла и увеличивая производительность. Чтобы применить команду «Упростить», выберите необходимый контур или объект, а затем выберите команду «Объект» > «Контур» > «Упростить».

Дополнительные сведения о команде «Упростить» см. в Справке Illustrator.

Выключите Быстрые направляющие

Быстрые направляющие обеспечивают создание, выравнивание, редактирование и преобразование объектов Illustrator по отношению к другим объектам. Если в файле много графических объектов Illustrator требует больше времени для отображения быстрых направляющих. Для отключения быстрых направляющих в меню «Вид» снимите флажок «Быстрые направляющие».

Дополнительную информацию о быстрых направляющих см. в разделе «Линейки, сетки, направляющие и метки обреза».

Растрируйте контуры кисти из щетины и отключите возможности PDF

Мазки кисти из щетины формируются из нескольких перекрывающихся прозрачных контуров с заливкой. Как любые другие контуры с заливкой в Illustrator эти контуры взаимодействуют с заливкой других объектов, включая другие контуры кисти из щетины.

Поэкспериментируйте с инструментами группы «кисть из щетины» и параметрами воспроизведения краски перед началом работы с большими графическими объектам. Изменение атрибутов кистей и применение изменений ведет к повторному отображению всех используемых кистей.

При использовании кистей из щетины можно уменьшить сложность и размер файла документа. Для этого выполните следующие действия:

  • Растрируйте некоторые контуры кисти из щетины. Не забудьте сохранить копию исходного графического объекта перед растрированием.

Если иллюстрация содержит большое количество (> 30) кистей из щетины, уменьшите сложность и количество контуров кистей из щетины. Выберите контуры, выполненные кистью из щетины, и выберите команду «Объект» > «Растрировать».

  • Отключите возможности PDF.

По умолчанию Illustrator сохраняет данные PDF, которые обеспечивают совместимость файлов Illustrator (*ai) с другими приложениями Adobe. Выберите «Файл» > «Сохранить» или «Файл» > «Сохранить как» и нажмите «Сохранить».В диалоговом окне «Параметры Illustrator» снимите флажок « Создать PDF-совместимый файл».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет