Устранение проблем с сохранением файлов

Возникают проблемы при сохранении файла в Illustrator? Ниже приведены инструкции по устранению неполадок, которыми вы можете воспользоваться.

Если будет обнаружено, что файл .ai поврежден, попробуйте выполнить следующие действия, чтобы восстановить содержимое поврежденного файла:

Решение

Шаги 

Сохранение файла в другом формате

  • Измените расширение файла .ai на другой формат (.svg, .png, .jpg), затем попробуйте снова сохранить файл.
  • Сохранение файла в формате Post-Script (PS)
    1. Выберите Файл > Печать.
    2. Укажите требуемые параметры печати.
    3. Выберите Файл Adobe Postscript в меню Принтер, а затем нажмите Сохранить.
    4. Введите имя файла, которое включает расширение .ps (например, Файл.ps), а затем нажмите ОК (Windows) или Сохранить (MacOS).
    5. Откройте файл PostScript в Illustrator, а затем попытайтесь сохранить его в формате .ai.

Примечание. Для выполнения этой задачи у вас должен быть установлен драйвер принтера PostScript. Информацию об установке принтеров Postscript в Windows см. в справке Windows.

Копирование содержимого в новый файл

  • Удалите из графического объекта ненужные элементы, такие как лишние точки, незакрашенные объекты и пустые текстовые контуры. Выберите Объект > Контур > Очистить.
  • Сохраните слои для графического объекта в новом файле. На панели «Слои» > Дополнительные параметры выберите Вклеить на прежние слои.
  • Выберите графический объект и нажмите Правка > Копировать.
  • Выберите Файл > Создать , чтобы создать новый файл.
  • В новом файле выберите Редактировать > Вставить спереди, чтобы вставить графический объект в нужном месте на странице.

Выявление и удаление поврежденных компонентов

Чтобы определить, поврежден ли объект, удалите его из нового файла, а затем сохраните и снова откройте файл. 

  • Определение поврежденного узора, градиента или дополнительного цвета
    • Нажмите Правка Выделить все и измените заливку и обводку для преобразования в черный цвет.
    • Если проблема не повторяется в новом файле, заново создайте узор, градиент или плашечный цвет в исходном файле.
      Примечание. Может исчезнуть прозрачность и информация о слоях.
  • Удаление всех поврежденных цветовых образцов, пользовательских цветов, цветовых групп, кистей, символов или стилей
    Нажмите Выбрать все неиспользуемое на панели меню «Цветовые образцы», в меню палитры «Кисти», в меню палитры «Символы» и в меню палитры «Стили», а затем нажмите Удалить.
  • Если текстовый объект поврежден, преобразуйте его в контуры или измените его шрифт
    • Выберите Объект > Разблокировать все.
    • Нажмите Правка > Выделить все.
    • Выберите Текст > Шрифт и выберите шрифт, который не используется в документе.
      Примечание. Чтобы предотвратить повреждение текстовых объектов в будущем, переустановите проблемный шрифт с исходного диска.

Неполадка по-прежнему не устранена?

  • Если ни один из вариантов не помог решить проблему, заново создайте файл в Illustrator после восстановления или воссоздания графики, шаблонов и дополнительных цветов, использованных в исходном файле. 
  • У вас может возникнуть другая неполадка с файлом, например, проблемы, связанные с памятью, разрешениями на доступ, сетью и съемными носителями. Для получения дополнительных сведений об этой проблеме, см. статью Выявление и устранение проблем с файлами.

Примите участие в обсуждении

Ask the community

Если у вас возник вопрос или есть идея, которой вы хотите поделиться, предлагаем присоединиться к Сообществу Adobe Illustrator. Мы будем рады узнать ваше мнение.

Логотип Adobe

Вход в учетную запись