Обзор палитры «Трансформирование»

Палитра «Трансформирование» предназначена для просмотра и задания геометрических данных для любого выделенного объекта, включая его положение, размер, поворот и наклон. Команды в меню палитры «Трансформирование» предоставляют дополнительные параметры и способы быстрого поворота и зеркального отражения объектов.

Примечание.

Кнопки и команды меню палитры «Трансформирование» доступны также на панели «Управление».

Палитра «Трансформирование»
Палитра «Трансформирование»

A. Локатор контрольной точки B. Значок «Сохранить пропорции» C. Меню палитры 

Отображение палитры «Трансформирование»

  1. Выберите меню «Окно» > «Объекты и макет» > «Трансформирование».

Просмотр информации о геометрии объектов

При выделении объекта на палитре «Трансформирование» и на панели «Управление» отображается информация о его геометрии. Если выделено несколько объектов, то информация представляет их все как один элемент.

  1. Выделите один или несколько объектов и отобразите палитру «Трансформирование» (меню «Окно» > «Объекты и макет» > «Трансформирование»).

    Информация о позиции определяется относительно начала координат и контрольной точки объекта. Угол определяется относительно монтажного стола, где горизонтальная линия располагается под углом 0°.

Изменение параметров трансформирования

Палитра «Трансформирование» включает несколько параметров, которые определяют, как трансформируются объекты и каким образом трансформации отображаются на палитре «Трансформирование» и на панели «Управление».

Изменение контрольной точки для выделенных объектов

Все операции трансформирования происходят относительно фиксированной точки на объекте или около него; эта точка называется контрольной точкой. Если выбран инструмент трансформирования, например инструмент «Масштабирование», в контрольной точке отображается значок .

Контрольная точка перемещена в центр (слева), произведено масштабирование объекта (справа)
Контрольная точка перемещена в центр (слева), произведено масштабирование объекта (справа)

  1. Выполните одно из следующих действий:
    • Чтобы указать другую контрольную точку для выбранного объекта, щелкните любую из девяти точек на локаторе контрольной точки  на палитре «Трансформирование» или на панели «Управление».


      При щелчке других контрольных точек на палитре «Трансформирование» или на панели «Управление» (вверху слева и справа) контрольная точка для выделенного объекта изменится (внизу слева и справа).

       

    • Чтобы переместить контрольную точку выбранного объекта в конкретное место, выберите инструмент «Поворот» , инструмент «Масштабирование»  или инструмент «Наклон» , поместите инструмент над значком контрольной точки и перетащите его в новое место. Либо выберите один из этих инструментов и щелкните в любом месте объекта или страницы. Контрольная точка перемещается в это место.

Примечание.

Если выбран инструмент «Трансформирование», то щелчок за пределами объекта не отменяет его выделение, а перемещает контрольную точку. Выберите «Редактирование» > Снять выделение для отмены выделения объекта.

Последняя выделенная в локаторе контрольная точка становится новой контрольной точкой по умолчанию для всех инструментов и объектов. Если перетащить значок контрольной точки объекта в другое место (не на узловую точку), то при снятии выделения с текущего объекта контрольная точка палитры возвращается в местоположение по умолчанию. InDesign сохраняет положение контрольной точки по умолчанию для новых документов, поэтому восстанавливать его не нужно.

Изменение информации, отображаемой для вложенных объектов

Палитра «Трансформирование» позволяет изменить ориентацию объекта на монтажном столе разворота, где горизонтальная линия имеет угол поворота 0°. По умолчанию это верно, даже если объект вложен в трансформированный объект контейнера (то есть объект является частью трансформированной группы или вставлен внутрь трансформированного фрейма). Например, если вставить не повернутое изображение внутрь фрейма, повернуть фрейм, содержащий изображение, на 10°, а затем выделить его с помощью инструмента «Частичное выделение», то палитра «Трансформирование» отображает угол поворота объекта 10°.

Угол поворота объекта, отображаемый относительно монтажного стола
Угол поворота объекта, отображаемый относительно монтажного стола

При необходимости можно отменить выбор параметра «Абсолютные значения», чтобы те же данные отображались относительно контейнера вложенного объекта. Если в приведенном выше примере отменить выбор параметра «Абсолютные значения», то палитра «Трансформирование» отображает нулевой угол поворота изображения (относительно повернутого контейнера).

Угол поворота объекта, отображаемый относительно объекта контейнера
Угол поворота объекта, отображаемый относительно объекта контейнера

  1. Откройте палитру «Трансформирование» или панель «Управление».
  2. В меню палитры «Трансформирование» или на панели «Управление» выполните одно из следующих действий:
    • Оставьте выделенным по умолчанию параметр «Абсолютные значения», чтобы для вложенных объектов отображались значения трансформирования относительно монтажного стола.

    • Отмените выбор параметра «Абсолютные значения», чтобы для вложенных объектов отображались значения поворота, масштаба и наклона относительно объекта контейнера.

Измерение положения выделенных объектов

Внешний вид значений X и Y на палитре «Трансформирование» для вложенных объектов, выделенных с помощью инструмента «Частичное выделение» , определяется командой «Показать смещение содержимого». Выделенная контрольная точка в локаторе контрольной точки палитры «Трансформирование» и палитры управления определяет, какая из девяти контрольных точек на выделенном объекте сравнивается с нулевой точкой документа или нулевой точкой фрейма контейнера. Нулевая точка фрейма контейнера всегда располагается в его верхнем левом углу.

Позиции выделенных объектов измеряются от трех позиций.

  • Позиция фрейма контейнера относительно нулевой точки документа. Включив или выключив параметр «Показать смещение содержимого», выделите фрейм контейнера при помощи инструмента «Выделение».

  • Позиция вложенного объекта относительно нулевой точки документа. Отключите параметр «Показать смещение содержимого» и выделите вложенный объект с помощью инструмента «Частичное выделение».

  • Позиция вложенного объекта относительно нулевой точки (левый верхний угол) его фрейма-контейнера. Включите параметр «Показать смещение содержимого» и выделите вложенный объект с помощью инструмента «Частичное выделение».

Позиция родительского фрейма, отображаемая относительно нулевой точки документа
Позиция родительского фрейма, отображаемая относительно нулевой точки документа

Позиция вложенного объекта, отображаемая относительно нулевой точки документа
Позиция вложенного объекта, отображаемая относительно нулевой точки документа

Позиция вложенного объекта, отображаемая относительно фрейма контейнера
Позиция вложенного объекта, отображаемая относительно фрейма контейнера

Если выбрана команда «Показать смещение содержимого», то значения «X» и «Y» встроенного объекта показаны относительно объекта контейнера, а значки «X/Y» на палитре «Трансформирование» меняются на «X+/Y+». Если эта команда не выбрана, то отображаются значения вложенного объекта относительно линеек.

  1. В меню палитры «Трансформирование» или панели «Управление» выберите или отмените выбор параметра «Показать смещение содержимого».

Включение или исключение толщины обводки при измерениях

Толщина обводки может влиять на размер и положение объекта. Можно изменить выравнивание обводки, а потом выбрать, откуда на палитре «Трансформирование» производится измерение размера и позиции объекта: от центра или от края обводки. Сведения об изменении выравнивания обводки см. в разделе Параметры палитры «Обводка».

Примечание.

Этот параметр не влияет на то, каким образом масштабирование фрейма изменяет толщину линий, а лишь определяет, влияют ли изменения на измерения.

  1. В меню палитры «Трансформирование» или на панели «Управление» выполните одно из следующих действий:
    • Выберите пункт «Размеры с учетом толщины линий», чтобы измерения проводились относительно внешнего края обводки объекта. Например, если один фрейм на 2 точки короче другого, но обводка более короткого фрейма на 2 точки толще, то при этом параметре оба фрейма будут отображаться с одинаковыми значениями высоты на палитре «Трансформирование» и на панели «Управление».

    • Отмените выбор параметра «Размеры с учетом толщины линий», чтобы измерения палитры представляли контур или фрейм объекта вне зависимости от толщины обводок. Например, для двух фреймов одинаковой высоты будут отображаться одинаковые значения высоты на палитре «Трансформирование» и на панели «Управление» вне зависимости от различий в толщине обводок.

Трансформирование объектов

Инструменты и команды меню позволяют изменить размер и форму объекта и изменить его ориентацию на монтажном столе. Панель «Инструменты» содержит четыре инструмента трансформирования: «Поворот», «Масштабирование», «Наклон» и «Свободное трансформирование». Кроме того, инструментом «Выделение» можно пользоваться для трансформирования объектов. Все эти операции трансформирования (плюс «отражение») доступны на палитре «Трансформирование» и панели «Управление», где они могут быть точно заданы.

Инструменты трансформирования (вверху) и палитра «Трансформирование» (внизу)
Инструменты трансформирования (вверху) и палитра «Трансформирование» (внизу)

A. Параметры поворота B. Параметры наклона C. Параметры масштабирования 

При трансформировании объектов следует учитывать следующие моменты.

  • Результаты трансформирования могут значительно различаться в зависимости от объекта выделения. Например, при повороте изображения объект поворота зависит от того, выделено ли изображение, фрейм или фрейм вместе с изображением. Используйте инструмент «Выделение» , чтобы трансформировать (поворачивать, изменять размер или наклон) весь контур и его содержимое (щелкните за пределами маркера захвата содержимого); используйте инструмент «Частичное выделение» , чтобы трансформировать только контур без содержимого или содержимое без контура. Чтобы трансформировать содержимое без его контура, убедитесь, что выделены все точки привязки.

Примечание.

Чтобы изменить размер фрейма и содержимого, используйте поля «Масштабирование по оси X в %» и «Масштабирование по оси Y в %», а не поля ширины (Ш) и высоты (В). С помощью полей ширины (Ш) и высоты (В) можно изменять отдельно только выбранный фрейм или только содержимое. Имейте в виду, что можно не только выбирать процентные значения в полях масштабирования. Можно ввести размеры, указав единицу измерения, например «6 п.».

  • Трансформирование воздействует на все выделенные объекты как на единый элемент. Например, если выделить несколько объектов и повернуть их на 30°, то они все повернутся вокруг одной контрольной точки. Чтобы повернуть каждый из выделенных объектов на 30° относительно его собственной контрольной точки, их необходимо выделять и поворачивать по отдельности.

  • При трансформировании шрифта может применяться один из двух методов выделения. При помощи инструмента «Выделение» или «Частичное выделение» выделите весь текстовый фрейм или текст, преобразованный в кривые, а затем воспользуйтесь инструментами трансформирования. Либо при помощи инструмента «Текст» выделите текст или установите в текстовый фрейм точку ввода, а затем задайте параметры трансформации на палитре «Трансформирование», панели «Управление» или в диалоговых окнах, доступных по двойному щелчку инструмента. В обоих случаях трансформирование применяется ко всему тексту внутри фрейма.

  • При повороте, наклоне или масштабировании группы параметры применяются ко всей группе, как и ко всем входящим в нее объектам. Например, при повороте группы на 30° значение поворота на палитре «Трансформирование» и на панели «Управление» будет равно 30°, независимо от того, выделена ли сама группа или частично выделен объект в группе.

Трансформирование объектов при помощи палитры «Трансформирование»

Чтобы задать совместное или раздельное трансформирование содержимого и фрейма, используйте инструменты выделения.

  1. Выделите объект для трансформирования.
    • Чтобы трансформировать фрейм вместе с его содержимым, выделите его при помощи инструмента «Выделение».

    • Для преобразования содержимого без преобразования фрейма выберите объект с помощью инструмента «Частичное выделение»  или щелкните маркер захвата содержимого изображения с помощью инструмента «Выделение».

    • Чтобы трансформировать фрейм без трансформирования содержимого, частично выделите фрейм, а затем выделите все узловые точки.

  2. На палитре «Трансформирование» или на панели «Управление» укажите исходную точку трансформации.

    Все значения на палитре относятся к ограничительным рамкам объектов. Значения «X» и «Y» указывают позицию выделенной контрольной точки на ограничительной рамке относительно начала координат.

  3. Выполните одно из следующих действий:
    • Введите новые значения в текстовые поля.
    • Выберите значения из доступных всплывающих меню.
    • Выберите команды в меню палитры.

    Примечание.

    Чтобы сохранить пропорции объекта при использовании параметров «Масштабирование по оси X в %» и «Масштабирование по оси Y в %», на палитре щелкните значок «Сохранить пропорции при масштабировании» . Если параметр не выбран, то по обеим сторонам значка появляются точки (в виде разорванного звена цепи). Вместо процентных значений можно указать размеры, указав единицу измерения, например «6 п.».

  4. Чтобы применить изменения, нажмите клавишу Tab, Enter (Windows) или Return (Mac OS).

Трансформирование объектов при помощи инструмента «Выделение»

Используйте инструмент «Выделение» для перемещения, изменения размеров и поворота объектов.

  1. Выберите объект при помощи инструмента «Выделение» . Чтобы трансформировать изображение внутри фрейма, щелкните маркер захвата содержимого, который появляется при наведении курсора на изображение.
  2. Выполните одно из следующих действий:
    • Чтобы переместить объекты, щелкните в любом месте внутри ограничительной рамки и начните перетаскивание.

    • Чтобы выполнить масштабирование объектов, нажмите клавишу Ctrl (Windows) или Command (Mac OS) и перетаскивайте любой маркер ограничительной рамки до достижения желаемого размера объекта. Удерживайте дополнительно клавишу Shift, если требуется сохранить пропорции объекта. Удерживайте дополнительно клавишу Alt (Windows) или Option (Mac OS), чтобы масштабирование объекта выполнялось относительно его центра.

    • Чтобы повернуть объект, поместите курсор в любое место за пределами ограничительной рамки. После изменения вида курсора на  выполняйте перетаскивание до тех пор, пока угол поворота выбранных объектов не достигнет требуемого значения.

    • Чтобы отразить объекты, перетащите указатель ограничительной рамки через противоположный край или рукоять, пока отражение объекта не достигнет нужного уровня.

Трансформирование объектов с помощью инструмента «Свободное трансформирование»

Инструмент «Свободное трансформирование» работает так же, как в приложениях Adobe Photoshop и Adobe Illustrator, предоставляя возможность выполнить любую операцию трансформирования с помощью одного инструмента. Различные операции трансформирования (поворот, масштабирование и др.) могут объединяться, если активен инструмент «Свободное трансформирование».

Примечание.

Комбинации клавиш позволяют быстро переключаться между инструментом «Свободное трансформирование» (по нажатию клавиши «E»), инструментом «Выделение» (клавиша «V») и инструментом «Частичное выделение» (клавиша «A»).

  1. С помощью соответствующего инструмента выделения выделите объект или объекты для трансформирования.
  2. Выберите инструмент «Свободное трансформирование» .
    • Чтобы переместить объекты, щелкните в любом месте внутри ограничительной рамки и начните перетаскивание.

    • Чтобы выполнить масштабирование объектов, перетаскивайте любую из рукоятей ограничительной рамки до достижения желаемого размера объекта. Чтобы сохранить пропорции, перетаскивайте рукоять, удерживая нажатой клавишу Shift.

    • Чтобы выполнить масштабирование объектов от центра ограничительной рамки, при перетаскивании удерживайте нажатой клавишу Alt (Windows) или Option (Mac OS).

    • Чтобы выполнить поворот объектов, поместите курсор в любое место за пределами ограничительной рамки. После изменения вида курсора на  выполняйте перетаскивание до тех пор, пока угол поворота выбранных объектов не достигнет требуемого значения.

    • Чтобы отразить объекты, перетащите указатель ограничительной рамки через противоположный край или рукоять, пока отражение объекта не достигнет нужного уровня.

    • Чтобы наклонить объекты, начните перетаскивание рукояти, а потом нажмите клавишу Ctrl (Windows) или Command (Mac OS). Удерживайте нажатой клавиши Alt и Ctrl (Windows) или Command и Option, чтобы выполнить наклон от обеих сторон объектов.

Поворот объектов

Объект можно поворачивать несколькими способами.

Поворот объекта с помощью инструмента «Поворот»

  1. Выделите объект для поворота. Чтобы повернуть и фрейм, и его содержимое, используйте инструмент «Выделение» для выделения фрейма. Чтобы повернуть содержимое без поворота фрейма, щелкните маркер захвата содержимого или используйте инструмент «Частичное выделение»  для частичного выделения объекта. Чтобы повернуть только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выберите инструмент «Поворот» .
  3. Чтобы использовать другую контрольную точку для поворота, щелкните в том месте, куда необходимо поместить контрольную точку.
  4. Разместите инструмент на расстоянии от контрольной точки и, удерживая кнопку мыши, перемещайте его вокруг нее. Чтобы ограничить движение инструмента углом, кратным 45°, держите нажатой клавишу Shift при перетаскивании. Для более точного управления перетащите курсор дальше от контрольной точки объекта.

Объекты также можно поворачивать с помощью инструмента «Свободное трансформирование».

Если «быстрые» направляющие (и «быстрые» размеры) включены, при вращении объекта на количество градусов, идентичное используемому при вращении расположенного рядом объекта, будут выведены визуальные подсказки. Например, если повернуть один объект страницы на 24 градуса, то при повороте другого объекта на угол, близкий к 24 градусам, появляется значок поворота.

Поворот объекта с помощью инструмента «Выделение»

  1. Выберите инструмент «Выделение» и поместите курсор рядом с маркером выделения. После изменения вида курсора на  выполняйте перетаскивание до тех пор, пока угол поворота выбранных объектов не достигнет требуемого значения.

Поворот объекта с помощью палитры «Трансформирование» и панели «Управление»

  1. Выделите объект для поворота. Чтобы повернуть и фрейм, и его содержимое, используйте инструмент «Выделение»  для выделения фрейма. Чтобы повернуть содержимое без поворота фрейма, щелкните маркер захвата содержимого или используйте инструмент «Частичное выделение»  для частичного выделения объекта. Чтобы повернуть только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий:
    • Чтобы повернуть объект на 90° по часовой или против часовой стрелки, нажмите любую из кнопок поворота на панели «Управление».

    • Для поворота на заданный угол выберите его во всплывающем меню «Угол поворота»  на палитре «Трансформирование» или панели управления.

    • В поле «Угол поворота»  на палитре «Трансформирование» или панели управления введите положительное значение угла для поворота выбранных объектов против часовой стрелки или отрицательное — для поворота по часовой стрелке, затем нажмите клавишу Enter (Windows) или Return (Mac OS).

    • Чтобы создать копию объекта и применить к ней новый угол поворота, введите значение в поле «Угол поворота» на палитре «Трансформирование», а затем при нажатой клавише Alt (Windows) или Option (Mac OS) нажмите клавишу Enter.

При повороте отдельного объекта заданное значение отображается на палитре «Трансформирование» или панели «Управление». При повороте нескольких объектов значение в поле «Угол поворота» сбрасывается в 0, хотя объекты и поворачиваются.

Поворот объекта при помощи команды «Поворот»

С помощью команды «Поворот» объект можно поворачивать на определенный угол. Данная команда также позволяет поворачивать копию выделенного объекта, оставляя при этом исходный объект на месте.

  1. Выделите объект для поворота. Чтобы повернуть и фрейм, и его содержимое, используйте инструмент «Выделение» для выделения фрейма. Чтобы повернуть только содержимое, частично выделите объект. Чтобы повернуть только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий, чтобы открыть диалоговое окно «Поворот».
    • Выберите «Объект» > «Трансформировать» > «Поворот».

    • Дважды нажмите инструмент «Поворот» .

    • Выберите инструмент «Поворот» и при нажатой клавише Alt (Windows) или Option (Mac OS) щелкните объект или область рядом с ним, чтобы выбрать новую контрольную точку.

  3. В поле «Угол» введите угол поворота (в градусах). При отрицательном значении поворот будет производиться по часовой стрелке, при положительном — против часовой.
  4. Выполните одно из следующих действий:
    • Для просмотра эффекта перед его применением выберите «Просмотр».

    • Для поворота объекта нажмите «ОК».

    • Для поворота копии объекта нажмите «Скопировать».

Перемещение объектов

Объекты можно перемещать путем вырезания из одного места и вставки в другое, посредством ввода новых горизонтальных и вертикальных координат, а также путем перетаскивания. Перетаскивание также позволяет перемещать копии объектов или копировать объекты в другие приложения.

С помощью «быстрых» направляющих очень удобно передвигать объекты на макете на точно заданные позиции. При перетаскивании объекта появляются временные направляющие, указывающие выравнивание перемещаемого объекта по краю страницы, по центру страницы или относительно другого элемента страницы.

Перемещение объектов

Для перемещения нескольких объектов рекомендуется использовать инструмент «Выделение». Если для выделения нескольких объектов или контуров используется инструмент «Частичное выделение», при перетаскивании перемещается только выделенная графика, контур или точки привязки.

  1. Выделите объект для перемещения. Чтобы переместить и фрейм, и его содержимое, используйте инструмент «Выделение»  для выделения фрейма. Чтобы переместить только содержимое, выделите объект инструментом «Частичное выделение» или наведите курсор на изображение и нажмите маркер захвата содержимого. Чтобы переместить только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий:
    • Для вставки объекта (или его копии) в новом местоположении выберите «Редактирование» > «Вырезать» или «Редактирование» > «Скопировать». Перейдите к требуемому развороту и выберите «Редактирование» > «Вставить». Объекты появятся в центре целевого разворота.
    • Для вставки копии в местоположении исходного объекта выберите «Редактирование» > «Копировать». Затем выберите «Редактирование» > «Вставить на место». (для смещения копии из положения исходного объекта используйте клавиши со стрелками).

    Примечание.

    Если требуется отображение объекта в одном и том же месте на многих страницах, рекомендуется создать страницу-шаблон и вставить объект на ней.

    • Чтобы переместить объект к конкретной точке координат, введите значение для каждого из параметров размещения по оси X (горизонтальная) или Y (вертикальная) на палитре «Трансформирование» или панели «Управление». Затем нажмите клавишу Enter (Windows) или Return (Mac OS).

    • Для постепенного смещения объекта в одном направлении нажимайте или удерживайте нажатой клавишу со стрелкой; если нажимать клавишу со стрелкой при нажатой клавише Shift, шаг смещения увеличивается в десять раз.

    • Для перемещения объекта перетаскиванием перетащите объект в новое место. Чтобы ограничить перемещение объекта по горизонтали, вертикали или диагонали углом, кратным 45°, удерживайте нажатой клавишу Shift при перетаскивании.

    Примечание.

    Перетащите маркер захвата содержимого для перемещения изображения внутри фрейма.

Перемещение объектов на точное расстояние

С помощью команды «Перемещение» объект можно переместить на определенное расстояние. Данная команда также позволяет перемещать копию выделенного объекта, оставляя при этом исходный объект на месте.

  1. Выделите объект для перемещения. Чтобы переместить и фрейм, и его содержимое, используйте инструмент «Выделение» для выделения фрейма. Чтобы переместить только содержимое, частично выделите объект. Чтобы переместить только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выберите «Объект» > «Трансформирование» > «Перемещение» либо дважды щелкните значок инструмента «Выделение» или «Частичное выделение» на панели «Инструменты».
  3. В диалоговом окне «Перемещение» выполните одно из следующих действий:
    • Введите расстояния по вертикальной и горизонтальной осям, на которые нужно переместить объект. Положительные значения перемещают объект вниз и вправо по оси X, а отрицательные — вверх и влево.

    • Чтобы переместить объект на точное расстояние и угол, введите расстояние и угол для перемещения. Вводимое значение угла рассчитывается в градусах от оси x. Положительное значение означает перемещение против часовой стрелки, отрицательное значение задает перемещение по часовой стрелке. Также можно ввести значения в диапазоне от 180° до 360°; эти значения преобразуются в соответствующие отрицательные значения (например, 270° преобразуется в –90°).

  4. Выполните одно из следующих действий:
    • Для просмотра эффекта перед его применением выберите «Просмотр».

    • Для перемещения объекта нажмите кнопку «ОК».

    • Для перемещения копии объекта нажмите «Скопировать».

Перемещение объектов в точное место

  1. Выделите объект для перемещения.
  2. Чтобы использовать другую контрольную точку для перемещения, щелкните место, куда необходимо поместить контрольную точку.

    Например, чтобы переместить объект в верхний левый угол страницы, выберите контрольную точку вверху слева.

  3. В полях «X» и «Y» палитры «Трансформирование» введите координаты, куда необходимо переместить выделенный объект.

Выбор расстояния перемещения объекта при сдвиге

  1. Выберите меню «Редактирование» > «Установки» > «Единицы измерения» (Windows) или «InDesign» > «Установки» > «Единицы измерения» (Mac OS).
  2. В поле «Перемещение объектов» укажите расстояние, на которое должны перемещаться выделенные объекты при каждом нажатии клавиши со стрелкой, а затем нажмите кнопку «ОК».

Примечание.

Если при перемещении выделенных объектов держать нажатой клавишу Shift, указанное в этом поле расстояние умножается в десять раз.

Масштабирование и размеров объектов

В InDesign изменение размера и масштабирование являются разными действиями. Изменение размера объекта — это просто изменение его параметров «Ширина» и «Высота». Масштабирование — указание процентного соотношения с исходным размером фрейма (принимаемым за 100%).

Различия между изменением размера и масштабированием не всегда очевидны. Чтобы наглядно их продемонстрировать, измените размер текстового фрейма, к которому применена обводка, а затем промасштабируйте его. При увеличении вдвое размера текстового фрейма размер текста и толщина обводки остаются прежними. При увеличении вдвое масштаба текстового фрейма размер текста и толщина обводки увеличиваются соответственно.

Изменение размера фрейма

По умолчанию: если выделен фрейм (но не его содержимое), то изменение значений его полей «Ширина» и «Высота» действует только на сам фрейм (не действует не его содержимое), вне зависимости выбранного в данный момент инструмента выделения.

Масштабирование фрейма и его содержимого

Если фрейм выбран с помощью инструмента «Выделение», то изменение его параметров «Масштабирование по оси X в %» и «Масштабирование по оси Y в %» затрагивает и сам фрейм, и его содержимое. Если выбран параметр «Автоподгонка», размер фрейма изменяется вместе с изменением размера содержимого.

Изменение размеров или масштабирование содержимого фрейма

Если требуется изменить размер или масштаб только содержимого фрейма, выберите содержимое фрейма с помощью маркера захвата содержимого или инструмента «Частичное выделение». После этого можно изменить значения полей «Ширина» и «Высота» либо «Масштаб» (в зависимости от того, какой результат требуется).

Как обойти настройки по умолчанию

Если требуется изменить масштаб фрейма или его содержимого в процентном соотношении, а затем перевести результат в текущую систему измерения, можно ввести величину с символом «процент», чтобы выбранная по умолчанию система измерений не учитывалась. К примеру, если текущая ширина составляет 12 п., и требуется уменьшить ее до 75%, введите «75%» в поле «Ширина». После нажатия кнопки «Ввод» в поле «Ширина» отобразится новое значение: 9 п.

Аналогичным образом, можно указать величину в другой системе измерений, если требуется изменить ее на определенное значение и отобразить результат в процентах от исходного. Например, если вместо «100%» ввести «9 п.», InDesign автоматически вычислит, на сколько процентов требуется изменить длину/ширину.

Изменение размера объекта

При перетаскивании рукояти фрейма с содержимым, например с импортированной графикой, размеры содержимого по умолчанию не изменяются. Важно понимать, что содержимое и фрейм контейнера являются отдельными элементами, каждый из которых имеет собственную ограничительную рамку. Простое перетаскивание фрейма импортированной графики приведет либо к обрезке графики, либо к появлению незаполненного пространства вокруг нее, что зависит от направления перетаскивания. Операция изменения фрейма независимо от его содержимого расширяет возможности адаптации, но ее освоение требует времени.

С помощью «быстрых» направляющих очень удобно изменять размеры объектов в соответствии с другими объектами на макете. При создании или перетаскивании объекта направляющие временно отображаются. Это означает, что объект, который вы двигаете, выравнивается по краю или по центру страницы, либо его размеры приводятся в соответствие другому элементу страницы.

Изменение размера импортированной графики
Изменение размера импортированной графики

A. Фрейм, выделенный с помощью инструмента «Выделение» B. Изменен размер фрейма C. Изменен масштаб фрейма и содержимого 
  • Чтобы изменить размер фрейма, перетащите любую рукоять при помощи инструмента «Выделение». Если при перетаскивании удерживать нажатой клавишу Ctrl (Windows) или Command (Mac OS), изменяется масштаб фрейма и его содержимого. При нажатии клавиши Shift масштаб изменяется пропорционально.

Примечание.

Если выбран параметр «Автоподгонка», размер фрейма изменяется вместе с изменением размера изображения.

  • Чтобы изменить размер содержимого графического фрейма, щелкните маркер захвата содержимого инструментом «Выделение» или выделите графический объект с помощью инструмента «Частичное выделение», а затем перетащите любой маркер графического фрейма.
  • Чтобы задать точный размер фрейма или его содержимого, выделите объект и введите в соответствующие поля на панели «Управление» значение ширины (Ш) или высоты (В).

Примечание.

Чтобы сохранить исходные пропорции объекта при использовании панели «Управление», убедитесь, что значок «Сохранить пропорции»  нажат.

  • Чтобы изменить размер фрейма и содержимого, используйте поля «Масштабирование по оси X в %» и «Масштабирование по оси Y в %», а не поля ширины (Ш) и высоты (В). С помощью полей ширины (Ш) и высоты (В) можно изменять отдельно только выбранный фрейм или только содержимое. Вместо процентного соотношения можно ввести размер и единицу измерения, например «6 п.».
  • Чтобы задать размер фрейма или его содержимого в процентах к текущему размеру, выделите объект и введите значение в поле ширины или высоты на палитре «Трансформирование».
  • Чтобы создать копию выделенного объекта и применить к ней новый размер, введите значение ширины или высоты в соответствующие поля на палитре «Трансформирование», а затем, удерживая Alt (Windows) или Option (Mac OS), нажмите клавишу Enter.

Примечание.

Изменив размер фрейма или объекта, можно воспользоваться параметром подгонки («Объект» > «Подгонка»), чтобы подогнать содержимое к размеру фрейма или наоборот.

Масштабирование объектов

При масштабировании объект увеличивается или уменьшается по горизонтали (вдоль оси x), по вертикали (вдоль оси y) либо и по горизонтали, и по вертикали относительно заданной контрольной точки.

По умолчанию в InDesign обводки масштабируются. Например, при масштабировании выделенного объекта с обводкой в 4 пункта до 200% на палитре «Обводка» отображается обводка в 8 пунктов, визуально становясь вдвое толще. Стандартное поведение обводки можно изменить, отменив выбор параметра «Регулировать толщину обводки при масштабировании» в меню палитры «Трансформирование» или панели «Управление».

Масштабирование объекта с помощью инструмента «Выделение»

  1. Для одновременного масштабирования содержимого и фрейма выделите объект инструментом «Выделение», удерживая нажатой клавишу Ctrl (Windows) или Command (Mac OS). Для пропорционального изменения размера объекта нажмите клавишу Shift.

Масштабирование объекта с помощью инструмента «Масштабирование»

  1. Выделите объект для масштабирования. Чтобы изменить масштаб и фрейма, и его содержимого, используйте инструмент «Выделение» для выделения фрейма. Чтобы изменить только масштаб содержимого, щелкните маркер захвата содержимого или выделите объект инструментом «Частичное выделение». Чтобы изменить только масштаб фрейма, частично выделите фрейм и выделите все точки привязки.
  2. Выберите инструмент «Масштабирование» .
  3. Разместите инструмент «Масштабирование» на расстоянии от контрольной точки и перетащите его. Для масштабирования только по оси Х или Y перетаскивайте инструмент «Масштабирование» только вдоль одной оси. Для пропорционального масштабирования удерживайте нажатой клавишу Shift при перетаскивании инструмента «Масштабирование». Для более точного управления начните перетаскивание инструмента дальше от контрольной точки объекта.

    Примечание.

    Объекты также можно масштабировать с помощью инструмента «Свободное трансформирование».

Масштабирование объекта с помощью палитры «Трансформирование»

Для сохранения исходных пропорций объекта при работе с палитрой «Трансформирование» выберите значок «Сохранить пропорции» .

  1. Выделите объект для масштабирования. Чтобы изменить масштаб и фрейма, и его содержимого, используйте инструмент «Выделение» для выделения фрейма. Чтобы изменить только масштаб содержимого, частично выделите объект. Чтобы изменить только масштаб фрейма, частично выделите фрейм и выделите все точки привязки.
  2. На палитре «Трансформирование» или панели «Управление» выполните одно из следующих действий:
    • Во всплывающем меню «Масштабирование по оси X в %»  или «Масштабирование по оси Y в %»  выберите одно из заранее заданных процентных значений.

    • В поле «Масштабирование по оси X в %» или «Масштабирование по оси Y в %» введите процентное значение (например, 120%) или конкретное расстояние (например, 10 п.), затем нажмите клавишу Enter или Return.

Масштабирование объекта с помощью клавиш со стрелками

  1. Выберите полностью или частично объект или фрейм.
  2. На палитре «Трансформирование» щелкните в поле «Масштабирование по оси X в %»  или «Масштабирование по оси Y в %» .
  3. Для масштабирования объекта с шагом 1% нажимайте клавишу со стрелкой вверх или вниз. При одновременном нажатии клавиши Shift и клавиши со стрелкой объект масштабируется с шагом 10%.

Если в подразделе «Основные» раздела «Установки» выбран режим «Настроить масштаб в процентах», увеличение масштаба указанным способом с последующим уменьшением на ту же величину в процентах приводит к восстановлению исходного масштаба объекта. Например, в результате увеличения масштаба круга диаметром 20 мм на 10% и последующего уменьшения масштаба на 10% снова получается круг диаметром 20 мм (а не 19,8 мм).

Масштабирование объекта с помощью команды «Масштабирование»

  1. Выделите объект для масштабирования. Чтобы изменить масштаб и фрейма, и его содержимого, используйте инструмент «Выделение» для выделения фрейма. Чтобы изменить только масштаб содержимого, частично выделите объект. Чтобы изменить только масштаб фрейма, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий, чтобы открыть диалоговое окно «Масштабирование».
    • Выберите «Объект» > «Трансформировать» > «Масштабировать».

    • Дважды нажмите инструмент «Масштабирование» .

    • Выберите инструмент «Масштабирование» и при нажатой клавише Alt (Windows) или Option (Mac OS) нажмите на объект или область рядом с ним, чтобы выбрать новую контрольную точку.

  3. Введите процентное значение в поле «Масштаб X» или «Масштаб Y».

    Примечание.

    Для сохранения исходных пропорций объекта при работе с палитрой «Трансформирование» выберите значок «Сохранить пропорции» .

  4. Выполните одно из следующих действий:
    • Для просмотра эффекта перед его применением выберите «Просмотр».

    • Для масштабирования объекта нажмите кнопку «ОК».

    • Для масштабирования копии объекта нажмите «Скопировать».

Указание способа для отслеживания масштабирования

Способ отслеживания масштабирования можно задать в разделе «Интерфейс». Если в разделе «Основные» диалогового окна «Установки» выбран параметр «Применить к содержимому», после масштабирования объекта на палитре «Трансформирование» восстанавливаются значения масштаба 100%. Если выбран параметр «Настроить масштаб в процентах», заданные значения масштаба, например 125%, не изменяются.

Если выделено несколько объектов, всегда будет отображаться значение масштаба 100%. При этом, если выбран параметр «Настроить масштаб в процентах», можно выделить отдельный объект и увидеть результат применения к нему эффекта трансформирования (например, 125%).

  1. Выберите «Редактирование» > «Установки» > «Основные» (Windows) или «InDesign» > «Установки» > «Основные» (Mac OS).
  2. В разделе «При масштабировании» выберите «Применить к содержимому» или «Настроить масштаб в процентах» и щелкните «OK».

Примечание.

Если выбран параметр «Настроить масштаб в процентах» и требуется промасштабировать объект, можно выбрать «Переопределить масштаб как 100%» в меню палитры «Трансформирование» или панели «Управление», чтобы восстановить процентные значения масштабирования до 100%.

Настройка толщины обводки при масштабировании объектов

  1. Выберите параметр «Регулировать толщину обводки при масштабировании» в меню палитры «Трансформирование» или панели «Управление».

Например, если данный параметр выбран, при масштабировании обводки в 4 пункта до 200% ее толщина становится равной 8 пунктам. Если этот параметр не выбран, размер объекта увеличится вдвое, а толщина обводки останется прежней — 4 пункта.

При выборе данного параметра и непропорциональном масштабировании объекта программа InDesign применяет ко всем сторонам объекта наименьшую толщину обводки. Предположим, что выделенный объект с обводкой в 4 пункта масштабируется до 200% только по оси X. Вместо применения обводки в 8 пунктов по оси X и в 4 пункта по оси Y программа InDesign применяет ко всем сторонам наименьшее значение — 4 пункта.

Масштабирование эффекта

Масштаб эффекта, примененного к ранее созданному объекту, изменяется пропорционально масштабу объекта. Изменение масштаба объекта в определенном соотношении приводит к изменению масштаба эффекта в том же соотношении.

В разделе «Установки» выберите «Основные» > «Применить к содержимому» > «Включить эффекты». Если требуется масштабировать объекты без масштабирования эффектов, снимите этот флажок.

«Установки» - «Включить эффекты»
«Установки» - «Включить эффекты»

Или

«Окно» > «Объекты и макет» > «Трансформирование». Для включения или отключения масштабирования эффекта выберите «Настраивать эффекты при масштабировании» во всплывающем меню.

Настройка масштабирования
Настройка масштабирования

Эта функция аналогична эффектам обводки. Поэтому при масштабировании эффектов применяется та же процедура, что и при масштабировании обводки.

Восстановление значения масштаба до 100%

В некоторых случаях может потребоваться восстановить для параметров «Масштаб X» и «Масштаб Y» значение 100%, не изменяя размеров объекта. Например, при открытии созданного в предыдущей версии InDesign документа со значениями масштаба, отличными от 100%, или после масштабирования объекта, для которого в разделе «Установки» выбран режим «Настроить масштаб в процентах». При выборе данной команды масштаб всех выделенных фреймов восстанавливается до 100%. Размер и внешний вид объектов при этом не меняются.

  1. Выделите один или несколько объектов, значения масштаба которых не равно 100%.

    Эта команда недоступна, если импортированное изображение выделено частично или объект имеет масштаб 100%.

  2. Выберите команду «Переопределить масштаб как 100%» в меню палитры «Трансформирование» или панели «Управление».

Примечание.

Выбор данной команды может привести к непредвиденным результатам для объектов в трансформированных группах.

Зеркальное отражение объектов

Отражение — это зеркальное отображение объекта вдоль невидимой оси в заданной контрольной точке. См. раздел Изменение параметров трансформирования.

Исходный объект (вверху) отражен с помощью команд «Зеркало по горизонтали» (в центре) и «Зеркало по вертикали» (внизу)
Исходный объект (вверху) отражен с помощью команд «Зеркало по горизонтали» (в центре) и «Зеркало по вертикали» (внизу)

Если объект зеркально отображен, индикатор зеркального отображения/поворота в центре панели «Управление» становится белым с черным контуром. Если объект не отображен зеркально, этот индикатор полностью черный.

  1. Выделите объект для зеркального отображения. Чтобы зеркально отобразить и фрейм, и его содержимое, используйте инструмент «Выделение» для выделения фрейма. Чтобы зеркально отобразить только содержимое, частично выделите объект. Чтобы зеркально отобразить только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий:
    • Для зеркального отображения, используя контрольную точку в качестве горизонтальной оси, нажмите кнопку «Зеркало по горизонтали» на панели «Управление».

    • Для зеркального отображения, используя контрольную точку в качестве вертикальной оси, нажмите кнопку «Зеркало по вертикали» на панели «Управление».

    Примечание.

    Объекты также можно зеркально отображать при помощи инструмента «Выделение» или «Свободное трансформирование», перетянув одну сторону ограничительной рамки объекта за противоположную сторону, либо путем ввода отрицательных значений в поля «Масштабирование по оси X в %» и «Масштабирование по оси Y в %» на палитре «Трансформирование» или панели «Управление».

Наклон объектов

Данная функция позволяет наклонять объект относительно его горизонтальной или вертикальной оси, а также вращать обе оси объекта. Эта функция полезна для:

  • имитации некоторых типов перспективы, например изометрической проекции;

  • наклона текстового фрейма;

  • создания отбрасываемых теней при наклоне копии объекта.

Наклон объекта

  1. Выделите объект для наклона. Чтобы наклонить и фрейм, и его содержимое, используйте инструмент «Выделение» для выделения фрейма. Чтобы наклонить только содержимое, щелкните маркер захвата содержимого или выделите объект инструментом «Частичное выделение». Чтобы наклонить только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий:
    • Чтобы наклонить выделенные объекты путем перетаскивания, выберите инструмент «Наклон» . Затем расположите инструмент «Наклон» на расстоянии от контрольной точки и перетащите его. Нажмите при перетаскивании клавишу Shift, чтобы ограничить наклон перпендикулярной вертикальной или горизонтальной осью. Если начать перетаскивание под неперпендикулярным углом, а затем нажать и держать клавишу Shift, наклон будет ограничен этим углом.


      Объекты, наклоняемые перетаскиванием инструмента «Наклон» с контрольной точкой в центре

    Примечание.

    Чтобы использовать другую контрольную точку для наклона, щелкните место, куда необходимо поместить контрольную точку.

    • Для наклона с использованием заданного угла выберите на палитре «Трансформирование» или панели «Управление» значение угла во всплывающем меню «Наклон» .
    • Для наклона с использованием конкретного угла на палитре «Трансформирование» или панели «Управление» введите в поле «Наклон»  положительное или отрицательное значение угла и нажмите клавишу Enter или Return.
    • Чтобы создать копию объекта и применить к ней новый угол наклона, введите значение в поле «Наклон» палитры «Трансформирование», а затем при нажатой клавише Alt (Windows) или Option (Mac OS) нажмите клавишу Enter.

При наклоне отдельного объекта указанное значение отображается на палитре «Трансформирование» или панели «Управление». При наклоне нескольких объектов значение в поле «Угол поворота» сбрасывается в 0, хотя объекты и наклоняются.

Примечание.

Объекты можно также наклонять с помощью инструмента «Свободное трансформирование».

Наклон объекта с помощью команды «Наклон»

С помощью данной команды объект можно наклонить под определенным углом. Эта команда также позволяет наклонять копию выделенного объекта, оставляя при этом исходный объект на месте.

  1. Выделите объект для наклона. Чтобы наклонить и фрейм, и его содержимое, используйте инструмент «Выделение» для выделения фрейма. Чтобы наклонить только содержимое, щелкните маркер захвата содержимого или выделите объект инструментом «Частичное выделение». Чтобы наклонить только фрейм, частично выделите фрейм и выделите все точки привязки.
  2. Выполните одно из следующих действий, чтобы открыть диалоговое окно «Наклон».
    • Выберите меню «Объект» > «Трансформирование» > «Наклонить».

    • Дважды нажмите инструмент «Наклон» .

    • Выберите инструмент «Наклон» и при нажатой клавише Alt (Windows) или Option (Mac OS) нажмите область, чтобы выбрать новую контрольную точку.

  3. Введите новый угол наклона.

    Угол наклона определяет, насколько будет наклонен объект относительно линии, перпендикулярной оси наклона (угол наклона вычисляется по часовой стрелке от текущей оси).

  4. Укажите ось, относительно которой будет наклоняться объект. Объект можно наклонить вдоль горизонтальной или вертикальной оси.
  5. Выполните одно из следующих действий:
    • Для просмотра эффекта перед его применением выберите «Просмотр».

    • Для наклона объекта нажмите «ОК».

    • Чтобы наклонить копию объекта, нажмите кнопку «Скопировать».

Повтор операций трансформирования

Операции трансформирования объектов, например перемещение, масштабирование, поворот, изменение размера, зеркальное отражение, наклон и подгонку, можно повторять. При этом можно повторить как отдельные операции, так и их последовательности, а также применить эти операции одновременно к нескольким объектам. Программа InDesign хранит в памяти все операции трансформирования до тех пор, пока не будет выбран другой объект или не будет выполнена другая задача.

Примечание.

Не все операции трансформирования записываются. Например, изменение контура или его точек не записывается как операция трансформирования.

  1. Выделите один или несколько объектов и выполните все операции трансформирования, которые необходимо повторить.
  2. Выделите один или несколько объектов, к которым нужно применить данные операции трансформирования.
  3. Выберите меню «Объект» > «Повторить трансформирование», после чего выберите один из следующих параметров.

    Повторить

    Применяет одну последнюю операцию трансформирования к выделенным объектам.

    Повторить индивидуально

    Применяет последнюю операцию трансформирования отдельно к каждому выделенному объекту, а не ко всей группе.

    Повторить последовательность

    Применяет последнюю последовательность операций трансформирования к выделенным объектам.

    Повторить последовательность индивидуально

    Применяет последнюю последовательность операций трансформирования отдельно к каждому выделенному объекту.

Сброс преобразований

  1. Выделите объект или объекты, которые были трансформированы.
  2. Выберите «Сбросить преобразования» в меню палитры «Трансформирование» или панели «Управление».

    Если не используются все значения по умолчанию, в результате сброса операций трансформирования изменится внешний вид объектов.

    Примечание.

    Если для масштаба использовалось значение 100%, сброс не приведет к изменению масштаба.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет