Примечание.

В Photoshop CS6 функциональные возможности 3D-рисования были доступны в Photoshop Extended. Все возможности Photoshop Extended доступны в Photoshop CC. Photoshop CC не имеет специальной версии Extended.

Общие сведения о 3D-файлах и их отображении

Photoshop позволяет выполнять размещение и анимацию 3D-моделей, редактировать текстуры и освещение, а также выбирать нужный режим рендеринга.

Основы работы с 3D-файлами

3D-файлы состоят из следующих компонентов:

Сетки

Укажите структуру 3D-модели. Сетка часто визуализируется в виде каркаса, структуры, напоминающей скелет и состоящей из тысяч отдельных полигонов. В 3D-модели содержится по меньшей мере одна сетка, а иногда она соединяет в себе несколько сеток. В Photoshop можно просматривать сетки в различных режимах рендеринга и манипулировать ими независимо друг от друга. Несмотря на то что число полигонов в сетке изменить нельзя, можно изменить ее ориентацию и осуществить ее трансформацию по различным осям. Можно также создавать собственные 3D-сетки, используя при этом уже готовые фигуры, или создать собственные с помощью преобразования существующих 2D-слоев. См. раздел Настройки 3D-сетки.

Примечание.

Для редактирования сетки из полигонов 3D-модели необходимо использовать программу, в которой она была создана.

Материалы

К сетке может быть привязан один или несколько материалов, определяющих внешний вид сетки или ее части. Материал, в свою очередь, зависит от подкомпонентов, называемых текстурными картами, взаимное наложение которых и обеспечивает внешний вид материала. Текстурная карта представляет собой 2D-изображение, обладающее различными качествами, например цветом, узором, освещенностью и выпуклостью. В Photoshop материал может состоять из девяти различных типов текстурных карт, определяющих в конечном итоге его внешний вид. См. раздел Параметры 3D-материалов.

Источники света

Существуют следующие типы: бесконечный свет, направленный свет, точечный свет, а также источники света на базе изображения, которые охватывают всю рабочую область. Можно настраивать цвет и его интенсивность, а также добавлять новые источники света в 3D-сцену. См. раздел Настройки 3D-источников света.

Открытие 3D-файла

В Photoshop можно открывать следующие 3D-форматы: DAE (Collada), OBJ, 3DS, U3D и KMZ (Google Планета Земля).

  1. Выполните одно из следующих действий.

    • Чтобы открыть 3D-файл отдельно от других, выберите «Файл» > «Открыть» и выберите файл.

    • Чтобы добавить 3D-файл как слой в открытый файл, выберите «3D» > «Создать слой из 3D-файла» Новый слой приобретает размеры открытого файла и представляет трехмерную модель на прозрачном фоне.

Производительность 3D-эффектов и параметры отображения

  1. Выберите меню «Редактирование» > «Установки» > «3D» (Windows) или Photoshop > «Установки» > «3D» (Mac OS).

  2. Чтобы получить сведения о параметрах, наведите на них указатель и прочитайте раздел «Описание» в нижней части диалогового окна.

Инструменты 3D-объекта и 3D-камеры

При выборе 3D-слоя становятся активными инструменты 3D-объекта и 3D-камеры. Используйте инструменты 3D-объекта, чтобы переместить или масштабировать 3D-модель; изменить внешний вид сцены можно с помощью инструментов 3D-камеры. Если система поддерживает OpenGL, то можно также манипулировать 3D-моделью и 3D-камерами с помощью 3D-оси. См. раздел Использование 3D-оси.

Перемещение, вращение и масштабирование модели с помощью инструментов 3D-объекта

Инструменты 3D-объекта применяются для вращения, изменения положения или масштабирования модели. При манипулировании 3D-моделью положение камеры остается неизменным.

Примечание.

Для отображения подсказок по каждому из 3D-инструментов в меню панели «Инфо» выберите пункт «Параметры панели» , затем щелкните «Показывать подсказки по инструментам». Чтобы просмотреть сведения на панели «Инфо», выберите инструмент, затем переместите указатель в окно изображения.

Photoshop: инструменты и параметры 3D-объектов
Инструменты и параметры 3D-объектов

A. Возврат к исходному положению объекта B. Поворот C. Прокрутка D. Панорама E. Скольжение F. Масштаб G. Меню позиции H. Сохранить текущую позицию I. Удалить текущую позицию J. Координаты позиции 
  1. Щелкните инструмент 3D-объекта на панели инструментов и удерживайте кнопку мыши, чтобы выбрать один из следующих типов:

    Примечание.

    Удерживайте клавишу «Shift» для ограничения поворота, панорамирования, скольжения или масштабирования одним направлением.

    Поворот

    Перетащите инструмент вверх или вниз для вращения модели вокруг оси X, либо влево или вправо — для вращения вокруг оси Y. Для прокрутки модели при перетаскивании удерживайте нажатой клавишу «Alt» (Windows) или «Option» (Mac OS).

    Прокрутка

    Перетащите инструмент из стороны в сторону для вращения модели вокруг оси Z.

    Панорама

    Перетащите инструмент из стороны в сторону для перемещения модели горизонтально либо вверх или вниз – для перемещения модели вертикально. Для одновременного перемещения вдоль осей X и Y при перетаскивании удерживайте нажатой клавишу «Alt» (Windows) или «Option» (Mac OS).

    Скольжение

    Перетащите инструмент поперек для перемещения модели горизонтально или вверх или вниз для перемещения ближе или дальше. Для одновременного перемещения вдоль осей X и Y, при перетаскивании удерживайте нажатой клавишу «Alt» (Windows) или «Option» (Mac OS).

    Масштаб

    Перетащите инструмент вверх или вниз для увеличения или уменьшения масштаба. Удерживайте клавишу «Alt» (Windows) или «Option» (Mac OS) при перетаскивании для масштабирования в направлении оси Z.

Щелкните значок «Возврат в исходное положение»  на панели «Параметры», чтобы вернуть модели ее первоначальный вид.

Чтобы изменить числовые значения позиции, вращения или масштаба, введите их в правой части панели параметров.

Перемещение 3D-камеры

Для изменения поля зрения камеры при неизменном положении 3D-объекта используйте инструменты 3D-камеры.

Примечание.

Для отображения подсказок по каждому из 3D-инструментов в меню панели «Инфо» выберите пункт «Параметры панели» , затем щелкните «Показывать подсказки по инструментам». Чтобы просмотреть сведения на панели «Инфо», выберите инструмент, затем переместите указатель в окно изображения.

Photoshop: инструменты и параметры 3D-камеры
Инструменты и параметры 3D-камеры

A. Возврат к исходному положению камеры B. Поворот C. Прокрутка D. Панорама E. Обход F. Масштаб G. Меню «Просмотр» H. Сохранить текущий вид с камеры I. Удалить текущий вид с камеры J. Координаты позиции камеры 
  1. Щелкните инструмент 3D-объекта на панели инструментов и удерживайте кнопку мыши, чтобы выбрать один из следующих типов:

    Примечание.

    Удерживайте клавишу «Shift»·для ограничения поворота, панорамы или обхода одним направлением.

    Поворот

    Перетащите для перемещения камеры в направлении оси X или Y. Удерживайте клавишу «Alt» (Windows) или «Option» (Mac OS) при перетаскивании для вращения камеры.

    Прокрутка

    Перетащите для прокрутки камеры.

    Панорама

    Перетащите для изменения панорамного вида камеры в направлении оси X или Y. Удерживайте клавишу «Alt» (Windows) или «Option» (Mac OS) при перетаскивании для изменения панорамного вида в направлении X или Z.

    Обход

    Перетащите для обхода камеры (перемещение в направлении оси Z и вращение вокруг оси Y). Удерживайте клавишу «Alt» (Windows) или «Option» (Mac OS) при перетаскивании для обхода в направлении Z/X (перемещение в направлении оси Z и вращение вокруг оси X).

    Масштаб

    Перетащите инструмент для изменения поля обзора 3D-камеры. Максимальное поле обзора равно 180.

    Камера перспективы (только масштаб)

    Отображает две параллельные линии, сходящиеся в точке схода.

    Ортогональная камера (только масштаб)

    Сохраняет параллельные линии без пересечений. Отображает модель в точном масштабе без искажений перспективы.

    Глубина резкости поля (только масштаб)

    Задает глубину резкости поля. Расстояние определяет удаленность находящегося в фокусе поля от камеры. Размытие затеняет оставшуюся часть изображения.

    Примечание.

    Анимируйте глубину резкости поля, чтобы смоделировать эффекты фокусировки.

Координаты 3D-камеры показаны в виде числовых значений X, Y и Z на панели параметров. Задать позицию камеры можно вручную, изменив эти значения.

Изменение или создание поля обзора 3D-камеры

  1. Выполните одно из следующих действий.

    • В меню «Просмотр» выберите стиль поля обзора модели.

    Примечание.

    Во всех предустановках ракурса камеры используется ортогональная проекция.

    • Для добавления заказного ракурса поместите 3D-камеру в необходимое положение с помощью инструментов 3D-камеры, а затем нажмите кнопку «Сохранить» на панели параметров.

    Примечание.

    Чтобы вернуть поле обзора камеры к значению по умолчанию, выберите инструмент «3D-камера» и щелкните значок «Возврат к исходному положению камеры» на панели параметров.

Ось 3D

3D-ось показывает текущую ориентацию моделей, камер, источников света и сеток в трехмерном пространстве по осям X, Y и Z. Она появляется при выборе любого 3D-инструмента, предоставляя дополнительные возможности для манипуляций с выделенным элементом.

Photoshop: ось 3D
Ось 3D с выбранным инструментом «Поворот сетки»

A. Выбранный инструмент B. Свернуть или развернуть ось 3D C. Переместить элемент вдоль оси D. Повернуть элемент E. Сжать или удлинить элемент F. Изменить размер элемента 

Примечание.

Для отображения осей 3D требуется, чтобы параметр «Использовать рисование OpenGL» был активен. 

Отображение или скрытие 3D-оси

  • Выберите «Вид» > «Показать» > «3D-ось».

Сворачивание, восстановление, изменение размера 3D-оси

  1. Поместите указатель над 3D-осью для отображения панели управления.

  2. Выполните одно из следующих действий.

    • Чтобы переместить 3D-ось, перетащите панель управления.

    • Чтобы свернуть ось, щелкните значок сворачивания.

    • Чтобы восстановить нормальный размер оси, щелкните свернутую ось.

    • Чтобы изменить размер, перетащите значок масштаба.

Перемещение, поворот или масштабирование выбранных элементов с помощью инструмента «Ось 3D»

Для использования 3D-оси выделите мышью элемент управления осью, а затем перетащите его следующим образом:

Примечание.

Доступные элементы управления оси меняются в зависимости от текущего режима редактирования (объект, камера, сетка или свет).

  • Чтобы переместить выбранный элемент вдоль оси X, Y или Z, выделите треугольный кончик любой из осей. Перетащите вдоль оси в любом направлении.

  • Чтобы повернуть элемент, щелкните изогнутый сегмент вращения в пределах кончика оси. Появится желтый кружочек, показывающий плоскость вращения. Вращайте объект вокруг 3D-оси, зажав кнопку мыши и осуществляя круговые движения по часовой стрелке или против нее. Для более точного вращения переместите указатель дальше от центра 3D-оси.

  • Чтобы изменить размер элемента, потяните за куб в центре 3D-оси по направлению вверх или вниз.

  • Чтобы сжать или растянуть элемент по направлению оси, потяните за один из цветных кубов трансформации по направлению к центральному кубу или от него.

  • Чтобы ограничить перемещение плоскостью объекта, переместите указатель в область пересечения двух осей рядом с центральным кубом. Между двумя осями появится желтый значок плоскости. Перетаскивайте в любом направлении. Чтобы активировать значок плоскости, можно также поместить указатель в нижнюю часть центрального куба.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет