Projects

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

Use this document to learn about Projects types in After Effects

About projects

An After Effects project is a single file that stores compositions and references to all the source files used by footage items in that project. Compositions are collections of layers. Many layers use footage items (such as movies or still images) as a source, though some layers—such as shape layers and text layers—contain graphics that you create within After Effects.

A project file has the filename extension .aep or .aepx. A project file with the .aep filename extension is a binary project file. A project file with the .aepx filename extension is a text-based XML project file.

The name of the current project appears at the top of the application window.

A template project file has the filename extension .aet. (See Template projects and example projects.)

XML project files

Text-based XML project files contain some project information as hexadecimal-encoded binary data, but much of the information is exposed as human-readable text in string elements. You can open an XML project file in a text editor and edit some details of the project without opening the project in After Effects. You can even write scripts that modify project information in XML project files as part of an automated workflow.

Elements of a project that you can modify in an XML project file:

  • Marker attributes, including comments, chapter point parameters, and cue point parameters

  • File paths of source footage items, including proxies

  • Composition, footage item, layer, and folder names and comments

Obs!

Footage item names are exposed in string elements in XML project files only if the names have been customized. Footage item names derived automatically from the names of source files and solid color names are not exposed in string elements

Some strings, such as workspace and view names, are exposed as human-readable strings, but modifications made to these strings are not respected when After Effects opens the project file.

Obs!

Do not use the XML project file format as your primary file format. The primary project file format for After Effects is the binary project file (.aep) format. Use the XML project file format to save a copy of a project and as an intermediate format for automation workflows.

Obs!

To save an XML project (.aepx) file as a binary project (.aep) file, choose File > Save As and enter a filename ending with .aep, without the x. (See Save and backup projects in After Effects.)

Project links embedded in QuickTime, Video for Windows files

When you render a movie and export it to a container format, you can embed a link to the After Effects project in the container file.

To import the project, import the container file, and choose Project from the Import As menu in the Import File dialog box. If the container file contains a link to a project that has been moved, you can browse to locate the project.

Create and open projects

Only one project can be open at a time. If you create or open another project file while a project is open, After Effects prompts you to save changes in the open project, and then closes it. After you create a project, you can import footage into the project.

  • To create a project, choose File > New > New Project.

  • To open a project, choose File > Open Project, locate the project, and then click Open.

You can also create and open a project from the Start screen.

  • To create a project, click New Project.
  • To open a project, click Open Project and navigate to the location of the project.

Jeff Almasol provides a script on his redefinery website that creates and saves a new project for each selected composition in the current project.

Template projects and example projects

A template project is a file with the filename extension .aet. You can create templates based on your projects.

Obs!

After Effects does not install template projects.

When you open a template project, After Effects creates a new, untitled project based on the template. Saving changes to this new project does not affect the template project.

Obs!

A great way to see how advanced users use After Effects is to open one of the template projects included with After Effects, open a composition to activate it, and press U or UU to reveal only the animated or modified layer properties. Viewing the animated and modified properties shows you what changes the designer of the template project made to create the template.

Often, the creator of a template project locks layers that are to be left unmodified, and leaves layers to be modified unlocked. It is a convenient way to prevent accidental or inappropriate modifications.

For more sources of After Effects example projects and template projects, see After Effects community resources on the Adobe website.

See this video tutorial by Andrew Devis on the Creative COW website for information about where to find template projects and sample expressions included with After Effects.

Open a template project

  • To open a template project, choose File > Open Project. On Windows, choose Adobe After Effects Project Template from the Files Of Type menu.

Create a template project

  • To convert a project to a template project, change the filename extension from .aep to .aet.
  • To save a copy of a project as a template project, choose File > Save A Copy, and then rename the copy with the filename extension .aet.

Set a template for new projects

You can create a template with your preferred project settings such as color management and folder structure, and use it as a foundation for every new project you create.

To set a template for your new After Effects projects:

  1. Choose Edit > Preferences > New Project.
  2. Enable the New project loads template check box.
  3. Click Choose Project Template and select a template file. 
Obs!

The format of the template project can be .aet, .aep, or .aex.

Team Projects

Team Projects is a hosted collaboration service for CC enterprise and CC teams users that enables editors to seamlessly collaborate in the editing workflow in real time. Using Team Projects, editors and motion graphics artists can work simultaneously in shared team projects within Adobe Premiere Pro, After Effects, and Adobe Prelude without any additional hardware.

The project updates are securely tracked in the cloud and the source files are saved locally or in lightweight, shared proxies. Team Projects also include deep collaboration features like version control and smart conflict resolution.

  • To create a team project, choose File > New > New Team Project.
  • To open a team project, choose File > Open Team Project.

For detailed information on how to use Team Projects for your collaborative workflow, see Working simultaneously in shared video projects.

Convert Team Project to an Adobe After Effects Project

You can convert your Team projects to a local Adobe After Effects Project (.aep). Select Edit > Team Projects > Convert Team Project to Project.

Converting Team Project to an Adobe After Effects Project
Converting Team Project to an Adobe After Effects Project

Save and back up projects in After Effects

  • To save a project, choose File > Save.
  • To save a copy of the project with a new automatically generated name, choose File > Increment And Save, or press Ctrl+Alt+Shift+S (Windows) or Command+Option+Shift+S (Mac OS).
  • A copy of the current project is saved in the same folder as the original project. The name of the copy is the name of the original followed by a number. If the name of the original ends with a number, that number is increased by 1.
  • To save the project with a different name or to a different location, choose File > Save As > Save As. The open project takes the new name and location; the original file remains unchanged.
  • To save the project as a copy in the XML project file format, choose File > Save As > Save A Copy As XML. (See About projects.)
  • To save a copy of the project with a different name or to a different location, choose File > Save As > Save A Copy. The open project retains its original name and location, and a copy is created with the new settings but is not opened.
  • To save a copy of a project to be opened by the previous major version, choose File > Save As > Save A Copy As <previous major version number>. (For more information, see this blog.)
Obs!

New features in the current version of After Effects that are used in a project are ignored in the project that is saved in the format of the previous version of After Effects.

To save a copy of the project and copies of assets used in the project to a single folder on disk, use the Collect Files command. (See Collect files in one location section for details).

Flowchart panel

In the flowchart for each project or composition, individual boxes (or tiles) represent each composition, footage item, and layer. Directional arrows represent the relationships between components.

Obs!

The Flowchart panel shows you only the existing relationships. You cannot use it to change relationships between elements.

Nested compositions and other elements that make up the composition appear when you expand a composition tile.

Mid-gray lines between tiles in the flowchart indicate that the Video or Audio switch for those items is deselected in the Timeline panel. Black or light gray lines indicate that the switch is selected, depending on the Brightness setting in the Appearance preferences.

  • To open the project flowchart, press Ctrl+F11 (Windows) or Command+F11 (Mac OS), or click the Project Flowchart button at the top of the vertical scroll bar on the right edge of the Project panel.
  • To open a composition flowchart, select the composition and choose Composition > Composition Flowchart, or click the Composition Flowchart button at the bottom of the Composition panel.
  • To activate (select) an item, click its tile in the Flowchart panel.

    When you click a composition in the flowchart, it becomes active in the Project panel and the Timeline panel. When you click a layer, it becomes active in the Timeline panel. When you click a footage item, it becomes active in the Project panel.

  • To customize the appearance of the flowchart, use the Flowchart panel menu and the buttons along the bottom of the panel.
Obs!

For tool tips identifying the buttons in the Flowchart panel, let your pointer hover over a button until the tool tip appears.

  • To delete elements, select them and press Delete. If the selected element is a footage item or composition, it is deleted from the project and no longer appears in the Timeline and Project panels. If the selected element is a layer, it is deleted from the composition in which it appears.
  • To access the context menu for a selected element, right-click (Windows) or Control-click (Mac OS) the icon to the left of the name in the element tile. The icons have various appearances, depending on the element type, such as layers and compositions . For example, you can use the context menu for a layer to work with masks and effects, or to change switches, apply transformations, and adjust layer image quality.
Obs!

When you change element properties in the Flowchart panel, be careful to context-click the icon in the tile, not the name of the element. The context menu associated with the element icon is different from the one that opens from the element name.

Rich Young provides additional information about the Flowchart panel and the Composition Mini-flowchart on the After Effects Portal website.

Adobes logotyp

Logga in på ditt konto