Learn how to share changes, receive changes, resolve editing conflicts when working on team projects.

Share your changes

The team projects service auto-saves every edit you make. However, your collaborators cannot see these edits until you choose to share your changes as a new version with them. Once you share your changes, an updated version is immediately made available to your collaborators. 

The team project service:

  • Examines your private view of the team project
  • Verifies that there are no conflicts with the work others have shared, and
  • Incorporates your changes into the current version of the shared team project. 

 

  1. Click the Share My Changes arrow icon located in the lower-right corner of the Team Project panel.

    Share changes
    Share changes
    Inviting collaborators to join a team project
    Inviting collaborators to join a team project
  2. Alternately, in the File menu, select Edit > Team Project > Share My Changes.

  3. You can see a screen that prompts you to enter a comment about the changes you made. To make your changes available to your collaborators, click Share.

    Share
    Share
    Event details
    Event details

    Obs!

    You are reminded every two hours if you have not shared your changes. To change the frequency of this reminder or dismiss it, modify the settings in Preferences > Collaboration  within the Unshared Team projects Changes section.

    ss_share_3b

Use visual cues

New asset status badges in Premiere Pro alert you when team members edit the assets before they share those changes. These visual cues avoid editing conflicts:

  • A white up arrow indicates that you have added an asset and not shared, so your collaborators do not have access to that asset in the team project.
Use visual cues
Use visual cues
  • A white pencil indicates that you have edited an asset.
Edited asset
Edited asset
  • A yellow pencil indicates that another collaborator has edited it.
Another collaborator edits an asset
Another collaborator edits an asset
  • A red pencil warns that you and another editor have edited the asset which would lead to a conflict when shared.
Conflict shared
Conflict shared
  • A red trash can warns that a collaborator has deleted an asset.
Deleted asset
Deleted asset

Get latest changes from collaborators

  1. Click the Get Latest Changes arrow icon located in the lower-right corner of the Team Project panel. Alternatively, from the File menu, select Edit > Team Project > Get Latest Changes. Any changes made by your collaborators are synchronized and made available in a new version.

    Share changes
    Get Latest Changes

You are notified whenever collaborators share changes in several ways:   

  • OS-level notifications
ss_share_4
  • Creative Cloud desktop application notifications.
Collaborators share changes on team projects
Collaborators share changes on team projects

When another collaborator shares changes, a corresponding "shared" badge is added to the item in the Team Project Panel, the Timeline, and the Program Monitor or Source Monitor. 

Resolve conflicts

When multiple collaborators simultaneously work on a team project, it is possible that some of your edited assets conflict with their versions shared by another collaborator. If you attempt to share your changes in that situation, team projects display a conflict resolution dialog box with the following options:

  • You can retain your version.
  • You can retain the shared version.
  • You can copy and rename your version before accepting the shared version.

You can also decide to individually or collectively resolve all conflicts.

Obs!

If you want to see the scope of changes in an asset or sequence before you resolve the conflict:

  • Click the Stop Resolving button in the Resolve conflicts dialog box
  • Navigate to the version history and open the conflicting asset as read-only in the source monitor, and 
  • Compare it with your version.

For more information, see Viewing Team Projects Versions.

 

11
Resolving editing conflicts

View unresolved conflicts

When you choose to stop resolving the conflicts with your team projects collaborators, a red badge indicator on the conflicting assets enables you to view and resolve them later. 

View unresolved conflicts
View unresolved conflicts

View versions of team projects

Each time a collaborator shares a change, the team projects service creates and stores a new version of the project. You can easily view or go back to a previously shared version. Versions are a permanent and easy way to maintain the shared history of a team project. 

  1. Select Edit >Team Project >Browse Versions to navigate the Media Browser to the current version of the project. At the right edge of the Media Browser, you can find the Team Project Version Slider, which allows you to quickly browse through all versions of the selected team project.

    View versions of team projects
    View versions of team projects
  2. Alternatively, right-click on a team project under "Creative Cloud" to run a list of all team project versions and associated information, such as previously made share comments. You can also use the versions slider to visually scroll through the various versions of the team projects. 

    Team project version
    Team project version
    Team projects versions
    Team projects versions
    Slider view of team project versions
    Slider view of team project versions
  3. Right-click team project under "Creative Cloud" in the Media Browser, and select New Team Project From Version to create a team project from a prior shared version. A dialog  box with the following characteristics opens up:

    • Pre-populate the name of the current team project and append a copy to it
    • Queue up the same list of collaborators as the original team project.

    To create a team project, click Ok.

    New team project from a version
    New team project from a version
    New team project dialog created from a version
    New team project dialog created from a version

View auto-saves

The team projects service automatically saves every edit you make. team projects data is saved automatically in a local database. Given an active network connection, it is synced to the team projects service automatically or whenever you try to share, get latest changes, or resolve conflicts.

The new auto-saves feature allows you to check when your edits were auto-saved, easily revert to a previous auto-save, or create a team project from an existing auto-saved edit.

  1. Select Edit >Team Project > Browse Auto-Saves to browse your personal auto-saves of the currently open team project.

    View autosaves
    View autosaves
  2. Alternatively, right-click on a team project under "Creative Cloud" and select the Team Project Auto-Saves... menu item to view a list of all your team project auto-saves. You can also use the Team Projects Auto-Saves slider to scroll through auto-saves.

    Menu item to open list view of Auto-Saves
    Menu item to open list view of Auto-Saves
    List view of auto-saves in a team project
    List view of auto-saves in a team project
    Browsing with the Team Projects Auto-Saves slider
    Browsing with the Team Projects Auto-Saves slider
  3. Select Make Auto-Save the Latest to undo a recent change and make a prior auto-save the current one.

    Make Auto-Save the Latest
    Make Auto-Save the Latest
  4. To create a team project from an auto-save, right-click on the team project under Creative Cloud and select New Team Project From Auto-Save and click OK.  A dialog opens and:

    • Pre-populates the name of the current team project
    • Appends an auto-saved copy to it
    • Queues up the same list of collaborators as the original team project.
    New team project from autosave
    New team project from autosave
    New team project dialog created from an autosave
    New team project dialog created from an autosave

    Obs!

    You cannot view auto-saves within Prelude as it does not support media browser.

Use interrupted connection mode

Team projects include an Interrupted Connection mode feature that allows you to continue working even if your Internet connection is temporarily interrupted.  During such interruptions, you cannot share your changes or get latest changes from other collaborators, but you can continue to work with your edits being saved locally.

0

When the Internet connection is interrupted and collaboration features are unavailable:

  • The collaborator icons disappear, the Get Latest Changes and Share My Changes buttons are disabled.
  • The sync status icon changes to a yellow warning triangle.

This icon is located in the lower-left corner of the Premiere Pro interface, and in the upper right corner in After Effects. Mouse over the icon to view the status of the connection mode disconnected (changes are saved locally)  and the time of the last sync before your connection was interrupted.


Team project
Team project
1

When you are reconnected to the Internet, the collaborator icons, Get Latest Changes and Share My Changes buttons reappear. The sync status icon changes to gray arrows to indicate that your local changes are pending to be  synced to the cloud. When these changes are synced, blue arrows are shown. A green check mark is shown once sync is complete. Mouse over the icon to view information about the Connected (all local changes have been synced remotely)  status and the time of the last sync.


Team project
Team project

Obs!

The team projects service is not designed to support offline workflows. Working in a team project for an extended period when disconnected from the Internet is not recommended. The Interrupted Connection mode feature is meant to provide safety and security if there are intermittent Internet interruptions only.

Denna produkt är licensierad enligt en Creative Commons Erkännande-Ickekommersiell-Dela Lika 3.0 Unported-licens  Twitter™- och Facebook-inlägg omfattas inte av villkoren i Creative Commons-licensen.

Juridiska meddelanden   |   Onlinesekretesspolicy