Experiencing issues while saving a file in Illustrator? Here are some self-troubleshooting steps that you can try.
Save issue

Sometimes, Illustrator is unable to save the file because the file is damaged or corrupt. 
  Facing a different issue? Click here for more help.


Try these resolutions

When the .ai file is found to be damaged, try the following resolutions to recover the affected file contents in a new and healthy file:

Save file with a different format

Change the .ai file to a different format (.svg, .png) and then try to save the file again.

Save file in a PostScript format

Save the Illustrator file as a PostScript file, and then open and save the PostScript file in Illustrator.

Note: To perform this solution you must have a PostScript printer driver installed. For information about installing Postscript printers in Windows Vista and XP, see the Windows Help Menus.

  1. Choose File > Print.

  2. Specify the desired print or output settings.
  3. Choose Adobe Postscript File from the Printer pop up menu, and then click Save.

  4. Type a filename that includes a .ps extension (for example, Filename.ps), and then click OK (Windows) or Save (macOS).

  5. Open the PostScript file in Illustrator and then try to save it in the .ai format.

Copy contents into a new file

  1.  Remove unwanted items, such as stray points, unpainted objects, empty text paths, from the artwork.
    Choose Object > Path > Cleanup.

  2. If the original file contains multiple layers, ensure the artwork appears on the same layers when you paste it into the new file.
    Choose Paste Remembers Layers from the Layers Panel more options menu.

  3. Using the Selection tool, drag a marquee around the artwork.

  4. Choose Edit > Copy.

  5. Choose File > New to create a new file.

  6. In the new file, choose Edit > Paste In Front to paste the artwork in the correct position on the page.

  7. Choose File > Save.

Identify and remove damaged components

To determine whether an object is damaged, delete it from the new file, and then save and reopen the file.

  • If an Illustrator-drawn object is damaged, re-create the object with the drawing tools.
  • If a linked image is damaged, re-create the original image, and then replace it in your artwork.
  • If a text object is damaged, convert the text object to outlines or change its font.

Change fonts

  1. Choose Object > Unlock All.

  2. Choose Edit > Select All.

  3. Choose Type > Font, and select a font that is not used in the document.

Opomba:

To prevent text objects from becoming damaged in the future, reinstall the problematic font from the original disk.

Delete unused swatches, custom colors, color groups, brushes, symbols, or styles

Eliminate a problem caused by a damaged swatch, brush, symbol, or style by deleting unused swatches, custom colors, color groups, brushes, symbols, or styles.

Choose Select All Unused from the Swatches panel menu, from the Brushes panel menu, from the Symbols panel menu, and from the Styles panel menu, and then press Delete.

Identify the damaged pattern, gradient, or custom color

To determine if the problem is caused by a damaged pattern, gradient, or custom color:

Choose Edit Select All and change the fill and stroke to process black. Check if the issue still occurs in a new file that does not contain patterns, gradients, or spot colors. If the issue does not recur, re-create the pattern, gradient, or spot color in the original file.

Note: You may lose the transparency and layer information.

Re-create the file

If no resolution works, re-create the file in Illustrator after resaving or re-creating graphics, templates, and custom colors used in the original file. 

Facing a different issue?

Apart from the damaged documents, there are some other general issues that can result in files not getting saved. For example, issues related to memory, access permissions, network, and removable media.

For more information about them, see Identify and troubleshoot file issues

Join the conversation

Ask the community

If you have a question to ask or an idea to share, come and participate in Adobe Illustrator Community. We'd love to hear from you.