Your computer must meet the minimum technical specifications outlined below to run and use Illustrator.

Applicable for:

November 2019 release

System requirements for earlier releases

Minimum system requirements for Illustrator

Windows

  Minimum requirement
Processor

Multicore Intel processor (with 64-bit support) or AMD Athlon 64 processor

Operating system Microsoft Windows 7 (64-bit) with Service Pack 1 or Windows 10* (64-bit)
RAM

8 GB of RAM (16 GB recommended) 

Hard disk

2 GB of available hard-disk space for installation; additional free space required during installation; SSD recommended

Monitor resolution

1024 x 768 display (1920 x 1080 recommended)

To use Touch workspace in Illustrator, you must have a touch-screen-enabled tablet/monitor running Windows 10 (Microsoft Surface Pro 3 recommended).

GPU

OpenGL 4.x

Optional: To use GPU Performance: Your Windows should have a minimum of 1GB of VRAM (4 GB recommended), and your computer must support OpenGL version 4.0 or greater.

Internet connection

Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.*

* Not supported on Windows 10 versions 1507, 1511, 1703, and 1709.

Opomba:

  • Scalable UI feature is supported on Winodws 10 (minimum resolution supported is 1920 x 1080).
  • Auto handle feature is supported on Windows 10.
  • GPU in Outline mode is supported on monitor with display resolution at least 2000 pixels in any dimension.

Supported video adapter

The following video adapter series support the new Windows GPU Performance features in Illustrator:

NVIDIA

 

  • NVIDIA Quadro K Series
  • NVIDIA Quadro 6xxx
  • NVIDIA Quadro 5xxx
  • NVIDIA Quadro 4xxx
  • NVIDIA Quadro 2xxx
  • NVIDIA Quadro 2xxxD
  • NVIDIA Quadro 6xx
  • NVIDIA GeForce GTX Series (4xx, 5xx, 6xx, 7xx, 9xx, Titan)
  • NVIDIA Quadro M Series
  • NVIDIA Quadro P Series

Important: Microsoft Windows may not detect the availability of the latest device drivers for NVIDIA GPU cards. Get the latest GPU card device drivers:

 - Quadro series
 - Other series

Intel

  • Intel HD Graphics 4600 Series
  • Intel HD Graphics 5000 Series
  • Intel Iris Graphics 5000 Series
  • Intel Iris Pro Graphics 5000 Series
  • Intel HD Graphics 6000 Series
  • Intel Iris Graphics 6000 Series

AMD

The following series are supported only on Windows 8 or later:

  • AMD Radeon R9 Series Graphics
  • AMD Radeon R7 Series Graphics
  • AMD Radeon HD 7000 Series Graphics
  • AMD Radeon HD 8000 Series Graphics
  • AMD FirePro V Series Graphics
  • AMD FirePro W Series Graphics

Opomba:

Ensure that you have the latest GPU card drivers installed. See Illustrator GPU Performance | Driver Updates.

macOS

  Minimum requirements
Processor

Multicore Intel processor with 64-bit support

Operating system macOS version 10.15 (Catalina), macOS version 10.14 (Mojave), and 10.13 (High Sierra)
RAM

8 GB of RAM (16 GB recommended)

Hard disk

2 GB of available hard-disk space for installation; additional free space required during installation; SSD recommended

Monitor resolution

1024 x 768 display (1920 x 1080 recommended)

GPU

Optional: To use GPU Performance: Your Mac should have a minimum of 1 GB of VRAM (2 GB recommended), and your computer must support OpenGL version 4.0 or greater.

For eGPU, support on Mac OS 10.13.5 or above.

Internet connection

Internet connection and registration are necessary for required software activation, validation of subscriptions, and access to online services.*

Opomba:

  • Scalable UI feature (minimum resolution supported is 1920 x 1080)
  • GPU in Outline mode is supported on Retina display

* NOTICE TO USERS:

  • Internet connection, Adobe ID, and acceptance of license agreement required to activate and use this product. This product may integrate with or allow access to certain Adobe or third-party hosted online services. Adobe services are available only to users 13 and older and require agreement to additional terms of use and the Adobe Privacy Policy. Applications and services may not be available in all countries or languages and may be subject to change or discontinuation without notice. Additional fees or membership charges may apply.
  • Illustrator is not supported on virtualized or server-based environments. These environments include, but are not limited to, Citrix Metaframe/Citrix Presentation Server, NVIDIA Grid, Microsoft App-V, VMWare, Parallels, and Virtual PC. "Thin Clients" are also server-based environments.
  • Illustrator is not supported on case-sensitive file system, removable flash storage devices, and network drives.

Language versions available for Illustrator

Illustrator is available in the following languages:

Dansk

Deutsch

English

Español

Français

Français*

Hebrew*

Hungarian

Italiano

Nederlands

Polish

Português (Brasil)

Svenska

Turkish

Ukrainian

čeština

Русский

عربي*

日本語

简体中文

繁體中文

한국어

* Arabic and Hebrew supported in a Middle Eastern version with full right-to-left language support, Arabic/Hebrew features, and an English interface; also in a North African French (Français*) version with full right-to-left language support, Arabic/Hebrew features, and a French interface.

Za ta izdelek je bila izdana neprenosljiva licenca za priznanje avtorstva, nekomercialno uporabo in skupno rabo pod enakimi pogoji 3.0  Objav v storitvah Twitter™ in Facebook ne urejajo pogoji pogodbe Creative Commons.

Pravna obvestila   |   Pravilnik o zasebnosti v spletu