Current Version: 9.5 |
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Dynamics için Adobe Sign v9.3.x desteği Kasım 2021'de sona ermiştir.
- Tüm paket sürümleri mümkün olan en kısa sürede en güncel sürüme yükseltilecektir.
- 9.3.x ve önceki sürümlere erişim olanağının, 2022'nin üçüncü çeyreğinde tamamen kaldırılması planlanmaktadır.
Lütfen bu yükseltme gereksiniminin, uygulanan güncellemelerin yapısı nedeniyle entegrasyonların normal kullanım ömürleri için bir istisna oluşturduğunu unutmayın.
MS Dynamics Online documents:
MS Dynamics On-Prem documents:
Common Questions
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Sign in to MS Dynamics.
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Navigate to Settings > Customization.
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Click the Customize the System option.
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In the left navigation pane, click the required custom entity.
For example, Yukti_test. -
To display the fields and controls, click the name of the Entity.
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Navigate to Forms, and then click the Information link associated with the Main form type.
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Add New field and enter the name of the field.
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Save and close.
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Drag-and-drop the field in the Entity, and then Save and publish all customization.
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Sign in to MS Dynamics.
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Navigate to Settings > Customization.
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Click the Customize the System option.
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In the left navigation pane, click the required custom entity.
For example, Customer.
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To display the fields and controls, click the name of the Entity.
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Copy the value from the Name field (for example the value is new_customer).
It is the internal system name of your custom Entity. -
Navigate to the 1:N Relationships option, under your custom Entity.
Click the New 1-to-Many Relationship button. -
Create the relationship:
- Choose Agreement from the Related Entity field.
The Name field changes to show {entityName}_adobe_agreement. - Paste the name of your custom entity, for example, new_customer, in the Display Name field.
The Name field changes its value to “new_” + {entityName} + “Id”. (new_new_customerID).
c. Click Save and Close.
The Relationship window closes.d. Click Publish All Customizations at the top of the 1:N Relationships page.
- Choose Agreement from the Related Entity field.
There is a known issue for On-Premises CRM environments that have a multiple server setup (CRM is on one server and DB is on another server) and their SPN is not configured correctly.
This results in the Admin Settings page showing up blank.
The best solution to this issue is to contact Microsoft Dynamics Support and enlist their support in configuring the SPN correctly.
A brief overview of the SPN configuration can be found here.
A workaround to the problem for most environments:
- Download the Microsoft Dynamics CRM SDK
- Run MicrosoftDynamics365SDK.exe
- Find and run the Plugin Registration Tool (SDK\Tools\PluginRegistration)
- Connect the Plugin Registration Tool to your Dynamics instance (click here for instructions)
- Browse the AdobeSign assembly
- Specify the Isolation Mode as None
- Click the Update Selected Plugins button when done
If this workaround does not solve the problem, contact Microsoft CRM Support to investigate the SPN for your environment.
Once the SPN issue is resolved, the Isolation Mode setting can be returned to Sandbox.
A sender is getting the following error while sending a record for signature. They get the error when the agreement record is created.
The error appears when the sender goes to more options and then clicks “Send for signature”. The issue occurs only in a production environment where the application security (F5) and load balancers are set up.
Answer:
When the managed solution for Acrobat Sign is imported in CRM, the associated plug-in libraries are registered under the isolation mode: sandbox. This causes problems in production environments. Manually update it to “None”.
Issue:
The following errors show up when importing Microsoft Dynamics v6:
Errors:
- “The import of solution Adobe Sign failed”
- "A SQL Server error occurred. Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support"
Cause:
The error during solution upgrade points to the SQL server error, which means there is a traffic overload in CRM’s DB connection or SQL server is in a bad state.
Resolution:
- CRM admin should inspect CRM server’s application Event Log to see if any other error can be seen there that could point to SQL server issues.
- Manually drop fulltext index on adobe_agreementBase and on adobe_agreementtemplateBase tables in SQL server.