PDFMaker 在 Office 2010、2013 或 2016 中與 Acrobat 或 Acrobat 2017 的問題

PDFMaker 工具列無法使用

在 Windows 安裝 Acrobat 或 Acrobat 2017 後,Acrobat PDFMaker 工具列在 Office 2010、2013 或 2016 應用程式中無法使用。

註解:

嘗試下列其中一或多個解決方案。

解決方案 1:從 Office 應用程式的停用項目清單中啟用 PDFMaker 增益集

Microsoft® Office 應用程式有時會自動停用增益集,以做為應用程式意外關閉時的故障保護。

  1. 開啟 Microsoft® Office 應用程式。

  2. 選取藍色的「檔案」選單 (位於左上角)。選取「[應用程式名稱] 選項」按鈕。在「選項」視窗左側清單上選擇「增益集」。在「選項」視窗底部的「管理快顯視窗選單」選擇「停用項目」。選取「前往」。

  3. 在「停用項目」清單中尋找 Acrobat PDFMaker Office COM 增益集:

    • 若「Acrobat PDFMaker Office COM 增益集」在清單中,請選取該項目,按一下「啟用」,然後按一下「關閉」。然後關閉並重新開啟 Office 應用程式。
    • 若「Acrobat PDFMaker Office COM 增益集」不在清單中,則使用「Windows 檔案總管」在 C:\Program Files\Adobe\Acrobat [Pro/Std、2015 或 2017]\PDFMaker\Office 中尋找 PDFMOfficeAddin.dll。若該檔案不存在,請前往「解決方案 5」尋找如何修復 Acrobat 安裝的指示。

      注意:
      若您將 Acrobat 安裝於 C:\Program Files\Adobe 預設路徑以外的位置,請將以上資料夾路徑修改為您的安裝位置。

解決方法 2:修改 PDFMaker OfficeAddin 或 PDFMOutlook 機碼的登錄項目

  1. 全部關閉 Office 免權利金資產。

  2. 按下 Windows + R 鍵以開啟「執行」命令視窗。

  3. 在「開啟」欄位中輸入 regedit,然後按一下「確定」

  4. 在登錄編輯程式中,前往下列位置:

    如果是 Outlook:「\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook」

    如果是 Word:「\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin」

    如果是 Excel:「\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin」

    如果是 PowerPoint:「\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\PowerPoint\Addins\PDFMaker.OfficeAddin」

  5. 開啟「Loadbehavior」的內容選單,然後選擇「修改」。在「編輯 DWORD 值」對話方塊中,將數值資料從「0」變更為「3」,然後選取「確定」。

    將 LoadBehavior 的值從 0 變更為 3。

  6. 關閉「登錄編輯程式」,然後重新啟動 Office 應用程式。

若 PDFMaker 增益集仍然不在 Office 應用程式中,請執行下列動作:

  1. 開啟「登錄編輯程式」,然後前往「HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\<Word/Excel/PowerPoint/Outlook>\Resiliency」。
  2. 建立機碼「DoNotDisableAddinList」,接著新增 DWORD「PDFMaker.OfficeAddin」並將其值設為「1」。
  3. 關閉「登錄編輯程式」,然後重新啟動 Office 應用程式。

解決方法 3:手動登錄 COM 增益集檔案

注意:

此程序涉及編輯 Windows 登錄。Adobe 不支援編輯任何包含重要系統和應用程式資訊的 Windows 登錄。在編輯登錄前,請務必進行備份。如需登錄的詳細資訊,請參閱 Windows 文件或聯絡 Microsoft®。

  1. 關閉所有 Office 應用程式。
  2. 在 Windows 檔案總管中,找出 PDFMOfficeAddin.dll 並記下可能包括空格的正確路徑。其預設路徑為:

    Acrobat:C:\Program Files (x86)\Adobe\Acrobat\PDFMaker\Office\PDFMOfficeAddin.dll

    Acrobat Classic (2015):C:\Program Files (x86)\Adobe\Acrobat 2015\PDFMaker\Office\PDFMOfficeAddin.dll

    Acrobat 2017:C:\Program Files (x86)\Adobe\Acrobat 2017\PDFMaker\Office\PDFMOfficeAddin.dll

  3. 執行下列任一項作業:

    • 在 Windows 7 上:選擇「開始 > 所有程式 > 附屬應用程式」。開啟「命令提示字元」的內容選單,選擇「以系統管理員身分執行」,然後進行驗證。
    • 在 Windows 8/10 上:使用「開始」按鈕旁的「搜尋」按鈕,搜尋「命令提示字元」。開啟「命令提示字元」的快顯選單,選擇「 以系統管理員身分 執行」,然後進行驗證。
  4. 在「命令提示字元」視窗,鍵入 regsvr32,然後鍵入一個空格以及您在步驟 1 記下的路徑。用引號括住該路徑。例如,若 PDFMOfficeAddin.dll 位於其預設位置,您可以鍵入下列命令:

    針對 Acrobat:regsvr32 "C:\Program Files\Adobe\Acrobat\PDFMaker\Office\PDFMOfficeAddin.dll"

    針對 Acrobat Classic (2015):regsvr32 "C:\Program Files\Adobe\Acrobat 2015\PDFMaker\Office\PDFMOfficeAddin.dll"

    針對 Acrobat 2017:regsvr32 "C:\Program Files\Adobe\Acrobat 2017\PDFMaker\Office\PDFMOfficeAddin.dll"

  5. 按下 Enter。
  6. 對話方塊出現確定登錄成功。選取「確定」以關閉此對話方塊。

  7. 關閉「命令提示字元」視窗。
  8. 開啟 Office 應用程式。

解決方案 4:請確定 Acrobat PDFMaker Office COM 已新增至 Office 應用程式的可用增益集清單中

Office 2010、2013 或 2016

  1. 開啟 Microsoft® Office 2010 應用程式。

  2. 選取藍色的「檔案」選單 (位於左上角)。選取「[應用程式名稱] 選項」按鈕。在「選項」視窗左側清單上選擇「增益集」。 

  3. 在「選項」視窗或「信任中心」視窗的底部,於「管理快顯視窗選單」中選擇「COM 增益集」。

  4. 選取「前往」。

  5. 在清單中尋找 Acrobat PDFMaker Office COM 增益集:

    • 若 Acrobat PDFMaker Office COM 增益集出現在清單中,但其旁邊的核取方塊並未勾選,那麼請勾選該核取方塊。選取「確定」。然後關閉並重新開啟 Office 應用程式。(若您無法勾選,而且已經嘗試過解決方案 1,則請選取「Acrobat PDFMaker Office COM 增益集」。按一下「移除」,然後繼續下一段落。)
    • 若 Adobe PDFMaker COM 增益集不在可用增益集清單中,那麼請按一下「新增」,然後導覽至 C:\Program Files\Adobe\Acrobat [Pro/Std、2015 或 2017]\PDFMaker\Office。選擇 PDFMOfficeAddin.dll。按一下「確定」。然後關閉並重新開啟 Office 應用程式。

      注意:若您將 Acrobat 安裝於 C:\Program Files\Adobe 預設路徑以外的位置,請將以上資料夾路徑修改為您的安裝位置。

解決方案 5:在其他應用程式未執行時修復 Acrobat 安裝

  1. 關閉所有開啟的應用程式。
  2. 重新啟動電腦。
  3. 開啟 Acrobat。
  4. 選擇「說明 > 修復 Acrobat 安裝」並按照螢幕指示。
  5. 當修復程序完成後,重新啟動您的電腦。

解決方法 6:在 Windows 簡化模式中移除並重新安裝 Acrobat

開機時自動執行的裝置驅動程式和程式可能會與 Acrobat 安裝程式發生衝突並產生問題。若要避免安裝衝突,請在 Windows 簡化模式重新安裝 Acrobat。在簡易模式中,非必要程式和驅動程式會被停用。

  1. 將任何個人檔案從 Acrobat 應用程式資料夾及其子資料夾移走。應用程式資料夾的預設位置是 C:\Program Files\Adobe\Acrobat [Pro/Std、2015 或 2017]。

  2. 請執行下列動作:

    • 在 Windows 7、8 和 10 上:開啟「開始」按鈕的內容選單,然後選擇「控制台程式和功能」。
  3. 在程式清單中,選取「Adobe Acrobat」或「Adobe Acrobat 2017」。

  4. 選取「解除安裝/變更」。

  5. 依照螢幕上的指示來移除應用程式。
  1. 關閉所有開啟的應用程式。
  2. 在停用非必要服務及啟動項目時重新啟動電腦。如需指示,請參閱下列文件:

  3. 連按兩下 Acrobat 或 2017 安裝檔案。依照螢幕上的指示完成安裝。

  4. 開啟 Acrobat 並選擇「說明 > 檢查更新」。請按照螢幕上的指示來安裝可用的更新。

  5. 重新啟用啟動項目及服務。如需指示,請參閱以上步驟 2 的「說明」文件。

  6. 重新啟動電腦。

 Adobe

更快、更輕鬆地獲得協助

新的使用者?