瞭解如何解決在 Adobe InDesign 中列印或轉存為 PDF 時可能會發生的問題。

依序進行本文件所述的工作,並在問題獲得解決時停止。

您也可以在這裡尋找列印及轉存的已知問題: https://helpx.adobe.com/tw/indesign.html

決定問題的層級

嘗試解決列印或轉存問題時,第一步是判斷發生問題的狀況。例如,錯誤是一次性的問題,或在列印/轉存所有文件、
部分文件或特定文件時都會重複出現?下列步驟和測試可協助定義問題的發生原因和時機,讓您找出解決方法。

1. 重新啟動電腦。

如果錯誤未重複發生,則原因可能是暫存通訊問題、低系統資源或其他暫存環境因素。如果在首次重新啟動電腦後,可列印或轉存檔案且未發生錯誤,但之後又再次發生錯誤,請在系統層級上疑難排解此問題

2. 將印表機關閉後再重新開啟。

如果錯誤未重複發生,則問題原因可能是印表機的記憶體。如果錯誤重複發生,請前往步驟 3。

3. 建立新的範例文件。

如果您成功列印或轉存新文件,但原始文件卻發生失敗,請在文件層級上疑難排解此問題

4. 使用其他應用程式列印或轉存檔案。

如果可從其他應用程式 (例如 WordPad、TextEdit) 列印檔案,或從其他應用程式 (例如 Illustrator、Photoshop) 轉存/儲存為 PDF,請在應用程式層級上難排解此問題

5. 列印至其他印表機。

如果可以使用其他印表機,請嘗試將文件列印至該印表機。如果列印成功,表示原先的印表機為關閉或處於離線狀態。請拔下印表機纜線再重新接上,然後在印表機上執行自我測試,檢查是否機器故障,或纜線是否損壞。如果這些步驟均無法辨識出問題,請在系統層級上疑難排解此問題

6. 使用不同的方法來建立 PDF 檔案.

  • 如果在 InDesign、Acrobat Standard、Pro 或 Pro Extended 中轉存為 PDF 時發生問題,請嘗試列印至 Adobe PDF 印表機。(如果使用 Mac OS 10.6 或更新版搭配 Acrobat 9,請參閱 Acrobat 9 另存為 Adobe PDF 的支援)。
  • 如果使用「列印」功能建立 PDF 發生問題,請改為選擇「檔案 > 轉存為 PDF」

疑難排解文件層級的列印或轉存問題

如果列印或轉存新文件時沒有發生錯誤,表示文件的列印或轉存設定可能失效,或文件中使用的某個物件或字體已損壞,或文件的結構發生損壞。試著進行下列一或多個步驟。

註解:

設定的位置可能會視您使用的印表機而定,也可能會和下列程序所列出的位置不同。請查看您的印表機文件。   

1. 轉存為 IDML (InDesign CS4 及更新版) 或 INX (InDesign CS3 及更新版)。

文件可能已損壞。從舊版 InDesign 或從 QuarkXPress 文件進行文件的轉換後,文件可能發生損壞。請轉存為 InDesign 標記語言 (IDML) 或 InDesign 交換格式 (INX),這麼做能去除有問題的資料。

2. (僅限 PostScript 印表機) 啟用 PostScript 錯誤處理。

Windows

  1. 選擇「檔案 > 列印」
  2. 按一下「設定」按鈕。
  3. 如果出現此對話框,請按一下「確定」: 「如果在 InDesign 的「列印」對話框中有您想要的列印設定,請在該對話框中進行設定,以避免發生列印衝突。」
  4. 在印表機上按一下滑鼠右鍵,然後選擇「內容」
  5. 在「一般」標籤中,按一下「列印喜好設定」
  6. 請按一下「進階」
  7. 展開「文件選項」,然後展開「PostScript 選項」。如果「傳送 PostScript 錯誤處理常式」沒有設為「是」,請按一下該項目,然後選擇快顯選單中的「是」

Mac OS X

  1. 選擇「檔案 > 列印」
  2. 按一下印表機。
  3. 在「預設集」選單下方的選單中選擇「錯誤處理」
  4. 選取「列印詳細報表」,然後按一下「列印」

若是 PostScript 錯誤導致問題,PostScript 錯誤處理常式將列印包含錯誤資訊的頁面。請參閱疑難排解 PostScript 錯誤

3. 排除文件中的圖形。

列印文件時排除圖形

  1. 選擇「檔案 > 列印」
  2. 按一下「圖形」,然後在「傳送資料」選單中選擇「無」
  3. 按一下「列印」

轉存文件時排除圖形

  1. 選擇「檔案 > 轉存」,然後選取「Adobe PDF (列印)」做為格式,或選取「存檔類型」。
  2. 選擇位置並按一下「儲存」
  3. 按一下「進階」,然後選取全部三項的「忽略 OPI」核取框:EPS、PDF 點陣圖
  4. 將 PDF 標準變更為「無」允許排除影像。
  5. 按一下「轉存」。

如果成功列印或轉存文件,表示頁面上的一或多個圖形元素可能已損壞。刪除單一頁面上的頁面或圖形框架來移除 50% 的圖形。接著請在每次變更後列印或轉存文件,判斷從群組中移除的已損壞圖形是否為錯誤的原因。如果在某次變更後成功列印或轉存文件,請回復變更,並移除剩餘頁面或圖形的其他 50%。請確認錯誤重複發生,然後再次刪除 50%,依此類推。識別持續產生錯誤的圖形後,請進行刪除並加以取代。您可能需要從建立該圖形的應用程式重新轉存圖形。

如果成功列印但不含圖形,也可能表示印表機記憶體不足。徵兆包括字體被替換、圖形遺失或不完整的列印成品。嘗試列印某個範圍的頁面,或只是發佈,查看是否列印較少的圖形。或嘗試以較低的解析度進行列印。

註解:

如果文件僅包含圖形元素,則只有當您在 InDesign 中啟用「列印空白頁面」選項時,才會在列印時收到空白頁面。在「列印」對話框的「一般」區段中選取「列印空白頁面」

4. 排除或將字體最小化。

列印時排除字體

  1. 選擇「檔案 > 列印」
  2. 按一下「圖形」
  3. 在「字體」區段的「下載」選單中選擇「無」
  4. 按一下「列印」

轉存為 PDF 時將字體最小化

您無法在列印時排除字體,但可以將使用的字體編號最小化。

  1. 選擇「文字 > 尋找字體」
  2. 在「文件」清單的「字體」中,按一下第一個字體,然後按住 Shift 鍵,並按一下最後一個字體,以選取清單中的所有字體。
  3. 在「取代為: 字體系列」清單中,選擇其他文件適用的已知字體,例如 Arial 或 Verdana。
  4. 按一下「全部變更」
  5. 按一下「完成」
  6. 選擇「檔案 > 轉存」,並選取「Adobe PDF (列印)」做為格式。
  7. 選擇位置並按一下「儲存」
  8. 按一下「轉存」。

如果文件成功列印或轉存,表示問題可能與文件中使用的其中一個字體有關。如果文件使用大量字體,請排除使文件較不複雜的字體。請將文件儲存為新名稱,同時測試字體,以判斷字體是否損壞。如果字體持續發生問題,請檢查文件中多個有效的字體,或重新向製造商下載字體,以確保字體沒有毀損。

5. 確認連結為有效。

若要檢視連結的狀態,請選擇「視窗 > 連結」。如果檔案名稱前面有問號或其他符號,請取消或重新連結這類檔案。如需 InDesign 連結的詳細資訊,請參閱管理圖形連結

6. 停用設定。

列印或轉存程序中的特定功能,在處理文件中的部分特殊內容時,有時會發生錯誤。盡可能排除這些類型的設定。
如果排除設定可解決問題,請分組重新啟用這些設定,以過濾出造成問題的特殊設定。

註解:

視您使用的印表機而定,可能會無法使用某些設定。

選擇「檔案 > 列印」,開啟「列印」對話框。然後在下列窗格中變更以下設定:

「一般」窗格

  • 將「份數」設定為 1
  • 選取「頁面」並停用「跨頁」
  • 清除「列印主版頁面」「列印非列印物件」 「列印可見的參考線和基線格點」
  • 將「列印圖層」設定為「可見和可列印圖層」

「設定」窗格

  • 將「紙張大小」設定為「由驅動程式定義」
  • 將「縮放寬度和高度」設定為 100%
  • 停用「縮圖」「拼貼」

「標記與出血」窗格

  • 停用「標記」「出血」 「印刷邊界」

「輸出」窗格

  • 將「色彩」設定為「複合色彩保留不變」
  • 停用「補漏白」「文字為黑色」「模擬疊印」
  • 油墨管理員中停用「油墨別名」

「圖形」窗格

  • 將「影像」設為「傳送資料至無或全部」
  • 將「字體」設為「下載至無或全部」
  • 將「PostScript」設為「層級 2」
  • 將「資料格式」設為 「ASCII」

「色彩管理」窗格

  • 將「色彩處理」設為「由 PostScript 印表機決定色彩」
  • 啟用「保留 CMYK 數值」

「頁面」面板 (位於「列印」對話框外)

選取所有頁面,按一下滑鼠右鍵,然後選擇「頁面屬性 > 跨頁平面化 > 無 (忽略透明度)」

7. 疑難排解增效模組。

從 InDesign 增效模組檔案夾中移除協力廠商增效模組,然後重新啟動 InDesign。如果該問題重複發生,請將增效模組移回 InDesign 增效模組檔案夾。如果問題未重複發生,即可分辨出發生衝突的增效模組:

  1. 選擇「說明 > 設定外掛程式」(Windows) 或「InDesign > 設定增效模組」(Mac OS)。
  2. 選取「集合的所有增效模組」,然後清除「顯示」區段中除「協力廠商」以外的所有選項。建立這些增效模組的清單。
  3. 結束 InDesign,並從 Plug-in 檔案夾移出這些增效模組:
    • Windows: /Program Files/Adobe/Adobe InDesign [版本]/Plug-Ins
    • Mac OS: /Applications/Adobe InDesign [版本]/Plug-Ins
  4. 重新啟動 InDesign,並嘗試重建問題:
    • 如果問題未重複發生,請重複步驟 3 和 4,將部分協力廠商的增效模組加回 Plug-Ins 檔案夾。
    • 如果該問題重複發生,請連絡前次移動的增效模組開發人員來查詢更新的相關資訊。

如需詳細資訊,請參閱疑難排解 InDesign 協力廠商增效模組

8. 從新的使用者帳戶列印或轉存。

使用者帳戶有時可能會損毀,讓應用程式無法讀取或寫入特定的檔案和檔案夾。建立新的使用者帳戶 (請勿刪除原先的使用者帳戶),並登入新的帳戶,然後重新試著列印或轉存文件。

Windows

選擇「開始 > 控制台 > 使用者帳戶」

Mac OS X

選擇「Apple 選單 > 系統偏好設定 > 使用者與群組」

9. 判斷文件是否損壞。

疑難排解應用程式層級的列印或轉存問題

如果您在列印任何 InDesign 文件時收到錯誤,請嘗試執行下列一或多項工作,以分辨應用程式層級的問題原因。

1. 重新建立 InDesign 偏好設定檔案。

當 InDesign 行為出現不正常的情形,刪除偏好設定 (也稱為「丟棄偏好設定」或「移除偏好設定」) 後再重新建立,通常可以解決問題。

有兩種重新建立偏好設定的方式:

  • 自動: 此方法可快速刪除目前的偏好設定檔案,然後重新產生一組新的預設偏好設定檔案。但您可能會遺失擁有的所有自訂設定。

-或-

  • 手動: 如果不想失去自訂設定,可以先將目前的偏好設定檔案重新命名,再重新建立一組新的預設偏好設定檔案。如此一來,若新的偏好設定仍無法解決列印或轉存問題,且您也有原始偏好設定檔案的備份 (其中含有所有自訂設定),就能使用該備份取代新的偏好設定檔案。

自動重新建立 InDesign 偏好設定檔案

註解:

重新建立 InDesign 偏好設定檔案會刪除之前的偏好設定資料,包括所有自訂設定。如果不想失去自訂設定,請手動重新建立偏好設定檔案

  1. 結束 InDesign。
  2. 重新啟動 InDesign,並按下適用於您作業系統的按鍵:
    • Mac OS: Control + Option + Command + Shift
    • Windows:Control + Alt + Shift
  3. 隨即會出現對話框,詢問您是否要刪除 InDesign 偏好設定檔案。按一下「是」。系統會以重新產生的預設偏好設定啟動 InDesign。

手動重新建立 InDesign 偏好設定檔案

將兩個偏好設定檔案重新命名 (例如將「InDesign SavedData」變更為「InDesign SavedData backup」,「InDesign Defaults」則變更為「InDesign Defaults backup」)。這些偏好設定檔案位於下列位置:

  • Mac OS X

    InDesign Defaults:

    Users/[使用者]/Library/Preferences/Adobe InDesign/Version [版本]/[語言]/InDesign Defaults

InDesign SavedData:

Users/[使用者]/Library/Caches/Adobe InDesign/Version [版本]/[語言]/InDesign SavedData

  • Windows XP

    InDesign Defaults:

    /Documents and Settings/[使用者]/Application Data/Adobe/InDesign/Version  [版本]/InDesign Defaults

預設為隱藏。瞭解如何顯示隱藏檔案。

InDesign SavedData:

/Documents and Settings/[user]/Local Settings/Application Data/Adobe/InDesign/Version [版本]/Caches/InDesign SavedData

  • Windows 7 和 8

InDesign Defaults:

C:\Users\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[語言]\InDesign Defaults

預設為隱藏。瞭解如何顯示隱藏檔案。

InDesign SavedData:

/Users/[使用者]/AppData/Local/Adobe/InDesign/Version[版本]/[語言]/Caches/InDesign SavedData

重新啟動 InDesign。InDesign 會建立一組新的預設偏好設定檔案。

如果持續發生列印或轉存問題,您可以將舊的偏好設定檔案命名為原先的名稱: InDesign SavedData 和 InDesign Defaults,以復原原始偏好設定。

2. (僅限 Windows) 確認您的印表機驅動程式為最新版。

為印表機安裝最新的驅動程式:

3. (僅限 Windows、PostScript 印表機) 將 PostScript 最佳化以獲得速度。

  1. 選擇「檔案 > 列印」
  2. 按一下「設定」並選取印表機,然後依序按一下「偏好設定」「進階」
  3. 展開「文件選項」,然後展開「PostScript 選項」。
  4. 選擇「PostScript 輸出選項」
  5. 選擇快顯選單中的「速度最佳化」,然後按一下「確定」
  6. 按一下「確定」,然後按一下「列印」

4. 停用印表機中的「頁面保護」。

請參閱印表機的隨附文件,以取得如何停用此功能的指示。

5. 將電腦連接至印表機。

如果在透過網路列印時發生問題,請將電腦直接連接至印表機,然後嘗試重新列印。

如果無法直接連接至印表機,請將文件另存為 PostScript 檔案。在能夠直接連線印表機,並將檔案傳送至印表機的電腦上使用命令提示字元。 

6. 將 PDF 另存在本機硬碟。

如果 PDF 轉存至網路位置時發生問題,請嘗試將 PDF 另存在本機硬碟。

網路不穩定或權限問題可能會在轉存至掛接的網路磁碟區時造成問題。如果能夠將檔案轉存至本機磁碟機,但無法轉存至網路位置,可以請 IT 部門調查此問題。

疑難排解印表機層級的列印問題。

解決列印至 PostScript 印表機的問題

如果列印至 PostScript 印表機時發生問題,請嘗試執行下列一或多項工作,並在完成每項工作後進行列印。

1. 使用更新的印表機驅動程式。

MacWindows 下載最新的 PostScript 印表機驅動程式。

註解:

如果使用網路印表機,則您使用的的印表機驅動程式可能與印表機伺服器作業系統相容,但與您電腦的作業系統不相容。若要安裝與您作業系統相容的印表機驅動程式,請使用「新增印表機」精靈重新設定網路印表機。請參閱安裝與您作業系統相容的印表機驅動程式

2. 使用更新的 PPD 檔案。

PostScript 印表機描述 (PPD) 檔案說明設定 (例如邊界、顏色和解析度) 的 PostScript 印表機功能。不正確或過期的 PPD 檔案可能會增加列印時間。使用印表機製造商建議的 PPD 檔案設定印表機。

請聯絡印表機製造商以取得 PPD 檔案,或從 Adobe 網站下載。

3. (僅限 Windows) 設定印表機以輸出最佳化的 PostScript 程式碼。

Windows 7:

  1. 選擇「開始 > 裝置和印表機」
  2. 按一下滑鼠右鍵並選擇「列印喜好設定 > 進階」
  3. 依序展開「文件選項」、「PostScript 選項」。
  4. 將「PostScript 輸出選項」設為「攜帶性最佳化」

4. 建立更多可用的磁碟空間。

確定有許多可用的硬碟空間。盡量讓硬碟保留至少總共 10% 的可用空間。若要產生更多空間,請搜尋並刪除電腦的暫存 (.tmp) 檔案,然後清除網頁瀏覽器使用的磁碟快取。如需清除磁碟快取的相關指示,請參閱您的瀏覽器文件。

若要瞭解釋放磁碟空間的其他方式,請參閱您作業系統的文件 (例如 Windows 的釋放電腦磁碟機空間的秘訣,或 Mac OS 的增加磁碟空間)。

5. 從本機印表機列印。

若列印至網路印表機,請嘗試從直接連接至本機印表機的電腦中列印檔案。如果可正確列印檔案,表示原因可能是與網路相關的問題。請連絡網路管理員以獲得協助。

6. (僅限 Windows) 安裝與您作業系統相容的印表機驅動程式。

若使用網路印表機,請安裝與您作業系統相容的印表機驅動程式。列印伺服器不一定會對用戶端電腦上執行的作業系統提供驅動程式。因此,您可使用列印伺服器作業系統適用的印表機驅動程式,但無法使用您電腦作業系統適用的印表機驅動程式。

Windows 7:

  1. 選擇「開始 > 裝置和印表機」
  2. 按一下「新增印表機」
  3. 選取「新增本機印表機」
  4. 選擇「建立新的連接埠 > 本機連接埠 > 下一步」
  5. 輸入連接埠名稱 (例如 \\[印表機伺服器名稱]\[印表機名稱]),然後按一下「確定」
  6. 遵循螢幕上的指示,安裝符合您網路印表機的品牌和型號。

解決列印至非 PostScript 印表機的問題

如果列印至非 PostScript 印表機時發生問題,請嘗試執行下列一或多項工作,並在完成每項工作後進行列印。

註解:

這些解決方法有時需要變更印表機驅動程式的內容。特定內容的位置隨印表機和印表機驅動程式而異。如需詳細資訊,請連絡印表機製造商或參閱印表機文件。

1. 列印成點陣圖。

  1. 選擇「檔案 > 列印」
  2. 確認您選取的是非 PostScript 印表機,然後選取「進階」窗格。
  3. 選取「列印為點陣圖」核取框,然後為您的印表機選取適用的解析度。

2. 確定印表機有足夠的記憶體。

若要以 300 dpi 列印,印表機至少應有 2 MB 的可用 RAM。若要以 600 dpi 列印,印表機至少應有 4 - 6 MB RAM。如需決定可用的印表機記憶體指示,請參閱印表機文件。

3. 如果印表機有 PostScript 模式,請使用此模式。

如需詳細資訊,請參閱印表機文件。

4. (僅限 Windows) 切換為標準 SVGA 驅動程式。

切換至標準的 Windows SVGA 驅動程式,判斷協力廠商的視訊驅動程式是否導致問題。若在使用標準 SVGA 驅動程式時未發生錯誤,請連絡視訊卡製造商以取得更新的驅動程式。如果驅動程式已是最新版,請嘗試選擇不同的視訊解析度 (例如 1024 x 768 而非更高的解析度)。

疑難排解系統層級的列印或轉存問題

如果從其他應用程式無法列印或轉存為 PDF,請聯絡 Apple 技術支援人員、Microsoft 技術支援人員或印表機製造商。連絡前,請務必檢查印表機與電腦之間的實體連線,因為可能只要重新連接鬆脫的纜線便可輕鬆解決問題。

此外,請思考系統最近是否有進行任何變更,且可能影響列印或轉存的程序。例如,最近是否執行過下列任何事項?

  • 更新硬體,或新增/移除任何硬體元件
  • 新增、更新或刪除任何軟體
  • 已安裝或刪除字體
  • 連線至網路
  • 清理或刪除硬碟中的檔案
  • 遇到隨機的系統問題,或在其他應用程式中遇到錯誤

變更系統通常會直接導致列印問題顯示。請保持一份系統變更的記錄,作為疑難排解列印及其他問題的資源。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策