您在開啟或儲存 InDesign 檔案時是否發生問題?繼續閱讀以了解可能的原因和解決方式。
系統層級問題可能造成錯誤及其他非預期的行為。在假定文件已受損前,請按照以下步驟進行:
InDesign 系統訊息會列出引發問題的情境,可協助您判斷當機的原因。以下提供幾種可能的情境與其解決方法:
遇到其他問題?需要更多協助嗎?
如果您的系統沒有足夠的記憶體 (RAM) 來讀取檔案,InDesign 就無法開啟檔案。記憶體不足的其中一項原因,是您的電腦可能開啟了過多應用程式。
如果您遇到以下任何與存取檔案相關的問題,InDesign 將無法開啟檔案,且會顯示錯誤訊息:
問題 |
解析度 |
未取得開啟此檔案的授權,或缺少所需的存取權限。 |
請向擁有者取得檔案的存取權限,然後嘗試再次登入。 提示:在處理共用檔案前,如果可行,請先建立本機副本。 |
該檔案早已開啟或由其他使用者鎖定 (使用中)。 |
從其他應用程式或使用者設定檔關閉檔案。 |
該檔案受密碼保護,或者檔案的登入資料或密碼無效。 |
確認輸入的登入憑證正確無誤。 |
該檔案置於某個網路中,但系統找不到該網路的位置。 |
檢查網路連線,並嘗試再次存取檔案。 |
如果檔案已在其他 InDesign 版本中開啟,InDesign 將無法開啟或儲存檔案。
如果讀取或寫入程序已中斷,或者無法存取或找不到檔案,InDesign 將無法開啟或儲存檔案。
以下情況可能導致檔案讀取或寫入程序中斷:
檔案位置 |
原因 |
解析度 |
---|---|---|
卸除式裝置 (USB 隨身碟、外部磁碟機、筆型隨身碟等等) |
裝置並未安全地從電腦上卸除或退出 |
請確認每一次執行讀取或寫入作業後,已安全地卸除裝置。 |
網路位置 |
網路連線中斷 |
請確認您的網路連線可用。 |
共用位置 |
無法再使用共用檔案 |
確認共用位置可供存取。 |
發現檔案損壞、毀損或系統嘗試自動復原檔時,InDesign 會顯示錯誤訊息。請根據情況選取索引標籤,並按照疑難排解步驟,嘗試復原文件內容。
以複本開啟文件時,InDesign 會從原始檔案中讀取並開啟未命名的複本。如果可以開啟文件複本,請選擇「檔案 > 另存新檔」,以有別於原始文件的名稱儲存複本,並使用複本而非原始文件。
請按照以下步驟將文件開啟為副本:
請先建立受損文件的備份副本,再開始進行疑難排解。下列部分作業會要求您變更或刪除文件的資訊。
文件備份副本可讓您快速復原資訊。如果文件位在網路磁碟區或卸除式媒體 (例如 CD 或隨身碟) 上,請將備份移至本機磁碟機。
使用 macOS 上的 Cmd-Opt-/ 和 Windows 上的 Ctrl-Alt-/ 快速鍵,強制重新撰寫所有內文。
將頁面元素複製到新文件中,可排除結構性 (內部) 損壞。複製頁面元素到新文件後,如果問題重複發生,請逐一刪除元素,找出是否為其中一個元素造成問題。
按照以下步驟將頁面元素複製到新文件:
您在 InDesign 中建立的樣式,或是您使用在其他應用程式中建立的檔案所轉存而成的樣式,都可能已經損壞。此外,可能還有一些空白頁面和不必要的元素。如果要了解這是否為問題所在,請刪除該樣式和頁面,然後重新儲存文件。
按照以下步驟刪除字元樣式:
按照以下步驟刪除段落樣式:
按照以下步驟刪除頁面:
刪除部分頁面後,如果問題重複發生,請將半數剩餘頁面刪除,並以新名稱儲存文件。接著,請嘗試重建問題。
判斷出造成問題的頁面後,請移除並替換其元素,包含轉存的圖形、InDesign 中繪製的物件,以及頁面中的文字框。
如果要判斷該問題是否與損壞的字體相關,請以標準字體 (例如 Arial 或 Times New Roman) 取代文件中使用的所有字體。如果變更字體後問題重複發生,則該問題與字體無關。如果問題沒有重複發生,則原始字體可能已損壞或過期。嘗試重新安裝原始字體,或取得由字體製造商發行的更新版本。
如果所有其他方式都失敗,則請重新建立文件。請經常建立備份複本,並定期測試文件,以確保轉存的元素不會造成問題。
除了上述各種情形,InDesign 在以下狀況中也可能無法開啟與復原檔案:
我們建議您傳送檔案,並協助我們調查問題。
如果問題仍然無法解決,請透過以下電子郵件地址,與我們分享受影響的檔案:idfile@adobe.com。我們會深入調查問題,如果檔案能夠恢復會通知您。
將檔案與我們分享不僅能讓 Adobe 團隊為您尋找問題的解決方案,也能協助我們識別及解決其他相似問題,進而改善整體的使用者體驗。
我們保證會將您的檔案保持高度機密,且只會將檔案用於分析問題。請確認您分享的檔案並未包含任何敏感的個人資訊。
我們會盡全力協助您,但是檔案恢復與否取決於許多因素,因此無法保證一定能解決問題。
我們很樂意聆聽您的意見。 與 Adobe InDesign 社群分享您的想法。
登入您的帳戶