User Guide Cancel

Edit images with Generative Fill

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop on the iPad
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
    29. Auto adjustment commands in Photoshop on the iPad
    30. Smudge areas in your images with Photoshop on the iPad
    31. Saturate or desaturate your images using Sponge tool
    32. Content aware fill for iPad
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
    19. Generate Image
    20. Generate Background
    21. Reference Image
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
    3. Generate image with descriptive text prompts
    4. Generate background with descriptive text prompts
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Blur Gallery
    2. Filter basics
    3. Filter effects reference
    4. Add Lighting Effects
    5. Use the Adaptive Wide Angle filter
    6. Use the Oil Paint filter
    7. Use the Liquify filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

Use simple text prompts to add or remove content non-destructively with Generative Fill in Photoshop on desktop.

Adobe Photoshop deeplink
Adobe Photoshop deeplink
Adobe Photoshop deeplink

Try it in Adobe Photoshop
Follow along with a sample file, get in-app help, tips, and learn resources within the Discover panel.

Adobe Firefly-powered Generative Fill   is a powerful AI tool that lets you add, remove, or modify images using simple text prompts. Use it in your creative workflows to add design elements like pink butterflies, snowy mountains, or sweeping vistas.

You can also start with a blank canvas and type in a text prompt to add a local town street, a city set in the future, or the galaxy - just about anything you can imagine.

Generate objects

Use Generative Fill in Photoshop on desktop to generate objects in your creative workflows with simple text prompts
Generate objects in your Photoshop canvas using Generative Fill.

  1. Select an object or area in your image using any selection tool in Photoshop

  2. Select Generative Fill in the Contextual Task Bar that appears.

    Select Edit > Generative Fill from the application bar or Ctrl command right-click on an active selection and select Generative Fill from the menu.

  3. Type your text prompt in the text-entry prompt box that appears in the Contextual Task Bar. You can describe the object or scene to be generated in more than 100 languages by writing effective prompts

    If you want Photoshop to fill the selection based on the surroundings, leave this field blank.

  4. Select Generate and then view the Variations in the Properties panel.

    A new Generative Layer is created in the Layers panel. Select this layer to bring up the Properties panel and review your text prompt, mask, and variations. You can reverse the effects if you don't like the generated variations without impacting your original image.

Generate backgrounds

Use Generative Fill in Photoshop on desktop to generate backgrounds in your creative workflows with simple text prompts
Generate a background in your Photoshop canvas using Generative Fill.

Select the background behind your subject and generate a new scene with text prompts. 

To do so, choose Select > Subject and then Select > Inverse. Then follow steps 2 through 5 from the Generate an object section. 

You could also Select Subject > Invert Selection > Text Prompt > Generate (all in the Contextual Task Bar).

Expand images

Extend an image using text prompts
Expand the canvas of your image using Generative Fill.

Expand the canvas of your image, then select the empty region and apply Generative Fill. You can seamlessly extend your image even without using text prompts.

You can also use Generative Expand to add generative content to an empty canvas.

  1. Select the Crop tool from the toolbar to view the crop borders on the edges of your photo. 

  2. Drag the corner and edge handles outward to expand your canvas size. 

  3. Press Enter [Windows] or Return [Mac] on the keyboard or the commit checkmark in the Crop options bar. By default, the extra canvas will use your background color.

  4. Use the Rectangular Marquee tool to select the extra canvas in the area you'd like to generate. 

  5. Follow steps 2 through 5 from the Generate an object section. 

Remove objects

Remove objects from your image using text prompts
Remove an object in your Photoshop canvas using Generative Fill.

Select the object(s) you want to remove, then select Generative Fill without a text prompt. Your selected object will be gone from the canvas or will be replaced with surrounding content in your image.  

Tip:

Avoid making a tight selection and always overlap some areas around the selection in your image to generate a better image result and ensure seamless blending.

New features and enhancements in Photoshop (beta) on desktop

Adobe Firefly Image 3 Model in Generative Fill

Generative Fill is now powered by the Adobe Firefly Image 3 Model, which yields greatly improved photographic quality, precise controls to inform your outputs, better prompt comprehension to understand complex descriptions, and generation variety to explore different results.

Generated outputs will be higher quality, enabling you to create with more intentionality, iterate with greater efficiency, and bring your vision to life with higher accuracy, details, and realism.

New Firefly Image Model now available in Generative Fill

Generate variations with Reference Image

Upload a reference image to help guide your creative workflow and generate more relevant and customized variations. You'll also get greater control over your generated results if you pair the image with descriptive text prompts.

Use the Reference Image feature, available as part of the Generate Fill workflow, to upload an image that helps influence the content of the generated variations.

This feature is most useful when details become hard to describe. 

Upload a reference image to generate more relevant and customized variations

Follow these steps to generate variations using Reference Image:

  1. Generate an object or scene using Generative Fill or Generative Expand workflows.

  2. Select the Reference Image   icon from the Contextual Task Bar or the Properties panel and then Choose image to upload your desired image. 

    Pair this image with descriptive text prompts, if necessary. 

Get more variations of similar style with Generate Similar

Generate Similar   allows you to use a generated variation as a reference image and produce more variations with similar content and style.

This enhances the accuracy and relevancy of your generated outputs and empowers you to generate similar variations until you land on one you like.

Use a generated variation as a reference image and produce more variations with similar content and style.

Use Generate Similar, available as part of the Generative FillGenerative ExpandGenerate Background, and Generate Image workflows, to iterate and generate similar variations based on an existing one.

  1. Generate using Generative Fill or Generative Expand.

  2. Select your preferred variation and then the Generate Similar icon from the Contextual Task Bar or the three-dots icon   in the Variations tab. 

  3. View the generated variations in the Properties panel. Choose the option that matches the selected variation's style and content. You can continue to generate similar variations until you land on one you like. 

Generate Background with descriptive text prompts

With the new Generate Background feature, create a new background for your image with generated content that matches the lighting, shadows, and perspective of the subject.

Simplify workflows and save time with a streamlined experience in the Contextual Task Bar.  

Additionally, you can import another image from your device and insert it as a background or select color fill to change the background to a desired color.

Use Generate Background to achieve new and custom backgrounds for product mockups, create unique sceneries, or ideate concepts. 

Follow these steps to start using Generate Background:

  1. On a blank canvas, select Import image from the Contextual Task Bar to use an image from your device. Select Done when imported. 

  2. Select Remove background in the Contextual Task Bar that appears. 

  3. Select Generate Background in the Contextual Task Bar and enter a descriptive text prompt, or keep the text prompt box empty. 

    Use the color fill icon    if you need to change the background to a desired color. 

    Additionally, you can import another image from your device and insert it as a background.

    Note:

    With Generate Background, Photoshop combines selecting, inverting, and generating with Generative Fill into a single step.

  4. Select Generate   and choose from the generated variations that appear in the Properties panel. 

Generate sharper variations with Enhance Detail

Enhance Detail   improves the sharpness of variations generated by Generative Fill. With this improvement, variations can have greater detail clarity and blend more seamlessly with the existing image.

You can feel more confident in the results, especially when producing higher quality content when pixel clarity or large size format matters.

Improve the sharpness of variations generated by Generative Fill

Follow these steps to start using Enhance Detail:

  1. Generate an object using Generative Fill

  2. Navigate to Properties panel > Variations to select your preferred variation.

  3. Select the Enhance Detail   icon, and your selected variation will be returned with increased sharpness and detail.  

Have a question or an idea?

Ask the Community

If you have a question to ask or an idea to share, come and participate in the Adobe Photoshop community. We'd love to hear from you.

More like this

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online