Présentation des méthodes de sélection

InDesign propose les méthodes et outils de sélection suivants :

Outil Sélection 

Permet de sélectionner des blocs de texte et des blocs graphiques, et de manipuler un objet à l’aide de son cadre de sélection. Si vous cliquez sur la saisie du contenu (anneau) qui s’affiche lorsque vous placez le pointeur de la souris sur une image, vous pouvez manipuler l’image à l’intérieur du bloc sans activer l’outil Sélection directe.

Saisie du contenu

Outil Sélection directe 

Permet de sélectionner le contenu d’un bloc, tel qu’un graphique importé, ou de travailler directement avec des objets modifiables, tels que des tracés, des rectangles ou du texte converti en tracé vectoriel.

Outil Texte 

Permet de sélectionner du texte dans un bloc de texte, sur un tracé ou dans un tableau.

Sous-menu Sélection

Vous permet de sélectionner le conteneur d’un objet (ou bloc) et son contenu. Le sous-menu Sélection permet également de sélectionner des objets en fonction de leur position par rapport aux autres objets. Pour afficher le sous-menu Sélection, choisissez Objet > Sélection. Vous pouvez également cliquer sur un objet avec le bouton droit de la souris (Windows) ou tout en maintenant la touche Contrôle enfoncée (Mac OS) pour afficher son menu contextuel, puis choisir Sélectionner.

Boutons de sélection du panneau Contrôle

Permettent de sélectionner le contenu à l’aide du bouton Sélectionner le contenu  ou le conteneur à l’aide du bouton Sélectionner le conteneur . Vous pouvez également utiliser les commandes de sélection de l’objet suivant ou précédent pour sélectionner les objets suivants ou précédents dans un groupe ou sur une planche.

Commandes Tout sélectionner et Tout désélectionner

Permettent de sélectionner ou de désélectionner tous les objets de la planche et de la table de montage, selon l’outil actif et la sélection en cours. Choisissez Edition > Tout sélectionner ou Edition > Tout désélectionner.

Remarque :

Cliquez deux fois sur un objet pour basculer entre la sélection du bloc ou de l’objet. Cliquez deux fois sur un bloc de texte pour placer le point d’insertion et passer à l’outil Texte.

Sélection d’objets

Un objet est un élément imprimable sur une page ou sur la table de montage (par ex. : un tracé ou un graphique importé). Un bloc ou un tracé est une forme que vous dessinez ou un conteneur pour le texte ou les graphiques. Un cadre de sélection est un rectangle doté de huit poignées de sélection et qui représente les dimensions verticales et horizontales d’un objet. Avant de pouvoir modifier un objet, vous devez le sélectionner à l’aide d’un outil de sélection.

Il existe deux manières de sélectionner un objet dans InDesign :

Tracé avec cadre de sélection sélectionné (à gauche), tracé sélectionné (au centre) et tracé avec points d’ancrage sélectionnés (à droite)
  • Utilisez l’outil Sélection  pour sélectionner le cadre de sélection de l’objet afin de réaliser des opérations de mise en page générales, comme le positionnement et le redimensionnement des objets. Dans le cas d’une image, cet outil vous permet de sélectionner soit le bloc, soit l’image dans le bloc.

Utilisation de l’outil Sélection pour modifier des images

A. La saisie du contenu apparaît lorsque vous placez le pointeur sur une image. B. Cliquez sur la saisie du contenu pour sélectionner le contenu. C. Cliquez en dehors de la saisie du contenu pour sélectionner le bloc. 
  • Vous pouvez utiliser l’outil Sélection directe  pour sélectionner le contenu d’un conteneur (tel qu’un graphique importé) ou des points individuels sur un tracé pour des opérations de redimensionnement sur des graphiques importés, de dessin et de modification de tracés, et de modification de texte.

Remarque :

un graphique importé est toujours contenu dans un bloc. Il est possible de sélectionner le graphique et son bloc, le graphique uniquement, ou son bloc uniquement. Le bloc et le cadre de sélection d’un graphique importé peuvent être de tailles différentes. Pour voir comment InDesign signale les éléments sélectionnés, consultez la section Modification d’objets à l’aide de blocs graphiques.

Cadre de sélection sélectionné (à gauche) comparé au tracé rectangulaire sélectionné (à droite)

Avec les objets rectangulaires, il peut être difficile de différencier le cadre de sélection du tracé de l’objet en lui-même. Un cadre de sélection affiche toujours huit grands points d’ancrage creux. Un tracé rectangulaire affiche toujours quatre petits points d’ancrage (creux ou solides).

Pour sélectionner un cadre de sélection

Pour tout objet, vous pouvez sélectionner son cadre de sélection, c’est-à-dire le rectangle indiquant ses dimensions horizontales et verticales (pour les objets associés, le cadre de sélection est un rectangle en pointillé). Le cadre de sélection est également appelé conteneur. Le cadre de sélection permet de déplacer, dupliquer et mettre à l’échelle un objet sans recourir à d’autres outils. Dans le cas d’un tracé, le cadre de sélection permet de traiter l’ensemble de l’objet sans risque de modification accidentelle des points d’ancrage qui définissent sa forme.

Remarque :

pour effectuer des opérations de déplacement ou de mise à l’échelle plus avancées, ou bien d’autres types de modification (rotation, etc.), utilisez le panneau Contrôle ou Transformation.

  1. A l’aide de l’outil Sélection, utilisez l’une des méthodes suivantes :
    • Cliquez sur l’objet. Si l’objet est un tracé sans remplissage, cliquez sur son bord. Si l’objet est une image, cliquez sur la saisie du contenu pour sélectionner le cadre de sélection de l’image ou cliquez en dehors de la saisie du contenu pour sélectionner le bloc.

    • Créez un rectangle de sélection autour de l’objet ou d’une partie de l’objet, par glisser-déplacer.

    • Une fois l’objet graphique ou le contenu imbriqué sélectionné, cliquez sur le bouton Sélectionner le conteneur  dans le panneau Contrôle.

Lorsque vous sélectionnez un ou plusieurs objets à l’aide de l’outil Sélection, un cadre de sélection indiquant la taille de chaque objet s’affiche. Si l’objet est sélectionné mais que le cadre de sélection ne s’affiche pas, il se peut que vous ayez sélectionné l’objet à l’aide de l’outil Sélection directe .

Si le bloc n’est pas sélectionné lorsque vous cliquez dessus, il existe plusieurs causes possibles : le bloc correspond à un élément de gabarit ou à un élément verrouillé, ou il figure sur un calque verrouillé (voir Sélection d’objets impossible).

Pour sélectionner un tracé ou des points sur un tracé

Dans InDesign, les tracés sont définis par des points d’ancrage, des points d’extrémité et des lignes directrices. Vous sélectionnez les points d’ancrage et les points d’extrémité à l’aide de l’outil Sélection directe.

Tracé avec un seul point sélectionné (à gauche) et avec plusieurs points sélectionnés (à droite)
  1. A l’aide de l’outil Sélection directe , cliquez sur le tracé pour le sélectionner.

    Observez la transformation de l’outil lorsque vous le placez sur un tracé  ou sur un point .

  2. Utilisez l’une des méthodes suivantes :
    • Cliquez sur un point individuel pour le sélectionner.

    • Pour sélectionner plusieurs points sur un tracé, appuyez sur la touche Maj et cliquez sur chaque point.

    • Pour sélectionner simultanément tous les points d’un tracé, cliquez sur le point situé au centre de l’objet, ou maintenez la touche Alt (Windows) ou Option (Mac OS) enfoncée et cliquez sur le tracé. Si vous sélectionnez une partie de l’objet à l’aide de l’outil Sélection directe, la commande Tout sélectionner vous permet également de sélectionner tous les points.

Pour sélectionner du texte à l’intérieur d’un bloc

  • Pour sélectionner du texte par glisser-déplacer, cliquez sur un bloc de texte à l’aide de l’outil Texte. Un point d’insertion s’affiche.
  • Pour créer un point d’insertion dans le texte, cliquez deux fois sur un bloc de texte à l’aide de n’importe quel outil de sélection. InDesign bascule automatiquement vers l’outil Texte.

Pour sélectionner un objet à l’intérieur d’un bloc

  1. Utilisez l’une des méthodes suivantes :
    • Cliquez sur l’objet à l’aide de l’outil Sélection directe . L’outil Sélection directe se transforme automatiquement en outil Main lorsqu’il est placé sur un objet graphique dans un bloc (il ne change pas lorsqu’il est placé sur un objet non graphique, comme un tracé).

    • Si l’objet contenu dans le bloc est une image, cliquez sur la saisie du contenu pour sélectionner l’image.

    Remarque :

    pour empêcher que la saisie du contenu ne s’affiche lorsque vous survolez une image, choisissez la commande Affichage > Extras > Masquer la saisie du contenu.

    • Lorsque le bloc est sélectionné, choisissez Sélection > Contenu dans le menu Objet ou dans le menu contextuel du bloc.
    • Après avoir sélectionné un bloc, cliquez sur le bouton Sélectionner le contenu du panneau Contrôle.
       

Pour sélectionner plusieurs objets

  • Pour sélectionner tous les objets compris dans une zone rectangulaire, utilisez l’outil Sélection  pour créer un rectangle de sélection autour des objets à sélectionner.
  • Pour sélectionner des objets non adjacents, utilisez l’outil Sélection pour sélectionner un objet puis cliquez sur d’autres objets en maintenant la touche Maj enfoncée. Si vous cliquez de nouveau sur un objet sélectionné, celui-ci sera désélectionné.
  • Pour ajouter des objets à une sélection, maintenez la touche Maj enfoncée tout en sélectionnant les autres objets à l’aide de l’outil Sélection. Si vous créez de nouveau un cadre de sélection autour des objets sélectionnés, ceux-ci seront désélectionnés.

Remarque :

Vous pouvez procéder de même avec l’outil Sélection directe pour sélectionner les objets imbriqués dans un groupe ou dans un bloc.

Pour sélectionner ou désélectionner tous les objets

Pour désélectionner tous les objets d’une planche et de sa table de montage, choisissez Edition > Tout désélectionner. Ou, si l’outil Sélection ou Sélection directe est actif, cliquez au moins à trois pixels de distance d’un objet.

L’action de la commande Tout sélectionner diffère selon le contexte :

  • Si l’outil Sélection  est actif, la commande Tout sélectionner sélectionne les tracés et les blocs de la planche et de la table de montage et active leur cadre de sélection.

  • Si l’outil Sélection directe  est actif et que vous sélectionnez un objet à l’aide de cet outil, la commande Tout sélectionner sélectionne tous les points d’ancrage de l’objet, mais ne sélectionne aucun autre objet. Si aucun objet n’est sélectionné, la commande Tout sélectionner sélectionne tous les objets de tracé de la planche et de la table de montage.

  • Lorsque l’outil Texte est actif et qu’un bloc de texte comporte un point d’insertion (signalé par une barre verticale clignotante), la commande Tout sélectionner sélectionne tout le texte de ce bloc ainsi que tous les blocs de texte qui lui sont liés (aucun autre objet n’est sélectionné).

  • Lorsqu’un objet est sélectionné dans un groupe, la commande Tout sélectionner sélectionne les autres objets du groupe (aucun autre objet n’est sélectionné sur la planche).

  1. Sélectionnez l’outil à utiliser. Si vous le souhaitez, sélectionnez un objet ou placez le point d’insertion dans un bloc de texte.
  2. Choisissez Edition > Tout sélectionner.

    Remarque :

    la commande Tout sélectionner ne sélectionne pas les objets imbriqués, les objets se trouvant sur des calques verrouillés ou masqués, les éléments de gabarit qui ne sont pas ignorés sur des pages de document ou les objets d’autres planches et tables de montage (à l’exception du texte lié).

Sélection d’objets impossible

Les conditions suivantes peuvent parfois empêcher la sélection d’un objet :

  • L’objet est recouvert par un autre objet de la pile. Maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée, puis cliquez plusieurs fois au même endroit jusqu’à ce que le bloc ou le groupe souhaité soit sélectionné (voir Sélection d’objets imbriqués ou superposés).

  • L’objet est un élément de gabarit, comme l’indique sa bordure en pointillé. Pour sélectionner un élément de gabarit, ayez recours au gabarit appliqué à la page du document ou remplacez l’élément de gabarit (voir Pour remplacer un élément de gabarit).

  • L’objet a été verrouillé au moyen de la commande Objet > Verrouiller. Choisissez la commande Objet > Tout déverrouiller sur la planche (voir Verrouillage ou déverrouillage d’objets).

  • L’objet figure sur un calque verrouillé. Déverrouillez le calque en cliquant sur l’icône de verrou figurant en regard de ce calque dans le panneau Calques (voir Verrouillage ou déverrouillage de calques).

Sélection d’objets imbriqués ou superposés

Lorsqu’un cadre contient un objet, on dit que cet objet est imbriqué dans un conteneur, ou bloc. Il existe trois principaux types d’imbrication : tracés dans des blocs, blocs dans des blocs et groupes dans des groupes. Vous devez toujours connaître avec exactitude les objets et les attributs d’objets à sélectionner, lesquels sont actuellement sélectionnés et les outils de sélection à utiliser pour modifier les sélections.

Pour contrôler les sélections dans les groupes imbriqués, utilisez les outils Sélection directe et Sélection ainsi que les boutons Sélectionner le contenu et Sélectionner le conteneur. Vous pouvez sélectionner des caractères de texte à tout moment à l’aide de l’outil Texte, quel que soit le niveau d’imbrication du bloc de texte.

Pour sélectionner des objets imbriqués, associés ou superposés

Lorsque vous imbriquez des objets ou que vous superposez des objets sur un même calque, il peut être difficile de sélectionner un seul objet ou bloc. Le menu Objet et le menu contextuel contiennent des options de sélection facilitant la sélection de l’objet voulu.

Sélection d’objets imbriqués

A. Sélection de l’image B. Sélection du tracé du bloc contenant l’image C. Sélection du groupe contenant le bloc 

Remarque :

Il est plus facile de localiser l’objet sélectionné lorsque le panneau Informations est ouvert.

  1. Cliquez sur l’objet imbriqué ou associé avec l’outil Sélection directe .
  2. Si vous n’arrivez pas à sélectionner l’objet désiré, utilisez l’une des méthodes suivantes :
    • Choisissez Objet > Sélectionner, puis choisissez l’une des options de sélection.
    • Placez le pointeur de la souris sur l’objet que vous voulez sélectionner et cliquez avec le bouton droit de la souris (Windows) ou cliquez en maintenant la touche Ctrl enfoncée (Mac OS) pour afficher le menu contextuel. Choisissez ensuite Sélection, puis l’option de sélection désirée.

    Remarque :

    la sélection d’objets par les commandes du menu contextuel ne produit pas les mêmes effets que les commandes du menu Objet > Sélectionner. Dans le menu contextuel, les sélections sont basées sur le point où vous cliquez pour l’affichage du menu. Dans cette optique, seul l’objet au-dessus ou au-dessous du point où vous cliquez est sélectionné, et non pas l’objet suivant dans l’ordre de superposition.

    • Maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée, puis cliquez plusieurs fois au même endroit jusqu’à ce que le bloc ou le groupe souhaité soit sélectionné (ne cliquez pas sur un point d’ancrage).

    • Pour sélectionner de manière individuelle tous les objets d’un groupe, sélectionnez le groupe à l’aide de l’outil Sélection, cliquez sur le bouton Sélectionner le contenu  du panneau Contrôle, puis choisissez Edition > Tout sélectionner.

  3. Pour vous déplacer progressivement dans une pile d’objets, utilisez l’une des méthodes suivantes :
    • Cliquez avec le bouton droit de la souris (Windows) ou cliquez en maintenant la touche Ctrl enfoncée (Mac OS), puis choisissez une option dans le menu contextuel Sélection.

    • Choisissez plusieurs fois de suite Objet > Sélection > Objet inférieur suivant ou Objet supérieur suivant jusqu’à ce que l’objet souhaité soit sélectionné. Lorsque vous atteignez le haut ou le bas de la pile, la sélection ne change pas.

    • Maintenez la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée et cliquez sur la pile pour descendre dans la pile en partant du haut. Lorsque vous atteignez la fin de la pile, la sélection recommence à partir du haut de la pile. Pour qu’elle commence à partir du bas de la pile, maintenez les touches Alt+Ctrl (Windows) ou Option+Commande (Mac OS) enfoncées et cliquez sur la pile à l’aide de l’outil Sélection.

    Remarque :

    les options du menu contextuel dépendent de la position du pointeur de votre souris.

Pour sélectionner plusieurs objets imbriqués

  1. A l’aide de l’outil Sélection directe , cliquez sur l’objet imbriqué.
  2. Maintenez la touche Maj enfoncée tout en cliquant sur les autres objets imbriqués à sélectionner.

Options de sélection

Les options du sous-menu Sélection (choisissez Objet > Sélection ou Sélection dans le menu contextuel) vous permettent de sélectionner des objets superposés, imbriqués ou associés. Certaines options peuvent ne pas être disponibles en fonction du type d’objet sur lequel vous travaillez. Lorsque vous utilisez le menu contextuel, l’objet sélectionné dépend de la position du pointeur de la souris.

Premier objet supérieur

Sélectionne l’objet le plus haut dans la pile.

Objet précédent

Sélectionne l’objet juste au-dessus de l’objet actif.

Objet suivant

Sélectionne l’objet juste au-dessous de l’objet actif.

Dernier objet inférieur

Sélectionne l’objet le plus bas dans la pile.

Contenu

Sélectionne le contenu du bloc graphique sélectionné ou un objet à l’intérieur du groupe sélectionné. Vous pouvez également cliquer sur le bouton Sélectionner le contenu du panneau Contrôle.

Conteneur

Sélectionne le bloc contenant l’objet sélectionné ou le groupe contenant l’objet sélectionné. Vous pouvez également cliquer sur le bouton Sélectionner le conteneur du panneau Contrôle.

Objet précédent/Objet suivant

Sélectionne l’objet précédent ou suivant du groupe si l’objet sélectionné fait partie d’un groupe, ou, s’il ne fait pas partie d’un groupe, sélectionne l’objet précédent ou suivant sur la planche. Cliquez tout en maintenant la touche Maj enfoncée pour ignorer cinq objets à la fois Cliquez tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée pour sélectionner le premier ou le dernier objet de la pile.

Disposition d’objets en pile

Les objets superposés sont empilés dans l’ordre de leur création ou importation. Vous pouvez modifier l’ordre de superposition des objets à l’aide du sous-menu Disposition.

Le panneau Calques permet également de déterminer l’ordre de superposition des objets. L’ordre des calques dans le panneau Calques détermine si les objets d’un calque s’affichent au-dessus ou au-dessous des objets d’autres calques. L’ordre de superposition des objets sur un calque repose sur l’ordre des objets de ce calque. Vous pouvez faire glisser les objets sur un calque ou utiliser la commande Objet > Disposition pour contrôler l’ordre de superposition des objets dans un calque. Si vous n’avez créé aucun calque, votre document contient simplement une superposition d’objets sur le calque par défaut. Les objets des gabarits se trouvent derrière tous les calques nommés.

Remarque :

le fait d’associer certains objets peut modifier l’ordre de superposition des objets par rapport aux objets non associés.

  1. Sélectionnez l’objet à déplacer au début ou à la fin d’une pile.
  2. Utilisez l’une des méthodes suivantes :
    • Pour déplacer un objet sélectionné au début ou à la fin d’une superposition, choisissez Objet > Disposition > Premier plan ou Objet > Disposition > Arrière-plan.

    • Pour déplacer un objet sélectionné vers l’avant ou vers l’arrière dans une superposition, choisissez Objet > Disposition > En avant ou Objet > Disposition > En arrière.

    • Dans le panneau Calques, cliquez sur le triangle d’affichage en regard d’un calque, puis faites glisser les objets figurant sur ce calque pour modifier leur ordre de superposition.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne