Observação:

A funcionalidade do OpenGL no After Effects CS6 é diferente da funcionalidade do OpenGL nas versões anteriores. Este documento é somente para o After Effects CS4 ao CS5.5. Para obter mais informações sobre a funcionalidade da GPU no After Effects CS6, consulte estevídeo.

Este documento pode ajudá-lo a solucionar problemas relacionados ao OpenGL que ocorrem quando você for usar o After Effects. Os erros de OpenGL pode se manifestar em muitas diferentes formas, incluindo (mas não limitado a) as seguintes:

  • O Adobe After Effects tem erro fatal ou fecha sem um erro ao ser iniciado.
  • Um erro fatal ou congelamento quando você arrastar a linha do tempo ou a visualização ou renderizar uma composição.
  • Um erro fatal quando você alterar as configurações de um efeito quando os visualizações do OpenGL estiverem ativadas.
  • Um erro fatal ou congelamento quando você ativar ou desativar visualizações do OpenGL.
  • A janela da composição demora muito tempo para redesenhar.
  • Artefatos ou blocos de pixels “lixo” são desenhados na janela da composição.
  • A janela da composição é desenhada de forma diferente quando as visualizações do OpenGL estiverem ativadas e desativadas.
  • Uma mensagem de erro como a seguir:

    “Aviso do After Effects: Ocorreu um problema ao processar comandos OpenGL”.

    “A instrução em ‘0x00fe1940’ referenciou a memória em ‘0x000000000’. A memória não pôde ser ‘lida’”.

    “AE_OpenGL: falha ao gerar o mapa de sombra (5065:0)”

    “Esta composição é muito complexa para o hardware OpenGL”.

    “Erro do After Effects: AE_OpenGL: Erro ao criar a textura. (5065 :: 0)"

Para obter informações sobre como configurar as preferências do visualização no After Effects para OpenGL e para obter uma lista dos recursos no After Effects que podem ser renderizados com o OpenGL, consulte Renderizar com o OpenGL na Ajuda do After Effects.

Para tirar o máximo proveito deste documento, execute as tarefas em ordem. Registre as tarefas que você executar e os resultados de cada uma, inclusive os erros e outros problemas. O Suporte Técnico da Adobe poderá usar essas informações para melhor ajudá-lo, caso você entre em contato.

Você deve estar conectado como um administrador para executar alguns dos procedimentos neste documento.

Para o Windows, alguns destes procedimentos exigem que você localize os arquivos ocultos e as pastas ocultas. Alguns procedimentos exigem a localização de arquivos pelo seu nome de arquivo completo, o qual pode incluir extensões (por exemplo, exemplo_nomedoarquivo.ini). Por padrão, o Windows Explorer não mostra arquivos ou pastas ocultos, nem extensões de nomes de arquivo reconhecidas por ele. Consulte Mostrar arquivos e pastas ocultos no Windows para obter detalhes.

Para o Windows Vista, as etapas neste documento que se referem ao Painel de controle estão relacionadas ao modo de exibição clássico. Para obter informações sobre a alternância do Painel de controle para o modo de exibição clássico e muitos outros procedimentos comuns do sistema operacional, consulte Procedimentos comuns do SO.

Estas tarefas podem ajudá-lo a resolver os problemas mais comuns com o OpenGL. Antes de executar qualquer uma dessas tarefas, faça o backup de todos os seus arquivos pessoais (por exemplo, arquivos do After Effects criados por você). Sempre reinicie o computador após a ocorrência de um erro do sistema para atualizar a memória. Continuar a trabalhar sem reiniciar o computador por agravar o problema.

1. Atualize para a versão mais recente do After Effects.

Para verificar se há atualizações, escolha Ajuda > Atualizações no After Effects.

2. Certifique-se de que o sistema atende aos requisitos mínimos para o After Effects.

Consulte esta página para obter uma lista dos requisitos do sistema do After Effects: Requisitos de sistema para o Adobe After Effects

3. Certifique-se de que a placa de vídeo e os drivers atendam os requisitos do OpenGL.

Usar o OpenGL no After Effects requer uma placa OpenGL que suporte o OpenGL 2.0.

Para determinar qual versão do OpenGL sua placa suporta, clique no botão Informações do OpenGL nas Preferências de visualização. No Mac OS, escolha After Effects > Preferences > Previews. No Windows, escolha Editar > Preferências > Visualizações.

Para obter informações sobre o hardware OpenGL suportado, consulte Recursos de GPU (CUDA, OpenGL).

Os drivers mais recentes da placa de vídeo podem aprimorar os recursos OpenGL de sua placa. Consulte Atualizar o driver da placa de vídeo abaixo.

4. Desative o OpenGL para determinar se ele está causando o problema.

Para desativar visualizações do OpenGL:

  1. Escolha After Effects > Preferences > Previews (Mac OS) ou Editar > Preferências > Visualizações (Windows).
  2. Cancele a seleção da opção Ativar OpenGL.

Observação: o OpenGL não suporta alguns recursos no After Effects, e a aparência da sua composição pode alterar entre o uso de visualizações do OpenGL e visualizações renderizadas pelo software. Para obter a lista dos recursos suportados pelo OpenGL, consulte Renderizar com o OpenGL na seção Renderizar e Exportar da Ajuda do After Effects.

5. Remova o plug-in OpenGL da pasta de plug-ins do After Effects.

Para determinar se o OpenGL causou o problema, remova o plug-in OpenGL e reinicie o After Effects.

Para remover o plug-in OpenGL:

  1. Sair do After Effects.
  2. Mac OS: Arraste o arquivo AE_OpenGL.plugin da pasta Applications/Adobe After Effects CS4/Plug-ins/Extensions para a área de trabalho.

    Windows: arraste o arquivo AE_OpenGL.AEX da pasta C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Plug-ins\Extensions para a área de trabalho.
  3. Reinicie o After Effects.

Se o problema voltar a ocorrer, o OpenGL não o causou. Arraste o plug-in OpenGL de volta ao local original. Se o problema não voltar a ocorrer, a causa do problema é o OpenGL. Consulte Atualizar o driver da placa de vídeo abaixo.

6. Atualize o driver da placa de vídeo.

Muitos problemas ou conflitos do OpenGL são solucionados ao atualizar o driver da placa de vídeo. Vários fabricantes de placa de vídeo atualizam com freqüência drivers de software. Se você não atualizou recentemente o driver da placa de vídeo, contate o fabricante da placa de vídeo para obter um driver atualizado ou faça o download de um no site do fabricante.

7. Reinicie o After Effects e teste o comportamento que causou o erro fatal. (Somente Windows)

Após um erro fatal causado por um problema de OpenGL no Windows, o After Effects CS4 pode automaticamente desativar a preferência Prevenir a fragmentação do espaço de endereço DLL. Essa preferência permite que o After Effects acesse uma quantidade maior de RAM contígua, mas pode ser incompatível com alguns drivers do OpenGL.

Você pode ativar ou desativar a preferência Prevenir a fragmentação do espaço de endereço DLL ao ir para Editar > Preferências > Memória e cache.

Deixe essa preferência ativada, a menos que você esteja experimentado erros fatais do OpenGL ou relativos a memória. Se você o desativar a preferência devido a um problema do OpenGL e mais tarde atualiza os drivers da placa de vídeo, reative a preferência. A seguir, teste o problema novamente.

8. Otimize a preferência Memória de textura.

Erros fatais ou erros do OpenGL podem ocorrer se o After Effects tentar usar muita memória de textura de vídeo. A memória de textura é a quantidade de RAM na placa de vídeo (VRAM).

Defina a preferência Memória de textura no After Effects:

  1. Multiplique o total de VRAM instalada por 80% para calcular a configuração ideal de memória de textura.
  2. No After Effects, escolha After Effects > > Preferences > Previews (Mac OS) ou Editar > Preferências > Visualizações (Windows).
  3. Clique em Informações do OpenGL.
  4. Insira o valor calculado na Etapa 1 e, a seguir, clique em OK.

O valor ideal para a memória de textura é de 80% de VRAM em sua placa gráfica. (Se você usa múltiplas placas de vídeo, calcule 80% de VRAM na placa de vídeo que esteja identificada na caixa de diálogo Informações do OpenGL). Se a preferência Memória de textura no After Effects estiver definida como mais de 80% de VRAM, é possível que não haja VRAM suficiente remanescente para que a placa de vídeo possa manipular a interface do usuário ou outras tarefas. (Por exemplo, a tela inteira pode ficar em branco). Se o valor for definido para menor do que 80%, as visualizações do OpenGL no After Effects podem demorar mais tempo para processar quadros.

Consulte Ajuda do Mac OS ou a Ajuda do Windows para obter informações sobre como determinar a quantidade de VRAM em uma placa de vídeo.

9. Remova os caches de imagem e a memória de vídeo.

Se o After Effects exibir artefatos ou “lixo” (blocos de pixels incorretos) na janela da composição, a memória de vídeo (VRAM) podem estar cheia, fragmentada ou corrompida. Limpe os caches de imagem e a memória de vídeo para esvaziar a VRAM e deixar que o After Effects recrie a visualização da composição.

Para limpar os caches de imagem, escolha Editar > Limpar > Caches de imagens.

Para limpar a memória de vídeo, escolha Editar > Limpar > Memória de vídeo.

Observação: algumas protetores de tela que usam o OpenGL (ou o Direct3D no Windows) podem corromper a memória de vídeo se eles forem ativados quando o After Effects estiver em execução. Altere ou desative o protetor de tela geralmente se você tiver com frequência problemas com imagens corrompidas na janela da composição após desativar o protetor de tela.

10. Altere a configuração de cores para a placa de vídeo para o Mais alto (32 bits) (Windows) ou Millions (Mac OS).

Consulte Ajuda do Mac OS ou a Ajuda do Windows para obter informações sobre como alterar as configurações da placa de vídeo ou de visualização.

11. Desative as funções avançadas da placa de vídeo. (Somente Windows)

A maioria dos drivers de placa de vídeo incluem utilitários que permitem acessar funções avançadas da placa. Em particular, a anti-suavização de serrilhado e as funções do modo de 16 bits poderão conflitar com o OpenGL e causar um erro fatal do After Effects. Defina as funções avançadas da placa para seus padrões e, a seguir, desative as opções de anti-suavização de serrilhado e o modo de 16 bits.

Se você estiver usando múltiplos monitores com uma placa Nvidia, defina a configuração de Múltiplos monitores como “Compatível”.

Consulte a documentação da placa de vídeo ou o site do fabricante para obter instruções sobre como acessar suas funções avançadas.

12. Utilize um único monitor.

Se você estiver usando múltiplos monitores e experimenta problemas com o OpenGL no After Effects, tente o seguinte:

  • Se você colocou a janela do aplicativo After Effects ou a janela Composição em um monitor secundário, mova a janela para o monitor principal.
  • Desconecte todos, com exceção de um monitor.
  • Se você estiver usando múltiplas placas de vídeo, remova todas exceto uma placa de vídeo. Para obter os melhores resultados com OpenGL, use uma única placa de vídeo “dual-head”.

13. Coloque o script Reduzir o tamanho da textura no OpenGL na pasta Scripts de inicialização.

O script Reduzir o tamanho de textura do OpenGL reduz a quantidade de memória de textura que o After Effects usa e pode fornecer uma melhor compatibilidade com placas de vídeo mais antigas.

Para inserir o script Rdeuzir o tamanho de textura do OpenGL na pasta de scripts Startup:

  1. Navegue até a pasta de scripts do After Effects.

    No Mac OS: Applications/Adobe After Effects CS4/Scripts.

    No Windows: C:\Program Files\Adobe\Adobe After Effects CS4\Support Files\Scripts.
  2. Mova o arquivo Reduce OpenGL Texture Size.jsx da pasta (suporte) para a pasta Startup.

Uma placa gráfica mais recente pode aprimorar os recursos OpenGL do seu computador e tornar o script desnecessário. Após você instalar uma nova placa e os drivers, mova o script Reduzir o tamanho da textura do OpenGL de voltar para a pasta (suporte). A seguir, redefina as preferências do After Effects.

14. Redefina as preferências do After Effects.

Recrie o arquivo de preferências do After Effects para eliminar problemas que as preferências danificadas do OpenGL possam causar.

Para recriar o arquivo de preferências do After Effects, reinicie o After Effects. Pressione Ctrl+Alt+Shift (Windows) ou Command+Option+Shift (Mac OS) enquanto o aplicativo estiver sendo inicializado.

15. Entre em contato com o Suporte técnico da Adobe.

Se nenhuma das etapas acima solucionou o erro ou o congelamento que ocorre com o After Effects, contate o Suporte Técnico da Adobe. Você pode encontrar as opções de suporte em Suporte da Adobe.

 

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online