OpenGL, GPU e After Effects

OpenGL é um conjunto de padrões de processamento de alto desempenho de gráficos 2D e 3D na unidade de processamento (GPU) para vários aplicativos. O OpenGL permite a renderização rápida de visualizações (modo Rascunho rápido).

O After Effects pode aproveitar a GPU (unidade de processamento gráfico) na placa de vídeo para alguns tipos específicos de processamento.

Os recursos de GPU do After Effects estão presentes nas 3 categorias a seguir:

  • Renderizador rastreado de raio 3D com aceleração por GPU (CUDA em placas de vídeo específicas)
  • Modo Rascunho rápido e hardware BlitPipe (OpenGL com requisitos um pouco rigorosos)
  • Buffer de troca de OpenGL (OpenGL com requisitos menos rigorosos)

IMPORTANTE: geralmente, o After Effects não necessita dos recursos CUDA de um conjunto específico de GPUs da Nvidia. Somente o renderizador rastreado de raio 3D com aceleração por GPU requer isso. Os demais recursos da GPU trabalham em qualquer GPU que atenda a alguns requisitos básicos, incluindo AMD and Intel GPUs. Continue lendo para obter mais recursos.

Vídeo: Requisitos de sistema para aceleração de GPU (OpenGL, CUDA)

Vídeo: Requisitos de sistema para aceleração de GPU (OpenGL, CUDA)
Neste vídeo de Todd Kopriva e da video2brain, conheça os requisitos de hardware e software em relação a vários recursos que usam a GPU.
Todd Kopriva

Preferências de configuração para OpenGL e GPU

O OpenGL oferece suporte para desenho de artigos de interface, como composição, gravação e painéis de camada. Outras funções de desenho, como grades, guias, réguas e caixas delimitadoras, são agora operadas pelo OpenGL também. Esse recurso também é conhecido como “Hardware BlitPipe”.

Para ativar o suporte OpenGL para desenhar itens de interface, clique na caixa de seleção dos painéis Composição de aceleração por hardware, Camada e Gravação em Editar > Preferências > Exibir (Windows) ou After Effects > Preferências > Exibir (Mac OS).

Você pode acessar informações sobre a GPU e o OpenGL na caixa de diálogo Informações da GPU. Escolha Editar > Preferências > Visualizações (Windows) ou After Effects > Preferências > Visualizações (Mac OS) para ter acesso à caixa de diálogo Informações da GPU. Clique no botão Informações da GPU para abrir a caixa de diálogo Informações da GPU. Nessa caixa de diálogo, consulte as informações sobre os recursos OpenGL para a GPU instalada. As informações ajudam a determinar os Níveis de suporte de recursos para a GPU. Também é possível visualizar se o CUDA está disponível na GPU e que versão está instalada.

Observação:

Para ativar o Rascunho rápido, clique no botão Visualizações rápidas no painel Composição e escolha Rascunho rápido. O Rascunho rápido provoca pequenas diferenças de aparência no painel Composição, mais adequados para uma visualização rápida. O Rascunho rápido é útil para configurar e visualizar uma composição para renderização posterior em rastreado de raio 3D.

Observação:

Se a sua GPU não for suportada ou você tiver um driver antigo, as composições de rastreado de raio 3D vão renderizar na CPU utilizando todos os núcleos físicos. Se você tiver uma configuração com suporte GPU em um ambiente descentralizado (por exemplo, um farm de renderização), force as composições de rastreado de raio 3D para renderizar na CPU, definindo a opção Rastreado de raio na caixa de diálogo Informações da GPU. As renderizações concluídas na CPU correspondem às renderizações concluídas na GPU.

Considerações de hardware para OpenGL, GPU e After Effects

Ao trabalhar com composições de traçamento de raios 3D, é importante ter o hardware necessário instalado no computador para trabalhar de maneira uniforme. Uma placa de vídeo NVIDIA com tecnologia CUDA integrada é necessária para trabalhar com composições de rastreado de raio 3D com aceleração de GPU.

Requisitos para os recursos GPU/OpenGL (Rastreado de raio 3D e Rascunho rápido)

Os seguinte recursos com base em GPU e OpenGL no After Effects requerem que os recursos sejam categorizadas com base nos recursos da GPU:

  • Renderizador rastreado de raio 3D
  • Renderização em GPU
  • Modo de visualizações Rascunho rápido
  • Transferência de blit mais rápida na tela (OpenGL SwapBuffer)
  • Preferência “Painéis Composição de aceleração por hardware, Camada e Gravação”

Vídeo: otimização para alto desempenho

Vídeo: otimização para alto desempenho
Neste vídeo, Brian Maffitt da Total Training mostra como otimizar seu computador para trabalhar com composições de rastreado de raio 3D.
Brian Maffitt e Total Training

Níveis de suporte de recursos

Para OpenGL SwapBuffer

Esse nível requer apenas uma GPU que pode fazer OpenGL 1.5 ou superior, com Shader Model 3.0, ou superior. A maioria das placas ATI e NVIDIA e o chipset Intel HD Graphics 3000 (disponível no MacBook Air, Mac Mini, várias máquinas Windows, etc.) e 4000 (somente Windows no momento) são suportadas. Se a GPU não suportar esses requisitos, uma transferência de blit do sistema operacional do software como o CS5.5 ocorrerá. Há também melhorias na transferência de blit do software no After Effects.

Para visualizações do Rascunho rápido, hardware BlitPipe e aceleração por GPU para animações

Inclui recursos do Nível 1. Esse nível requer o OpenGL 2.0 ou superior (com Shader Model 4.0, ou superior, no Windows) e 256 MB, ou superior, de memória de textura. A maioria das placas ATI e NVIDIA lançadas nos últimos cinco anos, além de Intel HD Graphics 3000/4000, suportam esse nível.

Se a GPU não suportar esses requisitos, esses recursos serão desabilitados:

  • Modo Rascunho rápido
  • A preferência “Painéis Composição de aceleração por hardware, Camada e Gravação”.
  • Opção “Usar OpenGL quando disponível” do efeito Desenho animado (o efeito Desenho animado que opera na CPU).

Para a renderização de rastreador de raio 3D na GPU

Inclui recursos do Nível 1 e 2 (para computadores com monitores vinculados). Esse nível requer suporte da GPU NVIDIA e 512 MB ou superior de memória de textura. Para ver uma lista atual de GPUs com suporte, consulte o site da Adobe.

Instalar drivers de GPU

Antes de trabalhar com os recursos do After Effects e CUDA, instale o driver de vídeo mais recente em sua GPU NVIDIA:


Windows: instale o driver mais recente certificado por WHQL para a sua GPU: http://www.nvidia.com/page/drivers.html

Mac OS: instale o driver CUDA NVIDIA (v4.0.50 ou superior): http://www.nvidia.com/object/mac-driver-archive.html

É possível atualizar o driver de CUDA no painel CUDA nas Preferências do sistema ou acessando o site da NVIDIA.

Observação:

Se a sua GPU não for suportada ou você tiver um driver antigo, as composições de rastreado de raio 3D vão renderizar na CPU utilizando todos os núcleos físicos. Se você tiver uma configuração com suporte GPU em um ambiente descentralizado (por exemplo, um farm de renderização), force as composições de rastreado de raio 3D para renderizar na CPU, definindo a opção Rastreador de raio na caixa de diálogo Informações da GPU (disponível nas preferências de Visualizações). As renderizações concluídas na CPU correspondem às renderizações concluídas na GPU.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online