Sobre filtros

Visão geral de filtro

Os filtros (efeitos gráficos) do permitem adicionar efeitos visuais enriquecedores ao texto, aos botões e clipes de filme. Um recurso exclusivo do Animate é que você pode animar os filtros aplicados usando interpolações de movimento.

Os modos de mesclagem do Animate permitem criar imagens compostas. Composição é o processo de variação da transparência ou interação de cor entre dois ou mais objetos sobrepostos. Os modos de mesclagem também incluem o controle da opacidade de objetos e imagens. Você pode usar os modos de mesclagem do Animate para criar realces ou sombras, que permitem exibir os detalhes de uma imagem, ou para colorir uma imagem.

Sobre filtros animados

Anime os filtros na linha do tempo. Os objetos em quadros principais separados, mas unidos por uma interpolação, terão os parâmetros dos filtros interpolados em quadros intermediários. Se na extremidade oposta da interpolação, o filtro não tiver um correspondente (do mesmo tipo), este será adicionado automaticamente, para assegurar que o efeito ocorra no final da sequência de animação.

Para evitar que interpolações de movimento funcionem de maneira incorreta, se um filtro estiver ausente de uma extremidade da interpolação ou se filtros forem aplicados em uma ordem diferente a cada extremidade, o Animate faz o seguinte:

  • Se você aplicar uma interpolação de movimento a um clipe de filme com filtros aplicados a ele, quando inserir um quadro principal na extremidade oposta da interpolação, o clipe de filme terá automaticamente os mesmos filtros, na mesma ordem de empilhamento, no último quadro da interpolação, conforme tinha no início da interpolação.

  • Se você colocar clipes de filme em dois quadros diferentes com filtros diferentes aplicados a cada um deles e aplicar um movimento de interpolação entre os quadros, o Animate processará primeiro o clipe de filme com a maioria dos filtros. O Animate em seguida compara os filtros aplicados ao primeiro clipe de vídeo em relação aos filtros que o segundo clipe de filme utiliza. Se não for encontrado nenhum filtro correspondente no segundo clipe de vídeo, o Animate irá gerar um filtro simulado sem parâmetros e com a cor dos filtros existentes.

  • Se existir uma interpolação de movimento entre dois quadros principais e você adicionar um filtro ao objeto de um quadro principal, o Animate adicionará automaticamente um filtro simulado ao clipe de filme quando alcançar o quadro principal na outra extremidade da interpolação.

  • Se existir uma interpolação de movimento entre dois quadros principais e você remover o filtro de um objeto de um quadro principal, o Animate removerá automaticamente o filtro correspondente do clipe de filme quando alcançar o quadro principal na outra extremidade da interpolação.

  • Se você definir de maneira inconsistente os parâmetros do filtro entre o início e o final de uma interpolação de movimento, o Animate aplicará as configurações de filtro do quadro inicial aos quadros interpolados. Configurações inconsistentes ocorrem quando os seguintes parâmetros são definidos diferentemente entre o início e o fim da interpolação: vazado, sombra interna, brilho interno e tipo de brilho de gradiente e bisel de gradiente.

    Por exemplo, se você criar uma interpolação de movimento usando o filtro de sombra projetada e aplicar uma sombra projetada com um vazado ao primeiro quadro da interpolação, e uma sombra interna ao último quadro da interpolação, o Animate corrigirá o uso inconsistente do filtro na interpolação de movimento. Nesse caso, o Animate aplica as configurações de filtro usadas no primeiro quadro da interpolação, uma sombra projetada com vazado.

Sobre o desempenho dos filtros e do Flash Player

O tipo, a quantidade e a qualidade dos filtros aplicados aos objetos pode afetar o desempenho dos arquivos SWF conforme você os executa. Quanto mais filtros você aplicar ao objeto, maior o número de cálculos que o Adobe® Flash® Player deverá processar para exibir corretamente os efeitos visuais que você criou. A Adobe® recomenda aplicar um número limitado de filtros a um determinado objeto.

Todos os filtros incluem controles que permitem ajustar a intensidade e a qualidade do filtro aplicado. O uso de configurações mais baixas melhora o desempenho em computadores mais lentos. Se você estiver criando conteúdo para reprodução em uma ampla gama de computadores ou se não tem certeza sobre a capacidade disponível dos computadores do seu público, defina o nível de qualidade como Baixo para maximizar o desempenho de reprodução.

Sobre os filtros do Pixel Bender

Adobe Pixel Bender™ é uma linguagem de programação desenvolvida pela Adobe que permite que os usuários criem filtros personalizados, efeitos e modos de mesclagem para utilizar no Animate e no After Effects. O Pixel Bender é independente de hardware e foi desenvolvido para ter uma execução eficiente em uma variedade de arquiteturas de GPU e CPU automaticamente.

Os desenvolvedores do Pixel Bender criam filtros por meio da gravação do código do Pixel Bender, que é salvo posteriormente em um arquivo de texto com a extensão de arquivo pbj. Uma vez gravado, um filtro do Pixel Bender pode ser usado por qualquer documento do Animate. Use o ActionScript® 3.0 para carregar o filtro e utilizar seus controles.

Para obter mais informações sobre o trabalho com o Pixel Bender no ActionScript, consulte o Guia do desenvolvedor do ActionScript 3.0.

Lee Brimelow publicou vários exemplos úteis do Pixel Bender em seu blog: http://theflashblog.com/?cat=44.

Os tutoriais em vídeo a seguir demonstram o uso dos filtros do Pixel Bender no Animate:

Trabalho com filtros

Aprimorado no Animate CC

Toda vez que você adiciona um novo filtro ao objeto, ele é adicionado à lista de filtros aplicados a esse objeto no Inspetor de propriedades. Você pode aplicar vários filtros ao objeto e remover filtros aplicados anteriormente. Você pode aplicar filtros apenas no texto, botão, clipe de filme, componentes e objetos de clipe compilados.

Você pode criar uma biblioteca de configurações de filtro que permite aplicar facilmente o mesmo filtro ou conjuntos de filtros ao objeto. O Animate armazena as predefinições de filtro criadas na seção Filtros do Inspetor de propriedades, no menu Filtros > Predefinições.

Com o Flash Professional CS6 e versões anteriores, a aplicação de filtros se restringiu apenas ao clipe de filme e aos símbolos de botão. Com o Animate CC, agora você pode aplicar filtros para clipes compilados e componentes clipe de filme. Isso permite que você adicione vários efeitos diretamente nos componentes, com o clique de um botão (ou dois), tornando a aparência de suas aplicações muito melhor. Com o Flash CS6, para adicionar filtros ou outros componentes, "envolva-o" dentro de um símbolo de clipe de filme. Isto é:

  1. Criar ou adicionar um componente ao palco.
  2. Clique com o botão direito no componente e selecione Converter para símbolo.
Com o CS6 (e versões anteriores), você pode adicionar filtros ou vários outros tipos de efeitos após envolver o componente dentro de um símbolo. Entretanto, isso foi apenas uma solução alternativa, e não a melhor prática sugerida.
 
Com o Animate CC, você pode adicionar vários filtros diretamente para os componentes usando os filtros, efeitos de cor e as opções de exibir as configurações disponíveis no Painel de propriedades. Para entender melhor este aprimoramento chave, considere o seguinte exemplo:
 
Adição do filtro Bisel a um componente de botão
 
  1. Criar ou adicionar um botão do Painel componentes no palco e selecionar o botão subsequente.
  2. No Painel de propriedades, clique no botão na lista suspensa na seção Filtros e selecione o filtro Bisel. São exibidas as propriedades e valores para o filtro Bisel.
  3. Modifique ou ajuste os valores apropriados para cada propriedade desejada. Por exemplo, Desfocar X, Desfocar Y, Energia, Sombra, etc. Você vai notar os efeitos refletindo sobre o botão selecionado simultaneamente.
O menu Adicionar filtro do Inspetor de propriedades

Aplicar ou remover filtro

  1. Selecione um objeto de clipe de filme, texto ou botão para aplicar ou remover o filtro.
  2. Na seção Filtros do Painel de propriedades, siga um destes procedimentos:

    • Para adicionar um filtro, clique no botão e selecione um filtro. Teste as configurações até obter a aparência desejada.

    • Para remover um filtro, selecione o filtro que deseja remover na lista de filtros aplicados e clique no botão Remover filtro . Você pode excluir ou renomear qualquer predefinição.

Cópia e colagem de filtro

  1. Selecione o objeto cujo filtro deseja copiar e selecione o painel Filtros.
  2. Selecione o filtro para copiar e clique no botão . No menu suspenso, clique em Copiar filtro selecionado. Para copiar todos os filtros, selecione Copiar todos os filtros.

  3. Selecione o objeto para aplicar o filtro e clique no botão. No menu suspenso, clique em Colar filtros.

Aplicação de filtro predefinido a um objeto

  1. Selecione o objeto cuja predefinição de filtro deseja aplicar e selecione a aba Filtro.
  2. Clique no botão para abrir o menu suspenso.

  3. Selecione a predefinição de filtro para aplicar na lista de predefinições disponíveis, na parte inferior da lista suspensa.

Observação:

Quando você aplica um filtro predefinido ao objeto, o Animate substitui qualquer filtro aplicado atualmente aos objetos selecionados pelos filtros usados na predefinição.

Ativação ou desativação de filtro aplicado a objeto

  1. Por padrão, todos os filtros permanecem ativos. Clique no ícone próximo ao nome do filtro para desativar o filtro na lista de filtros. Clique no botão X próximo ao nome do filtro para ativar um filtro.

    Observação:

    Para alternar o estado de ativação dos outros filtros da lista, clique com a tecla Alt pressionada (Windows) ou com a tecla Option pressionada (Macintosh) no ícone de ativação na lista Filtro. Se você clicar com a tecla Alt pressionada no ícone o filtro selecionado será ativado e todos os outros filtros da lista serão desativados.

Ativação ou desativação de todos os filtros aplicados ao objeto

  1. Clique no botão e selecione Ativar tudo ou Desativar tudo no menu suspenso.

    Observação:

    Para ativar ou desativar todos os filtros da lista, clique com a tecla Ctrl pressionada no ícone de ativação ou desativação, na lista Filtro.

Criação de bibliotecas de filtros predefinidos

Salve configurações de filtro como bibliotecas predefinidas que podem ser facilmente aplicadas a clipes de filme e objetos de texto. Compartilhe suas predefinições de filtro com outros usuários fornecendo a eles o arquivo de configuração de filtro. O arquivo de configuração de filtro é um arquivo XML salvo na pasta Configuração do Animate, no seguinte local:

 

  • Windows 7 e 8: C:\Users\nome do usuário\AppData\Local\Adobe\Flash CC\idioma\Configuration
  • (Apenas para o Flash Professional CS6 ou versões anteriores) Windows XP: C:\Documents and Settings\nome do usuário\Local Settings\Application Data\Adobe\Flash CS6\idioma\Configuration\Filters\filtername.xml
  • (Apenas para o Flash Professional CS6 ou versões anteriores) Windows Vista: C:\Users\nome do usuário\Local Settings\Application Data\Adobe\Flash CS6\idioma\Configuration\Filters\filtername.xml
  • Macintosh: Macintosh HD/Users/nome do usuário/Library/Application Support/Adobe/Flash CC/idioma/Configuration/Filters/filtername.xml

Criar uma biblioteca de filtros com configurações predefinidas

  1. Aplique o filtro ou os filtros a qualquer objeto selecionado.

  2. Clique no botão para adicionar um novo filtro.

  3. Selecione o filtro, clique no botão  e selecione Salvar como Predefinição.

  4. Digite um nome para as configurações de filtro na caixa de diálogo Salvar predefinição como; clique em OK.

Renomear predefinição de filtro

  1. Clique no botão e adicione um novo filtro.

  2. Selecione o filtro e clique no botão . Clique em Editar predefinições.

  3. Clique duas vezes no nome da predefinido para modificá-lo.

  4. Digite um novo nome de predefinição e clique em OK.

Excluir uma predefinição de filtro

  1. Clique no botão e adicione um novo filtro.

  2. Selecione o filtro e clique no botão .

  3. Clique em Editar predefinições.

  4. Na caixa de diálogo Editar predefinições, selecione a predefinição para remover e clique em Excluir.

Aplicação de filtros

Aplicação de sombra projetada

O filtro Sombra simula a aparência do objeto projetando uma sombra sobre uma superfície.

Texto com o filtro Sombra aplicado

Para obter uma amostra de sombra com interpolação clássica, consulte a página Amostras do Animate, em www.adobe.com/go/learn_fl_samples_br. Baixe e descompacte o arquivo zip Amostras e navegue ate o diretório Graphics\AnimatedDropShadow.

  1. Selecione o objeto a que deseja aplicar a sombra projetada.
  2. Na seção Filtros do Inspetor de propriedades, clique no botão e selecione Sombra.

  3. Edite as configurações de filtro:
    • Para definir a largura e a altura da sombra projetada, defina os valores de desfoque X e Y.
    • Para definir o escurecimento da sombra, defina o valor Intensidade. Quanto maior o valor numérico, mais escura será a sombra.
    • Selecione o nível de qualidade da sombra projetada. Alto aproxima-se da sombra do Desfoque gaussiano. Baixo maximiza o desempenho da reprodução.
    • Para definir o ângulo da sombra, insira um valor.
    • Para definir a distância da sombra a partir do objeto, defina o valor Distância.
    • Selecione Supressão para ocultar visualmente o objeto de origem e exibir apenas a sombra projetada pela imagem suprimida.
    • Para aplicar a sombra aos limites do objeto, selecione Sombra interna.
    • Para ocultar o objeto e exibir apenas a sombra dele, selecione Ocultar objeto. A opção Ocultar objeto permite criar mais facilmente uma sombra realista.
    • Para abrir o Seletor de cores e definir a cor da sombra, clique no controle Cor.

Criar uma sombra projetada inclinada

Inclinação do filtro Sombra para criar uma aparência de sombra mais realista

  1. Selecione o objeto com a sombra que deseja inclinar.
  2. Duplique (selecione Editar > Duplicar) o objeto de origem.
  3. Selecione o objeto duplicado e incline-o usando a ferramenta Transformação livre (Modificar > Transformar > Girar e inclinar).
  4. Aplique o filtro Sombra projetada ao clipe de filme ou objeto de texto duplicado. (O filtro já estará aplicado se o objeto duplicado já tiver uma sombra projetada.)
  5. No painel Filtros, selecione Ocultar objeto para ocultar o objeto duplicado enquanto deixa sua sombra visível.
  6. Selecione Modificar > Organizar > Enviar para trás para posicionar o objeto duplicado e sua sombra atrás do objeto original duplicado.
  7. Ajuste as configurações do filtro Sombra projetada e do ângulo da sombra projetada inclinada até alcançar a aparência desejada.

Aplicação de desfoque

O filtro Desfoque suaviza as arestas e os detalhes de objetos. Aplicar um desfoque ao objeto faz com que ele pareça como se estivesse atrás de outros objetos ou faz com que pareça que o objeto está em movimento.

Texto com o filtro Desfoque aplicado

  1. Selecione o objeto em que deseja aplicar o desfoque e selecione Filtros.
  2. Clique no botão e selecione Desfoque.

  3. Edite as configurações de filtro na aba Filtro:
    • Para definir a largura e altura do desfoque, defina os valores de Desfoque X e Y.
    • Selecione o nível de qualidade do desfoque. Alto aproxima-se da sombra do Desfoque gaussiano. Baixo maximiza o desempenho da reprodução.

Aplicação de brilho

O filtro Brilho permite aplicar uma cor ao redor das arestas do objeto.

Texto com o filtro Brilho aplicado

  1. Selecione o objeto em que deseja aplicar o brilho e selecione Filtros.
  2. Clique no botão e selecione Brilho.

  3. Edite as configurações de filtro na aba Filtro:
    • Para definir a largura e altura do brilho, defina os valores de Desfoque X e Y.
    • Para abrir o Seletor de cores e definir a cor de brilho, clique no controle Cor.
    • Para definir a nitidez do brilho, defina o valor Intensidade.
    • Para suprimir (ou ocultar visualmente) o objeto de origem e exibir apenas o brilho na imagem vazada, selecione Vazado.
    Uso do filtro Brilho com a opção Supressão

    • Para aplicar o brilho nos limites do objeto, selecione Brilho interno.
    • Selecione o nível de qualidade do brilho. Alto aproxima-se da sombra do Desfoque gaussiano. Baixo maximiza o desempenho da reprodução.

Aplicar bisel

O bisel aplica um realce ao objeto que faz com que ele pareça estar projetado acima da superfície do plano de fundo.

Texto com bisel aplicado

  1. Selecione o objeto a que deseja aplicar o bisel e selecione Filtros.
  2. Clique no botão e selecione Bisel.

  3. Edite as configurações de filtro na aba Filtro:
    • Para definir o tipo de bisel, selecione um bisel no menu Tipo.
    • Para definir a largura e altura do bisel, defina os valores de Desfoque X e Y.
    • Selecione a sombra e a cor de realce do bisel na paleta pop-up de cores.
    • Para definir a opacidade do bisel sem afetar a largura, defina o valor Intensidade.
    • Para alterar o ângulo da sombra que a aresta chanfrada projeta, defina o valor Ângulo.
    • Para definir a largura do bis, digite um valor em Distância.
    • Para vazar (ou ocultar visualmente) o objeto de origem e exibir apenas o bisel na imagem vazada, selecione Vazado.

Aplicar brilho de gradiente

A aplicação do brilho de gradiente produz uma aparência de brilho com cor de gradiente na superfície do brilho. O brilho de gradiente requer uma cor no inicio do gradiente com valor de Alfa igual a 0. Você não pode mover a posição dessa cor, mas pode alterar a cor.

Text com brilho de gradiente aplicado

  1. Selecione um objeto em que deseja aplicar o brilho de gradiente.
  2. Na seção Filtros do Inspetor de propriedades, clique no botão e selecione Brilho de gradiente.

  3. Edite as configurações de filtro na aba Filtro:
    • Selecione o tipo de brilho que deseja aplicar ao objeto no menu pop-up Tipo.
    • Para definir a largura e altura do brilho, defina os valores de Desfoque X e Y.
    • Para definir a opacidade do brilho sem afetar a largura, defina o valor Intensidade.
    • Para alterar o ângulo da sombra que o brilho projeta, defina o valor Ângulo.
    • Para definir a distância da sombra a partir do objeto, defina o valor Distância.
    • Para vazar (ou ocultar visualmente) o objeto de origem e exibir apenas o brilho de gradiente na imagem vazada, selecione Vazado.
    • Especifique a cor de gradiente do brilho. O gradiente contém duas ou mais cores que são atenuadas ou mescladas entre si. A cor que você seleciona no inicio do gradiente é referida como a cor alfa.
    • Para alterar uma cor no gradiente, selecione um dos ponteiros de cor abaixo da barra de definição de gradiente e clique no espaço de cor que aparece logo abaixo da barra de gradiente para exibir o Seletor de cores. Deslizar esses ponteiros ajusta o nível e a posição dessa cor no gradiente.
    • Para incluir um ponteiro no gradiente, clique na barra de definição de gradiente ou abaixo dela. Para criar um gradiente com até 15 transições de cor, adicione até 15 ponteiros de cor. Para reposicionar um ponteiro no gradiente, arraste o ponteiro ao longo da barra de definição do gradiente. Para remover um ponteiro, arraste-o para baixo e fora da barra de definição de gradiente.
    • Selecione o nível de qualidade do brilho de gradiente. Alto aproxima-se da sombra do Desfoque gaussiano. Baixo maximiza o desempenho da reprodução.

Aplicação de bisel de gradiente

A aplicação do bisel de gradiente produz uma aparência de elevação que faz com que o objeto pareça elevado acima do plano de fundo, com uma cor de gradiente na superfície do bisel. O bisel de gradiente requer uma cor no meio do gradiente com valor de alfa igual a 0.

  1. Selecione um objeto em que deseja aplicar o bisel de gradiente.

  2. Na seção Filtros do Inspetor de propriedades, clique no botão e selecione Bisel de gradiente.

  3. Edite as configurações de filtro na aba Filtro:

    • Selecione o tipo de bisel que deseja aplicar ao objeto no menu pop-up Tipo.

    • Para definir a largura e altura do bisel, defina os valores de Desfoque X e Y.

    • Para afetar a suavidade do bisel sem afetar a largura, digite um valor Intensidade.

    • Para definir o ângulo da fonte de luz, insira um valor em Ângulo.

    • Para vazar (ou ocultar visualmente) o objeto de origem e exibir apenas o bisel de gradiente na imagem vazada, selecione Vazado.

    • Especifique a cor de gradiente do bisel. O gradiente contém duas ou mais cores que são atenuadas ou mescladas entre si. O ponteiro do meio controla a cor alfa do gradiente. Você pode alterar a cor do ponteiro alfa, mas não pode reposicionar essa cor no gradiente.

      Para alterar uma cor no gradiente, selecione um dos ponteiros de cor abaixo da barra de definição de gradiente e clique no espaço de cor que aparece logo abaixo da barra de gradiente para exibir o Seletor de cores. Para ajustar o nível e a posição da cor no gradiente, deslize esses ponteiros.

      Para incluir um ponteiro no gradiente, clique na barra de definição de gradiente ou abaixo dela. Para criar um gradiente com até 15 transições de cor, adicione até 15 ponteiros de cor. Para reposicionar um ponteiro no gradiente, arraste o ponteiro ao longo da barra de definição do gradiente. Para remover um ponteiro, arraste-o para baixo e fora da barra de definição de gradiente.

Aplicação do filtro Ajustar cor

O filtro Ajustar cor permite controlar melhor os atributos de cor do objeto selecionado, incluindo contraste, brilho, saturação e matiz.

  1. Selecione o objeto em que deseja ajustar a cor.
  2. Na seção Filtros do Inspetor de propriedades, clique no botão Adicionar filtro e selecione Ajustar cor.

  3. Insira valores para os atributos de cor. Os atributos e seus valores correspondentes são os seguintes:

    Contraste

    Ajusta os realces, as sombras e os tons médios de uma imagem.

    Brilho

    Ajusta o brilho da imagem.

    Saturação

    Ajusta a intensidade da cor.

    Matiz

    Ajusta o sombreamento da cor.

  4. Para redefinir todos os ajustes de cor como 0 e retornar o objeto ao respectivo estado original, clique em Restaurar filtro.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online