Blur and Sharpen effects

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

About Blur & Sharpen effects

In general, blur effects sample the area around a pixel and assign to the pixel a new value that is the average of the sampled values. Increased blurriness is the result of increasing the size of the sample, whether the size is expressed as a radius or a length.

Some blur effects have a Repeat Edge Pixels option. Select this option to make the blur algorithm operate as if the pixel values beyond the edge of the layer are the same as the values of the edge pixels. This option keeps edges sharp, preventing them from darkening and becoming more transparent—the result of being averaged with a lot of zeroes. Deselect this option to make the blur algorithm operate as if the pixel values beyond the edge of the layer are zero.

Note:

Film grain and noise are removed from an image when you blur it. To make the image look more realistic, you may want to add noise back to the image so that it doesn’t look retouched. (See Noise & Grain effects.)

Stu Maschwitz compares the Box Blur, Fast Blur, and Gaussian Blur effects in a post on his ProLost blog.

Third-party effects in this category included with After Effects:

  • CC Cross Blur effect

  • CC Radial Blur effect

  • CC Radial Fast Blur effect

  • CC Vector Blur effect

Applying an effect or preset

You can apply an effect or an effect preset by dragging it on to your composition from the Effects & Presets panel. To open the Effects & Presets panel, choose Window > Effects & Presets.

Applying an effect or preset to your composition

Bilateral Blur effect

The Bilateral Blur effect selectively blurs an image so that edges and other details are preserved. Areas with high contrast—where pixel values differ by a large amount—are blurred less than areas of low contrast.

The primary difference between the Bilateral Blur effect and the Smart Blur effect is that edges and details are still blurred a small amount by the Bilateral Blur effect. The result is a softer, dreamier look than that achieved by the Smart Blur effect with equivalent settings.

The result of the Bilateral Blur effect is very similar to the result of the Surface Blur filter in Adobe Photoshop.

Eran Stern provides a demonstration of the Bilateral Blur effect on the Motionworks website.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Threshold

The radius of the blur is automatically decreased in areas where an edge or other prominent detail feature exists. The Threshold value determines how the Bilateral Blur effect decides what areas contain features to be preserved and what areas to be blurred by the full amount. A lower Threshold value causes more fine details to be preserved. A higher Threshold value causes a more simplistic result, with fewer details preserved.

Radius

A larger radius for a blur means that more pixels are averaged together to determine each pixel value, so increasing the Radius value increases the blurriness.

Colorize

When Colorize is not selected, the Bilateral Blur effect operates on one value for each pixel: its luminance value, which is a weighted average of its R, G, and B color channel values. The result is a monochromatic image.

When Colorize is selected, the Bilateral Blur effect operates on each color channel individually. The result is a color image.

Box Blur effect

Box Blur is similar to Fast Blur and Gaussian Blur, but Box Blur has the added advantage of an Iterations property, which allows you to control the quality of the blur.

Stu Maschwitz compares the Box Blur, Fast Blur, and Gaussian Blur effects in a post on his ProLost blog.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Iterations

How many times the blur is sequentially applied to the image. A value around 3 gives a blur similar in quality to Fast Blur. A higher number of iterations creates smoother transitions between colors and increases the blur, but it also increases the render time. The default value creates boxy results.

Camera Lens Blur effect

The effect is a replacement for the Lens Blur effect. The effect has a larger blur radius (500), and is much faster than the Lens Blur effect. The Camera Lens Blur effect also does not disable Render Multiple Frames Simultaneously multiprocessing, as its predecessor did.

For details, tutorials, and resources about the Camera Lens Blur effect, camera depth-of-field settings, and camera commands, see this article on the Adobe website.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Note:

Descriptions of the Camera Lens Blur effect’s properties also apply to the camera layer’s Camera Options properties group with the same (or similar) names.

Iris Properties

Iris properties include Shape, Roundness, Aspect Ratio, Rotation, and Diffraction Fringe.

Diffraction Fringe

Creates a halo around the edge of an iris that simulates light bending, concentrating around the edge of the iris blades. When set to 100, a natural normal halo that is based on the area represented in the shape of the blur is visible. At 500, all the energy of the blur is pushed from inside the blur to the ring/halo. This effect, in essence, emulates a catadioptric lens.

Blur Map

A control layer can be used as a blur map to affect Camera Lens Blur effect properties.

Layer

Layer to use as the blur map.

Channel

Luminance, color, or alpha channel for the blur map.

Blur Focal Distance

The value from the control layer that corresponds to zero blurring. The difference between the Blur Focal Distance value and a value from the control layer dictates the amount of blurriness for the corresponding area on the layer with the effect applied.

Highlight

Modifies color values of the pixels that are above the threshold. Higher highlight values produce the best results for getting a good blooming blur/glow effect.

Gain

The amount of energy fed into pixels that are above the threshold. Depending on how bright a pixel is above the threshold, the pixel value is increased in brightness by this relative amount.

Threshold

The luminosity limit on what is boosted by Gain. Pixels much brighter than the threshold are boosted more than those pixels slightly above it. Setting the threshold to 0 boosts any pixel with a brightness higher than 0. Setting it to 1 effectively eliminates any highlight (unless the image contains overbrights).

Saturation

The amount of color retained in the boosted pixel. Setting it to 0 pushes the boosted colors toward white (what the old Lens Blur effect used to do). Setting to 100 attempts to retain as much color as possible. This saturation of the highlights is especially noticeable in situations with colored lights (like a city scape at night), in which the colors create a multicolored tapestry of bokeh.

Edge Behavior

See About Blur & Sharpen effects for information about how Repeat Edge Pixels options are treated in blur effects.

Use Linear Working Space

Produces a result similar to a project set to a linearized working color space. Check this property (or set it from the project settings) to see realistic bokeh effects from your images.

Note:

In addition to enabling the Use Linear Working Space check box, be sure to work in 32-bpc color. Working with a lower color bit depth causes quantization.

Forward and backward compatibility

If the Camera Lens Blur effect is added to an After Effects CS5.5 and later project, and then saved as an After Effects CS5 project (see Save and back up projects in After Effects CS5.5 and later.), a warning appears stating that the effect is missing. Projects created in After Effects CS5 or earlier using the Lens Blur effect retain that effect when opened in After Effects CS5.5 and later. However, you cannot directly apply the Lens Blur effect in After Effects CS5.5 or later.

Camera-Shake Deblur effect

Camera-Shake Deblur effect helps you recover blurry footage caused by camera shake. You can stabilize a shaky footage with Warp Stabilizer VFX effect, but unwanted artifacts like motion blur may still exist. Camera-Shake Deblur effect reduces the unwanted artifacts to produce better results. The effect targets blurry frames and tries to reconstruct them by using sharp on either side of the blurry frame. Camera-Shake Deblur effect uses optical flow technology to blend the sharp frames with the blurry frames.

Before and after applying Camera-Shake Deblur effect
Before and after applying Camera-Shake Deblur effect

Applying Camera-Shake Deblur effect

To apply the effect, do any of the following:

  • To view it from the Effect menu, select Effects > Blur & Sharpen > Camera-Shake Deblur.
Viewing Camera-Shake Deblur in Effect menu
Viewing Camera-Shake Deblur in Effect menu

  1. In the Effects & Presets panel, click the search box and type Camera-Shake Deblur.   

    Viewing Camera-Shake Deblur in Effects & Presets menu
    Viewing Camera-Shake Deblur in Effects & Presets menu

  2. The effect is displayed under Blur & Sharpen effect category.

  3. Drag the effect to the timeline and apply it on the composition.

Camera-Shake Deblur effect provides you with a set of properties to control the effect performance.

To open the properties, follow these steps:

  1. In Effect Controls panel, twirl open Camera-Shake Deblur effect.

  2. Modify the properties displayed under the effect. 

    Modifying Camera-Shake Deblur properties in Effect Controls panel
    Modifying Camera-Shake Deblur properties in Effect Controls panel

Camera-Shake Deblur effect properties

  • Blur Duration: Changes the number of frames to compare around the blurry frame to get a non-motion-blurred frame. The Blur Duration property controls the number of frames for which motion blur lasts. Select a lower value for shorter period of shake, and a higher value for longer period of shake. 
  • Deblur Method: Uses the optical flow method, which affects how pixels are mapped from the non-motion-blurred frames to the blurry frame. You can choose between High Quality (slower) and Standard quality. High Quality (slower) provides more accurate results, but takes longer to process. Standard is fast and provides standard production-quality results.
  • Strength: Controls how much correction is applied to the blurry frame. You can adjust the strength values from 100% (default) to 200% depending on how blurry a frame is. Higher values can result in artifacts if the non-motion-blurred frames within the blur duration are not aligned properly with the blurry frames.
  • Shake Sensitivity: Determines the threshold of whether a frame is considered blurry enough to need deblurring. Lower Shake Sensitivity value deblurs only the blurriest frames and may not be able to identify other motion blurs. Higher Shake Sensitivity value is sensitive to any kind of motion blur and tries to deblur any motion blur identified. 

Tip: For best results, apply Camera-Shake Deblur effect after stabilizing footage. For example, apply the Warp Stabilizer VFX effect first, then apply Camera-Shake Deblur effect.

Note:

For shots that are difficult to deblur, applying multiple copies of Camera-Shake Deblur effect with a low Strength value may achieve better results.    

Camera-Shake Deblur effect in After Effects

Watch this video to learn about reducing motion blur with the Camera-Shake Deblur effect

Channel Blur effect

The Channel Blur effect individually blurs the red, green, blue, or alpha channels of a layer.

Note:

If you have noise or artifacts primarily in one color channel—such as MPEG compression artifacts in the blue channel of DV footage—use Channel Blur to clean up the noise in that channel, leaving the other channels sharp. This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Compound Blur effect

The Compound Blur effect blurs pixels in the effect layer based on the luminance values of a control layer, also known as a blur layer or blurring map. By default, bright values in the blur layer correspond to more blurring of the effect layer, while dark values correspond to less blurring; select Invert Blur for light values to correspond to less blurring.

This effect is useful for simulating smudges and fingerprints, or changes in visibility caused by atmospheric conditions such as smoke or heat, especially with animated blur layers such as those generated with the Turbulent Noise effect.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Maximum Blur

The maximum amount, in pixels, that any part of the affected layer can be blurred.

Stretch Map To Fit

Stretches the control layer to the dimensions of the layer to which it is applied; otherwise, the control layer is centered on the effect layer.

Steve Holmes provides a video tutorial on the Artbeats website that demonstrates the use of the Compound Blur effect.

Directional Blur effect

The Directional Blur effect gives a layer the illusion of motion.

Andrew Kramer provides a video tutorial on his Video Copilot website in which he demonstrates the use of the Directional Blur effect to make a gun slide look as if it is moving quickly.

This effect works with 8-bpc, 16-bpc, and 32-bpc color. The effect uses GPU acceleration for faster rendering.

Direction

The direction of the blur. The blur is applied equally on either side of the center of a pixel; therefore, a setting of 180° and a setting of 0° produce the same results.

Fast Box Blur effect

The effect can replicate the rendering result of Fast Blur (Legacy), but at a faster speed. To apply the effect, select Effect > Blur & Sharpen > Fast Box Blur. The Fast Box Blur effect is rendered using the GPU of your computer.

Applying Fast Box Blur effect
Applying Fast Box Blur effect

Note:

For scripting and expressions, the match name of the Fast Box Blur effect is ADBE Box Blur2. The older match name ADBE Box Blur still works to apply the effect, but with the older effect name Box Blur.

Gaussian Blur effect

The Gaussian Blur effect blurs and softens the image and eliminates noise. The quality setting of the layer doesn’t affect Gaussian Blur. 

This effect works uses the Repeat Edge Pixels option and works with 8-bpc, 16-bpc, and 32-bpc color. The effect uses GPU acceleration for faster rendering.

The Gaussian Blur effect is a replacement for the Gaussian Blur (Legacy) effect and produces slightly different rendering result than the Gaussian Blur (Legacy) effect.

Radial Blur effect

The Radial Blur effect creates blurs around a point, simulating the result of a zooming or rotating camera.

You can specify the level of anti-aliasing applied at Best quality; no anti-aliasing is applied at Draft quality. At Draft quality, the blur appears grainy. You may prefer the draft results for special effects, but the grain may flicker on interlaced displays.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Type

Spin blurs in arcs around the Center point, as if the camera were rotating; Amount specifies degrees of rotation. Zoom blurs radially outward from the center point; Amount specifies the length of the blur.

Sharpen effect

The Sharpen effect increases the contrast where color changes occur. The quality setting of the layer doesn’t affect Sharpen.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

The Sharpen effect uses GPU acceleration for faster rendering.

Smart Blur effect

The Smart Blur effect blurs an image while preserving lines and edges within the image. For example, you can use the Smart Blur effect to smoothly blur shaded areas while retaining crisp outlines of text and vector graphics.

This effect works with 8-bpc and 16-bpc color.

Radius

How far the filter searches for dissimilar pixels to blur.

Threshold

How different the values of pixels should be before they are eliminated.

Mode

What parts of the image receive the blur. Normal specifies that the blur be applied to the entire selection, whereas Edge Only and Overlay Edge specify that the blur be applied only to the edges of color transitions. Where significant contrast occurs, Edge Only applies black-and-white edges, and Overlay Edge applies white.

Unsharp Mask effect

The Unsharp Mask effect increases the contrast between colors that define an edge.

This effect works with 8-bpc, 16-bpc, and 32-bpc color.

Radius

The distance from the edge at which pixels are adjusted for contrast. If you specify a low value, only pixels near the edge are adjusted.

Threshold

The greatest difference between adjacent pixels for which contrast isn’t adjusted. A lower value produces a greater result. A value that is too low causes contrast for the entire image to be adjusted and can generate noise or cause unexpected results.

Adobe logo

Sign in to your account