若要将各个图形元素彼此自动对齐,请使用贴紧功能。 Animate 提供三种方法对齐舞台上的对象:

  • 对象贴紧功能可以将对象沿着其他对象的边缘直接与它们对齐。
  • 像素贴紧功能可以在舞台上将对象直接与单独的像素或像素的线条贴紧。
  • 贴紧对齐功能可以按照指定的贴紧对齐容差(即对象之间或对象与舞台边缘之间的预设边界)对齐对象。
  • “将位图贴紧至像素”可在创作时将位图贴紧至最近的像素,以使其在画布上看起来更为鲜明。

注意:还可以与网格或辅助线贴紧。

 

打开或关闭对象贴紧功能

若要打开对象贴紧功能,请使用选取工具的“贴紧至对象”功能键或“视图”菜单中的“贴紧至对象”命令。

如果选取工具的“贴紧至对象”功能键是打开的,则拖动元素时指针下面会出现一个黑色的小环。 当对象处于另一个对象的贴紧距离内时,该小环会变大。

  1. 选择“视图”>“贴紧”>“贴紧至对象”。如果该命令是打开的,则它的旁边会出现一个选中标记。

    当移动对象或改变其形状时,对象上选取工具的位置为贴紧环提供了参考点。 例如,如果通过拖动接近填充形状中心的位置来移动填充形状,它的中心点会与其他对象贴紧。 对于要将形状与运动路径贴紧从而制作动画的情况,该功能特别有用。

    注意:

    要在贴紧时更好地控制对象位置,可以从对象的转角或中心点开始拖动。

将位图贴紧至像素

要启用位图贴紧,请使用“视图”菜单中的“将位图贴紧至像素”命令。这可以确保在内容创作期间位图置于整数位置(不带小数值)。

  1. 选择“视图”>“贴紧”>“将位图贴紧至像素”

  2. 此选项旁边的勾选记号表示已启用该功能。当勾选记号为禁用状态时,您可以将位图放置在任何位置。

    创作时将位图贴紧至像素

调整对象的贴紧对齐容差

  1. 选择“编辑”>“首选参数”(Windows) 或“Animate”>“首选参数”(Macintosh),然后单击“绘画”。

  2. 在“绘画设置”下,调整“连接线”设置。

使用像素贴紧功能

若要打开像素贴紧功能,请使用“视图”菜单中的“贴紧至像素”命令。 如果“贴紧至像素”是打开的,当视图缩放比率设置为 400% 或更高的时候会出现一个像素网格。 像素网格表示 Animate 应用程序中显示的单个像素。当您创建或移动一个对象时,它会被限定到像素网格内。

如果创建的形状边缘处于像素边界内(例如,使用的笔触宽度是小数形式,如 3.5 像素),则“贴紧至像素”将贴紧至像素边界,而不是贴紧至形状边缘。

  • 若要打开或关闭像素贴紧功能,请选择“视图”>“贴紧”>“贴紧至像素”。 如果缩放比率设置为 400% 或者更高,像素网格就会显示出来。 如果该命令是打开的,则它的旁边会出现一个选中标记。

  • 若要临时打开或关闭像素贴紧功能,请按 C 键。 释放 C 键时,像素贴紧会返回到您用“视图”>“贴紧”>“贴紧至像素”选择的状态。

  • 若要暂时隐藏像素网格,请按 X 键。 当释放 X 键时,像素网格会重新出现。

 

编辑贴紧方式

当您选择“贴紧对齐”设置时,可以设置对象的水平或垂直边缘之间以及对象边缘和舞台边界之间的贴紧对齐容差。 也可以在对象的水平和垂直中心之间打开贴紧对齐功能。 所有“贴紧对齐”设置均以像素为度量单位。

  1. 选择“视图”>“贴紧”>“编辑贴紧方式”。
  2. 在“编辑贴紧方式”对话框中,选择要贴紧至的对象的类型。选择“保存默认值”,将指定设置保存在 .fla 文件中。保存的活动文档的设置将用于新的文档中。

    编辑贴紧方式

    在“编辑贴紧方式”对话框中,选择要贴紧至的对象的类型。
  3. 单击“高级”按钮并选择下列任一操作:
    • 要设置对象和舞台边界之间的贴紧对齐容差,请输入一个“影片边框”值。

    • 要设置对象的水平或垂直边缘之间的贴紧对齐容差,请输入“水平”和/或“垂直”值。

    • 要打开“水平居中对齐”或“垂直居中对齐”,请选择“水平居中对齐”和/或“垂直居中对齐”。

打开贴紧对齐

如果打开了“贴紧对齐”,则在您将对象拖到指定的贴紧对齐容差位置时,点线将出现在舞台上。 例如,如果将“水平”贴紧对齐容差设置为 18 个像素(默认设置),则当您正在拖动的对象距另一个对象正好是 18 个像素时,点线将沿着该对象边缘出现。 如果您打开“水平居中对齐”,则当您精确对齐两个对象的水平中心顶点时,点线将沿着这些顶点出现。

  1. 选择“视图”>“贴紧”>“贴紧对齐”。 如果该命令是打开的,则它的旁边会出现一个选中标记。

创建引导层

为了在绘画时帮助对齐对象,请创建引导层,然后将其他图层上的对象与在引导层上创建的对象对齐。 引导层不会导出,因此不会显示在发布的 SWF 文件中。 任何图层都可以作为引导层。 图层名称左侧的辅助线图标表明该层是引导层。

  1. 选择该层,然后右键单击 (Windows) 或按住 Control 单击 (Macintosh),然后从上下文菜单中选择“引导层”。 要将该层改回常规层,请再次选择“引导层”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略