使用 Animate 的舞台和工具面板

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

阅读本文可了解处理 Animate 中的图形内容时所用的舞台和工具面板。

欢迎屏幕概述

Animate (以前名为 Flash Professional CC)运行时如果不打开任何文档,则会显示“欢迎”屏幕。欢迎屏幕包含以下四个区域:

打开最近的项目

可以打开最近打开的文档(单击“打开”图标)。

新建

列出 Animate 文件类型,如 Animate 文档和 ActionScript® 文件。

从模板创建

列出创建 Animate 文档最常用的模板。

扩展

Animate Exchange 网站链接,其中可以下载辅助应用程序、扩展及相关信息。

通过“欢迎”屏幕还可以快速访问帮助资源。您可以对 Animate 做一个快速浏览,了解文档资源、查找 Adobe 授权的培训渠道。

  • 若要隐藏“欢迎”屏幕,可选择“不再显示”。

  • 若要显示“欢迎”屏幕,可选择“编辑”>“首选项”(Windows®) 或选择“Animate”>“首选项”(Macintosh®),然后从“常规”类别的“启动时”菜单中选择“欢迎屏幕”。

使用舞台

舞台是您在创建 Animate 文档时放置图形内容的矩形区域。创作环境中的舞台相当于 Flash Player 或 web 浏览器窗口中在播放期间显示文档的矩形空间。 默认显示的黑色轮廓表示舞台的轮廓视图。

要在工作时更改舞台的视图,请使用放大和缩小功能。 若要帮助在舞台上定位项目,可以使用网格、辅助线和标尺。

时间轴和带内容的舞台。

缩放舞台

要在屏幕上查看整个舞台,或要以高缩放比率查看绘图的特定区域,可以更改缩放比率级别。 最大的缩放比率取决于显示器的分辨率和文档大小。 舞台上的最小缩小比率为 8%。 舞台上的最大放大比率为 2000%。

注意:

您还可以在兼容设备中使用多点触控 (multi-touch) 手势。

  • 若要放大某个元素,请选择“工具”面板中的“缩放”工具 ,然后单击该元素。 若要在放大或缩小之间切换“缩放”工具,请使用“放大” 或“缩小” 功能键(当“缩放”工具处于选中状态时位于“工具”面板的选项区域中),或者按住 Alt 单击 (Windows) 或按住 Option 单击 (Macintosh)。

  • 要进行放大以使绘图的特定区域填充窗口,请使用“缩放”工具在舞台上拖出一个矩形选取框。

  • 要放大或缩小整个舞台,请选择“视图”>“放大”或“视图”>“缩小”。

  • 要放大或缩小特定的百分比,请选择“视图”>“缩放比率”,然后从子菜单中选择一个百分比,或者从文档窗口右上角的“缩放”控件中选择一个百分比。

  • 要缩放舞台以完全适合应用程序窗口,请选择“视图”>“缩放比率”>“符合窗口大小”。
  • 要裁切掉舞台范围以外的内容,可单击“剪切舞台外部的内容”图标
  • 要显示当前帧的内容,请选择“视图”>“缩放比率”>“显示全部”,或从应用程序窗口右上角的“缩放”控件中选择“显示全部”。 如果场景为空,则会显示整个舞台。
  • 要显示整个舞台,请选择“视图”>“缩放比率”>“显示帧”,或从文档窗口右上角的“缩放”控件中选择“显示帧”。

  • 若要显示围绕舞台的工作区,或要查看场景中位于或超出舞台区域的元素,请选择“视图”>“剪贴板”。剪贴板以浅灰色显示。 例如,要使一只鸟飞入帧中,可以先将鸟儿放置在剪贴板中舞台之外的位置,然后以动画形式使鸟儿进入舞台区域。

粘贴板颜色

以前,粘贴板颜色是根据用户界面主题固定的。从 2017 年 1 月发行版开始,粘贴板的颜色可以与舞台的颜色相同。该功能就可以让您使用的是一个没有边界的画布了。 

注意:

最终输出中只显示舞台内容。 

移动舞台视图

放大舞台以后,您可能无法看到整个舞台。要在不更改缩放比率的情况下更改视图,可以使用“手形”工具移动舞台。

注意:

您还可以在兼容设备中使用多点触控 (multi-touch) 手势。

  • 在“工具”面板中,选择“手形”工具并拖动舞台。 要临时在其他工具和“手形”工具之间切换,请在按住空格键的同时单击“工具”面板中的该工具。

旋转舞台

Animate 推出一种新的“旋转”工具,允许您临时旋转舞台视图,以特定角度进行绘制,而不用像“自由变换”工具那样,需要永久旋转舞台上的实际对象。不管当前已选中哪种工具,您都可以采用以下方法快速旋转舞台:同时按住 ShiftSpace 键,然后拖动鼠标使视图旋转。

要使用旋转工具旋转视图

  1. 选择与“手形”工具 (H) 位于同一组的“旋转”工具 (H),或者如果在使用其他工具(如画笔),可同时按住 ShiftSpace(空格)键临时切换为“旋转”工具。

    工具栏中的旋转工具

  2. 选中旋转工具后,屏幕上会出现一个十字形的旋转轴心点,可以更改轴心点的位置,单击需要的位置即可。

    十字形轴心点

  3. 设好轴心点后,即可以围绕轴心点拖动鼠标来旋转视图。

    旋转后的舞台

  4. 使用舞台旋转工具,可通过拖动的方法临时旋转舞台区域。当前旋转角度用十字轴心上的红线表示。

  5. 要将舞台重设为其默认视图,可单击“舞台位于中央”按钮。

缩放内容以适合舞台大小

PI 中的“缩放内容”选项允许您根据舞台大小缩放舞台上的内容。选中此选项后,如果调整了舞台大小,其中的内容便会随舞台同比例调整大小。

PI 中的“缩放内容”选项

缩放舞台大小

如今可以从 PI 直接访问高级设置中的“缩放内容”选项。选中此选项后,如果调整了舞台大小,其中的内容便会随舞台同比例调整大小。

PI 和“文档设置”对话框中有一个“链接”选项,可实现按比例添加舞台尺寸。默认情况下,舞台的高度和宽度属性是不关联在一起的。如果单击“链接”按钮启用关联功能,则当您修改高度或宽度属性的值后,另一个属性的值便会按比例改变。

如果选择“缩放内容”选项,舞台尺寸将自动关联并禁用。这是因为内容缩放在按比例更改舞台尺寸时才有意义。

按比例缩放舞台大小的“链接”按钮

设置画布透明度

您可以通过在颜色样本中选择 Alpha 颜色范围(百分比),将画布设为透明模式。为此可选择“画布”>“属性”>“舞台”>“Alpha %”。

基于选定锚点缩放舞台

您可以在“文档设置”中选择一个锚点,指定高度和宽度,然后将舞台缩放为该尺寸。禁用“缩放内容”后,舞台会根据所选锚点沿相应方向扩展,详见以下图像。

可据以缩放舞台的锚点

舞台缩放:示例

在下例中,舞台大小 550x400 从舞台右下角处的锚点按比例缩放为 750x600:

设置舞台基于右下角处的锚点进行缩放

舞台从右下角处的锚点沿设定方向缩放

注意:

您还可以在兼容设备中使用多点触控 (multi-touch) 手势。

使用标尺

当显示标尺时,它们将显示在文档的左沿和上沿。 您可以更改标尺的度量单位,将其默认单位(像素)更改为其他单位。 在显示标尺的情况下移动舞台上元素时,将在标尺上显示几条线,指出该元素的尺寸。

  • 要显示或隐藏标尺,请选择“视图”>“标尺”。

  • 要指定文档的标尺度量单位,请选择“修改”>“文档”,然后从“标尺单位”菜单中选择一个单位。

使用辅助线

显示标尺(“视图”>“标尺”)时,可以从标尺上将水平辅助线和垂直辅助线拖动到舞台上。

如果创建嵌套时间轴,则仅当在其中创建辅助线的时间轴处于活动状态时,舞台上才会显示可拖动的辅助线。

要创建自定义辅助线或不规则辅助线,请使用引导层。

  • 要显示或隐藏绘画辅助线,请选择“视图”>“辅助线”>“显示辅助线”。

    注意:如果在创建辅助线时网格是可见的,并且打开了“贴紧至网格”,则辅助线将贴紧至网格。

     

  • 要打开或关闭贴紧至辅助线,请选择“视图”>“贴紧”>“贴紧至辅助线”。

    注意:当辅助线处于网格线之间时,贴紧至辅助线优先于贴紧至网格。

     

  • 要移动辅助线,请使用“选取”工具单击标尺上的任意一处,将辅助线拖到舞台上需要的位置。

  • 要删除辅助线,请在辅助线处于解除锁定状态时,使用“选取”工具将辅助线拖到水平或垂直标尺。

  • 要锁定辅助线,请选择“视图”>“辅助线”>“锁定辅助线”,或者使用“编辑辅助线”(“视图”>“辅助线”>“编辑辅助线”)对话框中的“锁定辅助线”选项。

  • 要清除辅助线,请选择“视图”>“辅助线”>“清除辅助线”。 如果在文档编辑模式下,则会清除文档中的所有辅助线。 如果在元件编辑模式下,则只会清除元件中使用的辅助线。

设置辅助线首选参数

  1. 选择“视图”>“辅助线”>“编辑辅助线”,然后执行下列任一操作:

    • 要设置“颜色”,请单击颜色框中的三角形,然后从调色板中选择辅助线的颜色。 默认的辅助线颜色为绿色。

    • 要显示或隐藏辅助线,请选择或取消选择“显示辅助线”。

    • 若要打开或关闭贴紧至辅助线,请选择或取消选择“贴紧至辅助线”。

    • 选择或取消选择“锁定辅助线”。

    • 要设置“对齐精确度”,请从弹出菜单中选择一个选项。

    • 要删除所有辅助线,请单击“全部清除”。 “全部清除”命令将从当前场景中删除所有的辅助线。

    • 若要将当前设置保存为默认值,请单击“保存默认值”。

  2. 单击“确定”。

使用网格

网格将在文档的所有场景中显示为插图之后的一系列直线。

显示或隐藏绘画网格

  1. 请执行下列操作之一:

    • 选择“视图”>“网格”>“显示网格”。

    • 按 Ctrl+'(单引号)(Windows) 或 Command+'(单引号)(Macintosh)。

打开或关闭贴紧至网格线

  1. 选择“视图”>“贴紧”>“贴紧至网格”。

设置网格首选参数

  1. 选择“视图”>“网格”>“编辑网格”,然后从选项中进行选择。

  2. 若要将当前设置保存为默认值,请单击“保存默认值”。

关于主工具栏和编辑栏

应用程序窗口顶部的菜单栏包含带有用于控制功能的命令的菜单。

舞台顶部的编辑栏包含的控件和信息可用于编辑场景和元件,并更改舞台的缩放比率级别。

自定义工具栏

Animate 2020 版提供了随用户喜好添加、删除、组合或重新排列工具的功能。单击工具栏中的“更多选项”图标 (...),打开“工具”选项板。 

Animate 工具栏
Animate 工具栏

工具栏选项板
工具栏选项板

您可以将工具栏中的某个工具拖放到工具选项板中以将其删除。同样,您可以将工具选项板中的某个工具拖放到工具栏中所需的位置,从而将该工具导入到工具栏。 

此外,利用这些增强功能,您可以:

  • 在工具面板和工具选项板之间,添加/删除工具。 
  • 通过将某个工具拖放到其他工具或组上,将该工具合并到工具组中。
  • 将选定工具拖动到特定工具的上方或下方,以将该工具的位置重新排列到特定工具或组的上方或下方。

工具的逻辑分组

间隔条
使用间隔条进行逻辑分组

您可以通过在工具列表之间添加一个间隔条,对工具进行所需的逻辑分组。将工具选项板中的间隔条拖放到工具面板中,可生成此类分组。

拆分工具栏

拆分工具栏
拆分工具栏

添加间隔条后,可通过将间隔条拖放到工具面板外部的工作区域所需位置,拆分出工具栏的子组。您也可将拆分的工具栏合并回工具面板。选中拆分的工具栏,并将其拖放到工具面板上即可。

翻转
拆分翻转

将鼠标悬停在工具上并单击工具底部的高亮显示部分,可以轻松地调整工具栏的方向,将其设置为水平或垂直。  

重置工具栏
重置工具栏

重置工具栏

在工具选项板的汉堡形菜单中选择“重置”选项,可将工具面板设置为其默认状态。

子工具栏选项

填充颜色和笔触颜色

工具栏的“填充颜色”和“笔触颜色”部分已经过修改,从而与 Photoshop 和 illustrator 工具面板保持一致,且更容易访问。

访问画笔和擦除模式

现在,您还可以为画笔模式和擦除模式添加键盘快捷键。在 Mac 上创建键盘快捷键,请单击“Animate”>“键盘快捷键”;在 Windows 上,请单击“编辑”>“键盘快捷键”。启用工具后,按一次按键即可访问这些选项。

填充颜色和笔触
填充颜色和笔触

擦除模式
擦除模式

画笔模式
画笔模式

使用工具面板

使用“工具”面板中的工具可以绘图、上色、选择和修改插图,并可以更改舞台的视图。 “工具”面板分为四个部分:

  • “工具”区域包含绘图、上色和选择工具。
  • “查看”区域包含在应用程序窗口内进行缩放和平移的工具。
  • “颜色”区域包含用于笔触颜色和填充颜色的功能键。
  • “选项”区域包含用于当前所选工具的功能键。 功能键影响工具的上色或编辑操作。

要显示或隐藏工具面板,请选择“窗口”>“工具”

选择工具

  1. 请执行下列操作之一:

    • 在“工具”面板中单击该工具。 根据选择的工具,“工具”面板底部的选项区域中可能会显示一组功能键。

    • 按工具的键盘快捷键。 若要查看键盘快捷键,请选择“编辑”>“键盘快捷键”(Windows) 或“Animate”>“键盘快捷键”(Macintosh)。在 Macintosh 中,可能需要移动鼠标才能看到新指针出现。

    • 若要选择位于可见工具(例如“矩形”工具)的弹出菜单中的工具,请按住该可见工具的图标,然后从弹出菜单中选择另一工具。

画笔中的压力和斜度

Animate 对使用画笔工具绘制的笔触提供了压力和斜度支持。取决于对铁笔应用的压力或斜度,您可以绘制不同宽度的艺术和图案笔触。要想做进一步调整,可使用“宽度”工具来调整宽度点。

有关更多信息,请参阅“使用画笔”

注意:

工具栏中的压力和斜度图标仅在为计算机连接了 Wacom 压敏平板电脑时才显示。

使用上下文菜单

上下文菜单包含与当前选择内容相关的命令。 例如,当您在“时间轴”窗口中选择一个帧时,上下文菜单包含的是用于创建、删除和修改帧和关键帧的命令。 许多项目和控件在许多位置上(包括舞台上、时间轴内、“库”面板上以及“动作”面板上)都有上下文菜单。

  1. 右键单击 (Windows) 或按住 Control 单击 (Macintosh) 某个项目。
Adobe 徽标

登录到您的帐户