对文件存储问题进行故障诊断

在 Illustrator 中存储文件时遇到了问题?以下是您可以尝试进行故障诊断的一些步骤。

当报告 .ai 文件已损坏时,请尝试以下解决方案以恢复受影响的文件内容:

解决方案

步骤 

使用其他文件格式存储文件

  • 将 .ai 文件更改为其他格式(.svg、.png 和 .jpg),然后尝试再次存储文件。
  • 以 Post-Script (PS) 格式存储文件
    1. 选择文件 > 打印
    2. 指定所需的打印设置。
    3. 打印机弹出菜单中选择 Adobe Postscript 文件,然后单击存储
    4. 键入包含 .ps 扩展名的文件名(例如,Filename.ps),然后单击确定 (Windows) 或存储 (macOS)。
    5. 在 Illustrator 中打开 PostScript 文件,然后尝试以 .ai 格式存储该文件。

注意:要执行这项解决方法,您必须安装 PostScript 打印机驱动程序。有关在 Windows 中安装 Postscript 打印机的信息,请参阅 Windows 帮助。

将内容复制到新的 文件

  • 从图稿中删除不需要的项目,例如游离点、未上色对象、空文本路径。选择对象 > 路径 > 清理
  • 在新文件中保留图稿的图层。在“图层面板”> 更多选项中,选择粘贴时记住图层。
  • 选择图稿,然后选择编辑 > 复制
  • 选择文件 > 新建来创建一个新文件。
  • 在新文件中,选择编辑 > 粘贴在前面以便将图稿粘贴到页面上的正确位置。

识别并移除损坏的组件

要确定对象是否损坏,请将其从新文件中移除,然后存储并重新打开文件。 

  • 识别损坏的图案、渐变或自定颜色
    • 选择编辑 > 全选,并将填色和描边更改为印刷黑色。
    • 如果新文件中没有再次出现该问题,请在原始文件中重新创建图案、渐变或专色。
      注意:您可能会丢失透明度和图层信息。
  • 删除损坏的色板、自定义颜色、颜色组、画笔、符号或样式
    从“色板”面板菜单、“画笔”面板菜单、“符号”面板菜单和“样式”面板菜单中选择所有未使用的项,然后按 Delete
  • 将损坏的文本对象转换为轮廓或更改其字体
    • 选择对象 > 解锁全部对象
    • 选择编辑 > 全选
    • 选择文字 > 字体,并选择一种文档中未使用的字体。
      注意:为防止文本对象未来受损,请从原始磁盘重新安装有问题的字体。

问题仍未解决?

  • 在重新存储或者重新创建原始文件中使用的图形、模板和自定颜色之后,如果仍不奏效,请在 Illustrator 中重新创建文件。 
  • 您可能会遇到与文件相关的其他问题,例如与内存、访问权限、网络、可移动媒体有关的问题。要了解有关此问题的更多信息,请查看确定文件问题并对其进行故障诊断

加入对话

Ask the community

如果想提出问题或分享您的看法、意见和建议,请前往并加入 Adobe Illustrator 社区。我们期待收到您的反馈。

Adobe 徽标

登录到您的帐户