了解如何解决从 InDesign 打印或导出为 PDF 时会出现的问题。

请按顺序执行本文档中的任务,解决问题后停止。

您也可以在以下位置找到已知的打印和导出问题以及解决方案:https://helpx.adobe.com/cn/indesign.html

确定问题的级别

在尝试解决打印或导出问题时,第一步是确定问题是在什么情况下出现的。例如,在打印或导出所有文档、一些文档或特定文档时,
错误是一次性问题还是一贯重现的问题?下面的步骤和测试可帮助您明确问题是如何以及何时出现的,以便可以找到解决方案。

1. 重新启动计算机。

如果错误没有再次出现,表明可能是临时通信问题、系统资源不足或其他临时环境因素造成的错误。如果在最初重新启动计算机后可以正常打印或导出,但稍后再次出现该错误,请在系统级别诊断问题

2. 先关闭再打开打印机。

如果错误没有再次出现,表明可能是打印机的内存问题造成的问题。如果错误再次出现,请转至步骤 3。

3. 创建一个新样例文档。

如果可以成功打印或导出新文档,但无法打印或导出原始文档,请在文档级别诊断问题

4. 使用不同的应用程序打印或导出。

如果可以从其他应用程序(例如,写字板、TextEdit)中打印或者可以从其他应用程序(例如,Illustrator、Photoshop)中导出/另存为 PDF,请在应用程序级别诊断问题

5. 使用不同的打印机进行打印。

如果还有一台打印机,请尝试使用该打印机打印文档。如果打印成功,确保原始打印机已打开且联机。移除并重新连接打印机电缆,然后对打印机运行自检,以检查是否存在机械故障或损坏的电缆。如果这些步骤都没有找出问题,请在系统级别诊断问题

6. 使用不同的方法创建 PDF 文件.

  • 如果在从 InDesign 到 Acrobat Standard、Pro 或 Pro Extended 导出为 PDF 时出现问题,请尝试使用 Adobe PDF Printer 进行打印。(如果使用的是运行 Acrobat 9 的 Mac OS v10.6 或更高版本,请参阅 Acrobat 9 另存为 Adobe PDF 支持。)
  • 如果在使用“打印”功能创建 PDF 文件时出现问题,请改为选择“文件”>“导出为 PDF”

诊断文档级别的打印或导出问题

如果在打印或导出新文档时未出现错误,表明原始文档的打印或导出设置可能无效,该文档中使用的对象或字体可能已损坏,或者该文档的结构可能已损坏。请尝试下面的一个或多个步骤。

注意:

根据您使用的打印机,设置的位置可能有所不同,可能与以下过程中所示的内容不同。请查看打印机文档。   

1. 导出为 IDML(InDesign CS4 及更高版本)或 INX(InDesign CS3 及更低版本)。

文档可能已损坏。从以前版本的 InDesign 或 QuarkXPress 文档转换后,可能会出现损坏的文档。导出为 InDesign 标记语言 (IDML) 或 InDesign 交换 (INX) 格式可以消除有问题的数据。

2. (仅限 PostScript 打印机)启用 PostScript 错误处理功能。

Windows

  1. 选择“文件”>“打印”。
  2. 单击“设置”按钮。
  3. 如果显示以下对话框,请单击“”:“如果 InDesign 的‘打印’对话框中存在所需的打印设置,请原样保留以避免打印冲突”。
  4. 右键单击打印机,然后选择“属性”。
  5. 在“常规”选项卡中,单击“打印首选项”。
  6. 单击“高级”
  7. 展开“文档选项”,然后展开“PostScript 选项”。如果未将“发送 PostScript 错误处理程序”设置为“是”,请单击该选项,然后从弹出菜单中选择“”。

Mac OS X

  1. 选择“文件”>“打印”。
  2. 单击打印机。
  3. 从“预设”菜单下面的菜单中选择“错误处理”。
  4. 选择“打印详细报告”,然后单击“打印”。

如果问题是由 PostScript 错误造成的,PostScript 错误处理程序将打印一个包含错误信息的页面。请参阅诊断 PostScript 错误

3. 从文档中排除图形。

在打印文档时排除图形

  1. 选择“文件”>“打印”。
  2. 单击“图形”,然后从“发送数据”菜单中选择“”。
  3. 单击“打印”。

在导出文档时排除图形

  1. 选择“文件”>“导出”,然后选择“Adobe PDF(打印)”作为格式或“另存为类型”。
  2. 选择一个位置,然后单击“保存”。
  3. 单击“高级”,然后选中全部三个“对 OPI 省略”复选框:“EPS”、“PDF”和“位图”。
  4. 将 PDF 标准更改为“”以允许排除图像。
  5. 单击“导出”。

如果成功打印或导出文档,表明页面上的一个或多个图形元素可能已损坏。请删除页面或单个页面上的图形框架以删除 50% 的图形。然后,在每次更改后打印或导出文档,以确定是否是删除的组中损坏的图形造成的错误。如果在更改后可以打印或导出文档,请恢复更改,然后删除剩余页面或图形的另外 50%。确认是否再次出现该错误;如果出现,请再次删除 50%,依此类推。在找出导致错误反复出现的图形后,删除和替换这些图形。您可能需要从创建图形的应用程序中重新导出图形。

如果成功打印没有图形的作业,也可能表明打印机内存不足。症状包括字体被取代、缺少图形或打印输出不完整。尝试打印一定范围的页面,或简化出版物以查看在具有较少图形的情况下是否正确打印。或者尝试以较低的分辨率打印。

注意:

如果文档仅包含图形元素,只有在 InDesign 中启用了打印空白页面的选项,才会在打印时得到空白页面。在“打印”对话框的“常规”部分中,选择“打印空白页面”。

4. 排除或最大限度地减少字体。

在打印时排除字体

  1. 选择“文件”>“打印”。
  2. 单击“图形”。
  3. 在“字体”部分中,从“下载”菜单中选择“”。
  4. 单击“打印”。

在导出为 PDF 时最大限度地减少字体

在导出时无法排除字体,但是您可以最大限度地减少使用的字体数目。

  1. 选择“文字”>“查找字体”
  2. 在“文档中的字体”列表中,单击第一个字体,然后按住 Shift 键并单击最后一个字体以选择列表中的所有字体。
  3. 在“替换为:字体系列”列表中,选择您知道在其他文档中使用的字体,例如 Arial 或 Verdana。
  4. 单击“全部更改”。
  5. 单击“完成”
  6. 选择“文件”>“导出”,然后选择“Adobe PDF(打印)”作为格式。
  7. 选择一个位置,然后单击“保存”。
  8. 单击“导出”。

如果可以成功打印或导出文档,表明问题可能与文档中使用的某种字体有关。如果文档使用了大量字体,排除字体可以将文档变得较为简单。以新名称保存文档,然后一次测试一种字体,以确定它们是否已损坏。如果某种字体不断表现出问题,请检查该字体的多个活动实例或从制造商处重新下载该字体,以确保该字体未损坏。

5. 确保链接有效。

要查看链接的状态,请选择“窗口”>“链接”。取消链接或重新链接文件名前面带有问号或其他符号的任何文件。有关 InDesign 链接的更多信息,请参阅管理图形链接

6. 禁用设置。

有时,错误是由打印或导出过程中的特定功能在处理文档中的某些特定内容时造成的。应尽可能多地禁用这些类型的设置。如果
去除设置可以解决问题,请再次成组启用这些设置以找出导致问题的特定设置。

注意:

根据您使用的打印机,某些设置可能不可用。

选择“文件”>“打印”以打开“打印”对话框。然后在下面的窗格中更改以下设置:

“常规”窗格

  • 将份数设置为 1
  • 选择“页面”以禁用“跨页”。
  • 清除“打印母版页”、“打印非打印对象 和“打印可见参考线和基线网格”。
  • 将打印图层设置为“可见并可打印的图层”。

“设置”窗格

  • 将纸张大小设置为“由驱动程序定义”。
  • 将缩放宽度和缩放高度设置为 100%
  • 禁用“缩览图”和“平铺”。

“标记和出血”窗格

  • 禁用“标记”、“出血 和“辅助信息”。

“输出”窗格

  • 将颜色设置为“复合保持不变”。
  • 禁用“陷印”、“文本为黑色”和“模拟套印”。
  • 在“油墨管理器”中,禁用“油墨别名”。

“图形”窗格

  • 将“图像:发送数据”设置为“无”或“全部”
  • 将“字体:下载”设置为“无”或“全部”
  • 将 PostScript 设置为“级别 2”。
  • 将数据格式设置为 ASCII

“色彩管理”窗格

  • 将颜色处理设置为“让 PostScript 打印机确定颜色”。
  • 启用“保留 CMYK 颜色值”。

“页面”面板(在“打印”对话框外部)

选择所有页面,右键单击,然后选择“页面属性”>“跨页拼合”>“无(忽略透明度)”

7. 增效工具故障诊断。

从 InDesign Plug-ins 文件夹中删除第三方增效工具,然后重新启动 InDesign。如果再次出现该问题,请将增效工具移回到 InDesign Plug-ins 文件夹中。如果问题没有再次出现,请找出发生冲突的增效工具。

  1. 选择“帮助”>“配置增效工具”(Windows) 或“InDesign”>“配置增效工具”(Mac OS)。
  2. 选择“设置的所有增效工具”,然后清除“显示”部分中除“第三方”以外的所有选项。创建这些增效工具的列表。
  3. 退出 InDesign,然后将这些增效工具移到 Plug-in 文件夹外部:
    • Windows:/Program Files/Adobe/Adobe InDesign [版本]/Plug-Ins
    • Mac OS:/Applications/Adobe InDesign [版本]/Plug-Ins
  4. 重新启动 InDesign 并尝试再现问题。
    • 如果问题没有再次出现,请重复执行步骤 3 和 4,将某些第三方增效工具添加回 Plug-Ins 文件夹。
    • 如果再次出现问题,请与上次移动的增效工具的开发商联系以了解更新情况。

有关更多信息,请参阅 InDesign 第三方增效工具故障诊断

8. 从新用户帐户中打印或导出。

有时,用户帐户可能已损坏,而禁止应用程序读取或写入某些文件和文件夹。请创建一个新用户帐户(不要删除原始用户帐户),登录新帐户,并重新尝试打印或导出文档。

Windows

选择“开始”>“控制面板”>“用户帐户”

Mac OS X

选择苹果菜单 >“系统偏好设置”>“用户与群组”

9. 确定文档是否已损坏。

诊断应用程序级别的打印或导出问题

如果您在打印任何 InDesign 文档时收到一条错误,请尝试以下一项或多项任务,以找出应用程序级别问题的原因。

1. 重新创建 InDesign 首选项文件。

当 InDesign 行为异常时,删除首选项(也称为“废弃首选项”或“移除首选项”)并重新创建它们通常可以解决问题。

重新创建首选项的方式有两种:

  • 自动:这种方法可以快速删除当前的首选项文件,然后重新生成一组新的默认首选项文件。但是,您可能具有的任何自定义设置都会丢失。

-或-

  • 手动:如果您不希望丢失自定义设置,请在重新生成一组新的默认首选项文件之前重命名当前的首选项文件。这样一来,如果新的首选项无法解决打印或导出问题,您具有原始首选项文件的备份(包括所有自定义设置),您可以用其替换新的首选项文件。

自动重新创建 InDesign 首选项文件

注意:

重新创建 InDesign 首选项文件会删除之前的首选项数据,包括所有自定义设置。如果您不希望丢失自定义设置,请手动重新创建首选项文件

  1. 退出 InDesign。
  2. 重新启动 InDesign 并立即按住适合 OS 的键:
    • Mac OS :Control + Option + Command + Shift
    • Windows:Control + Alt + Shift
  3. 此时将显示一个对话框,询问您是否要删除 InDesign 首选项文件。单击“”。将使用重新生成的默认首选项启动 InDesign。

手动重新创建 InDesign 首选项文件

重命名两个首选项文件(例如,将“InDesign SavedData”更改为“InDesign SavedData backup”,将“InDesign Defaults”更改为“InDesign Defaults backup”)。首选项文件位于以下位置:

  • Mac OS X

    InDesign Defaults:

    Users/[用户]/Library/Preferences/Adobe InDesign/Version [版本]/[语言]/InDesign Defaults

InDesign SavedData:

Users/[用户]/Library/Caches/Adobe InDesign/Version [版本]/[语言]/InDesign SavedData

  • Windows XP

    InDesign Defaults:

    /Documents and Settings/[用户]/Application Data/Adobe/InDesign/Version [版本]/InDesign Defaults

默认情况下处于隐藏状态。了解如何显示隐藏文件。

InDesign SavedData:

/Documents and Settings/[用户]/Local Settings/Application Data/Adobe/InDesign/Version[版本]/Caches/InDesign SavedData

  • Windows 7 和 8

InDesign Defaults:

C:\Users\DC-work\AppData\Roaming\Adobe\InDesign\Version 11.0\[语言]\InDesign Defaults

默认情况下处于隐藏状态。了解如何显示隐藏文件。

InDesign SavedData:

/Users/[用户]/AppData/Local/Adobe/InDesign/Version[版本]/[语言]/Caches/InDesign SavedData

重新启动 InDesign。InDesign 将创建一组新的默认首选项文件。

如果打印或导出问题仍然存在,则您可以通过将旧首选项文件重命名回原始名称(即 InDesign SavedData 和 InDesign Defaults)来恢复原始首选项。

2. (仅限 Windows)确保打印机驱动程序最新。

为打印机安装最新的驱动程序:

3. (仅限 Windows 上的 PostScript 打印机)针对速度优化 PostScript。

  1. 选择“文件”>“打印”。
  2. 单击“设置”,选择打印机,单击“首选项”,然后单击“高级”。
  3. 展开“文档选项”,然后展开“PostScript 选项”。
  4. 选择“PostScript 输出选项”。
  5. 从弹出菜单中选择“为速度优化”,然后单击“确定”。
  6. 单击“确定”,然后单击“打印”。

4. 在打印机中禁用页面保护功能。

有关如何禁用该功能的说明,请参阅打印机附带的文档。

5. 将计算机连接到打印机。

如果在通过网络打印时出现问题,请将计算机直接连接到打印机,然后重新尝试打印。

如果无法直接连接到打印机,请将文档另存为 PostScript 文件。在可以直接连接到打印机的计算机上使用命令提示符将文件发送到打印机。 

6. 作为 PDF 保存到本地硬盘驱动器。

如果作为 PDF 导出到网络位置时出现问题,请尝试作为 PDF 保存到本地硬盘驱动器。

在导出到安装的网络卷时,网络不稳定或权限问题可能会导致出现问题。如果您可以将文件导出到本地驱动器,但是无法导出到网络位置,请让 IT 部门调查问题。

诊断打印机级别的打印问题

解决使用 PostScript 打印机进行打印的问题

如果您在使用 PostScript 打印机进行打印时遇到问题,请尝试以下一项或多项任务。在执行每项任务后进行打印。

1. 使用更新的打印机驱动程序。

下载适用于 MacWindows 的最新打印机驱动程序。

注意:

如果您使用的是网络打印机,您使用的打印机驱动程序可能与打印服务器的操作系统兼容,但是与您的计算机的操作系统不兼容。要安装与操作系统兼容的打印机驱动程序,请使用“添加打印机”向导重新配置网络打印机。请参阅安装与操作系统兼容的打印机驱动程序

2. 使用更新的 PPD 文件。

PostScript 打印机描述 (PPD) 文件描述了 PostScript 打印机的设置功能,例如,边距、颜色和分辨率。不正确或过时的 PPD 文件可能会增加打印时间。请使用打印机制造商建议的 PPD 文件配置打印机。

要获取 PPD 文件,请与打印机制造商联系或从 Adobe 网站下载。

3. (仅限 Windows)将打印机设置为输出优化的 PostScript 代码。

对于 Windows 7:

  1. 选择“开始”>“设备和打印机”
  2. 右键单击并选择“打印首选项”>“高级”
  3. 展开文档选项,然后展开 PostScript 选项。
  4. 将 PostScript 输出选项设置为“为可移植性优化”。

4. 创建更多可用磁盘空间。

确保具有足够的可用硬盘空间。设法至少使 10% 的总硬盘空间可用。要创建更多空间,请搜索并删除计算机上的临时 (.tmp) 文件,并清除 Web 浏览器使用的磁盘缓存。有关清除磁盘缓存的说明,请参阅浏览器文档。

要了解释放磁盘空间的其他方式,请参阅适用于您的 OS 的文档(例如,适用于 Windows 的在 PC 上释放驱动器空间的提示或适用于 Mac OS 的增加磁盘空间)。

5. 使用本地打印机进行打印。

如果使用网络打印机进行打印,请尝试从直接连接到本地打印机的计算机中打印文件。如果正确打印文件,则问题可能是由网络相关问题造成的。请与网络管理员联系以获得帮助。

6.(仅限 Windows)安装与操作系统兼容的打印机驱动程序。

如果使用的是网络打印机,请安装与操作系统兼容的打印机驱动程序。打印服务器并不始终为客户端计算机上运行的操作系统提供驱动程序。因此,您使用的打印机驱动程序可能适用于打印服务器的操作系统,但不适用于计算机的操作系统。

对于 Windows 7:

  1. 选择“开始”>“设备和打印机”
  2. 单击“添加打印机”。
  3. 选择“添加本地打印机”。
  4. 选择“创建新端口”>“本地端口”>“下一步”
  5. 输入端口名称(例如,\\[打印服务器名称]\[打印机名称])并单击“确定”。
  6. 按照屏幕上的说明,安装与网络打印机品牌和型号匹配的驱动程序。

解决使用非 PostScript 打印机进行打印的问题

如果您在使用非 PostScript 打印机进行打印时遇到问题,请尝试以下一项或多项任务。在执行每项任务后进行打印。

注意:

某些解决方案要求您更改打印机驱动程序属性。特定属性的位置因打印机和打印机驱动程序而异。有关详细信息,请与打印机制造商联系或参阅打印机文档。

1. 作为位图打印。

  1. 选择文件 > 打印
  2. 确保已选择非 PostScript 打印机,然后选择“高级”窗格。
  3. 选中“作为位图打印”复选框,并为打印机选择适当的分辨率。

2. 确保打印机具有足够的内存。

要以 300 dpi 进行打印,打印机应至少具有 2 MB 的可用 RAM。要以 600 dpi 进行打印,打印机应至少具有 4–6 MB 的 RAM。有关确定可用打印机内存的说明,请参阅打印机文档。

3. 使用打印机的 PostScript 模式(如果有)。

有关详细信息,请参阅打印机文档。

4. (仅限 Windows)切换到标准 SVGA 驱动程序。

切换到标准 Windows SVGA 驱动程序,以确定问题是不是由第三方视频驱动程序造成的。如果在使用标准 SVGA 驱动程序时未出现错误,请与视频卡制造商联系以获取更新的驱动程序。如果已使用最新的版本,请尝试使用不同的视频分辨率(如 1024 x 768,而不是更高的分辨率)。

诊断系统级别的打印或导出问题

如果无法从任何应用程序中将任何内容打印或导出为 PDF,请与 Apple 技术支持、Microsoft 技术支持或打印机制造商联系。在致电之前,请务必检查打印机和计算机之间的物理连接,因为有可能通过重新连接松动的电缆轻松解决问题。

还要考虑最近对系统进行了哪些更改,这些更改可能会影响打印或导出过程。例如,最近是否执行了以下任何任务?

  • 更新了硬件或者添加或删除了硬件组件
  • 添加、更新或删除了软件
  • 安装或删除了字体
  • 连接到了网络
  • 从硬盘驱动器中清除或擦除了文件
  • 遇到了随机系统错误或其他应用程序中的错误

通常,对系统的更改直接与出现的打印问题相对应。保留对系统所做的更改记录,以作为解决打印和其他问题的资源。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略