- InDesign 用户指南
- 了解 InDesign
- InDesign 简介
- 工作区
- 生成式 AI(在中国大陆不可用)
- InDesign 简介
- 创建文档和设置文档布局
- 添加内容
- 文本
- 排版规则
- 设置文本格式
- 审阅文本
- 拼写检查和语言词典
- 添加引用
- 样式
- 表
- 交互性
- 图形
- 颜色和透明度
- 查找和替换
- 共享
- 导入、导出和发布
- 扩展 InDesign
- 自动化
- 故障排除
打开或保存 InDesign 文件时遇到问题?继续阅读了解可能的原因和解决方案。
系统级别的问题可能会导致错误和其他意外行为。在假设文档已损坏之前,请执行以下步骤:
-
确保您的系统满足运行最新版本 InDesign 的最低系统要求。
-
InDesign 系统消息提供了一份会导致问题出现的情景列表,可帮助您确定发现崩溃的原因。下面是一些情景及其对应解决方案:
遇到其他问题?需要更多帮助?
当系统没有足够内存 (RAM) 读取文件时,InDesign 无法打开文件。内存不足的原因之一可能是计算机上打开的应用程序过多。
解决方案
- 清理磁盘以减少驱动器上不必要的文件数量,并确保 Windows 临时文件夹为空。
- 退出一些应用程序以释放系统内存。
- 如果可能,扩展系统的 RAM。
如果文件遇到以下任何访问相关问题,InDesign 无法打开文件并显示错误消息:
问题 |
分辨率 |
无权打开此文件,或者所需的访问权限不可用。 |
从文件所有者获取访问权限,然后尝试重新登录。 提示:如果可能,在处理共享文件之前,创建一份本地副本。 |
该文件已被其他用户打开或锁定(正在使用)。 |
从其他应用程序或用户配置文件中关闭文件。 |
该文件受密码保护,或者该文件的登录名或密码无效。 |
确保提供正确的登录凭据。 |
文件位于网络上,无法访问网络位置。 |
检查网络连接,然后尝试再次访问该文件。 |
InDesign 无法打开或保存已在其他版本的 InDesign 中打开的文件。
解决方案
- 关闭在其他 InDesign 版本中打开的文件。
- 如果无法关闭文件,请强制关闭所有版本的 InDesign 或重新启动计算机。
- 如果您在保存文件时遇到此问题,请尝试更改文件名和位置。
如果读取或写入过程中断,或者无法访问或找到文件,InDesign 将无法打开或保存文件。
以下是一些可能导致文件读取或写入过程中断的情况:
文件位置 |
原因 |
分辨率 |
---|---|---|
可移动设备(U 盘、外部驱动器、笔式驱动器等) |
设备未从计算机安全移除或弹出 |
确保每次执行读取或写入操作后都安全移除设备。 |
网络位置 |
网络连接丢失 |
确保网络连接可用。 |
共享位置 |
共享的文件不再可用 |
确保共享位置可访问。 |
当发现文件已损坏或尝试自动恢复文件时,InDesign 会显示一条错误消息。根据您的场景选择一个选项卡,然后按照疑难解答步骤尝试恢复文档内容。
快速排查外部因素
- 如果文档是从 Adobe PageMaker、QuarkXPress 或以前版本的 InDesign 转换的,请尝试重新转换文档。如果问题再次出现,请对原始文档进行故障排除,确定其源应用程序是否有损坏,然后再重新转换。损坏的 PageMaker 或 QuarkXPress 文档很可能在转换后仍然损坏。
- 如果您是通过电子邮件、FTP 或可移动媒体(例如 CD)接收的文档,请以其他方式获取副本。或者,重新发送文档。媒体损坏或电子邮件传输错误可能会损坏文档。如果文件是通过电子邮件发送的,请让发件人先压缩文件(如使用 WinZip 或 Smith Micro 的 StuffIt),以保护数据。
- 请考虑从 InDesign 卸载第三方插件。插件有时可能导致文件损坏。请参阅 InDesign 第三方增效工具问题疑难解答。
- 使用另一台计算机打开文档,即改变系统环境。通过这样的方式,可以消除导致问题发生的变量。
- InDesign 首选项文件(InDesign SavedData 和 InDesign Defaults 文件)存储插件、功能及应用程序自身相关信息。损坏的 InDesign 首选项文件可能会导致 InDesign 文档出现意外行为。您可以通过恢复或重新创建首选项文件来轻松确定问题是否与这些文件相关。有关更多信息,请参阅恢复所有首选项。
- 增加启动磁盘上的可用空间量。InDesign 会使用临时文件来存储和检索数据,并会将这些临时文件写入启动磁盘。从原则上讲,启动磁盘上的可用空间应为文档大小(包括链接的图像)的三到五倍或者磁盘容量的百分之十,以较大者为准。您可以通过删除不必要的文件或者将文件存储在不同的分区或磁盘上,来释放启动磁盘上的空间。要查看启动磁盘上的可用空间量,请执行以下操作:
- 选择桌面上的启动磁盘图标。
- 选择文件 > 获取信息 > 常规信息。
- 请注意磁盘的“容量”和“可用空间”。
解决方案:打开文档的副本,而不是原始文档。
当您以副本形式打开文档时,InDesign 将从原始文件中读取内容并打开一个无标题的副本。如果可以打开文档副本,请选择文件 > 存储为,以与原始文档不同的文件名存储副本,然后使用文档副本,而不使用原始文档。
请按照以下步骤将文档作为副本打开:
问题
从 InDesign 19.2 创建或保存的几个 InDesign 文档无法在 InDesign 19.1 中打开
解决方案 1:在 InDesign 19.2 及更高版本中打开文档,并将其导出为 IDML,以便在旧版本的 InDesign 19.1 及更低版本中使用。
解决方案 2:在 ID 19.3 中打开并保存文档,以便使用所有版本无缝工作。
在开始故障排除之前,请创建损坏文档的备份副本。以下某些任务要求您更改或删除文档的信息。
使用文档的备份副本能够快速恢复信息。如果文档位于网络卷或可移动媒体(如 CD 或跳转驱动器)上,请将备份移至本地驱动器。
请按顺序完成以下任务。
在 macOS 上使用快捷键 Cmd Opt-/,在 Windows 上使用快捷键 Ctrl Alt-/ 强制重排所有文章。
将页面元素复制到新文档会造成结构(内部)损坏。如果将页面元素复制到新文档后问题再次出现,请逐个删除元素,查看是否其中一个元素出现问题。
按照以下步骤将页面元素复制到新文档中:
您在 InDesign 中创建或随在其他应用程序中创建的文件导入的样式可能已损坏。此外,还可能存在一些空白页面和不需要的元素。要查明是否果真如此,请删除存在问题的样式和页面,然后重新存储文档。
按照以下步骤删除“字符样式”:
按照以下步骤删除段落样式:
按照以下步骤删除页面:
如果删除一些页面后问题再次出现,请删除剩余的一半页面,并以新名称保存文档。然后尝试再现问题。
- 如果问题再次出现,说明剩余页面之一可能含有损坏的元素。继续删除页面,直至找到导致出现问题的页面。
- 如果问题再次出现,说明删除页面之一可能含有损坏的元素。替换删除的页面,直至找到导致出现问题的页面。
确定导致出现问题的页面后,移除并替换页面中的元素,包括导入的图形、InDesign 绘制的对象及页面上的文本框架。
要确定问题是否与损坏的字体有关,请使用标准字体(例如 Arial 或 Times New Roman)替换文档中使用的所有字体。如果在您更改字体后问题再次出现,表明与字体无关。如果问题没有再次出现,说明原始字体可能损坏或过期。尝试重新安装原始字体或从字体制造商处获取更新版本。
如果所有其他方法都失败,请重新创建文档。经常备份文档,并定期测试文档,以确保导入的元素不会导致问题。
除上述情况外,InDesign 在以下情况下也无法打开文件和恢复文件:
- 意外或未知错误
- 文件损坏,无法修复
- 尝试打开的文件扩展名不受 InDesign 支持
解决方案
我们建议您发送文件,并协助我们调查该问题。
我们愿意随时为您提供帮助!
如果所有解决方案均不起作用,请将受影响的文件作为附件发送电子邮件至 idfile@adobe.com。我们将会调查发生的问题并告知您是否可以恢复文件。
您与我们共享文件,不仅可以支持 Adobe 团队找到您问题的解决方案,还可以通过确定并解决其他类似问题来帮助我们改善整体用户体验。
我们保证将对您的文件严格保密,并且仅用于调查目的。 确保共享的文件不包含任何敏感个人信息。
我们会尽力为您提供帮助,但由于文件恢复取决于各种因素,因此,我们不能承诺提供的解决方案永久有效。
相关资源
告知我们
我们非常乐意听到您的反馈。与 Adobe InDesign 社区分享您的想法。