了解如何诊断损坏的 InDesign 文件问题。

只要您在某个 InDesign 文档中工作时发生错误或其他意外行为,该文档就可能会损坏。InDesign 具有一项自动文档恢复功能,可以防止系统崩溃或断电造成的损坏。但是,它无法防止其他系统级问题(例如软件冲突、低磁盘空间或病毒)造成的损坏。本故障诊断指南可以帮助您找出并解决 InDesign 文档中损坏的问题。还可以帮助您找出并解决似乎是文档损坏但却与其他原因相关的系统级问题。

检查系统级问题

系统级问题会导致错误和其他意外行为。在假定文档损坏之前,要确保系统相对来说没有问题。例如,在执行下面的文档损坏故障诊断任务之前,考虑运行磁盘修复实用程序,然后重新打开文档以查看是否已修复。

Windows:请参阅检查硬盘是否存在错误

Mac OS:请参阅解决启动问题并执行磁盘维护

文档损坏故障诊断

请按顺序完成以下任务。当弄清问题时停止。 

注意:

在完成每项故障诊断任务后,重新启动 InDesign 并打开文档,以查看问题是否已修复。请按以下方式打开文档:

选择“文件”>“打开”,选择文档,然后选择“复制”。以新名称重新保存文档,查看是否已修复。

1. 备份文档。

在开始故障诊断之前,为损坏的文档创建备份副本。以下某些任务要求您更改或删除文档中的信息。有了文档的备份副本,您可以轻松地恢复信息。如果文档在网络卷或可移动介质(例如 CD 或闪存盘)上,请将备份移至本地驱动器。

2. 安装最新的 InDesign 更新。

  • 在 InDesign 中,选择帮助 > 更新

-或-

-或-

3. 重新创建首选项文件。

InDesign 将有关增效工具、功能以及应用程序本身的信息存储在首选项文件(即 InDesign SavedData 和 InDesign Defaults 文件)中。损坏的 InDesign 首选项文件会导致 InDesign 文档出现意外行为。您可以通过重新创建首选项文件来轻松确定问题是否与其相关。

注意:

重新创建 InDesign 首选项文件将恢复设置的默认值,因此,与旧首选项文件关联的自定义设置将会丢失。要保留这些自定义设置,请重命名旧首选项文件

要重新创建 InDesign 首选项文件,请执行以下操作:

  1. 退出 InDesign。

  2. 重新启动 InDesign 并按住适合 OS 的键:

    • Mac OS X:Control + Option + Command + Shift
    • Windows:Control + Alt + Shift
  3. 当系统提示删除 InDesign 首选项文件时,单击“”。将使用默认设置和重新生成的首选项文件启动 InDesign。

    注意:

    如果系统未提示删除首选项文件,您可以手动删除首选项

  4. 打开文档,查看是否已修复。如果问题仍然存在,请转至下方的任务 4

    手动删除或重命名首选项文件

    或者(或另外),您也可以:

    • 手动删除首选项文件(例如,如果在前面的过程中启动 InDesign 时系统未自动提示删除首选项)

    -或-

    • 手动重命名首选项文件(例如,如果您不希望丢失与旧首选项文件关联的自定义设置)

    请在下表中查找您的 OS,以查看这些文件所在的位置。

    操作系统 首选项文件的位置
    Mac OS X

    InDesign Defaults

    Users/[用户]/Library/Preferences/Adobe InDesign/Version [版本]/[语言]/InDesign Defaults

    InDesign SavedData

    Users/[用户]/资源库/Caches/Adobe InDesign/Version [版本]/InDesign SavedData

    Windows XP

    InDesign Defaults

    C:\Documents and Settings\[用户]\Application Data\Adobe\InDesign\Version [版本]\InDesign Defaults

    默认情况下处于隐藏状态。了解如何显示隐藏文件

    InDesign SavedData

    C:\Documents and Settings\[用户]\Local Settings\Application Data\Adobe\InDesign\Version[版本]\Caches\InDesign SavedData

    Windows 7/8

    InDesign Defaults

    C:\Users\[用户]\AppData\Adobe\InDesign\Version[版本]\[语言]\InDesign Defaults

    默认情况下处于隐藏状态。了解如何显示隐藏文件

    InDesign SavedData

    C:\Users\[用户]\AppData\Local\Adobe\InDesign\Version[版本]\[语言]\Caches\InDesign SavedData

    完成删除或重命名后,重新启动 InDesign 以重新创建首选项文件,然后打开文档以查看是否已修复。

    如果问题仍然存在,通过删除新文件并将旧首选项文件重命名回原始名称来恢复原始首选项。

4. 以 IDML(InDesign CS4 及更高版本)或 INX(InDesign CS3 及更低版本)格式保存文档。

  1. 在 InDesign 中打开文件。

  2. 选择“文件”>“导出”

  3. 从“另存为类型”菜单中,选择“InDesign Markup”(CS4 及更高版本)或“InDesign Interchange”(CS3 及更低版本)。

  4. 为文件指定名称和位置,然后单击“保存”。

  5. 在 InDesign 中,打开导出的 IDML 或 INX 文件。

    如果问题不复存在,继续使用 IDML 或 INX 文件替代原始文档。如果问题仍然存在,请转至其他步骤。

5. 在源应用程序中诊断转换的文档。

如果文档是从 Adobe PageMaker、QuarkXPress 或以前版本的 InDesign 转换而来,请尝试重新转换文档。如果问题再次出现,请在重新转换之前在源应用程序中诊断原始文档是否损坏。损坏的 PageMaker 或 QuarkXPress 文档很有可能在转换后仍然是损坏的。

有关诊断损坏的 PageMaker 出版物的信息,请参阅诊断损坏的出版物。有关诊断损坏的 QuarkXPress 文档的信息,请访问 Quark 网站

6. 删除字符和段落样式。

您在 InDesign 中创建或随在其他应用程序中创建的文件导入的样式可能已损坏。要查明是否果真如此,请删除样式,然后重新保存文档。

要删除字符样式,请执行以下操作:

  1. 在 InDesign 中,打开文档并选择“文字”>“字符样式”

  2. 在“字符样式”面板中,选择除“[无字符样式]”之外的所有样式。要选择多种样式,请在选择样式的同时按 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

  3. 从“字符样式”菜单中,选择“删除样式”。

  4. 保存文档,查看是否已修复。如果问题仍然存在,请尝试删除段落样式。

要删除段落样式,请执行以下操作:

  1. 在 InDesign 中,打开文档并选择“文字”>“段落样式”

  2. 在“段落样式”面板中,选择除“[无段落样式]”之外的所有样式。要选择多种样式,请在选择样式的同时按 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

  3. 从“段落样式”菜单中,选择“删除样式”。

  4. 保存文档,查看是否已修复。如果问题仍然存在,请转至下方的任务 7。

7. 检查字体是否损坏。

要确定问题是否与损坏的字体有关,请以标准字体(例如 Arial 或 Times New Roman)替换文档中使用的所有字体

如果在您更改字体后问题再次出现,表明与字体无关。如果问题没有再次出现,表明原来的一种或多种字体可能已损坏或已过时。请尝试重新安装原来的字体或从字体制造商处获取更新的版本。

8. 检查对象和图形是否损坏。

尝试确定是否是母版页面或文档页面上的特定元素导致了问题。要找出元素,首先删除空页面和不必要的元素,例如粘贴板或隐藏层上的元素。

要删除页面,请执行以下操作:

  1. 在 InDesign 中,打开文档并选择“窗口”>“页面”

  2. 在“页面”面板中,使用“选择”工具选择要删除的页面。按 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 可选择多个页面,按 Shift 键可选择连续的页面范围。

    删除页面
    在"页面"面板中选择要删除的页面。

  3. 在“页面”面板中,单击“删除”图标。

  4. 单击“确定”以确认删除。

如果在您删除某些页面后问题再次出现,请删除剩余页面的一半,并以新名称保存文档。然后,尝试重现问题。

  • 如果问题再次出现,表明剩余页面之一可能包含损坏的元素。继续删除页面,直至找到导致问题的页面。
  • 如果问题没有再次出现,表明删除的页面之一可能包含损坏的元素。替换删除的页面,直至找到导致问题的页面。

确定导致问题的页面后,删除并替换上面的元素,包括页面上导入的图形、InDesign 绘制的对象以及文本框架。

9. 将页面元素复制到新文档中。

将页面元素复制到新文档中会留下结构(内部)损坏。如果在您将页面元素复制到新文档中后问题再次出现,请逐个删除元素,以查看是否其中一个元素是问题所在。

要将页面元素复制到新文档中,请执行以下操作:

  1. 在 InDesign 中,打开原始文档。

  2. 选择“文件”>“新建”,然后在“新建文档”对话框中单击“确定”。

  3. 选择“窗口”>“平铺”以显示两个文档。

  4. 单击原始文档以将其激活。

  5. 选择“窗口”>“页面”以激活“页面”面板。

  6. 将页面或跨页拖动到新文档窗口中。InDesign 会将页面或跨页复制到新文档中,根据需要添加页面。

  7. 以新名称 (不同于原始文档的名称)保存新文档,并尝试重现问题。

    • 如果问题再次出现,表明不是结构损坏(例如,母版页面或文档页面上的损坏)。请逐个删除元素,以查看是否其中一个元素导致了问题。
    • 如果问题没有再次出现,表明或许是结构损坏。对剩余的每个页面或跨页重复执行步骤 4 到 7。

10. 再获取一份文档。

如果您是通过电子邮件、FTP 或可移动介质(例如 CD)收到的文档,请以不同的方式再获取一份。或者,让发件人重新发送文档。损坏的介质或错误电子邮件传输会损坏文档。如果是通过电子邮件发送的文档,让发件人首先压缩文档(例如,使用 WinZip 或 Smith Micro 的 StuffIt)以保护数据。

其他建议

仍然有问题?请尝试以下方法。

删除第三方插件.

考虑从 InDesign 中卸载第三方增效工具。增效工具有时会导致文件损坏。请参阅 InDesign 第三方增效工具故障诊断

使用不同的计算机打开文档。

通过改为不同的系统环境,您可以去除导致问题的可变因素。

访问 Adobe 用户间论坛。

有问题的不止您一人!其他用户可能在文档中遇到过类似的问题并发布了解决方案。请访问 InDesign 论坛

重新创建文档。

如果其他全部都不奏效,请重新创建文档。经常创建备份副本并定期测试文档以确保导入的元素并未导致问题。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略