重复使用图形和文本的方法

InDesign 提供了多种不同的方法来帮助重新利用图形和文本。

片段

片段是一个文件,它包含对象,并描述对象在页面或跨页中的彼此相对位置。(请参阅使用片段。)

对象库

对象库为徽标、旁注、引文、其他重复项等项目提供了一个方便的存储位置。(请参阅使用对象库。)

模板

模板是包括假字和图形的文档。(请参阅使用文档模板。)

使用片段

片段是一个文件,它用于存放对象并描述对象在页面或页面跨页中彼此之间的相对位置。使用片段可以方便地再次使用页面对象和确定页面对象的位置。通过将对象存储在片段文件中可以创建一个片段,其扩展名为 .IDMS。(早期 InDesign 版本使用 .INDS 扩展名。)将片段文件置入 InDesign 中时,可以决定是将对象按其原始位置放置,还是将对象放在单击鼠标的位置。可以将片段存储在“对象库”和 Adobe Bridge 中,也可以存储在硬盘中。

置入时,片段内容将保留其图层关联。如果片段包含资源定义,且这些定义也存在于片段被复制到的文档中,则片段将使用该文档中的资源定义。

InDesign CS5 中创建的片段可以在 InDesign CS4 中打开,但无法在其他早期的 InDesign 版本中打开。

创建片段

  1. 执行以下操作之一:
    • 使用选择工具选择一个或多个对象,然后选择“文件”>“导出”。从“保存类型”(Windows) 或“存储格式”(Mac OS) 菜单中,选择“InDesign 片段”。输入文件名称,然后单击“存储”。

    • 使用选择工具选择一个或多个对象,然后将所选项目拖到桌面。这样便会创建一个片段文件。重命名该文件。

    • 选中一个或多个对象,然后将所选对象拖入 Mini Bridge 面板中。这样便会创建一个片段文件。重命名该文件。

    • 将“结构”视图中的项目拖到桌面。

将片段添加到文档中

  1. 选择“文件”>“置入”。
  2. 选择一个或多个片段(*.IDMS 或 *.INDS)文件。
  3. 在希望放置片段文件左上角的位置单击载入的片段光标。

    如果将插入点置于文本框中,片段将作为定位对象置于文本中。

    置入片段之后,所有对象将保持选中状态。通过拖动,可以调整所有对象的位置。

  4. 如果载入了多个片段,则通过滚动并单击载入的片段光标可以置入其他片段。

注意:

可以将片段文件从桌面拖动到 InDesign 文档中,然后单击想要作为片段左上角的位置。

选择如何置入片段

可以将片段对象按其原始位置置入,而不是根据页面上的单击位置置入片段对象。例如,某个文本框架在作为片段的一部分导出时显示在页面的中间,在将该文本框架作为片段置入后,它仍会出现在同样的位置上。

  1. 在“文件处理”首选项中,选择“位置”菜单的“原始位置”可以保留对象在片段中的原始位置。选择“位置”菜单中的“光标位置”,则可以根据您单击的位置来置入片段。

注意:

可以按住 Alt 键 (Windows) 或 Option 键 (Mac) 以覆盖处理片段时选择的“位置”设置。例如,如果选择了“放置在光标位置”,但又希望按各自原始位置置入片段对象,请当在页面上单击载入的片段光标时,按住 Alt/Option 键。

使用对象库

对象库有助于组织最常用的图形、文本和页面。也可以向库中添加标尺参考线、网格、绘制的形状和编组图像。可以根据需要创建任意多个库 - 例如,可以针对不同的项目或客户,创建不同的对象库。

在工作会话期间,可以打开多个库(数量取决于系统内存)。可以跨越多个服务器和平台共享对象库,但同一个库一次只能由一个人打开。如果对象库包含文本文件,请确保对所有要访问该库的系统而言,文件的字体都可用并处于活动状态。

在对象库中添加页面元素(如图形)时,InDesign 将保留所有导入或应用的属性。例如,如果将 InDesign 文档中的图形添加到某个库中,该库中的副本会原样复制原始文档(包括原始文档的链接信息),这样,当磁盘上的对应文件发生变化时就会更新此图形。

如果从 InDesign 文档中删除对象,此对象的缩略图将仍然显示在“库”面板中,所有链接信息也保持不变。如果移动或删除原始对象,则下次从“库”面板中将它置入文档中时,在“链接”面板中,该对象的名称旁边会显示一个缺失链接图标。

在每个对象库中,可以根据标题、项目添加到库中的日期或关键字,来识别和搜索项目。还可以通过对库项目排序并显示它们的子集,来简化对象库的视图。例如,可以隐藏除 EPS 文件以外的所有项目。

库面板中的对象库
库面板中的对象库

A. 对象缩略图和名称 B. “库项目信息”按钮 C. “显示库子集”按钮 D. “新建库项目”按钮 E. “删除库项目”按钮 

向对象库中添加项目时,InDesign 会存储所有页面、文本和图像属性,并采用如下方式维护库对象与其他页面元素之间的相互关系,

  • 对于拖入“库”面板时在 InDesign 文档中处于编组状态的元素,在拖出“库”面板时仍保持编组状态。

  • 文本将保留自己的格式。

  • 对段落样式、字符样式和对象样式而言,与目标文档所用样式同名者将转换为目标文档的样式;不同名者将添加文档中。

  • 在“图层”面板菜单中选中“粘贴时记住图层”选项后,会保留对象的原始图层。

创建对象库

对象库在磁盘上是以命名文件的形式存在。创建对象库时,请指定其存储位置。库在打开后将显示为面板形式,可以与任何其他面板编组;对象库的文件名显示在它的面板选项卡中。关闭操作会将对象库从当前会话中删除,但并不删除它的文件。

可以在对象库中添加(或删除)对象、选定页面元素或整页元素。可以将库对象从一个库添加或移动到另一个库。

  1. 选择“文件”>“新建”>“库”。
  2. 在“CC 库”对话框中,您可以选择继续使用 InDesign 的对象库,或者也可以使用 CC 库来组织、浏览并访问您的所有创意资源。有关更多详细信息,请参阅 Creative Cloud Libraries - 协作、同步和共享资源

  3. 为库指定位置和名称,然后单击“保存”。要记住,所指定名称将成为该库的面板选项卡的名称。

打开现有库

  1. 执行以下操作之一:
    • 如果已经在当前会话中打开了一个库(且尚未关闭),请在“窗口”菜单中选择该库文件。

    • 如果尚未打开库,请选择“文件”>“打开”,然后选择一个或多个库。在 Windows 中,库文件使用 INDL 扩展名。InDesign 将把那些来自早期版本程序的新打开的库转换为新的库格式,系统会要求您用新的名称存储这些库。

关闭库

  1. 单击要关闭的库的选项卡。
  2. 执行以下操作之一:
    • 在“对象库”面板菜单中选择“关闭库”。

    • 在“窗口”菜单中选择库文件名。

删除库

  1. 在资源管理器 (Windows) 或 Finder (MacOS) 中,将库文件拖到“回收站”(Windows) 或“废纸篓”(Mac OS) 中。在 Windows 中,库文件具有 INDL 扩展名。

将对象或页面添加到库中

  1. 执行以下操作之一:
    • 将文档窗口中的一个或多个对象拖到活动的“对象库”面板中。

    • 在文档窗口中选择一个或多个对象,然后单击“对象库”面板中的“新建库项目”按钮。

    • 在文档窗口中选择一个或多个对象,然后在“对象库”面板菜单中选择“添加项目”。

    • 在“对象库”面板菜单中选择“将第 [number] 页上的项目作为单独对象添加”,以便将所有对象作为单独的库对象添加。

    • 在“对象库”面板菜单中选择“添加第 [number] 页上的项目”,以便将所有对象作为一个库对象添加。

    • 将元素从“结构”窗格中拖到活动的“对象库”面板中。

注意:

如果在执行以上任何命令时按住 Alt 键 (Windows) 或 Option 键 (Mac OS),则在库中添加项目后将显示“项目信息”对话框。

将库中的对象添加到文档中

  1. 执行以下操作之一:
    • 将“对象库”面板中的对象拖到文档窗口中。

    • 在“对象库”面板中,选择一个对象,然后在“对象库”面板菜单中选择“置入项目”。此方法将把对象按其原始的 X、Y 坐标置入。

    • 将 XML 元素拖到“结构”窗格中的某个父元素中或拖到页面中。

管理库对象

使用“对象库”面板管理对象。

使用新项目更新库对象

  1. 在文档窗口中,选择要添加到“库”面板中的项目。
  2. 在“库”面板中,选择要替换的对象,然后从“对象库”面板菜单中选择“更新库项目”。

将对象从一个库复制或移动到另一个库

  1. 将某个库的面板选项卡拖出“对象库”面板组,分离二者,这样就可以同时看到两个库。
  2. 执行以下操作之一:
    • 要将对象从一个库复制到另一个库,请将对应项目从一个“库”面板选项卡拖到另一个“库”面板选项卡中。

    • 要将对象从一个库移动到另一个库中,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS),然后将对应项目从一个“库”面板选项卡拖到另一个“库”面板选项卡中。

从对象库中删除对象

  1. 在“对象库”面板中,选择一个对象,然后执行以下操作之一:
    • 单击“删除库项目”按钮。

    • 将对应项目拖到“删除库项目”按钮上。

    • 在“对象库”面板菜单中选择“删除项目”。

更改对象库显示

对象库将对象显示为缩略图或文本列表。可以按对象名称、存在时间或类型对缩略图或列表进行排序。如果已经编录了对象,则列表视图和排序选项的效果最佳。

  1. 执行以下操作之一:
    • 要以缩略图的形式查看对象,请在“对象库”面板菜单中选择“缩览图视图”或“大缩览图视图”。

    • 要以文本列表的形式查看对象,请在“对象库”面板菜单中选择“列表视图”。

    • 要将对象排序,请在“对象库”面板菜单中选择“排序项目”,然后选择一种排序方法。

查看所有对象

  1. 在“对象库”面板菜单中选择“显示全部”。

查看、添加或编辑库信息

对于大型或大量对象库,可以使用显示对象的名称、按照对象类型或采用描述性文字编录库信息。

  1. 在“对象库”面板中,执行以下操作之一:
    • 双击任何对象。

    • 选择一个对象,然后单击“库项目信息”按钮。

    • 选择一个对象,然后在“对象库”面板菜单中选择“项目信息”。

  2. 根据需要查看或更改“项目名称”、“对象类型”或“说明”选项,然后单击“确定”。

在库中查找对象

搜索对象时,会隐藏除搜索结果以外的所有对象。还可以使用搜索功能显示和隐藏特定类别的对象。例如,可以只显示名称中包含单词“star”的对象项目。

  1. 在“对象库”面板菜单中选择“显示子集”,或单击“显示库子集”按钮。
  2. 执行以下操作之一:
    • 要搜索库中的所有对象,请选择“搜索整个库”。

    • 要仅在库中当前列出的对象中搜索(精炼上一次的搜索结果),请选择“搜索当前显示的项目”。

  3. 在“参数”部分的第一个菜单中选择一个类别。
  4. 在第二个菜单中,指定搜索中必须包含还是排除在第一个菜单中选择的类别。
  5. 在第二个菜单的右侧,键入要在指定类别中搜索的单词或短语。
  6. 要添加搜索条件,请单击“更多选择”(最多可以单击五次);每单击一次,可以添加一个搜索项。要删除搜索条件,请根据需要单击“较少选择”;每单击一次,可以删除一个搜索项。
  7. 要只显示那些与所有搜索条件都匹配的对象,请选择“匹配全部”。要显示与条件中任何项匹配的对象,请选择“匹配任意一个”。
  8. 单击“确定”开始搜索。

注意:

要再次显示所有对象,请在“对象库”面板菜单中选择“显示全部”。

将对象库资源迁移到 CC 库

“Creative Cloud 库”可用于组织、浏览和访问创意资源。在 InDesign 中,您可以使用 CC 库来替代对象库。

注意:

InDesign 仍然支持对象库。

InDesign 允许您将对象库资源迁移到 CC 库。

  1. 在对象库面板中,单击“迁移”按钮可迁移当前库中的所有资源。

    或者,也可以从库中选择多个资源,右键单击并选择相关选项以迁移选定的资源。

  2. 在“迁移资源”对话框中,选择相关选项以将资源迁移到新的或现有的 Creative Cloud 库。

有关 CC Libraries 的更多详细信息,请参阅 Creative Cloud Libraries - 协作、同步和共享资源

Creative Cloud Libraries - 协作、同步和共享资源
Creative Cloud Libraries - 协作、同步和共享资源
Creative Cloud Libraries - 协作、同步和共享资源

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略