编码过程

要对视频或音频项进行编码,请将其添加到 Adobe Media Encoder 的编码队列,然后选择编码预设或创建自定义设置。您可以指示应用程序在您将项目添加到队列后开始编码,或者让应用程序等到您决定开始编码时再开始。

将项目添加到编码队列 - 将视频或音频文件拖入 Adobe Media Encoder 中的队列。

使用预设对项目进行编码 - 从队列中含有项目的“格式”和“预设”弹出菜单中选择格式和预设。或者从预设浏览器选择一个预设并拖动到“队列”中的任何项。有关更多信息,请参阅使用预设进行编码

使用自定义设置对项目进行编码 - 选择项目并选择“编辑”>“导出设置”,然后选择您的设置。有关更多信息,请参阅使用自定义设置进行编码

要自动开始对队列中的项目进行编码(或关闭该功能),请选择或取消选择“首选项”对话框中的“空闲时间超过后面的设定时自动开始排队”选项。有关更多信息,请参阅首选项一文。

AME 屏幕
Adobe Media Encoder 主窗口

将项目导入到编码队列

  • 要添加视频或音频文件,请执行以下操作之一:
    • 将一个或多个文件从桌面或媒体浏览器拖动到队列中。
    • 单击“添加源”按钮并选择一个或多个文件。
    • 双击“队列”面板中打开的区域,然后选择一个或多个文件。
  • 要添加 Adobe Premiere Pro 序列,请执行以下操作之一:
    • 在 Adobe Premiere Pro 项目中在媒体浏览器中导航,然后单击序列并拖动到队列中。
    • 选择“文件”>“添加 Premiere Pro 序列”,选择一个 Premiere Pro 项目,然后从该项目选择一个或多个序列。
    • 单击一个序列并从 Adobe Premiere Pro 的“项目”面板拖动到队列中。
    • 单击一个 Premiere Pro 项目并从桌面拖动到队列中。
  • 要添加 Adobe After Effects 合成,请执行以下操作之一:
    • 在媒体浏览器中的 Adobe After Effects 项目内导航,并将合成拖放到队列中。
    • 选择“文件”>“添加 After Effects 合成”,选择一个 After Effects 项目,然后从该项目中选择一个合成。
    • 单击一个合成并从 After Effects 中的“项目”面板拖动到队列中。
    • 单击一个 After Effects 项目并从桌面拖动到队列中。

停止编码

  • 选择“文件”>“停止当前文件”,停止对当前项的编码。Adobe Media Encoder 继续编码队列中的其余项。
  • 选择“文件”>“停止队列”,停止对队列中的所有项进行编码。

解释编码队列中的项目

当 Adobe Media Encoder 导入视频资产时,它试图确定资产的像素长宽比、帧速率、场序,以及如何解释 alpha 通道(透明度)信息。如果 Adobe Media Encoder 对于这些特性的确定有误,您可以明确指定正确的解释。

  1. 选择编码队列中的一个或多个项目。

  2. 选择“文件”>“解释素材”。也可以右键单击文件,然后选择“解释素材”

    interpret selection
    “解释素材”选项

  3. 选择适当的解释设置。

    iterpret window
    “解释素材”对话框

标识编码队列中的缺失项

您可以在编码之前标识队列中存在缺失项的源和输出。这有助于您在编码之前确认并修复问题。存在任何缺失项的源或输出旁会显示警告状态。将鼠标悬停在相应图标上可查看与此问题相关联的错误的摘要。

在以下情况下,Adobe Media Encoder 会显示警告图标:

  • Premiere Pro 项目包含脱机媒体。在此情况下,Adobe Media Encoder 会使用代理媒体代替缺失的集合。如果没有代理,则使用显示“媒体脱机”消息的图形。
  • Premiere Pro 项目中缺少部分字体。
  • Premiere Pro 项目中缺少部分效果。
  • 叠加效果中缺少部分文件。
标识缺失项
标识缺失项

Adobe Media Encoder 中的监视文件夹

您可以配置 Adobe Media Encoder 在名为监视文件夹的特定文件夹中查找文件。Adobe Media Encoder 在监视文件夹中找到一个视频或音频文件时,会使用为文件夹指定的编码设置对文件进行编码,然后将已编码的文件导出到在监视文件夹中创建的“输出”文件夹中。

Adobe Media Encoder 中的“监视文件夹”面板可用于添加和管理文件夹。您可以通过下列操作中的一项来添加监视文件夹:

  1. 选择“文件”>“添加监视文件夹”,并选择文件夹。
  2. 双击“监视文件夹”面板的空白区域并选择文件夹。
  3. 在资源管理器 (Windows) 或 Finder (Mac OS) 中创建文件夹,然后将其拖动到“监视文件夹”面板。

创建后您可以看到文件夹名称位于“监视文件夹”面板的左列。

由监视文件夹添加到编码队列中的项目将在您启动队列时随着队列中的其他项目一起编码。

注意:

如果您选中了“空闲时间超过后面的设定时自动开始排队”首选项,而且监视文件夹在编码队列中添加了一个新项目,当指定的时间过去后,编码将开始。

注意:

使“自动对监视文件夹进行编码”复选框保持选中状态,以便在项目添加到监视文件夹时自动对项目进行编码。

添加预设

您可以在文件夹名称旁边的监视文件夹的弹出菜单中选择一种格式和预设。或者将预设从预设浏览器拖动到监视文件夹。

使用监视文件夹,从单个源项中以多种格式创建输出

使用监视文件夹,您可以通过单个操作生成多个输出。例如,您想要在每次转码视频资产时都生成 AVI 影片和 JPEG 缩览图图像。请按照以下步骤,通过单个用户操作创建这些文件:

  1. 例如,使用资源管理器 (Windows) 或 Finder (Macintosh) 创建名为“My_WatchFolder”的文件夹。

  2. 通过单击“添加文件夹”按钮创建监视文件夹,然后导航到刚刚创建的名为“My_Watchfolder”的文件夹。

    1. 单击“格式”,然后从弹出菜单中选择“MPEG4”作为格式。

    2. 单击“预设”,然后从“预设”弹出菜单中选择所需的设置。

      preset and format
      “格式”和“预设”弹出菜单

    3. 单击“输出文件夹”。选择想要生成结果的位置。

      Output Folder
      输出文件夹

  3. 就像在步骤 2 中创建文件夹一样,创建也指向文件夹“My_Watchfolder”的“监视文件夹”项目。

    1. 从“格式”菜单中选择“AVI”作为格式。

    2. 从“预设”菜单中选择一种预设,然后单击“确定”

    3. 单击“输出文件夹”。选择想要生成结果的位置。

  4. 就像在步骤 2 和步骤 3 中创建文件夹一样,创建也指向文件夹“My_Watchfolder”的“监视文件夹”项目。

    1. 从“格式”菜单中选择“JPEG”作为格式。

    2. 从“预设”菜单中选择一种预设,然后单击“确定”

    3. 单击“输出文件夹”。选择想要生成结果的位置。

  5. 单击源文件并拖动到“My_WatchFolder”中,然后单击“启动队列”按钮。如果启用了“自动对监视文件夹进行编码”,则编码过程会自动开始。

完成后,每个文件都位于预期的输出位置。

注意:

应自定义预设,并且必须取消选择“导出为序列”选项。这样会只导出视频的第一帧,通常为黑色。

注意:

不支持通过监视文件夹将静止图像序列用作源素材。如果一组静止图像放入受监视的文件夹,则每个单独的静止文件将作为单独的项目添加到“队列”,而不是作为单个素材的整个序列添加。

保存编码队列

您退出 Adobe Media Encoder 时,编码队列和所有编码设置将自动保存。

当用户开始编码时,同时会自动保存编码队列。

要手动保存编码队列,请选择“文件”>“保存队列”

注意:

如果希望在关闭并重新启动 Adobe Media Encoder 后,完成的已编码项目仍然保留在队列里,请取消选中“首选项”>“退出时将队列中已完成的文件删除”复选框。

从编码队列中移除项目

  1. 选择要从编码队列中删除的项目。

  2. 单击“移除”按钮,选择“编辑”>“清除”,或者按 Delete 键。

    Delete file new
    从编码队列中删除项目

复制编码队列中的项目

  1. 选择要在编码队列中复制的项目。

  2. 执行以下操作之一:

    • 单击“复制”按钮,选择“编辑”>“复制”
    • Ctrl-D (Windows) 或 Command-D (Mac OS)
    • 右键单击该文件,然后选择“复制”
    Duplicate item
    复制项目

跳过编码队列中的项目

跳过项目

  1. 选择要在编码队列中跳过的项目。

  2. 选择“编辑”>“跳过所选项目”,或者可以右键单击该文件并选择“跳过所选项目”

    Skip selection
    跳过所选项目

重置已跳过的文件以进行编码

  1. 在编码队列中选择要重置为“就绪”状态的项目。

  2. 选择“编辑”>“重置状态”,或者也可以右键单击该文件并选择“编辑”>“重置状态”

    Reset status
    重置已跳过的文件的状态

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略