Collect assets and export in batches

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Create documents
      3. Tools Default keyboard shortcuts | Illustrator
      4. Customize keyboard shortcuts
      5. Artboards
      6. Customize the workspace
      7. Properties panel
      8. Set preferences
      9. Touch Workspace
      10. Microsoft Surface Dial support in Illustrator
      11. Recovery, undo, and automation
      12. Rotate view
      13. Rulers, grids, and guides
      14. Accessibility in Illustrator
      15. Safe Mode
      16. View artwork
      17. Use the Touch Bar with Illustrator
      18. Files and templates
      19. Synchronize settings using Adobe Creative Cloud
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Upgrade cloud storage for Adobe Illustrator
      4. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D effects and Adobe Substance materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Create 3D objects
      4. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Duplicate objects
      8. Rotate and reflect objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Create text
      2. Fonts and typography
      3. Format type
      4. Import and export text
      5. Format paragraphs
      6. Special characters
      7. Create type on a path
      8. Character and paragraph styles
      9. Tabs
      10. Text and type
      11. Find missing fonts (Typekit workflow)
      12. Update text from Illustrator 10
      13. Arabic and Hebrew type
      14. Fonts | FAQ and troubleshooting tips
      15. Create 3D text effect
      16. Creative typography designs
      17. Scale and rotate type
      18. Line and character spacing
      19. Hyphenation and line breaks
      20. Text enhancements
      21. Spelling and language dictionaries
      22. Format Asian characters
      23. Composers for Asian scripts
      24. Create text designs with blend objects
      25. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Import artwork files
      2. Import bitmap images
      3. Import artwork from Photoshop
      4. Place multiple files | Illustrator CC
      5. Unembed images
      6. Import Adobe PDF files
      7. Import EPS, DCS, and AutoCAD files
      8. Links information
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Export artwork
      2. Collect assets and export in batches
      3. Package files
      4. Create Adobe PDF files
      5. Extract CSS | Illustrator CC
      6. Adobe PDF options
      7. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash on launch issues
    2. Recover files after crash
    3. File issues
    4. GPU device driver issues
    5. Wacom device issues
    6. DLL file issues
    7. Memory issues
    8. Preferences file issues
    9. Font issues
    10. Printer issues
    11. Share crash report with Adobe

The Export for Screens workflow is a new way to generate assets of different sizes and file formats in one action. The ability to quickly export makes the generation of imaging collateral (icons, logos, images, mockups, and more) simpler and faster - especially for web and mobile workflows.

For example, in a mobile app development scenario, the User Experience Designer may want to frequently regenerate updated icons and logos. He can add these icons and logos to the Asset Export panel, and then export them to various file types and sizes in one click of a button. 

Useful features:

  • Export to multiple formats and sizes in one quick action. 
  • Export to typical or custom sizes (scales): 1x, 2x, 3x, 0.5x, 1.5x, and more.
  • The algorithm to generate PNG files has been revised to:
    • Generate PNG files faster than before. 
    • Produce better transparency in PNG-8 files.

Formats available: 

  • PNG (PNG-8, PNG-24)
  • JPEG (JPEG 100%, JPEG 85%, JPEG 50%, JPEG 25%)
  • SVG
  • PDF
The Export for Screens dialog (Assets tab).

Exporting assets (Export for Screens workflow)

Export entire artboards or individual artwork

  1. Do one of the following:

    • Shortcut: (Win) Alt + Ctrl + E / (Mac) Cmd + Opt + E. 
    • Click File> Export > Export for Screens.
    • Select artwork and click File > Export Selection.
    • Right-click selected artwork and click Collect for Export.

    In the Export for Screens dialog, edit the settings that you want to use while exporting your artwork.

  2. Select the scope of what you want to export. Two tabs are available:

    Artboards tab.

    Choose from the artboards available to export. Click an artboard to select or de-select it. Also use your mouse and the Shift key to make multiple selections.

    Assets tab.

    Choose from the assets that you have collected in the Asset Export panel. See the section Asset Export panel below.

    Note:

    Click the thumbnail or list icons to view the items differently.

    The Export for Screens dialog (Artboards tab).

  3. Based on the tab you are in, choose what you want to export as files. A check mark indicates whether the artboard or asset is selected or not.

    Artboards tab:

    • All. Select all artboards. Each artboard will be exported individually.
    • Range. Select individual artboards to export, from those available in the document. For example, 1, 2, 4-6 selects artboards 1, 2, 4, 5, and 6.
    • Full Document. Exports the entire document as one artwork.

    Assets tab:

    • All Assets. Select this option to export all the assets collected in the Assets tab.
    Note:

    To start afresh, click Clear Selection to deselect all the collected assets. You can start selecting specific artwork by clicking on thumbnails.

  4. Specify the settings for the exported files.

    • Scale. Specify the scale factor for the output file.
    • Location. Specify the folder location where exported files will be placed.
    • Open Location after Export. Select this option to specify if you want the folder that holds the exported assets to be opened using a file browser (Explorer or Finder).
    • Suffix. Provide a suffix to ensure output files have unique names.
    • Format. Specify if you need .png, .svg, .jpg, or .pdf file output.
    • Prefix. Provide a string that will serve as the start of the file names generated.
    • Add Scale button. Click Add Scale to add an additional output scale/format to export.
    • Delete button. Click the X symbol to delete an output type.
    • Presets.
      • iOS: Click to add the preset file output types generally required for iOS projects.
      • Android: Click to add the preset file output types generally required for Android form factor projects.
  5. (Optional) Click the Settings icon () to specify output settings for exported file formats.

  6. Click the Export Artboards or Export Assets button.

Asset Export panel

Collect and export in a jiffy.

The Asset Export panel displays assets that you collect from your artwork. These assets are, typically, the art that you want to export frequently.

For example, in a mobile app development scenario, the User Experience Designer may want to frequently regenerate updated icons and logos. It is easy to add these icons and logos to the Asset Export panel, and then export them to various file types and sizes in one click of a button. 

The Asset Export panel

Collect artwork for export

Adding assets to the Asset Export panel

You can collect objects in the Asset Export panel for export as multiple assets or a single asset.

Collect artwork for export as multiple assets

To collect objects/ layers for export as multiple assets, add them to the Asset Export panel (Window > Asset Export). Do one of the following:

  • Drag artwork into the Asset Export panel.
  • Right-click an asset and choose Collect for Export > As Multiple Assets. Alternatively, select artwork and click the Generate multiple assets from the selection icon () in the Asset Export panel.
  • To add the highlighted layers in the Layers panel as assets, click the Collect For Export icon at the bottom of the Layers panel.
Note:

Each time you drag artwork into the Asset Export panel, the asset is ‘collected’. This does not create a duplicate object on your artboard or in CC Libraries. When you update the artwork in your document, the corresponding asset is automatically updated in the Asset Export panel.

Collect artwork for export as a single asset

Do one of the following:

  • Press Alt/ Option while dragging artwork into the Asset Export panel.
  • Right-click an asset and choose Collect for Export > As Single Asset. Alternatively, select artwork, and then press Alt/ Option while clicking the Generate a single asset from the selection icon () in the Asset Export panel.

Exporting assets (Asset Export panel workflow)

Export assets using the Asset Export panel

Export assets using the Asset Export panel

  1. Click Window > Asset Export, to launch the Asset Export panel.

  2. View the collected assets in the Asset Export panel. A border indicates whether the asset is selected for export or not.

    Note:

    Only assets with a border are exported. Click a thumbnail to select or deselect it.

  3. Click the Export Settings triangle  to view or add what formats/sizes you want to export your files to:

    • Scale. Specify the scale factor for the output file. 
    • Suffix. Provide a suffix to ensure output files have unique names.
    • Format. Specify if you need .png, .svg, .jpg, or .pdf file output.
    • Add Scale button. Click to add an additional output scale/format to export.
    • Delete button. Click the X symbol to delete an output type.
    • Presets:
      • iOS: Click to add the preset file output types generally required for iOS projects.
      • Android: Click to add the preset file output types generally required for Android form factor projects.
  4. (Optional) From the fly-out menu, choose Format Settings to specify output settings for exported file formats.

  5. (Optional) From the fly-out menu, click Open Location After Export to view the exported files immediately after an export workflow.

  6. To generate files, click Export.

    While exporting assets, Illustrator creates subfolders at the export location by default based on the scaling options you choose. For example, if you select multiple scale formats in the Asset Export panel, say 1x 2x, and 3x to export a file as PNG, Illustrator creates subfolders named 1x, 2x, and 3x for the exported files. For formats that do not support scaling options, Illustrator names the subfolders based on the file formats selected for exporting—for example, SVG and PDF. 

    To export files in a folder without creating any subfolders, deselect the Create Subfolders option from the Asset Export panel or the Export For Screens dialog box.

    Note:

    To change the folder location of the asset you're exporting, or to specify details like a file prefix, use the Export for Screens dialog. Click   to open the Export For Screens dialog. All options set in the Asset Export panel are retained in the Export For Screens dialog.

Output settings for exported assets

Format-specific options for exported assets

Format-specific options for exported assets

The Format Settings dialog allows you to specify the output settings for each file type you can export to:

  • In the Export for Screens dialog, click the Settings icon to launch the Format Settings dialog.
  • In the Asset Export panel, click the fly-out menu and choose Format Settings.
Provide format-specific settings in the Format Settings dialog.
Provide format-specific settings in the Format Settings dialog.

Adobe logo

Sign in to your account