Work with Photoshop files in InDesign

Find answers to common questions when importing Photoshop assets in InDesign.

Things to know when moving files to InDesign

Try the following workflows that suit your design objectives:

Workflow How To Achieve
Adjust layer visibility Adjust the visibility of top-level layers while placing a file or using the Object Layer Options dialog box. View the desired comp if your Photoshop file contains layer comps. Click Layer comps in Photoshop to learn more. 
Remove background or wrap text
Use paths, masks, and alpha channels in a Photoshop file to remove backgrounds or wrap text around graphics when importing in InDesign. Click Masks and alpha channels in Photoshop and Alpha channels in InDesign to learn more. 
Assign a color profile
Import a Photoshop file with an embedded ICC color management profile for InDesign to detect if the color management is active. To override the profile in InDesign, use the Import Options dialog box or assign a different color profile. Click Work with color profiles in Photoshop and Manage colors in InDesign to learn more. 
See spot colors See spot-color channels in Photoshop files as spot colors in the InDesign Swatches panel. Click Spot color channels in Photoshop to learn more. 
Preview your files

See the screen resolution version of your Photoshop files in the layout, even though the actual graphic file may be linked or embedded. See Image size and resolution in Photoshop and Link or embed graphic files in InDesign to learn more. 

Import Photoshop files to InDesign

The Place command is most frequently used to import Photoshop files to InDesign. Click Place graphics in InDesign to learn more about adding files to your InDesign document. 

  1. Select the frame

    From InDesign, select the frame if you are importing into or replacing an existing frame.

    If you are importing a graphic without a frame, ensure that nothing in the document is selected. Click Frames and objects in InDesign to learn more about importing graphics without a frame. 

  2. Place the file

    • Choose File > Place from the InDesign menu and select your file.
    • If you select multiple files, you can click or drag in the document to place the selected files one at a time. 
    • If the new image doesn’t fit the frame, select Object > Fitting  to fit the graphic into the frame. Click Place Photoshop files in InDesign to learn more. 
    Choose File > Place to place Photoshop file in InDesign
    Choose File > Place to place Photoshop file in InDesign

You can also drag and drop Photoshop files to InDesign and maintain their attributes and editing capabilities. 

Use layer comps in Photoshop to improve InDesign workflows

Layer comps (or compositions) are a neat way to create, manage, and view multiple versions of your layouts or content in one Photoshop file. They reduce the need for redundant layers when importing a Photoshop file to InDesign.

You can save more than one design idea using layer comps.

Layer comps in a Photoshop file
Layer comps in a Photoshop file

Layer comps are the snapshot of a state of the Layers panel and record layer visibility, layer position, layer appearance, and layer comp selection. 

With layer comps, you can experiment with layer styles, visibility, opacity, colors, effects, and placement using attributes and states while toggling between layers in the same Photoshop file. Click Layer comps to learn more about using them in Photoshop. 

When you import this file to InDesign, you can choose from different states in the Layer Comp dropdown menu, instead of having to adjust the visibility of layers. This way you can import only one file and use layer comps as part of the file.

Avoid Photoshop files from looking pixelated in InDesign

To avoid your Photoshop file from getting pixelated in InDesign, go to File > Place to select the file, instead of simply copying and pasting it.

Also, make sure you choose the right display settings to view files at full resolution in InDesign. (Click Graphics display to learn more about controlling graphics display performance.)

Note:

High Quality Display is checked by default in the View > Display Performance menu. 

Choose the right display settings in InDesign to view images at full resolution
Choose the right display settings in InDesign to view images at full resolution

Prevent oversaturation of colors when placing images from Photoshop to InDesign

To prevent your Photoshop image from looking oversaturated in Indesign, ensure your color profiles match between both the applications (tagged images). Go to Edit > Color Settings to adjust settings for both. 

Access color profiles in Photoshop by going to Edit > Color Settings
Access color profiles in Photoshop by going to Edit > Color Settings

Use your CMYK image in an InDesign document created with the default North American General Purpose Color Settings. The color settings set US Web Coated SWOP as the assigned CMYK profile and the policy is set to ignore linked profiles. 

Use Assign Profile to tag your images with specific profiles or untag them by removing the profiles.

Assign Profile (Edit Menu > Assign Profile) in Photoshop
Assign Profile (Edit Menu > Assign Profile) in Photoshop

Select a different profile and assign it without converting colors to the profile space. This can change the appearance of the colors as displayed on your monitor.

Click Work with color profiles to learn more about assigning or removing a color profile in Photoshop and InDesign. 

Got a question or an idea?

Ask the Community

If you have a question to ask or an idea to share, come and participate in the Adobe Photoshop community and Adobe InDesign community. We'd love to hear from you!

Adobe logo

Sign in to your account