Verze: Illustrator CS2 až CS5

Témata

Aplikace Adobe Illustrator je optimalizována pro tisk na tiskárnách s podporou jazyka PostScript. Velké množství rozšířených funkcí aplikace Illustrator lze vlastně popsat pouze pomocí jazyka PDL (Page Description Language) PostScript. Tiskárny bez podpory jazyka PostScript (například tiskárny Hewlett-Packard LaserJets, Canon BubbleJets nebo Epson Stylus) používají neúplné programovací jazyky DPL (například jazyky PCL nebo QuickDraw), ve kterých nelze všechny objekty a atributy používané v kresbách aplikace Illustrator popsat. Většina tiskáren bez podpory jazyka PostScript spoléhá při předávání tiskových informací tiskárně na informace z obrazovky, prostředky hostitelských počítačů a značkové ovladače tiskáren.

Při tisku výstupu aplikace Illustrator na tiskárně bez podpory jazyka PostScript se může stát, že se určité objekty nevytisknou nebo se vytisknou nesprávně. Chování při tisku se může lišit podle toho, jakou tiskárnu a jakou verzi softwaru tiskárny používáte. Problémy s tiskem na tiskárnách bez podpory jazyka PostScript se mohou projevovat mnoha různými způsoby, mimo jiné například takto:

  • Text nebo jiné objekty na stránce částečně nebo zcela chybí.
  • Dojde k chybě nebo zablokování systému.

Při odstraňování problémů s tiskem dokumentů aplikace Illustrator na tiskárnách bez podpory jazyka PostScript vám však může pomoci, když budete postupovat podle níže uvedených kroků. Může se stát, že v některých případech, například u starších tiskáren, jejichž ovladače se již neaktualizují, vám uvedené kroky nepomohou a budete muset použít alternativní řešení. Několik alternativních řešení najdete na konci tohoto dokumentu.

Postup odstraňování problémů

Pomocí kroků uvedených v této části se vám podaří najít nejčastější příčiny problémů s tiskem, ke kterým dochází v aplikaci Illustrator. Než začnete postupovat podle těchto kroků, zkontrolujte, zda není příčinou problému poškozený soubor aplikace Illustrator. Zjistíte to tak, že otevřete nový soubor a pokusíte se problém reprodukovat. Pokud v novém souboru k danému problému nedochází, je předchozí soubor aplikace Illustrator pravděpodobně poškozený. Informace o odstraňování problémů s poškozenými soubory aplikace Illustrator najdete v článku 320318 s názvem „Řešení potíží s poškozenými soubory (Illustrator CS2 a novější)“.

Pokud dojde k chybě systému, vždy restartujte počítač, aby se aktualizovala paměť počítače. Pokud byste počítač nerestartovali, mohlo by dojít ke zhoršení problému.

1. Aktualizujte nebo přeinstalujte ovladač tiskárny.

Nejnovější verzi ovladače používané tiskárny vám poskytne výrobce příslušné tiskárny. Pokud k problému dochází i přesto, že používáte nejnovější verzi ovladače tiskány, odeberte ovladač a potom jej přeinstalujte z původních instalačních disků nebo z disku CD-ROM.

2. Změňte možnost bitmapového tisku v aplikaci Illustrator.

Pokud používáte aplikaci Illustrator pro systém Windows, změňte nastavení možnosti Tisknout jako bitmapu v dialogovém okně Tisk. To znamená, že pokud je zaškrtnuto příslušné políčko, tak jeho zaškrtnutí zrušte, a naopak.

Chcete-li možnost bitmapového tisku změnit, vyberte položku Soubor > Tisknout > Další volby a zaškrtněte políčko Tisknout jako bitmapu, případně jeho zaškrtnutí zrušte.

Poznámka: Pokud tisk ve formátu bitmapy v dialogovém okně Tisk vypnete, vytvoří aplikace Illustrator pomocí ovladače tiskárny a informací o rozhraní GDI (Graphic Display Interface) vektorová tisková data, které se tisknou rychleji, ale mohou být u některých zařízení příčinou nekonzistentního tisku.

3. Použijte vylepšený ovladač PCL.

Pokud používáte systém Windows a tiskárna podporuje vylepšený ovladač PCL, nainstalujte tento vylepšený ovladač. Pokyny k instalaci vylepšeného ovladače pro konkrétní tiskárnu najdete v dokumentaci k dané tiskárně nebo vám je poskytne její výrobce.

4. Přepněte na standardní ovladač grafické karty systému Windows.

Spuštěním systému v režimu VGA přepněte na standardní ovladač grafické karty systému Windows:

  • V systému Windows Vista a Windows 7: V seznamu možností při spuštění vyberte možnost Zapnout video s nízkým rozlišením (640×480) a stiskněte klávesu Enter. Pokud se tato nabídka nezobrazí nebo jen velmi rychle problikne, vyberte možnost Start > Ovládací panely, klikněte na položku Systém a údržba a potom na položku Systém. Vyberte kartu Upřesnit, v části Spuštění a zotavení systému vyberte možnost Vybrat nastavení a potom zvyšte hodnotu nastavení Doba zobrazení seznamu operačních systémů.
  • V systému Windows XP: Restartujte systém Windows, po zobrazení výzvy stiskněte klávesu F8 a v zobrazené nabídce vyberte možnost Zapnout režim VGA. Pokud se tato nabídka nezobrazí nebo jen velmi rychle problikne, vyberte možnost Start > Nastavení > Ovládací panely, klikněte dvakrát na položku Systém a potom klikněte na kartu Upřesnit. V části Spuštění a zotavení systému vyberete možnost Nastavení a zvyšte hodnotu nastavení Doba zobrazení seznamu operačních systémů.
  • V systému Windows 2000: Restartujte systém Windows, po zobrazení výzvy stiskněte klávesu F8 a v nabídce vyberte možnost Režim VGA. Pokud se tato nabídka nezobrazí nebo jen velmi rychle problikne, vyberte možnost Start > Nastavení > Ovládací panely, klikněte dvakrát na položku Systém a potom klikněte na kartu Upřesnit. Vyberete možnost Spuštění a zotavení systému a zvyšte hodnotu nastavení Doba zobrazení seznamu operačních systémů (v sekundách).

Jestliže při použití ovladače Super VGA nebo VGA funguje tisk z aplikace Illustrator správně, může být ovladač grafické karty poškozený či zastaralý, případně nemusí být kompatibilní s ovladačem tiskárny nebo aplikací Illustrator. Chcete-li získat aktualizovaný ovladač grafické karty, obraťte se na jejího výrobce.

5. Změňte formát textu.

Pokud se text tiskne nesprávně nebo se netiskne vůbec, uložte kopii souboru aplikace Illustrator a potom proveďte jednu z následujících akcí:

  • Jako typ použijte bílý tah s nulovým počtem bodů.
  • Převeďte text na obrysy. U malého textu (24 bodů nebo méně) použijte bílý tah s nulovým počtem bodů, abyste zabránili zkreslení znaků převáděných na obrysy.
  • Pomocí nástroje pro výběr vyberte v aplikaci Illustrator text a výběrem možnosti Objekt > Rastrovat jej převeďte na rastr.

6. Přidejte skrytý barevný objekt.

Pokud se barevný text tiskne černě a jedná se o jediný prvek na stránce, vytvořte skrytý objekt, který bude mít stejnou barvu jako text:

  1. Vyberte nástroj obdélník, nakreslete obdélník a vybarvěte jej stejnou barvou jako text.
  2. Nakreslete dostatečně velký obdélník, který bude zcela překrývat obdélník vytvořeny v kroku 1. Vybarvěte nový obdélní bíle a umístěte jej tak, aby překrýval původní obdélník.

7. Nastavte položku Tisknout vrstvy na možnost Všechny vrstvy.

Vyberte možnost Soubor > Tisknout, klikněte na možnost Všeobecné a v nabídce Tisknout vrstvy vyberte položku Všechny vrstvy.

8. Nastavte tiskárnu s podporou jazyka PostScript jako výchozí. (Tento postup lze použít pouze v systému Windows.)

V systému Windows nastavte tiskárnu s podporou jazyka PostScript jako výchozí. Chcete-li nastavit výchozí tiskárnu, vyberte možnost Start > Nastavení > Tiskárny (Windows XP, Windows 2000) nebo Start > Ovládací panely > Hardware a zvuk > Tiskárny (Windows Vista). Pravým tlačítkem myši klikněte na požadovanou tiskárnu a vyberte příkaz Nastavit jako výchozí.

Poznámka: Pokud nemáte tiskárnu s podporou jazyka PostScript, můžete i tak nainstalovat její ovladač a nastavit ji jako výchozí tiskárnu:

  1. Vyberte možnost Start > Nastavení > Tiskárny (Windows XP, Windows 2000) nebo Start > Ovládací panely > Hardware a zvuk > Tiskárny (Windows Vista) a potom vyberte možnost Přidat tiskárnu.
  2. Postupujte podle pokynů na obrazovce a dejte pozor, abyste vybrali tiskárnu s podporou jazyka PostScript (například Apple LaserWriter Pro), nikoli tiskárnu bez této podpory (například HP DeskJet). Pokyny k použití Průvodce přidáním tiskárny najdete k dokumentaci k systému Windows.

Pokud budete chtít v aplikaci Illustrator tisknout na jiné než výchozí tiskárně systému Windows, postupujte následujícím způsobem:

  1. Vyberte možnost Soubor > Tisknout.
  2. V nabídce Tiskárna vyberte požadovanou tiskárnu.
  3. Pokud chcete ponechat tuto tiskárnu vybranou, klikněte na tlačítko Hotovo. Jestliže chcete zahájit tisk, klikněte na tlačítko Tisknout.

9. Použijte k tisku místní tiskárnu.

Pokud jste připojeni k síťové tiskárně, připojte tiskárnu přímo k počítači. Jestliže se soubor vytiskne správně, mohou být problémy způsobeny potížemi se sítí. Požádejte o pomoc správce sítě.

Alternativní řešení

Pokud ani po provedení kroků uvedených v části Postup odstraňování problémů nelze dokument aplikace Illustrator na tiskárně bez podpory jazyka PostScript vytisknout, mohou vám pomoci následující alternativní řešení.

10. Uložte soubor ve formátu PDF (Portable Document Format).

Výběrem položky Acrobat PDF v rozevíracím seznamu v dialogovém okně Uložit jako uložte soubor aplikace Illustrator ve formátu PDF a soubor PDF potom otevřete a vytiskněte v aplikaci Adobe Reader.

11. Použijte k tisku jinou aplikaci.

Vytiskněte soubor aplikace Illustrator z jiné aplikace (například z aplikace Adobe Photoshop nebo Adobe InDesign).

Poznámka: K problémům s tiskem na tiskárnách bez podpory jazyka PostScript může docházet i v jiných aplikacích. Soubor aplikace Illustrator můžete uložit nebo exportovat do jiného formátu (například TIFF nebo EPS) nebo se jej pokusit vytisknout pomocí jiné aplikace.

12. Použijte k tisku jinou tiskárnu.

Použijte tiskárnu s podporou jazyka PostScript nebo jinou tiskárnu bez této podpory.

Poznámka: Někteří výrobci tiskáren bez podpory jazyka PostScript (například Hewlett-Packard nebo Epson) nabízí pro své tiskárny hardware nebo software zajišťující podporu jazyka PostScript. Informace o dostupnosti hardwaru nebo softwaru pro podporu jazyka PostScript vám poskytne příslušný výrobce.

 

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online