Otevření sdíleného obsahu

Soubory úloh (.inca) mohou otevírat pouze uživatelé InCopy. Pokud uživatel InCopy otevře soubor aplikace InDesign obsahující úlohu, uživatel bude mít přístup k veškerému spravovanému obsahu bez ohledu na úlohy.

  1. Proveďte jeden z následujících úkonů.
    • V InCopy zvolte Soubor > Otevřít, vyberte soubor úlohy (.icma nebo .inca) a klikněte na Otevřít.

    • V aplikaci InDesign nebo v InCopy zvolte Soubor > Otevřít, vyberte soubor aplikace InDesign (.indd) obsahující přiřazený obsah a klikněte na Otevřít.

    • Otevřete balíček úlohy. Viz Přijímání balíčků (InCopy).

Názvy úloh a jejich obsah se zobrazí v panelu Úlohy.

Vyhrazení obsahu

Když si vyhradíte položku, do souborového systému se umístí skrytý soubor zámku (.idlk). Jakmile je obsah vyhrazený, máte výhradní kontrolu nad jeho obsahem, a nikdo jiný nemůže provádět jeho změny. Vyhradit si můžete pouze obsah InCopy; nemůžete si vyhradit dokumenty aplikace InDesign s informacemi o rozvržení.

Když se pokusíte zavřít dokument aplikace InDesign obsahující jeden nebo více souborů obsahu InCopy, které máte vyhrazené, objeví se výstražná zpráva s požadavkem, abyste všechen obsah zpřístupnili. Pokud dokument zavřete, aniž byste soubory obsahu zpřístupnili, zůstanou vyhrazené pro vás až do příštího otevření dokumentu aplikace InDesign. Při uložení dokumentu aplikace InDesign se automaticky uloží i všechny soubory obsahu InCopy, které je možné upravovat.

Vyhrazení obsahu (InDesign)

  1. Proveďte jeden z následujících úkonů:
    • V rozvržení vyberte textové nebo grafické rámečky, které chcete upravovat, a zvolte Úpravy > InCopy > Vyhradit si.

    • V panelu Úlohy vyberte soubory a z nabídky panelu zvolte Vyhradit si.

Když si v aplikaci InDesign vyhradíte dostupný obsah, zobrazí se na textovém rámečku v aplikaci InDesign ikona Upravovaný . Pokud jsou soubory úloh uložené na lokálním serveru, v InCopy se na rámečku InCopy a v panelu Úlohy zobrazí ikona Používaný .

Vyhrazení obsahu (InCopy)

  1. Proveďte jeden z následujících úkonů:
    • Pokud je požadovaný obsah součástí úlohy, zvolte Soubor > Otevřít a vyberte soubor úlohy (.icma nebo .inca).

    • Pokud byl požadovaný obsah exportován jako samostatné soubory, zvolte Soubor > Otevřít a vyberte soubor InCopy (.icml nebo .incx). Chcete-li vidět rozvržení, abyste mohli přizpůsobit délku textu, vyberte dokument aplikace InDesign.

  2. Proveďte jeden z následujících úkonů:
    • Chcete-li si vyhradit jeden soubor obsahu InCopy, zvolte Soubor > Vyhradit si.

    • Chcete-li si najednou vyhradit všechen obsah v úloze, vyberte tuto úlohu v panelu Úlohy a z nabídky panelu zvolte Vyhradit si.

    • Chcete-li si vyhradit jednotlivé položky úlohy, otevřete seznam úloh v panelu Úlohy, vyberte položku nebo více položek a z nabídky panelu zvolte Vyhradit si.

    Vedle jedné nebo více položek v panelu Úlohy se zobrazí ikona Upravovaný , která označuje, že máte obsah vyhrazený pro výhradní použití.

  3. Pokud se zobrazí výzva pro aktualizaci obsahu změnami, klikněte na OK.

Když si v InCopy vyhradíte dostupný obsah, zobrazí se na textovém rámečku InCopy a panelu Úlohy ikona Upravovaný . V aplikaci InDesign se na rámečku aplikace InDesign zobrazí ikona Používaný .

Otevírání spravovaných souborů (InCopy)

Otevření spravovaného souboru obsahu (.icml nebo .incx) přímo v InCopy a práce s tímto souborem v zobrazení článku může být vhodnější pro rychlé psaní a úpravy. Jednotlivý spravovaný soubor si nemusíte vyhradit pro úpravy; InCopy to udělá automaticky. Při uložení a zavření souboru InCopy automaticky obsah zpřístupní. Příkazy pro uložení jsou odlišné v případě, že jste otevřeli jednotlivé soubory.

Aktualizace souborů úloh (InDesign)

Změny do úloh můžete uložit ručně nebo při zavření aktuálního dokumentu. Aktualizace souboru úlohy je jediný způsob, jak zpřístupnit změny rozvržení uživatelům InCopy.

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li aktualizovat vybrané úlohy, vyberte je v panelu Úlohy a z nabídky panelu Úlohy zvolte Aktualizovat vybrané úlohy.

    • Chcete-li aktualizovat všechny neaktuální úlohy v současném dokumentu, z nabídky panelu Úlohy zvolte Aktualizovat zastaralé úlohy. Aktualizují se pouze úlohy, které jsou neaktuální.

    • Chcete-li aktualizovat všechny úlohy v aktuálním dokumentu, z nabídky panelu Úlohy zvolte Aktualizovat všechny úlohy.

Poznámka:

Pokud má uživatel InCopy otevřenou úlohu, když tuto úlohu aktualizujete, v InCopy se vedle úlohy v panelu Úlohy zobrazí ikona Neaktuální .

Aktualizace obsahu

Chcete-li zajistit, abyste vždy pracovali na nejaktuálnějším obsahu, dávejte pozor na ikony Neaktuální v panelu Úlohy a podle nich provádějte aktualizaci obsahu. Aktualizace souboru úlohy InCopy a jeho obsahu nebo aktualizace jednotlivých souborů obsahu zkopíruje data z poslední kopie v souborovém systému, aby verze na vašem počítači odpovídala verzi v souborovém systému. Aktualizace nevyžaduje zpřístupnění nebo vyhrazení a nedá vám práva pro úpravy. Aktualizace ale může způsobit problémy v případě, že jiný uživatel odstranil váš zámek.

Poznámka:

Aktualizace obsahu neaktualizuje obsah v balíčcích úloh, které uživatelé nevrátili.

Typický pracovní postup aktualizace je následující:

  1. Uživatel InCopy otevře soubor úlohy nebo si vyhradí jednotlivý soubor obsahu a upraví obsah.

  2. Uživatel InCopy uloží soubor obsahu, čímž aktualizuje jeho kopii v souborovém systému, a pokračuje v práci.

  3. Uživatel aplikace InDesign uvidí ikonu Neaktuální vedle výběru v panelech Úlohy a Vazby a na příslušném rámečku ikony Používaný a Neaktuální textový obsah nebo Neaktuální grafický obsah .

    Panel Úlohy s ikonami Používaný a Neaktuální (vlevo) a rozvržení s neaktuálním obsahem (vpravo)
  4. Uživatel aplikace InDesign aktualizuje obsah.

Aktualizace obsahu při otevření spravovaného dokumentu (InDesign)

  1. Zvolte Soubor > Otevřít, najděte soubor, který chcete otevřít, a klikněte na Otevřít.
  2. Klikněte na Ano v okně s dotazem, zda chcete v dokumentu aktualizovat upravený obsah ze souborového systému.
  3. Proveďte jeden z následujících úkonů:
    • Chcete-li, aby vazby aktualizoval InDesign, klikněte na Automaticky opravit vazby.

    • Chcete-li opravit vazby ručně, klikněte na Neopravovat, a pak v panelu Vazby vyberte soubor, který chcete aktualizovat, a z nabídky panelu zvolte Aktualizovat vazbu.

Aktualizace obsahu při práci (InDesign)

  1. Proveďte jeden z následujících úkonů:
    • V rozvržení vyberte textové nebo grafické rámečky a zvolte Úpravy > InCopy > Aktualizovat obsah.

    • V panelu Vazby vyberte textové nebo grafické rámečky a klikněte na tlačítko Aktualizovat vazbu nebo z nabídky panelu Úlohy zvolte Aktualizovat vazbu.

Aktualizace obsahu při práci (InCopy)

  1. Proveďte jeden z následujících úkonů:
    • Kliknutím umístěte textový kurzor do textového rámečku, abyste ho vybrali, a pak zvolte Soubor > Aktualizovat obsah.

    • Vyberte obsah v panelu Úlohy a pak klikněte na tlačítko Aktualizovat obsah , nebo z nabídky panelu Úlohy zvolte Aktualizovat obsah.

Obsah můžete také aktualizovat pomocí panelu Vazby.

Neúmyslné aktualizace práce

Ve většině případů jsou příkazy aktualizace pro obsah, který jste si vyhradili, nedostupné, protože tento obsah by měl být vždy aktuální. Může se ale vyskytnout nežádoucí situace, pokud jiný uživatel odstraní zámek vyhrazeného obsahu (přetažením souboru zámku [.idlk] do koše), a upraví obsah. V takovém případě mohou být příkazy pro aktualizaci dostupné, i když máte obsah vyhrazený pro sebe, což prakticky umožní dvěma lidem upravovat obsah současně. Aktualizace obsahu způsobí ztrátu práce. Abyste dostali co nejlepší výsledky, neodstraňujte soubory zámků.

Aktualizace rozvržení aplikace InDesign

Uživatelé aplikace InDesign mohou upravovat rozvržení (například změnit velikost nebo umístění textových rámečků článku) a ukládat změny, zatímco uživatelé InCopy upravují text těchto textových rámečků. V pracovním postupu se sdíleným serverem závisí způsob upozornění uživatelů InCopy na změny rozvržení na tom, zda otevřeli soubor úlohy nebo si vyhradili jednotlivé soubory obsahu a také otevřeli připojený soubor aplikace InDesign.

Platí následující pravidla:

  • Pokud uživatel aplikace InDesign změní rozvržení rámečků v úloze, tento uživatel musí aktualizovat úlohu, aby byly změny návrhu dostupné pro uživatele InCopy. InDesign neaktualizuje automaticky soubory úloh při uložení dokumentu.

  • Jakmile uživatel aplikace InDesign aktualizuje úlohu uloženou na sdíleném serveru, zobrazí se v InCopy v panelu Úlohy vedle příslušné úlohy ikona Neaktuální . V InCopy musí uživatel aktualizovat návrh, aby viděl aktuální rozvržení.

  • Pokud uživatel aplikace InDesign změní rozvržení exportovaného obsahu, který není součástí úlohy, zobrazí se vedle názvu dokumentu InDesign v panelu Úlohy ikona Neaktuální a titulní pruh dokumentu označuje neaktuální rozvržení. Uživatelé InCopy mohou aktualizovat aktivní dokument aplikace InDesign posledními změnami rozvržení a stylů.

Aktualizace rozvržení v InCopy je užitečná pro přizpůsobení množství textu velikosti rámečků, protože v zobrazení rozvržení a sloupců je vidět aktuální vzhled a zalomení řádků.

  1. Proveďte jeden z následujících úkonů:
    • Pokud máte otevřený soubor úlohy a v panelu Úlohy je vedle názvu úlohy zobrazena ikona Neaktuální , klikněte na tlačítko Aktualizovat návrh , nebo zvolte Soubor > Aktualizovat návrh. Tento příkaz nelze vzít zpět.

    • Pokud nepracujete se soubory úloh a máte otevřený více než jeden dokument aplikace InDesign, vyberte ten, který chcete aktivovat, a zvolte Soubor > Aktualizovat návrh.

Zpřístupnění obsahu

Když zpřístupníte spravovaný soubor obsahu, uložíte ho do sdíleného místa v souborovém systému, kde si ho mohou pro úpravy a jiné změny vyhradit ostatní uživatelé. Export textového nebo grafického rámečku z aplikace InDesign ho automaticky také zpřístupní.

Přestože je zpřístupněný soubor dostupný pro úpravy, nemůžete ho ve skutečnosti upravovat, dokud si ho nevyhradíte (pokud obsah neupravujete v jednouživatelském režimu v InCopy). Zpřístupněním obsahu se vzdáte možnosti úprav, ale soubor nezavřete. Obsah zůstane otevřený na obrazovce, ale je ve stavu pouze ke čtení.

Zásuvné moduly LiveEdit Workflow nevytvářejí více verzí souboru. Místo toho se soubory přepíšou, když je aktualizujete v InCopy nebo v aplikaci InDesign.

Pokud pracujete na balíčku úlohy, po zpřístupnění balíčku úlohy ho vraťte nebo předejte dál.

Zpřístupnění spravovaného obsahu (InDesign)

  1. Proveďte jeden z následujících úkonů:
    • Vyberte obsah v rozvržení a zvolte Úpravy > InCopy > Zpřístupnit.

    • V panelu Úlohy vyberte obsah a z nabídky panelu zvolte Zpřístupnit.

Zpřístupnění spravovaného obsahu (InCopy)

  1. Proveďte jeden z následujících úkonů:
    • Vyberte obsah v zobrazení rozvržení a zvolte Soubor > Zpřístupnit.

    • V panelu Úlohy vyberte obsah a z nabídky panelu zvolte Zpřístupnit.

    Poznámka:

    Před zpřístupněním obsahu můžete odvolat naposledy provedené změny.

    Poznámka:

    Když soubor zpřístupníte, zobrazí se ikona Dostupný na textovém nebo grafickém rámečku v rozvržení v aplikaci InDesign, v zobrazení rozvržení v InCopy, v panelu Úlohy a v pruhu článku (InCopy).

Uložení změn (InDesign)

Když pracujete s obsahem, který jste si vyhradili, můžete uložit své změny a aktualizovat kopii článku v souborovém systému.

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li uložit vybraný obsah bez uložení změn do dokumentu aplikace InDesign nebo některého z jeho připojených souborů, vyberte obsah v rozvržení a zvolte Úpravy > InCopy > Uložit obsah.

    • Chcete-li uložit všechny soubory obsahu, které máte vyhrazeny, zvolte Soubor > Uložit. Tento typ uložení neprovede automaticky aktualizaci souborů úloh nebo vyhrazených souborů obsahu v InCopy. U vyhrazených souborů v panelu Úlohy v InCopy se ale bude zobrazovat ikona Neaktuální .

    • Chcete-li uložit dokument aplikace InDesign pod novým názvem s vazbami na existující soubory InCopy, zvolte Soubor > Uložit jako. Poté se budou úlohy v souboru InDesign zobrazovat jako chybějící, dokud nebudou aktualizovány.

    • Chcete-li uložit kopii právě aktivního dokumentu, zvolte Soubor > Uložit kopii. Kopii můžete dát nový název a umístění, vazby na existující soubory InCopy se zachovají.

Ukládání změn (InCopy)

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li uložit soubor InCopy pod stejným názvem a do stejného umístění v souborovém systému, zvolte Soubor > Uložit obsah. Soubor zůstává vyhrazený pro vás.

    • Chcete-li uložit soubor obsahu InCopy s novým názvem, zvolte Soubor > Uložit obsah jako. Nově vytvořený soubor obsahu není spravován v pracovním postupu. Příkaz Uložit obsah jako je dostupný pouze v případě, že jste přímo otevřeli soubor obsahu InCopy (.icml nebo .incx).

    • Chcete-li uložit kopii právě aktivního souboru obsahu InCopy, zvolte Soubor > Uložit kopii obsahu. Kopii můžete dát nový název a umístění. Uložená kopie není spravovaná v pracovním postupu. Příkaz Uložit kopii obsahu je dostupný pouze v případě, že jste přímo otevřeli soubor obsahu InCopy (.icml nebo .incx).

    • Chcete-li uložit všechny právě otevřené a vyhrazené soubory obsahu InCopy, zvolte Soubor > Uložit celý obsah. Tím uložíte všechny soubory v jejich aktuálním umístění. Příkaz Uložit celý obsah je dostupný pouze v případě, že jste otevřeli soubor úlohy nebo soubor aplikace InDesign.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online