Ongelma

Asennettaessa Adobe Creative Suite 3 -tuotteita tai yksittäisiä Creative Suite 3 -sovelluksia näkyy jokin seuraavista virheviesteistä:

  • ”Asennuksen aikana ilmeni joitakin ongelmia.”
  • ”Komponenttien asennus epäonnistui.”
  • ”Jaettujen komponenttien asennus epäonnistui.”

Ratkaisut

Ratkaisu 1: Suorita CS5 Cleaner Tool -työkalu.

Adobe CS5 Cleaner Tool auttaa ratkaisemaan Adobe Creative Suite 5-, Adobe Creative Suite 4- ja Adobe Creative Suite 3 -ohjelmistojen asennusongelmia. Katso ohjeita CS5 Cleaner Tool -työkalun lataamiseen ja suorittamiseen kohdasta Asennusongelmien ratkaisu CS5 Cleaner Tool -työkalulla  (cpsid_82947).


Ratkaisu 2: Tarkista, onko Tapahtumienvalvonta-työkalussa virhenumeroita.

Tarkista, onko Windowsin Tapahtumienvalvonta-työkalussa MSI-asennusohjelmaan liittyviä virheitä. Lisätietoja Tapahtumienvalvonta-työkalun tarkistamisesta on kohdassa Windowsin Tapahtumienvalvonta, joka on tämän dokumentin Lisätietoja-osiossa.

Katso alla olevasta taulukosta yleisiä MSI-asennusohjelmaa koskevia virhenumeroita ja ratkaisuja. Vaikka jotkin viitteenä olevat ohjeet ohjaavat tiettyyn tuotteeseen, ohjetta voi soveltaa kohteeseen, johon Tapahtumienvalvonta-työkalussa viitataan.

Virheen numero Sovellus Ratkaisu
1406 tai 1402 Acrobat TechNote 329137
1603 Koko Suite Ratkaisu 6
1309, 1321 Koko Suite Ratkaisu 9
1704 tai 1500 Koko Suite TechNote 332507

Ratkaisu 3: Poista virustentorjuntaohjelmistot ja kaikki palomuurisovellukset käytöstä ennen Creative Suite 3:n tai jonkin sen yksittäistuotteen asentamista.

Virustentorjuntaohjelmistojen tarkoitus on estää haitallisten sovellusten asentaminen järjestelmään. Jos virustentorjuntaohjelmisto epäilee, että Adobe-sovellus on virus, tuote ei asennu oikein. Lisäksi, jos virustarkistusohjelmisto tarkistaa tiedoston tai rekisterikohdan päivitystä varten, se estää käytön. Poista Adobe Creative Suite 3 -tuote, jos et ole poistanut virustentorjuntaohjelmistoa käytöstä ennen asennusta. Poista myös virustentorjuntaohjelmisto ja palomuuri käytöstä. Kun molemmat on poistettu käytöstä, asenna ohjelmisto uudelleen.

Adobe Creative Suite 3 sisältää Version Cue -nimisen ohjelman. Se asentaa Bonjour-nimisen palvelun, joka etsii verkosta muita koneita, joissa Bonjour on käytössä. Version Cuen asennus saattaa epäonnistua, jos palomuuri ei ole tietoinen tästä protokollasta ja estää sen. Poista palomuuri käytöstä asennuksen yhteydessä, jolloin tätä virheilmoitusta ei esiinny.

Ratkaisu 4: Varmista, että sinulla on riittävästi levytilaa. Jos ei, vapauta levytilaa kohdeasemaan tai asenna tuote asemaan, jossa on riittävästi levytilaa.

Tarkista asentamasi Adobe Creative Suite 3 -tuotteen järjestelmävaatimukset. Varmista, että asema, johon olet asentamassa, täyttää vähimmäisvaatimukset. Järjestelmävaatimustiedot löytyvät Adobe.com-sivuston tuotesivuilta http://www.adobe.com/fi/products.

Ratkaisu 5: Poista Adoben esijulkaisuohjelmistot.

Poista Adoben ohjelmistojen esijulkaisuversiot tai beetaohjelmistot tietokoneelta ohjeen CS3-esijulkaisujen poistaminen (kb401574) mukaan.

Ratkaisu 6: Poista Google Desktop.

Google Desktop saattaa estää Adobe Creative Suite 3 -tuotteiden asentamisen. Poista Google Desktop järjestelmäohjeiden mukaan ennen Adobe Creative Suite 3 -tuotteen asentamista.

Ratkaisu 7: Tarkista asennusväline.

Creative Suite 3 -asennusohjelman toiminta voi epäonnistua, jos Creative Suite 3 -levy on virheellinen tai vahingoittunut tai jos tietokoneen kiintolevy on viallinen.

Määritä, onko asennusväline vahingoittunut seuraavien ohjeiden avulla:

  1. Tarkista, onko DVD-levyssä pölyä tai onko se vahingoittunut. Puhdista DVD-levy pehmeällä, nukkaamattomalla kankaalla. Tarkista, onko DVD käyristynyt tai onko sen takapuolella hankausjälkiä, naarmuja tai värivirheitä.
  2. Kopioi DVD:n sisältö kiintolevylle.

  3. Kokeile asentaa Adobe Creative Suite 3 toiseen tietokoneeseen. Jos se onnistuu, ongelma saattaa johtua alkuperäisen tietokoneen tiedostojärjestelmästä tai kiintolevystä. Katso lisätietoja tämän dokumentin Lisätietoja-osiossa olevasta kohdasta Kiintolevyn tarkistustyökalut.

  4. Kokeile työpöytäasennusta. Katso lisätietoja työpöytäasennuksista jostakin seuraavista dokumenteista:
  1. Jos olet hankkinut sähköisen ohjelmistotoimituksen (ESD), lataa ohjelmisto uudelleen. Jos tiedosto on vioittunut latauksen aikana, se aiheuttaa virheitä asennuksessa.

Ratkaisu 8: Poista Flash Playerin aiemmat versiot.

Jos asennusohjelman lokitiedostossa olevassa virheviestissä on seuraavat tiedot, poista Flash Playerin aiemmat versiot:

1: 0 2: Install Flash Player 8 Plugin.msi 3: {91057632-CA70-413C-B628-2D3CDBBB906B} 4: {91057632-CA70-413C-B628-2D3CDBBB906B}; 5: 0 6: 1 7: 1 8: 0 Error 1714.The older version of Adobe Flash Player 9 Plugin cannot be removed. (”Adobe Flash Player 9 -lisäosan vanhempaa versiota ei voi poistaa”). Ota yhteyttä tekniseen tukiryhmääsi.

Flash Playerin poistaminen:

  1. Poista lokitiedostot kansiosta \Program Files\Common Files\Adobe\Installers. Tiedostot sisältävät sanat ”log” tai ”gz” tai päättyvät niihin. Poista tiedostot, ellet juuri nyt käytä niitä virheviestien paikantamiseen. Jos ne ovat sinulla käytössä, siirrä ne tästä kansiosta uuteen kansioon työpöydällä, josta voit käyttää niitä.
  2. Korjaa tai asenna Creative Suite 3.

Ratkaisu 9: Päivitä käyttöoikeudet tiedostoihin.

Jos saat virheilmoituksen "Windows Installer Error 1321 'The Installer has insufficient privileges to modify the file C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\AcrobatConnect.cfg,'” (’Asennusohjelmalla ei ole tarvittavia oikeuksia seuraavan tiedoston muokkaamiseen’), päivitä käyttöoikeudet kyseisiin kansioihin. (Virhe näkyy Tapahtumienvalvonta-työkalussa tai Adobe Creative Suiten asennuslokissa.) 

Seuraavassa on esimerkki Adobe Creative Suiten asennuslokista tai Tapahtumienvalvonta-työkalusta:

Action 11:21:48: InstallValidate. Validating install Action start 11:21:48: InstallValidate. Error 1321.The Installer has insufficient privileges to modify the file C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\AcrobatConnect.cfg. Action ended 11:21:48: InstallValidate. Return value 3. (Virhe 1401.Avaimen luominen ei onnistunut: \Software\Classes\.tif\OpenWithList\Illustrator.exe. Varmista, että sinulla on avaimeen tarvittavat käyttöoikeudet, tai ota yhteys tukihenkilöstöön. Toiminto päättyi 25:52:19: InstallFinalize. Palautusarvo 3.)

Selvitä asennuslokista, minkä kansion tai tiedoston käyttöoikeuksia täytyy muuttaa. Alla olevat ohjeet viittaavat kansioon, johon ongelmat yleisesti liittyvät. Katso tietoa asennuslokin paikantamisesta ja lukemisesta kohdasta Adobe Creative Suiten asennusloki.

Windows XP Professional:

  1. Valitse Käynnistä > Oma tietokone.
  2. Valitse Työkalut > Kansion asetukset.
  3. Napsauta Näytä-välilehteä.
  4. Vieritä Lisäasetukset-osion loppuun ja poista valinta kohdasta Käytä yksinkertaista tiedoston jakamista.
  5. Valitse OK.
  6. Valitse Käynnistä > Suorita.
  7. Kirjoita %SYSTEMROOT%\system32 ja valitse OK.
  8. Napsauta hiiren kakkospainikkeella Macromed-kansiota ja valitse Ominaisuudet.
  9. Valitse Suojaus-välilehti.
  10. Varmista, että Järjestelmänvalvojat ja SYSTEM on mainittu ja että suojauksen käyttöoikeudet on asetettu täyteen hallintaan.
  11. Napsauta Lisäasetukset.
  12. Napsauta omistaja-välilehti
  13. Valitse Järjestelmänvalvojat.
  14. Valitse Korvaa omistaja alisäilöissä ja objekteissa -asetus ja napsauta Käytä.
  15. Napsauta Käyttöoikeudet-välilehteä.
  16. Valitse "Korvaa kaikkien alemman tason objektien oikeudet näillä, jos ne koskevat alemman tason objekteja" -vaihtoehto
  17. Napsauta OK ja kyllä suojaus-ruudulla.
  18. Napsauta hiiren kakkospainikkeella Macromed-kansiota ja valitse Poista.
  19. Asenna Creative Suite uudelleen.

Windows XP Home:

  1. Käynnistä uudelleen vikasietotilassa.
  2. Käynnistä Windows uudelleen.

    1. Paina F8 ennen kuin Windows käynnistyy (kun esimerkiksi näet viestin Käynnistyksen lisäasetukset).
    2. Valitse käynnistysvaihtoehdoista vikasietotila.
    3. Kun Windows on vikasietotilassa, Vikasietotila-teksti näkyy työpöydän joka kulmassa.
      • Jos Vikasietotila-teksti ei esiinny näytön jokaisessa kulmassa, toista vaiheet a–c.
      • Jos vikasietotila-teksti on näytön jokaisessa kulmassa, kirjaudu sisään kyseisen koneen ylläpitäjänä.
    4. Jos valintaikkuna osoittaa, että Windows on vikasietotilassa, napsauta OK.
  3. Valitse Käynnistä > Oma tietokone.
  4. Valitse Työkalut > Kansion asetukset.
  5. Napsauta Näytä-välilehteä.
  6. Vieritä Lisäasetukset-osion loppuun ja poista valinta kohdasta Käytä yksinkertaista tiedoston jakamista.
  7. Valitse OK.
  8. Valitse Käynnistä > Suorita.
  9. Kirjoita %SYSTEMROOT%\system32 ja valitse OK.
  10. Napsauta hiiren kakkospainikkeella Macromed-kansiota ja valitse Ominaisuudet.
  11. Valitse Suojaus-välilehti.
  12. Varmista, että Järjestelmänvalvojat ja SYSTEM on mainittu ja että suojauksen käyttöoikeudet on asetettu täyteen hallintaan.
  13. Napsauta Lisäasetukset.
  14. Napsauta omistaja-välilehti
  15. Valitse Järjestelmänvalvojat.
  16. Valitse Korvaa omistaja alisäilöissä ja objekteissa -asetus ja napsauta Käytä.
  17. Napsauta Käyttöoikeudet-välilehteä.
  18. Valitse "Korvaa kaikkien alemman tason objektien oikeudet näillä, jos ne koskevat alemman tason objekteja" -vaihtoehto
  19. Napsauta OK ja kyllä suojaus-ruudulla.
  20. Napsauta hiiren kakkospainikkeella Macromed-kansiota ja valitse Poista.
  21. Asenna Creative Suite uudelleen.

Windows Vista:

  1. Valitse Käynnistä > Suorita.
  2. Kirjoita %SYSTEMROOT%\system32 ja valitse OK.
  3. Napsauta hiiren kakkospainikkeella Macromed-kansiota ja valitse Ominaisuudet.
  4. Valitse Suojaus-välilehti.
  5. Varmista, että Järjestelmänvalvojat ja SYSTEM on mainittu ja että suojauksen käyttöoikeudet on asetettu täyteen hallintaan.
  6. Jos järjestelmänvalvojille ja järjestelmälle ei ole asetettu täyttä hallintaa:
    1. Napsauta Muokkaus.
    2. Seuraa näytössä olevia ohjeita Käyttäjätilien valvonta -korotuskehotteeseen.
    3. Tee tarvittavat muutokset.
  7. Napsauta Lisäasetukset.
  8. Napsauta Muokkaa ja selaa Käyttäjätilien valvonta -korotuskehotteeseen.
  9. Napsauta Omistaja-välilehteä.
  10. Valitse Järjestelmänvalvojat.
  11. Valitse Korvaa omistaja alisäilöissä ja objekteissa -asetus ja napsauta Käytä.
  12. Napsauta Käyttöoikeudet-välilehteä.
  13. Valitse "Korvaa kaikkien alemman tason objektien oikeudet näillä, jos ne koskevat alemman tason objekteja" -vaihtoehto
  14. Napsauta OK ja kyllä suojaus-ruudulla.
  15. Napsauta hiiren kakkospainikkeella Macromed-kansiota ja valitse Poista.
  16. Napsauta Jatka, ja seuraa näytössä olevia ohjeita Käyttäjätilien valvonta -korotuskehotteeseen.
  17. Asenna Creative Suite uudelleen.

Komentorivi:

Tätä tapaa voi käyttää kaikissa Windows-versioissa, mutta se vaatii Komentokehote-apuohjelman käyttöä.

  1. Valitse Käynnistä > Suorita. Kirjoita Avaa-kenttään cmd. Valitse OK.

    Huomautus:
    Korota oikeudet Windows Vistassa siten että Käyttäjätilien valvonta on käytössä.





    1. Valitse Käynnistä > Apuohjelmat.
    2. Napsauta hiiren kakkospainikkeella komentorivisovellusta ja valitse komento Suorita järjestelmänvalvojana.
  2. Käytä seuraavia komentoja lainausmerkit mukaan lukien ja paina rivinvaihtonäppäintä jokaisen rivin lopussa. Muista myös lisätä välilyönti kolmannella rivillä olevien kohtien /T, /E, /C ja /G väliin:

    c: cd "%SYSTEMROOT%\system32" cacls "Macromed" /T /E /C /G Administrators:F cacls "Macromed" /T /E /C /G SYSTEM:F exit

Ratkaisu 10: Päivitä rekisteriavaimet, jotka on mainittu virhelokissa.

Jos saat Windowsin asennusohjelman virheviestin "1402 Could not read value to key" (”Avaimen arvoa ei voitu lukea”) tai "1406 Could not write value to key" (”Avaimen arvoa ei voitu kirjoittaa”), päivitä oikeudet rekisteriavaimiin. (Virhe näkyy Tapahtumienvalvonta-työkalussa tai Adobe Creative Suiten asennuslokissa.)

Selvitä asennuslokista, mikä rekisteriavain vaatii käyttäjäoikeuksien muokkaamista. Katso tietoa asennuslokin paikantamisesta ja lukemisesta kohdasta Adobe Creative Suiten asennusloki.

Seuraavassa on esimerkki Adobe Creative Suiten asennuslokista tai Tapahtumienvalvonta-työkalusta:

[6240] Fri Apr 27 18:02:12 2007 INFO Error 1406.Could not write value to key \Software\Classes\CLSID\{1171A62F-05D2-11D1-83FC-00A0C9089C5A}. Verify that you have sufficient access to that key, or contact your support personnel. [6240] Fri Apr 27 18:02:12 2007 INFO Action ended 18:02:12: InstallFinalize. Return value 3. (Virhe 1401.Avaimen luominen ei onnistunut: \Software\Classes\.tif\OpenWithList\Illustrator.exe. Varmista, että sinulla on avaimeen tarvittavat käyttöoikeudet, tai ota yhteys tukihenkilöstöön. Toiminto päättyi 25:52:19: InstallFinalize. Palautusarvo 3.)

[6321] Mon May 01 13:04:06 2007 INFO Error 1402.Could not read value to key \Software\Classes\CLSID\{1171A62F-05D2-11D1-83FC-00A0C9089C5A}. Verify that you have sufficient access to that key, or contact your support personnel. [6321] Fri May 01 13:04:06 2007 INFO Action ended 18:02:12: InstallFinalize. Return value 3. (Virhe 1401.Avaimen luominen ei onnistunut: \Software\Classes\.tif\OpenWithList\Illustrator.exe. Varmista, että sinulla on avaimeen tarvittavat käyttöoikeudet, tai ota yhteys tukihenkilöstöön. Toiminto päättyi 25:52:19: InstallFinalize. Palautusarvo 3.)

Huomautus: Suorita tässä ratkaisussa olevat vaiheet sen jälkeen, kun olet asentanut Adobe Creative Suite 3:n.

Alla lueteltu pääkäyttäjien ryhmä on paikallisten pääkäyttäjien oletusryhmä Windows XP- ja Windows Vista -versioissa.

Vastuuvapauslauseke: Tämä toimenpide sisältää Windows-rekisterin muokkauksen. Adobe ei tarjoa tukea sellaisen rekisterin muokkaamiseen, joka sisältää välttämättömiä järjestelmä- ja sovellustietoja. Varmista, että teet varmuuskopiot rekisteristä ennen kuin muokkaat sitä. Lisätietoja rekisteristä saat Windowsin dokumentoinnista tai ottamalla yhteyttä Microsoftiin.

Voit varmuuskopioida nykyisen järjestelmän ja rekisterin kahdella tapaa ennen näiden ohjeiden vaiheiden suorittamista:

  • Luo tietokoneellesi palautuspiste valitsemalla Käynnistä > Ohjelmat > Apuohjelmat > Järjestelmätyökalut > Järjestelmän palautus.
  • Varmuuskopioi nykyinen rekisteri välittömästi rekisterieditorin avaamisen jälkeen valitsemalla Tiedosto > Vie. Tallenna nykyisen rekisterin varmuuskopio käyttäen nimeä ja sijaintia, jotka muistat.

Windows XP:

  1. Kirjoita muistiin avaimen polku, johon virheviesti viittaa ja anna asennuksen jatkua. Lokitiedostossa saattaa olla useita rekisteriavaimia. Kirjoita kaikki tiedostossa mainitut polut muistiin. Esimerkiksi: \Software\Classes\CLSID\{1171A62F-05D2-11D1-83FC-00A0C9089C5A}.
  2. Valitse Käynnistä > Suorita, Kirjoita regedit Suorita-valintaruudun avoimeen tekstikenttään ja napsauta sitten OK.
  3. Varmuuskopioi nykyinen rekisteritiedosto:
    1. Valitse rekisterieditorin valintaruudussa Tiedosto > Vie.
    2. Kirjoita tiedostolle nimi ja valitse paikka.
    3. Valitse vientialueeksi Kaikki.
    4. Valitse Tallenna.
  4. Siirry virhesanomassa mainitun avaimen päätietueeseen. Esimerkiksi avaimelle \Software\Classes\CLSID\{1171A62F-05D2-11D1-83FC-00A0C9089C5A} avaa (kaksoisnapsauta) HKEY_LOCAL_MACHINE >SOFTWARE > Software > Classes > CLSID.

    Huomautus: Nämä vaiheet saattavat olla hieman erilaisia virhesanoman polun mukaan. Kaikki mainitut rekisteriavaimet alkavat HKEY_LOCAL_MACHINE-kansiosta.
  5. Napsauta hiiren kakkospainikkeella pääavainta ja valitse käyttöoikeudet (HKEY_LOCAL_MACHINE\SOFTWARE\Software\Classes\CLSID).
  6. Tarkista, että Järjestelmänvalvojat ja SYSTEM ovat luettelossa ja että Salli-sarakkeesta on valittu Täydet oikeudet.
  7. Napsauta Lisäasetukset Käyttöoikeudet-valintaruudussa.




    Napsauta Lisäasetukset Käyttöoikeudet-valintaruudussa
  8. Valitse Järjestelmänvalvojat-ryhmä (1), valitse Korvaa omistaja alisäilöissä ja objekteissa (2), napsauta Käytä (3) ja valitse Käyttöoikeudet-välilehti (4).

    Huomautus: Valitse nykyinen pääkäyttäjätili, jos pääkäyttäjäryhmä ei ole käytettävissä.





    Valitse ”Korvaa omistaja...” ja napsauta Käytä.
  9. Valitse Palauta käyttöoikeudet ja ota käyttöön oikeuksien periytyminen näille aliobjekteille (1) ja napsauta sitten OK (2).




    Valitse ”Palauta käyttöoikeudet...” ja napsauta OK.
  10. Napsauta Lisäsuojausasetukset-valintaruudussa OK. Windows määrittää alempien tasojen oikeudet ylätason oikeuksien mukaisiksi.
  11. Toista vaiheet 1–10 kaikille muille rekisteriavaimille.

Windows Vista:

  1. Kirjoita ylös polku virhesanomassa viitattuun avaimeen. Lokitiedostossa saattaa olla useita rekisteriavaimia. Kirjoita kaikki tiedostossa mainitut polut muistiin. Esimerkiksi: \Software\Classes\CLSID\{1171A62F-05D2-11D1-83FC-00A0C9089C5A}.
  2. Valitse Käynnistä, kirjoita regedit hakukenttään ja paina sitten Enter.
  3. Varmuuskopioi nykyinen rekisteritiedosto:

    1. Valitse rekisterieditorin valintaruudussa Tiedosto > Vie.
    2. Kirjoita tiedostolle nimi ja valitse paikka.
    3. Valitse vientialueeksi Kaikki.
    4. Valitse Tallenna.
    5. Sulje Regedit.
  4. Siirry virhesanomassa mainitun avaimen päätietueeseen. Esimerkiksi avaimelle \Software\Classes\CLSID\{1171A62F-05D2-11D1-83FC-00A0C9089C5A} avaa (kaksoisnapsauta) HKEY_LOCAL_MACHINE >SOFTWARE > Software > Classes > CLSID.

    Huomautus: Nämä vaiheet saattavat olla hieman erilaisia virhesanoman polun mukaan. Kaikki mainitut rekisteriavaimet alkavat HKEY_LOCAL_MACHINE-kansiosta.
  5. Napsauta hiiren kakkospainikkeella pääavainta ja valitse käyttöoikeudet (HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID).
  6. Tarkista, että Järjestelmänvalvojat ja SYSTEM ovat luettelossa ja että Salli-sarakkeesta on valittu Täydet oikeudet.
  7. Napsauta Lisäasetukset Käyttöoikeudet-valintaruudussa.
  8. Valitse Omistaja-välilehdestä Järjestelmänvalvojat-ryhmä ja lisää valintamerkki kohtaan ”Korvaa omistaja alisäilöissä ja objekteissa”.

    Huomautus: Valitse nykyinen pääkäyttäjätili, jos Järjestelmänvalvojat-ryhmä ei ole käytettävissä.
  9. Valitse Oikeudet-välilehdellä vaihtoehto ”Salli periytyvien käyttöoikeuksien välitys pääobjektista tälle objektille”. Valitse myös vaihtoehto ”Palauta käyttöoikeudet ja ota käyttöön oikeuksien periytyminen näille aliobjekteille”.
  10. Napsauta Lisäsuojausasetukset-valintaruudussa OK. Windows määrittää alempien tasojen oikeudet ylätason oikeuksien mukaisiksi.
  11. Toista vaiheet 1–10 kaikille muille rekisteriavaimille.

Jos Adobe Creative Suite 3 näyttää edelleen virheviestin, tarkista virheen aiheuttavan rekisteriavaimen käyttöoikeudet. Joissakin tapauksissa avaimen nimeäminen uudelleen asettaa asennusohjelman luomaan avaimen uudelleen ja palauttamaan käyttöoikeudet, jos avain on viallinen. Jos et voi vaihtaa käyttöoikeuksia tai nimetä tätä avainta uudelleen, ota yhteyttä Microsoftiin tai laitteistokauppiaaseen.

Ratkaisu 11: Poista nykyiset Adobe-väriprofiilit ja päivitä rekisteriasetukset.

Jos saat Windowsin asennusohjelmaa koskevan virheviestin ”Updating component registration Message type: 2, Argument: 1 Message type: 2, Argument: 1”, poista nykyiset Adobe-väriprofiilit ja päivitä oikeudet rekisteriavaimiin. (Virhe näkyy Tapahtumienvalvonta-työkalussa tai Adobe Creative Suiten asennuslokissa.)

Tarkista, että virhe on kirjattu lokitiedostoon etsimällä asennuslokista palautusarvoa 3. Katso tietoa asennuslokin paikantamisesta ja lukemisesta kohdasta Adobe Creative Suiten asennusloki.

Seuraavassa on esimerkki Adobe Creative Suiten asennuslokista tai Tapahtumienvalvonta-työkalusta:

UninstallColorProfilesRollback.E35C3ECB_5FDA_49E1_AB1F_D472B7CB9017 (Adobe) -*-*-*-*-*-*-*-*-*-*-*-*- BEGIN - Adobe_UninstallColorProfiles -*-*-*-*-*-*-*-*-*-*-*-*- (Adobe) UninstallColorProfiles - MSIRUNMODE_ROLLBACK (Adobe) Requesting property: CustomActionData (Adobe) Property cannot be retrieved (Adobe) No Color Profiles to manipulate (Adobe) -*-*-*-*-*-*-*-*-*-*-*-*- END - Adobe_UninstallColorProfiles -*-*-*-*-*-*-*-*-*-*-*-*- Removing ODBC components Updating component registration Message type: 2, Argument: 1 Message type: 2, Argument: 1 Action ended 13:52:26: INSTALL. Return value 3. (Virhe 1401.Avaimen luominen ei onnistunut: \Software\Classes\.tif\OpenWithList\Illustrator.exe. Varmista, että sinulla on avaimeen tarvittavat käyttöoikeudet, tai ota yhteys tukihenkilöstöön. Toiminto päättyi 25:52:19: InstallFinalize. Palautusarvo 3.)

Alla lueteltu pääkäyttäjien ryhmä on paikallisten pääkäyttäjien oletusryhmä Windows XP- ja Windows Vista -versioissa.

Vastuuvapauslauseke: Tämä toimenpide sisältää Windows-rekisterin muokkauksen. Adobe ei tarjoa tukea sellaisen rekisterin muokkaamiseen, joka sisältää välttämättömiä järjestelmä- ja sovellustietoja. Varmista, että teet varmuuskopiot rekisteristä ennen kuin muokkaat sitä. Lisätietoja rekisteristä saat Windowsin dokumentoinnista tai ottamalla yhteyttä Microsoftiin.

Voit varmuuskopioida nykyisen järjestelmän ja rekisterin kahdella tapaa ennen näiden ohjeiden vaiheiden suorittamista:

  • Luo tietokoneellesi palautuspiste valitsemalla Käynnistä > Ohjelmat > Apuohjelmat > Järjestelmätyökalut > Järjestelmän palautus.
  • Ota varmuuskopio nykyisestä rekisteristä heti rekisterieditorin avaamisen jälkeen valitsemalla Tiedosto > Vie. Tallenna nykyisen rekisterin varmuuskopio käyttäen nimeä ja sijaintia, jotka muistat.

Vanhojen ICC-profiilien poistaminen

  1. Siirry Windowsin resurssienhallinnassa kohtaan\WINDOWS\system32\spool\drivers\color.
  2. Poista seuraavat ICC-profiilit:
    • AdobeRGB1998.icc
    • AppleRGB.icc
    • ColorMatchRGB.icc
    • EuropeISOCoatedFOGRA27.icc
    • EuroscaleUncoated.icc
    • JapanColor2001Coated.icc
    • JapanColor2001Uncoated.icc
    • JapanColor2002Newspaper.icc
    • JapanWebCoated.icc
    • USSheetfedCoated.icc
    • USSheetfedUncoated.icc
    • USWebCoatedSWOP.icc
    • USWebUncoated.icc



      Huomautus: Kaikkia lueteltuja tiedostoja ei ehkä löydy hakemistoista. Poista kaikki ne, jotka sieltä löytyvät. Jos et onnistu poistamaan ICC-profiilia, kokeile korjata kansion oikeudet. Käytä Ratkaisussa 9: Päivitä käyttöoikeudet tiedostoihin
      olevia ohjeita apuna.



  3. Toista vaiheet 1–2 käyttäen kansion sijaintina seuraavaa: \Program Files\Common Files\Adobe\Color\Profiles.

Rekisteriavaimen päivittäminen

Windows XP:

  1. Valitse Käynnistä > Suorita, Kirjoita regedit Suorita-valintaruudun avoimeen tekstikenttään ja napsauta sitten OK.
  2. Varmuuskopioi nykyinen rekisteritiedosto:
    1. Valitse rekisterieditorin valintaruudussa Tiedosto > Vie.
    2. Kirjoita tiedostolle nimi ja valitse paikka.
    3. Valitse vientialueeksi Kaikki.
    4. Valitse Tallenna.
  3. Siirry kohtaan HKLM\SOFTWARE\Adobe\.
  4. Napsauta hiiren kakkospainikkeella PDF:n järjestelmänvalvojan asetukset ja valitse Oikeudet.
  5. Tarkista, että Järjestelmänvalvojat ja SYSTEM ovat luettelossa ja että Salli-sarakkeesta on valittu Täydet oikeudet.
  6. Napsauta Lisäasetukset Käyttöoikeudet-valintaruudussa.




    Napsauta Käyttöoikeudet-valintaruudussa kohtaa Lisäasetukset
  7. Valitse Järjestelmänvalvojat-ryhmä (1), valitse Korvaa omistaja alisäilöissä ja objekteissa (2), napsauta Käytä (3) ja valitse Käyttöoikeudet-välilehti (4).

    Huomautus: Valitse nykyinen pääkäyttäjätili, jos pääkäyttäjäryhmä ei ole käytettävissä.





    Valitse ”Korvaa omistaja...” ja sen jälkeen Käytä.
  8. Valitse Palauta käyttöoikeudet ja ota käyttöön oikeuksien periytyminen näille aliobjekteille (1) ja napsauta sitten OK (2).




    Valitse ”Palauta käyttöoikeudet...” ja napsauta OK.
  9. Napsauta OK (3) "Lisäsuojausasetukset" -valintaruudussa. Windows määrittää alempien tasojen oikeudet ylätason oikeuksien mukaisiksi.

Windows Vista:

  1. Valitse Käynnistä, kirjoita regedit hakukenttään ja paina sitten Enter.
  2. Varmuuskopioi nykyinen rekisteritiedosto:

    1. Valitse rekisterieditorin valintaruudussa Tiedosto > Vie.
    2. Kirjoita tiedostolle nimi ja valitse paikka.
    3. Valitse vientialueeksi Kaikki.
    4. Valitse Tallenna.
    5. Sulje Regedit.
  3. Siirry kohtaan HKLM\SOFTWARE\Adobe\
  4. Napsauta hiiren kakkospainikkeella PDF:n järjestelmänvalvojan asetukset.
  5. Tarkista, että Järjestelmänvalvojat ja SYSTEM ovat luettelossa ja että Salli-sarakkeesta on valittu Täydet oikeudet.
  6. Napsauta Lisäasetukset Käyttöoikeudet-valintaruudussa.
  7. Valitse Omistaja-välilehdestä Järjestelmänvalvojat-ryhmä ja lisää valintamerkki kohtaan ”Korvaa omistaja alisäilöissä ja objekteissa”.

    Huomautus: Valitse nykyinen pääkäyttäjätili, jos Järjestelmänvalvojat-ryhmä ei ole käytettävissä.
  8. Valitse Oikeudet-välilehdellä vaihtoehto ”Salli periytyvien käyttöoikeuksien välitys pääobjektista tälle objektille”. Valitse myös vaihtoehto ”Palauta käyttöoikeudet ja ota käyttöön oikeuksien periytyminen näille aliobjekteille”.
  9. Napsauta Lisäsuojausasetukset-valintaruudussa OK. Windows määrittää alempien tasojen oikeudet ylätason oikeuksien mukaisiksi.

Jos et voi vaihtaa käyttöoikeuksia tai nimetä tätä avainta uudelleen, ota yhteyttä Microsoftiin tai laitteistokauppiaaseen.

Ratkaisu 12: Ota yhteyttä Adoben tekniseen tukeen.

Jos mikään edellä olevista ratkaisuista ei auta etkä onnistu asentamaan Creative Suite 3 -tuotetta, ota yhteyttä Adoben tekniseen tukeen. Varmista, että asennusohjelman lokitiedosto ja Tapahtumienvalvonta-työkalun tiedot ovat saatavilla, jos sinua pyydetään lähettämään ne. Katso lisätietoja siitä, miten saat nämä tiedot ohjeesta Adobe Creative Suiten asennusloki tai Windowsin Tapahtumienvalvonta.

Lisätietoja

Windowsin Tapahtumienvalvonta-työkalu ja Adobe Creative Suiten asennusohjelma auttavat ongelman syyn määrityksessä.

Windowsin Tapahtumienvalvonta

Tapahtumienvalvonta on Microsoftin apuohjelma, joka kerää tietoa virheistä, joita esiintyy Windowsia käytettäessä. Adobe Creative Suite 3 -asennusohjelma käyttää useita Windowsin asennusohjelmia eri tuotteiden asennuksen aikana. Windowsin Tapahtumienvalvonta-työkalua voi käyttää Windows-asennusohjelman käytössä ilmenevien ongelmien vianmääritykseen.

  1. Käynnistä Tapahtumienvalvonta.
    • Windows XP
      1. Valitse Käynnistä > Suorita, ja kirjoita eventvwr
      2. Valitse OK.
    • Windows Vista
      1. Napsauta Käynnistä-painiketta.
      2. Kirjoita hakukenttään eventvwr ja paina Enter-näppäintä.
  2. Valitse Sovellus.
  3. Etsi Tyyppi-sarakkeesta keltaisia varoituksia ja punaisia virheitä, jotka sisältävät Lähde-sarakkeessa myös MSI-asennusohjelman.

    Huomautus: Joskus tiedot osoittavat sovellukseen tai palveluun, joka aiheuttaa ristiriidan asennusohjelman kanssa ja aiheuttaa asennusohjelman toiminnan epäonnistumisen. Adoben tukipalvelut saattavat tarvita näitä tietoja, jos otat yhteyttä Adoben tekniseen tukeen.

Adobe Creative Suiten asennusloki

Adobe Creative Suite 3:n asennuslokissa on tarkat tiedot asennuksen epäonnistumisesta (tai onnistumisesta). Lokitiedoston avulla ongelma voidaan selvittää nopeasti. Jokaisen asennusyrityksen yhteydessä edelliseen asennuslokiin lisätään tietoa. Jos vanha asennusloki poistetaan ennen uutta asennusyritystä, vianmääritys saattaa sujua helpommin. Lokitiedosto luodaan niin Windows- kuin Mac OS -käyttöjärjestelmässäkin. Virheviestien muoto on kuitenkin erilainen käyttöjärjestelmien erojen vuoksi.

  1. Siirry Adobe Creative Suite 3:n lokitiedostoon.

    \Program Files\Common Files\Adobe\Installers-kansio.
  2. Pura Adobe Creative Suite 3:n lokitiedosto.

    Tärkeää: Lokitiedoston arkistoinnissa käytetään gzip-pakkausohjelmaa, ja sen purkamiseen tarvitaan purkuohjelma, kuten Winzip tai WinRAR.

    Lokitiedoston nimeä koskeva huomautus:
    • Esimerkiksi Creative Suite 3 Design Premium -version lokitiedosto on nimeltään Adobe Creative Suite 3 Design Premium 1.0.log.gz.
  3. Hae lokitiedostoja seuraavilla merkkikoon huomioivilla avainsanoilla: FATAL, DEBUG, ERROR ja Return Value 3 (vain Windows).
    Jos lokitiedosto sisältää yhden tai useamman seuraavista virheviesteistä, kokeile Ratkaisuja 1–5 ja sen jälkeen virheviestin vieressä olevaa ratkaisua:

Kiintolevyn tarkistustyökalut

Voit varmistaa kiintolevyn eheyden suorittamalla levyn tarkistukseen tarkoitettuja apuohjelmia. Vahingoittuneet sektorit, ristikkäiskytketyt tiedostot tai muut tiedostojen vioittumiset saattavat aiheuttaa asennuksen epäonnistumisen. Näiden apuohjelmien suorittaminen auttaa korjaamaan virheitä kiintolevyssä tai tunnistamaan ongelmia.

Levyn eheytys

Windowsin Levyn eheytys -työkalu on suunniteltu lisäämään käyttönopeutta (ja joskus myös lisäämään käytettävissä olevan levytilan määrää). Levyn eheytys järjestää levylle tallennetut tiedostot uudelleen vierekkäisten säilytystilojen käyttämiseksi.

Levyn eheytys -työkalun käynnistäminen:

  1. Valitse Käynnistä > Kaikki ohjelmat > Apuohjelmat > Järjestelmätyökalut > Levyn eheytys.
  2. Valitse Pääasiallinen kiintolevy ja napsauta Eheytä.

Chkdsk

Chkdsk on komentoriviapuohjelma, joka tarkistaa, onko kiintolevyssä virheitä ja viallisia sektoreita. ”f”-kytkin on suunniteltu tarkistamaan virheet ja korjaamaan löytyneet virheet.

Käynnistä Chkdsk

  • Windows XP
    1. Valitse Käynnistä > Suorita.
    2. Kirjoita cmd ja napsauta OK.
    3. Kirjoita chkdsk /f ja paina Enter-näppäintä.
    4. Kun tarkistus on valmis, kirjoita exit ja paina Enter-näppäintä.
  • Windows Vista
    1. Valitse Käynnistä > Ohjelmat > Apuohjelmat.
    2. Napsauta hiiren kakkospainikkeella komentokehotetta ja valitse komento Suorita järjestelmänvalvojana.



      Huomautus: Jos näytöllä näkyy Käyttäjätilien valvonta -valintaikkunoita, noudata ohjeita prosessin sallimiseksi. Anna kehotettaessa järjestelmänvalvojan tunnus ja salasana.



    3. Kirjoita cmd ja napsauta OK.
    4. Kirjoita chkdsk /f ja paina Enter-näppäintä.
    5. Kun tarkistus on valmis, kirjoita exit ja paina Enter-näppäintä.


Lisensoitu Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License -lisenssin mukaan.  Creative Commons -lisenssien ehdot eivät koske Twitter™- ja Facebook-viestejä.

Lakisääteiset ilmoitukset   |   Online-tietosuojakäytäntö