Lisez ce document pour en savoir plus sur les types de projet dans After Effects

À propos des projets

Un projet After Effects est un fichier unique dans lequel sont stockées les compositions et les références à tous les métrages auxquels le projet fait appel. Les compositions sont des ensembles de calques. Si bon nombre de calques utilisent des éléments de métrage (comme des films ou des images fixes) en tant que source, d’autres (par exemple, les calques de forme et de texte) contiennent des graphiques créés dans After Effects.

Un fichier de projet porte l’extension .aep ou .aepx. Un fichier de projet portant l’extension .aep est un fichier de projet binaire, tandis qu’un fichier de projet portant l’extension .aepx est un fichier de projet XML texte.

Le nom du projet actif est indiqué en haut de la fenêtre de l’application.

Un modèle de fichier de projet porte l’extension .aet. Voir Modèles de projets et exemples de projets.

Fichiers de projet XML

Les fichiers de projet XML contiennent certaines informations relatives au projet, sous forme de données binaires codées au format hexadécimal. Toutefois, la majorité de ces informations se présentent sous la forme de texte lisible dans des éléments de chaîne. Vous pouvez ouvrir un fichier de projet XML dans un éditeur de texte et modifier certains détails relatifs au projet sans ouvrir ce dernier dans After Effects. Vous pouvez même écrire des scripts permettant de modifier les informations d’un fichier de projet XML, dans le cadre d’un workflow automatisé.

Les éléments d’un projet que vous pouvez modifier dans un fichier de projet XML sont les suivants :

  • Les attributs de repères, y compris les commentaires, les paramètres de points de chapitre et les paramètres de signal de départ

  • Les chemins d’accès aux éléments de métrage sources, y compris les doublures

  • Les noms de la composition, des éléments de métrage, des calques et des dossiers, ainsi que les commentaires

Remarque :

les noms des éléments de métrage sont présentés sous la forme de chaînes dans les fichiers de projet XML uniquement s’ils ont été personnalisés. En revanche, les noms d’éléments de métrage obtenus de façon automatique à partir des fichiers source et des couleurs unies n’apparaissent pas sous forme de chaînes

Certaines chaînes, comme les noms des espaces de travail et des vues, sont affichées de manière lisible, mais les modifications qui y sont apportées ne sont pas respectées à l’ouverture du fichier de projet dans After Effects.

Remarque :

évitez d’utiliser le format de fichier de projet XML comme format principal. En effet, dans After Effects, il s’agit du format de fichier de projet binaire (.aep). Vous pouvez faire appel au format XML pour enregistrer une copie d’un projet ou l’employer comme format intermédiaire pour les workflows d’automatisation.

Remarque :

Pour enregistrer un fichier de projet XML (.aepx) en tant que fichier de projet binaire (.aep), sélectionnez Fichier > Enregistrer sous, puis saisissez le nom du fichier avec le suffixe .aep, sans le x (voir Enregistrement et sauvegarde de projets dans After Effects.)

Liens de projets incorporés dans les fichiers QuickTime et Video for Windows

Lorsque vous effectuez le rendu d’un film et que vous l’exportez au format de conteneur, vous pouvez y incorporer un lien vers le projet After Effects.

Pour importer le projet, importez le fichier conteneur, puis choisissez la commande Projet dans le menu Importer sous de la boîte de dialogue Importer fichier. Si le fichier conteneur comporte un lien vers un projet qui a été déplacé, vous pouvez le rechercher.

Création et ouverture de projets

Un seul projet peut être ouvert à la fois. Si vous créez ou ouvrez un fichier de projet alors qu’un autre projet est déjà ouvert, un message After Effects vous invite à enregistrer les modifications apportées au projet ouvert, puis ferme ce dernier. Après avoir créé un projet, vous pouvez y importer un métrage.

  • Pour créer un projet, choisissez Fichier > Nouveau > Nouveau projet.

  • Pour ouvrir un projet, choisissez Fichier > Ouvrir un projet, recherchez le projet, puis cliquez sur Ouvrir.

Vous pouvez également créer et ouvrir un projet à partir de l’écran de démarrage.

  • Pour créer un projet, cliquez sur Nouveau projet.
  • Pour ouvrir un projet, cliquez sur Ouvrir un projet, puis accédez à son emplacement.

Sur son site Web redefinery, Jeff Almasol propose un script qui crée et enregistre un projet pour chacune des compositions sélectionnées dans le projet actuel.

Modèles de projets et exemples de projets

Un modèle de projet est un fichier dont l’extension de nom de fichier est .aet. Vous pouvez créer des modèles sur la base de vos projets.

Remarque :

After Effects CC n’installe pas de modèles de projet.

Lorsque vous ouvrez un modèle de projet, After Effects crée un nouveau projet sans titre basé sur ce modèle. Les modifications que vous apportez à ce nouveau projet n’affectent en rien le modèle.

Remarque :

Un moyen simple de découvrir la façon dont les utilisateurs avancés travaillent avec After Effects est d’ouvrir l’un des modèles de projet fournis avec After Effects, d’ouvrir une composition pour l’activer et d’appuyer sur U ou UU sur le clavier pour afficher uniquement les propriétés de calque animées ou modifiées. Vous verrez ainsi les modifications effectuées pour créer ce modèle.

Il est fréquent que le créateur d’un modèle de projet verrouille les calques qu’il convient de ne pas modifier et qu’il laisse déverrouillés ceux destinés à être modifiés. Il s’agit d’un moyen pratique d’empêcher toute modification fortuite ou inopportune.

Pour trouver d’autres exemples et modèles de projets After Effects, rendez-vous sur la page Ressources communautaires d’After Effects sur le site Web d’Adobe.

Visionnez ce didacticiel vidéo d’Andrew Devis sur le site Web Creative COW pour savoir où trouver les modèles de projets et les échantillons d’expressions inclus avec After Effects.

Ouverture d’un modèle de projet

  • Pour ouvrir un modèle de projet, choisissez Fichier > Ouvrir un projet. Sous Windows, choisissez Adobe After Effects Project Template dans le menu Fichiers de type.

Création d’un modèle de projet

  • Pour convertir un projet en modèle de projet, remplacez l’extension de nom de fichier .aep par l’extension .aet.
  • Pour enregistrer une copie d’un projet en tant que modèle de projet, sélectionnez Fichier > Enregistrer une copie sous, puis renommez la copie en ajoutant l’extension de nom de fichier .aet.

Définition d’un modèle pour les nouveaux projets

Vous pouvez créer un modèle avec vos paramètres de projet préférés, tels que la gestion des couleurs et la structure de dossiers, et l’utiliser comme base pour chaque nouveau projet.

Pour définir un modèle pour vos nouveaux projets After Effects, procédez comme suit :

  1. Sélectionnez Édition > Préférences > Nouveau projet.
  2. Cochez la case Le nouveau projet charge le modèle.
  3. Cliquez sur Sélectionnez le modèle de projet et choisissez ensuite un fichier de modèle. 

Remarque :

Le modèle de projet peut être au format .aet, .aep ou .aex.

Projets d’équipe

Projets d’équipe est un service de collaboration hébergé destiné aux équipes et aux utilisateurs professionnels de CC. Il permet aux monteurs de collaborer, aisément et en temps réel, sur le workflow de montage. Le service Projets d’équipe permet aux monteurs et spécialistes de l’animation graphique de travailler simultanément sur des projets d’équipe partagés dans Adobe Premiere Pro CC, Adobe After Effects CC et Adobe Prelude CC, sans faire usage de matériel supplémentaire.

Les mises à jour du projet font l’objet d’un suivi sécurisé en mode cloud et les fichiers source sont enregistrés en local ou sur des doublures légères partagées. Le service Projets d’équipe ajoute des fonctionnalités de collaboration approfondies, telles que le contrôle des versions et la résolution intelligente des conflits.

  • Pour créer un projet d’équipe, sélectionnez Fichier > Nouveau > Nouveau Projet d’équipe.
  • Pour ouvrir un projet d’équipe, sélectionnez Fichier > Ouvrir Projet d’équipe.

Pour obtenir des informations détaillées sur l’utilisation du service Projets d’équipe pour votre workflow de collaboration, voir Traitement simultané de plusieurs projets vidéo partagés.

Convertir un Projet d’équipe en projet Adobe After Effects

Vous pouvez convertir vos Projets d’équipe en projets locaux Adobe After Effects (.aep). SélectionnezEdition > Projets d’équipe > Convertir le Projet d’équipe en projet.

Conversion d’un Projet d’équipe en projet Adobe After Effects
Conversion d’un Projet d’équipe en projet Adobe After Effects

Enregistrement et sauvegarde de projets dans After Effects

  • Pour enregistrer un projet, choisissez Fichier > Enregistrer.
  • Pour enregistrer une copie du projet sous un nom généré automatiquement, sélectionnez Fichier > Incrémenter et enregistrer, ou appuyez sur les touches Ctrl + Alt + Maj + S (Windows) ou Commande + Option + Maj + S (Mac OS).
  • Une copie du projet en cours est enregistrée dans le dossier du projet d’origine. Le nom de la copie est formé du nom du projet d’origine suivi d’un numéro. Si le nom du projet d’origine s’achève déjà par un numéro, celui-ci est augmenté de 1.
  • Pour enregistrer le projet sous un nom ou un emplacement différent, choisissez Fichier > Enregistrer sous > Enregistrer sous. Le projet ouvert adopte le nouveau nom et se place dans le nouveau répertoire. Le fichier d’origine, quant à lui, ne change pas.
  • Pour enregistrer le projet en tant que copie au format de fichier XML, sélectionnez Fichier > Enregistrer sous > Enregistrer une copie sous XML (voir À propos des projets).
  • Pour enregistrer une copie du projet sous un nom ou à un emplacement différent, sélectionnez Fichier > Enregistrer sous > Enregistrer une copie. Le projet ouvert conserve son nom d’origine et ne change pas de répertoire. La copie est créée avec les nouveaux paramètres, mais elle ne s’ouvre pas.
  • Pour enregistrer une copie d’un projet afin qu’elle puisse être ouverte par la version principale précédente, sélectionnez Fichier > Enregistrer sous > Enregistrer une copie sous <numéro de la version principale précédente>. (Pour plus d’informations, consultez ce blog.)

Remarque :

Les nouvelles fonctionnalités de la version actuelle d’After Effects utilisées dans un projet sont ignorées une fois le projet enregistré au format de la version précédente d’After Effects.

Pour enregistrer une copie du projet et des copies des éléments qui y sont utilisés dans un dossier du disque, utilisez la commande Rassembler les fichiers. (Pour plus d’informations, voir Rassemblement des fichiers dans un emplacement unique).

Panneau Organigramme

Dans l’organigramme de chaque projet ou composition, les cases (ou cadres) représentent chaque composition, métrage et calque, tandis que les flèches directionnelles représentent la corrélation des composants.

Remarque :

le panneau Organigramme affiche uniquement les interdépendances existantes. Il ne vous permet pas de modifier l’interdépendance des éléments.

Les compositions imbriquées et tous les autres éléments constitutifs d’une composition sont visibles lorsque le titre de la composition est développé.

La présence de lignes d’un gris moyen entre les cadres de l’organigramme indique que les options Audio ou Vidéo de ces éléments sont désélectionnées dans le panneau Montage. Si ces lignes sont noires ou gris clair, cela signifie que ces options sont sélectionnées. La couleur des lignes dépend alors de la valeur du paramètre Luminosité dans les préférences d’aspect.

  • Pour ouvrir l’organigramme du projet, appuyez sur les touches Ctrl + F11 (Windows) ou Commande + F11 (Mac OS) ou cliquez sur le bouton Organigramme des projets au-dessus de la barre de défilement verticale à droite du panneau Projet.
  • Pour ouvrir l’organigramme d’une composition, sélectionnez la composition, puis choisissez Composition > Organigramme de la composition ou cliquez sur le bouton Organigramme des comp. en bas du panneau Composition.
  • Pour activer (sélectionner) un élément, cliquez sur le cadre correspondant dans le panneau Organigramme.

    Lorsque vous cliquez sur une composition dans l’organigramme, elle devient active dans le panneau Projet et le panneau Montage. Lorsque vous cliquez sur un calque, il devient actif dans le panneau Montage. Lorsque vous cliquez sur un métrage, il devient actif dans le panneau Projet.

  • Pour personnaliser l’aspect de l’organigramme, utilisez le menu du panneau Organigramme et les boutons alignés au bas du panneau.

Remarque :

Pour afficher les info-bulles identifiant les boutons du panneau Organigramme, faites pointer votre curseur sur un bouton et attendez que l’info-bulle correspondante s’affiche.

  • Pour supprimer des éléments, sélectionnez-les et cliquez sur Suppr. Si l’élément sélectionné est un métrage ou une composition, il est supprimé du projet et n’est donc plus visible dans le panneau Montage, ni le panneau Projet. S’il s’agit d’un calque, il est supprimé de la composition où il apparaît.
  • Pour accéder au menu contextuel associé à l’élément sélectionné, cliquez sur l’icône située à gauche du nom dans le titre de l’élément avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Mac OS). Les icônes adoptent un aspect différent selon le type d’élément : par exemple, calque et composition . Vous pouvez ainsi utiliser le menu contextuel associé à un calque pour travailler avec des masques et des effets ou modifier des options, appliquer des transformations et ajuster la qualité d’image du calque.

Remarque :

lorsque vous modifiez les propriétés d’un élément dans le panneau Organigramme, veillez à effectuer un clic contextuel sur l’icône du cadre, et non sur le nom de l’élément. Le menu contextuel associé à l’icône de l’élément est différent de celui qui s’ouvre depuis le nom de l’élément.

Sur le site Web After Effects Portal, Rich Young propose des informations supplémentaires sur le panneau Organigramme et le mini-organigramme des compositions.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne