User Guide Cancel

Work with Smart Objects

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop on the iPad
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
    29. Auto adjustment commands in Photoshop on the iPad
    30. Smudge areas in your images with Photoshop on the iPad
    31. Saturate or desaturate your images using Sponge tool
    32. Content aware fill for iPad
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
    19. Generate Image
    20. Generate Background
    21. Reference Image
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
    3. Generate image with descriptive text prompts
    4. Generate background with descriptive text prompts
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Blur Gallery
    2. Filter basics
    3. Filter effects reference
    4. Add Lighting Effects
    5. Use the Adaptive Wide Angle filter
    6. Use the Oil Paint filter
    7. Use the Liquify filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

Understand Smart Objects and use them for non-destructive edits in Photoshop.

Topics in this article:

What are Smart Objects

Smart Objects are layers that contain image data from raster or vector images, such as Photoshop or Illustrator files. Smart Objects preserve an image's source content with all its original characteristics, enabling you to perform nondestructive editing to the layer.

In Photoshop, you can embed the contents of an image into a Photoshop document. In Photoshop, you can also create Linked Smart Objects whose contents are referenced from external image files. The contents of a Linked Smart Object are updated when its source image file changes.

Linked Smart Objects are distinct from duplicated instances of a Smart Object within a Photoshop document. With Linked Smart Objects, you can use a shared source file across multiple Photoshop documents which is a familiar and welcome concept for web designers.

Smart Object benefits

With Smart Objects, you can:

  • Perform nondestructive transforms. You can scale, rotate, skew, distort, perspective transform, or warp a layer without losing original image data or quality because the transforms don't affect the original data.

  • Work with vector data, such as vector artwork from Illustrator, that otherwise would be rasterized in Photoshop.

  • Perform nondestructive filtering. You can edit filters applied to Smart Objects at any time.

  • Edit one Smart Object and automatically update all its linked instances.

  • Apply a layer mask that's either linked or unlinked to the Smart Object layer.

  • Try various designs with low-resolution placeholder images that you later replace with final versions.

You can't perform operations that alter pixel data—such as painting, dodging, burning, or cloning—directly to a Smart Object layer, unless it is first converted into a regular layer, which will be rasterized. To perform operations that alter pixel data, you can edit the contents of a Smart Object, clone a new layer above the Smart Object layer, edit duplicates of the Smart Object, or create a new layer.

Note:

When you transform a Smart Object that has a Smart Filter applied to it, Photoshop turns off filter effects while the transform is being performed. Filter effects are applied again after the transform is complete. See Apply Smart Filters.

Photoshop smart object benefits
Regular layer and a Smart Object in the Layers panel. The icon in the lower-right corner of the thumbnail indicates a Smart Object.

Photoshop Smart Object in the Layers panel
(Photoshop) A linked Smart Object in the Layers panel

Create embedded Smart Objects

You can create embedded Smart Objects using several methods: by using the Open As Smart Object command; placing a file (Photoshop CS6) or placing a file as embedded (Photoshop, and Photoshop CS6), pasting data from Illustrator; or converting one or more Photoshop layers to Smart Objects.

  1. Do any of the following:
    • (Photoshop) Choose File > Place Embedded to import files as Smart Objects into an open Photoshop document.
    • Choose File > Open As Smart Object, select a file, and click Open.
    • (Photoshop CS6) Choose File> Place to import files as Smart Objects into an open Photoshop document.
    Note:

    Although you can place JPEG files, it's better to place PSD, TIFF, or PSB files because you can add layers, modify pixels, and resave the file without loss. (Saving a modified JPEG file requires you to flatten new layers and recompress the image, causing image quality degradation).

    • Choose Layer > Smart Object > Convert to Smart Object to convert a selected layer into a Smart Object.
    • In Bridge, choose File > Place > In Photoshop to import a file as a Smart Object into an open Photoshop document.
    • Select one or more layers and choose Layer > Smart Objects > Convert To Smart Object. The layers are bundled into one Smart Object.

    • Drag PDF or Adobe Illustrator layers or objects into a Photoshop document.

    • Paste artwork from Illustrator into a Photoshop document, and choose Smart Object in the Paste dialog box. For the greatest flexibility, enable both PDF and AICB (No Transparency Support) in the File Handling & Clipboard section of the Preferences dialog box in Adobe Illustrator.

Create linked Smart Objects

In Photoshop, you can create Linked Smart Objects. The contents of Linked Smart Objects are updated when the source image file changes. Linked Smart Objects are particularly useful for teams or in cases where assets must be reused across designs.

Follow these steps to create a Linked Smart Object:

  1. Choose File > Place Linked.
  2. Select an appropriate file and click Place.

The Linked Smart Object is created and is displayed in the Layers panel with a link icon ().

Note:

You can also create a Linked Smart Object in an open document by dragging and dropping the appropriate file while keeping the following key pressed:

(Windows) Alt key
(Mac OS) Option key

To change this default behavior, turn off Preferences > General > Always Create Smart Objects While Placing.

File size savings using Linked Smart Objects

Since Linked Smart Objects maintain a dependency on an external file rather than embedding a source file within the containing document, they often result in significantly smaller file sizes. While Linked Smart Objects do not store the original file in the containing document, they still store a flattened and scaled version of the image data from the original file. In some cases, the size of this data may be much larger than the size of the original file, making the file size savings seem negligible.

Update Linked Smart Objects

If an external source file changes while a Photoshop document referencing it is open, the relevant Linked Smart Object is automatically updated. However, when you open a Photoshop document containing out-of-synch Linked Smart Objects, you can update the Smart Objects:

  • Right-click a Linked Smart Object layer and choose Update Modified Content.
  • Choose Layer > Smart Objects > Update Modified Content.

Linked Smart Objects whose source images have changed are visually highlighted in the Layers panel:

Photoshop Out-of-sync Linked Smart Objects highlighted in the Layers panel
Out-of-sync Linked Smart Objects are highlighted in the Layers panel.

Note:

You can update all linked Smart Objects in the current Photoshop document by choosing Layer > Smart Objects > Update All Modified Content.

Photoshop Linked Smart Objects with missing external source files highlighted in the Layers panel
Linked Smart Objects with missing external source files are highlighted in the Layers panel.

Note:

While detecting changes to Linked Smart Objects or updating a Linked Smart Object, Photoshop looks only at the immediate linked file. Links nested inside Smart Objects are not updated.

To resolve a Linked Smart Object with a missing external source, follow these steps:

  1. Right-click the Linked Smart Object layer icon and choose Resolve Broken Link.
  2. Navigate to the new location of the missing object.
  3. Click Place.

View Linked Smart Object properties

With a Linked Smart Object layer selected in the Layers panel, choose Window > Properties.

The following properties are displayed:

  • The path of the external source file for the Linked Smart Object
  • The Linked Smart Object size and positional coordinates (X, Y)

You can perform the following actions directly from within the Properties panel:

  • Edit the contents of the external image file. If necessary, Photoshop opens an external application that can handle the source image file. For example, Photoshop opens Adobe Illustrator if the external source image is a .ai file.
  • Embed the Linked Smart Object within the current document.

Embed Linked Smart Objects

Do one of the following:

  • Right-click a Linked Smart Object layer in the Layers panel and choose Embed Linked.
  • Choose Layer > Smart Objects > Embed Linked.
  • In the Properties panel, click Embed.
Note:

Choose Layer > Smart Objects > Embed All Linked to embed all Linked Smart Objects in the Photoshop document.

Package Linked Smart Objects

You can package the Linked Smart Objects in a Photoshop document, such that their source files are saved to a folder on your computer. A copy of the Photoshop document is saved along with the source files in the folder.

  1. Choose File > Package.
  2. Select a location where you want to place the source files and a copy of the Photoshop document.

Any audio or video Linked Smart Objects in the document are packaged as well.

Note:

You must save a file before packaging the Linked Smart Objects that it contains.

How Photoshop locates linked files

Photoshop always looks for linked files in the last-known relative location. If the linked file is not found in that location, Photoshop looks for it:

  • In the last-known absolute location
  • Using a saved alias (Mac OS only)
  • In the same folder as the containing document

This behavior allows you to move, copy, and share project folders and files with minimal risk of encountering broken links.

Note:

The Resolve Missing Assets dialog always displays the last-known absolute path of missing source files.

Convert an embedded Smart Object to a linked Smart Object

You can convert an embedded Smart Object to a Linked Smart Object. Transforms, filters, and other effects applied to the embedded Smart Object are preserved when it is converted.

Do the following:

  1. Select an embedded Smart Object layer in the Photoshop document.
  2. Choose Layer > Smart Object > Convert To Linked.
  3. Select the location on your computer where you want to save the source file. Enter a name for the file, including a supported extension. For example, link_file.jpg.

Filter the Layers panel by Smart Objects

  1. In the Layers panel, select Smart Object from the filtering pop-up menu.
Photoshop Filter layers by Smart Objects
Filter layers by Smart Objects

  1. Click one of the following icons:
  •     Filter for up-to-date Linked Smart Objects
  •     Filter for out-of-synch Linked Smart Objects
  •     Filter for missing Linked Smart Objects
  •     Filter for embedded Smart Objects
Note:

You can use the toggle switch () to turn off layer filtering.

Duplicate an embedded Smart Object

  1. In the Layers panel, select a Smart Object layer, and do one of the following:
    • To create a duplicate Smart Object that is linked to the original, choose Layer > New > Layer Via Copy, or drag the Smart Object layer to the Create A New Layer icon at the bottom of the Layers panel. Edits you make to the original affect the copy and vice versa.

    • To create a duplicate Smart Object that isn't linked to the original, choose Layer > Smart Objects > New Smart Object Via Copy. Edits you make to the original don't affect the copy.

    A new Smart Object appears in the Layers panel with the same name as the original and "copy" as a suffix.

Edit the contents of a Smart Object

When you edit a Smart Object, the source content is opened in either Photoshop (if the content is raster data or a camera raw file) or the application that handles the placed format by default (for example, Adobe Illustrator or Adobe Acrobat). When you save changes to the source content, the edits appear in all linked instances of the Smart Object in the Photoshop document.

  1. Select the Smart Object from the Layers panel, and do one of the following:
    • Choose Layer > Smart Objects > Edit Contents.
    • Double-click the Smart Objects thumbnail in the Layers panel.
    • In the Properties panel, click Edit Contents.
  2. Click OK to close the dialog box.
  3. Make edits to the source content file, then choose File > Save.

    Photoshop updates the Smart Object to reflect the changes you made. (If you don't see the changes, make the Photoshop document containing the Smart Object active.)

Replace the contents of a Smart Object

You can replace the image data in one Smart Object or multiple linked instances. This feature lets you quickly update a visual design, or replace low-resolution placeholder images with final versions.

Note:

When you replace a Smart Object, any scaling, warping, or effects that you applied to the first Smart Object are maintained.

  1. Select the Smart Object, and choose Layer > Smart Objects > Replace Contents.
  2. Navigate to the file you want to use, and click Place.
  3. Click OK.

    The new content is placed in the Smart Object.

Convert an embedded or linked Smart Object to layers

Introduced in Photoshop 21.0 (November 2019 release)

You can convert an embedded or linked smart object back into its component layers directly into a Photoshop document. If there are multiple layers in the Smart Object, the layers are unpacked into a new layer group within the Layers panel. Transforms and Smart Filters on Smart Objects containing more than a single layer are not retained when you unpack. 

Convert a Smart Object back into its component layers
Convert a Smart Object back into its component layers

  1. Select the Smart Object layer from the Layers panel.

  2. Do any of the following:

    • Right-click (Win) / Control-click (Mac) the Smart Object layer and select Convert To Layers from the context menu. 
    • From the menu bar, choose Layer > Smart Objects > Convert To Layers.
    • In the Properties panel, click Convert To Layers.
    • From the Layers panel's options menu, choose Convert To Layers
  3. The layers are unpacked into a layer group in the Layers panel.

Rasterize an embedded or linked Smart Object

You can rasterize the contents of a Smart Object to a regular layer if you no longer need to edit the Smart Object data. Transforms, warps, and filters applied to a Smart Object are no longer editable after the Smart Object is rasterized.

Select the Smart Object, and choose Layer > Smart Objects > Rasterize.  

Note:

If you want to re-create the Smart Object, reselect its original layers and start from scratch. The new Smart Object won't retain transforms you applied to the original Smart Object.

Export the contents of an embedded Smart Object

  1. Select the Smart Object from the Layers panel, and choose Layer > Smart Objects > Export Contents.

  2. Choose a location for the contents of the Smart Object, then click Save.

    Photoshop exports the Smart Object in its original placed format (JPEG, AI, TIF, PDF, or other formats). If the Smart Object was created from layers, it is exported in PSB format.

Reset Smart Object transforms

If you've transformed a Smart Object, you can reset all transformations you've previously applied by doing one of the following: 

  • Right-click the Smart Object layer and choose Reset Transform
  • Choose Layer > Smart Objects > Reset Transform

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online