按一下「開始 > 執行」
上次更新時間
2022年9月30日
問題
安裝或移除 Adobe Acrobat 時,收到關於擱置、未完成或已中斷安裝的 Windows 錯誤訊息。Acrobat 安裝失敗,而安裝程式無法成功回復不完整的安裝。
可能的錯誤訊息如下:
- 「錯誤 1704。Adobe Acrobat 或 Adobe Reader 的安裝目前已暫停。」
- 「內部錯誤 2711。在功能表格中找不到指定的功能名稱『PatchExtras』。」
- 「錯誤 1500。正在進行其他安裝。繼續安裝前,請先完成該項安裝。」
原因
電源中斷、系統提早關機或系統問題,導致 Windows Installer 損毀。已取消的安裝會回復安裝動作,且不會造成安裝暫停。
解決方法
若要解決錯誤,請嘗試下列其中一個步驟:
解決方法 1:停止所有進行中的安裝程式
註解:
此程序涉及編輯 Windows 登錄。Adobe 不支援編輯登錄,因為其中包含重要的系統和應用程式資訊。在編輯登錄前,請務必進行備份。如需有關登錄的詳細資訊,請參閱 Windows 文件或聯絡 Microsoft。
-
-
鍵入 regedit, 然後按一下「確定」。
-
導覽至機碼:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\ 並查看 Inprogress 機碼是否存在。
-
刪除該機碼,然後重新啟動安裝。
解決方法 2:取消登錄 Windows Installer 服務後,再重新登錄。
-
按一下「開始 > 執行」
-
輸入 msiexec/unreg,然後按一下「確定」。
-
按一下「開始 > 執行」
-
鍵入 msiexec / regserver, 接著按一下「確定」。