A táblázatok cellákat tartalmazó sorokból és oszlopokból épülnek fel. A cella nem más, mint egy szövegkeret, amelyben szöveg, rögzített keretek és egyéb táblázatok helyezhetők el. A táblázatokat létrehozhatja az Adobe InDesign CS5 programban, vagy exportálhatja őket más alkalmazásokból.

Megjegyzés:

Az Adobe InCopy programban a táblázatok létrehozásához, szerkesztéséhez és formázásához az Elrendezés nézetet használja.

Táblázatok létrehozása

A táblázatok cellákat tartalmazó sorokból és oszlopokból épülnek fel. A cella nem más, mint egy szövegkeret, amelyben szöveg, szövegközi grafikák és egyéb táblázatok helyezhetők el. Táblázatok létrehozhatók teljesen újként, de akár már meglévő szövegből történő átalakítással is, sőt, egy másik táblázatba is beágyazhatók.

Táblázat létrehozásakor az új táblázat kitölti a befoglaló szövegkeret szélességét. Ha a kurzor a sor elején van, akkor a program a kurzorral megegyező sorba szúrja be a táblázatot, ha viszont a kurzor valamelyik sor közepén van, akkor a következő sorba.

A táblázatok a szövegközi grafikákhoz hasonlóan együtt mozognak az őket körülvevő szöveggel: egy adott táblázat például összefűzött kereteken is átnyúlik, ha a fölötte található szöveg betűmérete módosul, illetve ha szöveget ad hozzá vagy töröl a felhasználó. Görbén elhelyezkedő szöveg alkotta kereten azonban nem jeleníthető meg táblázat.

Függőleges táblázatokat is ugyanúgy készíthet, mint vízszinteseket. A táblázat szövegiránya a táblázat létrehozásához használt szövegkeret szövegirányától függ, és a táblázat szövegiránya követi a szövegkeret szövegirányának módosításait. Ugyanez a működés érvényesül a keretrácsban létrehozott táblázatokra is. A táblázat celláinak szövegiránya azonban a táblázat szövegirányától függetlenül módosítható.

Megjegyzés:

Táblázat létrehozása előtt ellenőrizze a szövegkeret szövegirányát.

Tekintse meg Michael Murphy táblázatok létrehozásáról és formázásáról szóló cikkét: Mind Your Table Manners.

Jeff Witchell az InfiniteSkills.com-tól videóútmutatót készített a témában: The basics of setting up tables.

Táblázat létrehozása teljesen újként

A létrehozott táblázat kitölti a befoglaló szövegkeret szélességét.

  1. A Szöveg eszköz  segítségével helyezze el a beszúrási pontot oda, ahová a táblázatot szeretné helyezni.
  2. Kattintson a Táblázat menü Táblázat beszúrása parancsára.
  3. Adja meg a sorok és az oszlopok számát.
  4. Adja meg a vízszintes cellák számát a Sor szakaszban, és a függőleges cellák számát az Oszlop szakaszban.
  5. Ha a táblázat tartalma több oszlopot vagy keretet is felölel, adja meg, hogy hány fejléc- vagy láblécsorban ismétlődjenek az adatok.
  6. (Nem kötelező lépés:) Válasszon táblázatstílust.
  7. Kattintson az OK gombra.

A táblázatok sormagasságát a választott táblázatstílus határozza meg: a különböző stílusok például cellastílusokkal formázhatják a táblázat egyes részeit. Ha e cellastílusok közül bármelyik is tartalmaz bekezdésstílusokat, akkor ez utóbbi stílusok sortávolsága szabja meg a szóban forgó terület sormagasságát. Ha nincs megadva bekezdésstílus, a dokumentum alapértelmezett infoterülete vezérli a sormagasságot. (Az infoterület a sortávolságon alapul. Ebben az értelemben az infóterület a kijelölt szövegbeli kiemelés hozzávetőleges magassága.)

Táblázat létrehozása már meglévő szövegből

Mielőtt táblázattá alakítaná a szöveget, győződjön meg arról, hogy a szöveg beállításai helyesek.

  1. Az átalakításra történő előkészítés részeként szúrja be az oszlopok elkülönítésére szolgáló tabulátorokat, vesszőket és bekezdésvégjeleket vagy egyéb karaktereket. Szúrja be a sorok elkülönítésére szolgáló tabulátorokat, vesszőket és bekezdésvégjeleket vagy egyéb karaktereket. (Sok esetben szerkesztés nélkül is táblázattá alakítható a szöveg.)
  2. Jelölje ki a Szöveg eszközzel  a táblázattá alakítandó szöveget.
  3. Kattintson a Táblázat menü Szöveg táblázattá alakítása parancsára.
  4. Az Oszlopelválasztó és a Sorelválasztó mezőben adja meg, hogy hol kezdődjenek az új sorok és oszlopok. Válasszon a Tabulátor, a Vessző vagy a Bekezdés lehetőség közül, vagy írja be a használandó karaktert (például a pontosvesszőt) az Oszlopelválasztó vagy a Sorelválasztó mezőbe. (A beírt karakter látható lesz a menüben, amikor legközelebb táblázatot hoz létre szövegből.)
  5. Ha mind az oszlopokhoz, mind a sorokhoz ugyanazt az elválasztó karaktert adja meg, írja be a táblázatban szerepeltetni kívánt oszlopok számát.
  6. (Nem kötelező lépés:) Táblázatstílus megadásával formázza a táblázatot.
  7. Kattintson az OK gombra.

Ha bármely sorban a táblázat oszlopainak számánál kevesebb elem található, a sort üres cellák töltik ki.

Táblázat beágyazása táblázatba

  1. Tegye a következők egyikét:
    • Jelölje ki a beágyazandó cellákat vagy táblázatot, és kattintson a Szerkesztés menü Kivágás vagy Másolat parancsára. Vigye a kurzort abba a cellába, amelyben meg szeretné jeleníteni a táblázatot, és kattintson a Szerkesztés menü Beillesztés parancsára.

    • Kattintson bele egy cellába, majd a Táblázat menü Táblázat beszúrása parancsára, adja meg a sorok és oszlopok számát, végül kattintson az OK gombra.

  2. Szükség szerint adja meg a belső margót. (Lásd Táblázatban lévő szöveg formázása.)

Cellában létrehozott táblázat esetén az egérrel nem jelölhető ki a cella szélén túllógó táblázat egyetlen része sem. Ehelyett növelni kell a sor vagy az oszlop méretét, vagy a kurzort a táblázat első részébe kell helyezni, és billentyűparancsokkal kell áthelyezni a kurzort és kijelölni a szöveget.

Táblázatok importálása egyéb alkalmazásokból

Ha az Elhelyez paranccsal importál táblázatokat tartalmazó Microsoft Word dokumentumot vagy Microsoft Excel-számolótáblát, az importált adatok szerkeszthető táblázat formájában jelennek meg. Az adatok formázása az importálási beállításokat összegző párbeszédpanelen végezhető el.

Lehetősége van arra is, hogy egy Excel-számolótáblából vagy egy Word dokumentumbeli táblázatból illesszen be adatokat InDesign vagy InCopy dokumentumba. A más alkalmazásokból beillesztett szöveg formázásának mikéntjét a Beállítások párbeszédpanel Vágólap kezelése kategóriájának beállításai határozzák meg. Ha be van jelölve a Csak szöveg választógomb, az adatok formázatlan, tabulátorral tagolt, ezáltal táblázattá alakítható szövegként jelennek meg. Ha a Minden információ (indexjelölők, minták, stílusok, stb.) választógomb az aktív, a beillesztett szöveg formázott táblázatként lesz látható.

Ha már meglévő táblázatba illeszti be a szöveget egy másik alkalmazásból, szúrjon be kellő számú sort és oszlopot, hogy legyen elegendő hely a szövegnek, jelölje be a Beállítások párbeszédpanel Vágólap kezelése kategóriájának Csak szöveg választógombját, és győződjön meg arról, hogy legalább egy cella ki van jelölve (hacsak nem cellába szeretné beágyazni a beillesztett táblázatot).

Ha az importált táblázatot részletesebben is szeretné beállítani, illetve ha meg akarja tartani a táblázat formázását, akkor használja az Elhelyez parancsot a táblázat importálásához. Ha meg kívánja őrizni a táblázat kapcsolatát az eredeti számolótáblával, akkor válassza a Hivatkozások létrehozása szöveg- és táblázatfájl elhelyezésekor beállítást a Fájlkezelés beállításokban.

Megjegyzés:

A másolási és beillesztési paranccsal is beilleszthet egy tabulátorokkal tagolt szöveget a kijelölt táblázatcellákba. Így a formázás módosítása nélkül cserélhet le tartalmat. Tegyük föl például, hogy egy havilapban kívánja frissíteni egy formázott táblázat tartalmát. Az egyik lehetőség egy Excel táblázat csatolása. Ha azonban más forrásból származik a tartalom, kimásolhatja az új tartalmat tartalmazó tabulátorokkal tagolt szöveget, kijelölheti a formázott InDesign táblázatban a cellák tartományát, majd beillesztheti a tartalmat.

Szöveg hozzáadása táblázathoz

A táblázatok celláiba szöveg, rögzített objektumok, XML címkék és egyéb táblázatok vehetők fel. A táblázatsorok magasságát automatikusan úgy állítja be a program, hogy a további sorok is elférjenek (kivéve, ha rögzített sormagasság van megadva). Lábjegyzetek nem vehetők fel táblázatokba.

  1. A Szöveg eszközzel  tegye a következők egyikét:
    • Vigye a kurzort az egyik cellába, és írjon be szöveget. Az ENTER (RETURN) billentyűt megnyomva hozzon létre egy új bekezdést ugyanabban a cellában. A cellákon a Tab billentyűvel lépkedhet előre (a Tab billentyűt az utolsó cellában lenyomva új sort szúrhat be). Visszafelé a Shift+Tab billentyűkombinációval lépkedhet.

    • Másolja a szöveget a vágólapra, helyezze a beszúrási pontot egy cellába, és kattintson a Szerkesztés menü Beillesztés parancsára.

    • Helyezze a beszúrási pontot abba a cellába, ahol a szöveget elhelyezni kívánja, kattintson a Fájl menü Elhelyez parancsára, végül kattintson duplán valamelyik szövegfájlra.

Grafikák hozzáadása táblázathoz

Ha grafikát szeretne felvenni egy különálló InCopy dokumentumban lévő táblázatba, ne felejtsen el Elrendezés nézetre váltani. Ha csatolt InDesign dokumentum táblázatába szeretne grafikát felvenni, hívja segítségül az InDesign alkalmazást, így nagyobb hatékonysággal méretezhető át a szövegkeret.

  1. Végezze el a következő műveletek valamelyikét:
    • Helyezze a kurzort oda, ahol meg szeretné jeleníteni a grafikát, kattintson a Fájl menü Elhelyez parancsára, végül az Elhelyez párbeszédpanel fájllistájában kattintson duplán a grafika fájlnevére.

    • Vigye a kurzort a grafika leendő helyére, kattintson az Objektum menü Rögzített objektum almenüjének Beszúrás parancsára, és adja meg a beállításokat. A rögzített objektumhoz a későbbiekben is hozzáadhat grafikákat.

    • Másoljon a vágólapra egy grafikát vagy egy keretet, vigye a kurzort a kívánt helyre, és kattintson a Szerkesztés menü Beillesztés parancsára.

Ha a felvenni kívánt grafika nagyobb a cellánál, a program automatikusan úgy állítja be a cella magasságát, hogy elférjen a grafika – a cella szélessége azonban nem változik, ezért nem kizárt, hogy a grafika túlnyúlik a cella jobb oldali szegélyén. Ha a grafika helyeként megadott sor magassága rögzített, akkor az annál magasabb grafikák hatására a cella túlszedett lesz.

Megjegyzés:

A túlszedett cellák elkerülése végett célszerű lehet a szóban forgó képet a táblázaton kívülre helyezni, majd átméretezni és beilleszteni a táblázatcellába.

Fejlécek és láblécek hozzáadása táblázathoz

Hosszú táblázat létrehozásakor valószínűleg több oszlopra, keretre vagy oldalra is kiterjed a táblázat. Fejlécek és láblécek használatával a táblázat valamennyi felosztott részén megismételheti a megjelenítendő információt.

A táblázat létrehozásakor fejlécsorok és láblécsorok is felvehetők. Ez a művelet, valamint az ilyen sorok táblázatbeli megjelenésének módosítása a Táblázat beállításai párbeszédpanelen is végrehajtható. A törzssorok fejlécsorokká és láblécsorokká is átalakíthatók.

se_04
Header rows repeated once per frame

Megjegyzés:

Ha a táblákat folytatólagosan szeretné számozni (pl. 1A tábla, 1B tábla stb.), adjon hozzá változót a táblázat fejlécéhez vagy láblécéhez. (Lásd: Futó feliratok létrehozása ábrákhoz és táblázatokhoz.)

  1. Fejlécsorok létrehozásához jelölje ki a táblázat tetején lévő, láblécsorok létrehozásához pedig a táblázat alján található sorokat.
  2. Kattintson a Táblázat menü Sorok átalakítása almenüjének Fejléchez vagy Lábléchez parancsára.
  1. Helyezze a kurzort a táblázatba, és kattintson a Táblázat menü Táblázat beállításai almenüjének Fejlécek és láblécek parancsára.
  2. Adja meg a fejlécsorok és a láblécsorok számát. A táblázat tetejére vagy aljára további üres sorokat is felvehet.
  3. Az ismétlést beállító legördülő listákban válassza ki, hogy minden szöveges oszlopban (ha a szövegkeretekben több oszlop is van), keretenként egyszer vagy oldalanként egyszer jelenjen-e meg a fejlécben vagy a láblécben lévő információ.
  4. Ha nem szeretné, hogy a táblázat első sorában megjelenjen a fejlécben tárolt információ, jelölje be az Első kihagyása jelölőnégyzetet. Az Utolsó kihagyása négyzetet bejelölve a program nem tünteti fel a láblécben tárolt információt.

    Az Első kihagyása beállítás különösen hasznos, ha azt akarja jelezni, hogy a fejléc vagy lábléc folytatódik. Például több oldalra átnyúló táblázat esetén olyan fejlécet érdemes készíteni, hogy „2. táblázat (folytatás)”. Mivel a táblázat első oldalán nem szabad megjelennie „(folytatás)” feliratnak, az Első kihagyása beállítást kell választani, és a táblázat első sorába csak annyit beírni, hogy 2. táblázat.

  5. Kattintson az OK gombra.
  1. Végezze el a következő műveletek valamelyikét:
    • Helyezze a kurzort a fejlécsorba vagy a láblécsorba, és kattintson a Táblázat menü Sorok átalakítása almenüjének Törzshöz parancsára.

    • Kattintson a Táblázat menü Táblázat beállításai almenüjének Fejlécek és láblécek parancsára, és változtassa meg a fejlécsorok és a láblécsorok számát.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat