Jelöljön ki egy szövegrészt

  1. A Szöveg eszköz használatával végezze el az alábbi műveletek egyikét:
    • A szövegkurzor húzásával jelölje ki a kívánt karaktert, szót vagy szövegblokkot.

    • Egy szót duplán rákattintva jelölhet ki. A szó körüli szóközöket nem jelöli ki a program.

    • Egy karakterre duplán kattintva kijelölheti a szomszédos azonos típusú karaktereket. Ha például egy bekezdésben latin szöveg, kandzsi és hiragana is szerepel, és duplán kattint egy kandzsi karakterre, kijelöli a karakterlánc szomszédos kandzsi karaktereit is.

    • Egy sorra triplán kattintva jelölje ki az egész sort. Ha a Sorok kijelölése háromszoros kattintással beállítás nem aktív, a szövegre triplán kattintva az egész bekezdést kijelöli a program.

    • Ha a Sorok kijelölése háromszoros kattintással beállítás be van kapcsolva, az egész bekezdés kijelöléséhez négyszer kell kattintani a bekezdésre.

    • Kattintson ötszörösen, így jelölje ki az egész szövegegységet, vagy a szövegegység tetszőleges pontjára kattintva válassza a Szerkesztés menü Minden kijelölése. parancsát

Megjegyzés:

Ha jegyzetrögzítőt tartalmazó szöveget jelöl ki, a fenti eljárás bármelyikével egyúttal a jegyzetet és tartalmát is kijelöli.

Ha nem sikerül kijelölni a keretben lévő szöveget, lehetséges, hogy a szövegkeret zárolt rétegen vagy mesteroldalon található. Próbálja megszüntetni a réteg zárolását vagy lépjen a mesteroldalra. A szövegkeret elhelyezkedhet más szövegkeret vagy áttetsző objektum alatt is. Lásd: Fedett keretben lévő szöveg kijelölése.

A tripla kattintás hatásának módosítása

  1. Kattintson a Szerkesztés > Beállítások > Szöveg parancsra (Windows) vagy az InCopy > Beállítások > Szöveg parancsra (Mac OS).
  2. Jelölje be a Sorok kijelölése háromszoros kattintással jelölőnégyzetet, ha tripla kattintással egy egész sort ki szeretne jelölni (ez az alapértelmezett beállítás). Törölje a jelet a jelölőnégyzetből, ha tripla kattintással egy bekezdést szeretne kijelölni.

Fedett keretben lévő szöveg kijelölése

  1. Válassza a Kijelölés eszközt , nyomja le (és tartsa lenyomva) a Ctrl (Windows), illetve a Command (Mac OS) billentyűt, majd kattintással jelölje ki a kívánt szövegkeretet.
  2. Válassza a Szöveg eszközt, majd kattintson a szövegkeretbe vagy jelölje ki a megfelelő szöveget.

Szöveg beillesztése

A dokumentumba más alkalmazásokból vagy az Adobe InCopy programból illeszthet szöveget.

Ha a beszúrási pont nem egy szövegkeretben helyezkedik el, amikor szöveget illeszt az InDesign alkalmazásba, a program egy új egyszerű szövegkeretet hoz létre. Ha a beszúrási pont egy szövegkeretben áll, a program abba a keretbe illeszti a szöveget. Ha beillesztéskor egy szövegrész ki van jelölve, a beillesztett szöveg felülírja a kijelölt szöveget.

Ha a Szerkesztés > Beillesztés rácsformázás nélkül parancsra kattintva illeszt szöveget keretrácsba, megmarad az eredeti szöveg betűtípusa, betűmérete és karaktertérköz-beállítása. A szöveget kijelölve, majd a Szerkesztés > Rácsformázás alkalmazása parancsra kattintva a keretrács tulajdonságai szerint formázhatja meg a beillesztett szöveget.

Szöveg beillesztése más alkalmazásokból

  1. Ha meg szeretné őrizni a formázást és például a stílusokra vagy a tárgymutató-jelölőkre vonatkozó információkat, nyissa meg a Beállítások párbeszédpanel Vágólap kezelése szakaszát, és a Beillesztés csoportban jelölje be a Minden információ választógombot. Ha beillesztéskor ezeket az elemeket és információkat törölni szeretné, a Csak szöveg választógombot jelölje be.
  2. Vágjon vagy másoljon ki szöveget más alkalmazásból vagy egy InCopy-dokumentumból.
  3. Tetszés szerint jelöljön ki egy szövegrészt vagy kattintson egy szövegkeretbe. Ellenkező esetben a program a szöveget egy új keretbe illeszti be.
  4. Tegye a következők egyikét:
    • Kattintson a Szerkesztés menü Beillesztés parancsára. Ha a beillesztett szöveg nem tartalmazza az összes kívánt formázást, lehetséges, hogy módosítania kell az RTF-dokumentumokra vonatkozó beállításokat az Importálási beállítások párbeszédpanelen.

    • Kattintson a Szerkesztés menü Beillesztés formázás nélkül parancsára. (A Beillesztés formázás nélkül parancs elhalványítva jelenik meg, ha a Beállítások párbeszédpanel Vágólap kezelése szakaszában lévő Csak szöveg beállítást engedélyezve illeszt be szöveget más alkalmazásokból.)

    • Válassza a Szerkesztés > Beillesztés rácsformázás nélkül parancsot.

Megjegyzés:

Húzással is elhelyezhet szöveget más alkalmazásokból az InDesign-dokumentumban, sőt közvetlenül a Windows Intézőből, illetve a Mac OS Finderből is beszúrhat szövegfájlt vagy szövegszerkesztőben készült fájlt. A szöveg új szövegkeretbe kerül. Ha húzás közben lenyomva tartja a Shift billentyűt, eltávolíthatja a formázást. A Beállítások párbeszédpanel Vágólap kezelése szakaszában megadott beállítással meghatározhatja, hogy a program megőrizze-e például a tárgymutató-jelölőket vagy a színmintákat.

Térköz automatikus beállítása szövegbeillesztéskor

Szövegbeillesztéskor a program szükség szerint automatikusan felvehet vagy eltávolíthat térközöket. Ha például kivág egy szót a vágólapra, majd két szó közé beilleszti azt, a szó előtt és után szóköz jelenik meg. Ha a szót egy mondat végére, közvetlenül a pont elé illeszti be, a program nem ad hozzá szóközt.

Megjegyzés:

Ez a funkció elsősorban latin szöveghez használatos. Ez a funkció csak akkor érhető el, amikor a Latin szöveg beillesztése van beállítva latin nyelvhez a Karakter panelen.

  1. Nyissa meg a Szerkesztés > Beállítások > Rácsok (Windows), illetve InCopy  > Beállítások > Rácsok (Mac OS) menüt.
  2. Jelölje be a Térköz automatikus igazítása szavak kivágásakor és beillesztésekor jelölőnégyzetet, és kattintson az OK gombra.

Szöveg beillesztése keretrácsba

Beilleszthet szöveget úgy is, hogy az megtartsa eredeti formázását. Ha módosított tulajdonságokkal másol szöveget egyik keretrácsból egy másikba, a beillesztett szöveg csak a módosított tulajdonságokat tartja meg. Emellett lehetősége van formázás nélküli beillesztésre is.

  1. Vágjon vagy másoljon ki szöveget más alkalmazásból vagy egy InCopy-dokumentumból.
  2. Jelenítse meg a szövegbeillesztési pontot a keretrácsban, vagy jelöljön ki egy szövegrészt.
  3. Tegye a következők egyikét:
    • A szöveg rácsformázással egyező beillesztéséhez válassza a Szerkesztés > Beillesztés lehetőséget.

    • A szöveg rácsformázás nélküli beillesztéséhez válassza a Szerkesztés > Beillesztés rácsformázás nélkül lehetőséget.

Később bármikor alkalmazhatja a rácsformázást a Szerkesztés > Rácsformázás alkalmazása paranccsal. A szöveg felveszi a Nevesített rácsok panelben megadott rácsformátum-beállításokat.

Rácsformázás alkalmazása szövegre

A rácsformázást bármely szövegre alkalmazhatja, ha az nem felel meg a formátumnak.

  1. Jelölje ki a szöveget.
  2. Válassza a Szerkesztés > Rácsformázás alkalmazása parancsot.

Szövegirány módosítása

  1. Jelölje ki a szövegkeretet.
  2. Tegye a következők egyikét:
    • Válassza a Szöveg > Írásirány > Vízszintes vagy Függőleges lehetőséget.

    • Válassza a Szöveg > Szövegegység menüpontot a Szövegegység panel megjelenítéséhez. Válasszon Vízszintes vagy Függőleges Szövegirányt.

Hasáb vagy Szövegegység nézetben a szöveg vízszintesen jelenik meg akkor is, ha a függőleges megjelenítést választotta ki. Elrendezés nézetben a szöveg függőleges, ha ezt választotta ki.

A függőleges szövegkeretek vagy keretrácsok vízszintessé, a vízszintes szövegkeretek vagy keretrácsok pedig függőlegessé válnak. Ennek módosítása a teljes szövegegységet módosítja, és a kijelölt kerethez fűzött minden további keret is módosul.

Megjegyzés:

A keretek egyes karaktereinek irányát a Tate-chu-yoko funkcióval, vagy a Karakter panel Karakterforgatás funkciójával módosíthatja.

Szöveg húzása

Az egér használatával húzással is elhelyezhet szöveget a szövegegység-szerkesztőben vagy az Elrendezés nézetben. Akár a szövegegység-szerkesztőből is áthúzhatja a szöveget az elrendezési ablakba (vagy fordítva), sőt bizonyos párbeszédpanelekre (például a Keresés/csere panelre) is húzhatja a szöveget. Ha a húzást zárolt vagy nem lefoglalt szövegegységből végzi, a program áthelyezés helyett másolja a szöveget. Húzáskor a szöveget másolhatja vagy új keretet hozhat létre.

Hasáb, Szövegegység és Elrendezés nézetben az egérrel húzással is áthelyezheti a szöveget. Mi több, egyes párbeszédpanelekre (például a Keresés/csere panelre) is húzhatja a kívánt szöveget. Ha a húzást zárolt vagy nem lefoglalt szövegegységből végzi, a program áthelyezés helyett másolja a szöveget. Húzáskor a szöveg másolására is lehetőség van.

Jeff Witchel oktatóvideója szövegek húzásáról (angol nyelven): Using InDesign Drag and Drop Text.

  1. A „fogd és vidd” funkció engedélyezéséhez nyissa meg a Szerkesztés > Beállítások > Szöveg (Windows), illetve InCopy  > Beállítások > Szöveg (Mac OS) menüt, jelölje meg az Engedélyezés Elrendezés nézetben, valamint Elrendezés Szövegszerkesztőben (InDesign), illetve Engedélyezés Hasáb és Szövegegység nézetben (InCopy) lehetőségeket, majd kattintson az OK gombra.
  2. Jelölje ki az áthelyezni vagy másolni kívánt szöveget.
  3. Tartsa a mutatót a kijelölt szöveg felett mindaddig, amíg a húzást jelző ikon  meg nem jelenik, majd húzza el a szöveget.

    Húzás közben a kijelölt szöveg nem mozdul, mindössze egy függőleges vonal jelzi, hogy az egérgomb felengedésekor a szöveg hol fog megjelenni. A függőleges vonal minden olyan szövegkeretben látható, amely fölé húzza az egérmutatót.

  4. Végezze el a következő műveletek valamelyikét:
    • A szöveg máshová húzásához vigye a függőleges vonalat arra a helyre, ahol a szöveget el szeretné helyezni.

    • Ha a szöveget új szövegkeretbe szeretné helyezni, a húzás megkezdése után nyomja le (és tartsa lenyomva) a Ctrl (Windows), illetve a Command (Mac OS) billentyűt, a művelet végén pedig előbb az egérgombot, majd a billentyűt engedje fel.

    • Ha a szöveget a formázás megőrzése nélkül szeretné máshová húzni, a húzás megkezdése után nyomja le (és tartsa lenyomva) a Shift billentyűt; a művelet végén előbb az egérgombot, majd a billentyűt engedje fel.

    • A szöveg másolásához a húzás megkezdése után nyomja le (és tartsa lenyomva) az Alt (Windows), illetve az Option (Mac OS) billentyűt, a művelet végén pedig előbb az egérgombot, majd a billentyűt engedje fel.

Megjegyzés:

Ezeket a módosítóbillentyűket különféle kombinációkban használhatja. Ha például formázatlan szöveget szeretne új keretbe másolni, a húzás megkezdése után nyomja le (és tartsa lenyomva) az Alt+Shift+Ctrl (Windows), illetve az Option+Shift+Command (Mac OS) billentyűkombinációt.

Ha a húzással elhelyezett szöveg pozíciója nem tökéletes, a szövegbeállítások között jelölje be a Térköz automatikus igazítása jelölőnégyzetet.

Karakterek transzponálása

Ha a beírás során két szomszédos karaktert transzponál, a Transzponálás paranccsal végezheti el a javítást. Ha például az 1243 számot írta be az 1234, helyett, a Transzponálás parancs megcseréli a 4 és a 3 számokat.

  1. Helyezze a beszúrási pontot a transzponálni kívánt két karakter közé.
  2. Kattintson a Szerkesztés menü Transzponálás parancsára.

Megjegyzés:

A Transzponálás parancs csak a szövegekben lévő karakterekre és számokra érvényes. Nem mozgathatja az InCopy jegyzetek szerkesztőpontjait, a táblázatokat, a szóközöket és más, nem nyomtatható karaktereket. Nem használhatja a Transzponálás parancsot zárolt szövegben.

Rejtett karakterek megtekintése

Szöveg szerkesztésekor gyakran hasznos a nem nyomtatható karakterek, például a szóközök, a tabulátorok és a bekezdésjelek megjelenítése. Ezek a karakterek csak dokumentumablakban láthatók;nyomtatáskor nem.

wt_01
Nonprinting characters hidden (top) and visible (bottom)
  1. Tegye a következők egyikét:
    • Válassza a Szöveg > Rejtett karakterek megjelenítése parancsot. A menüparancs mellett egy pipa jelenik meg.

    • Kattintson a Rejtett karakterek megjelenítése gombra a  vízszintes eszközsoron.

Mesteroldalon található szöveg szerkesztése

Az InDesign-dokumentumokban a mesteroldalak olyan sablonok, amelyek több oldalra érvényesek. A mesteroldalak általában csak a dokumentum összes oldalán megjelenő általános elrendezési elemeket határozzák meg, például a margókat, oldalszámokat, fejléceket és lábléceket. Az InCopy programmal szerkesztheti az InDesign mesteroldalakon lévő szövegeket, ha a szöveg csatolt fájl. Nem módosíthatja azonban a mesteroldal által vezérelt keretjellemzőket, és nem szerkesztheti a mesteroldal szövegét a dokumentum más (szokásos) oldalairól.

Megjegyzés:

Ha nem tud beszúrási pontot elhelyezni szokásos oldal nem zárolt szövegkeretébe, akkor valószínű, hogy az a szöveg mesteroldalon található. Érdeklődjön a keretek beállításáért felelős felhasználónál és a tervezőcsapatnál.

  1. Kattintson a Nézet menü Elrendezés nézet parancsára, ha a dokumentum még nincs Elrendezés nézetben.
  2. Válassza az oldalmezőből a mesteroldalt a dokumentumablak bal alsó részén.
    wt_05
    Selecting the InDesign master page
  3. A mesteroldalon jelölje ki a szerkeszteni kívánt szöveget, és végezze el a módosításokat.

A mesteroldalon található szöveg szerkesztéséhez a mesteroldalnak olyan kezelt szövegeket kell tartalmaznia, amelyet lefoglalt.

Műveletek visszavonása

A legutóbbi műveleteket akár több száz lépésig visszavonhatja vagy megismételheti. A visszavonható műveletek pontos számát a rendelkezésre álló memória mérete és az elvégzett műveletek fajtája határozza meg. A legutóbbi műveletek bejegyzéseit a program törli mentéskor, bezáráskor vagy kilépéskor, így többé nem lehet ezeket visszavonni. Visszavonhatja a műveleteket azok befejezése előtt is, vagy visszaállíthat egy korábban mentett verziót.

  1. Tegye a következők egyikét:
    • A legutóbbi módosítás visszavonásához kattintson a Szerkesztés menü Visszavonás [művelet] parancsára. (Bizonyos műveleteket nem vonhat vissza, például a görgetést.)

    • Az előzőleg visszavont művelet megismétléséhez kattintson a Szerkesztés menü Ismétlés [művelet] parancsára.

    • A projekt legutóbbi mentése óta elvégzett módosítások visszavonásához kattintson a Fájl menü Tartalom visszaállítása parancsára.

    • Az InCopy által be nem fejezett módosításokat (például ha folyamatjelző sávot lát) az Escape billentyűvel állíthatja le.

    • A párbeszédpanel a módosítások alkalmazása nélküli bezárásához kattintson a Mégse gombra.

Ugrás helyjelölőre

A helyjelölők hasonlóak a könyvjelzőkhöz, és dokumentum helyének jelölésére használhatók. Ez akkor hasznos, ha gyorsan és gyakran kell visszatérnie ehhez a helyhez. Egy dokumentumnak csak egy helyjelölője lehet.

  1. Helyezze a beszúrási pontot arra a helyre, ahová a jelölőt be szeretné illeszteni.
  2. Kattintson a Szerkesztés menü Helyjelölő almenüjének Jelölő beszúrása parancsára. (Ha már beszúrt egy helyjelölőt, kattintson a Jelölő cseréje parancsra.)

A dokumentum bármely helyéről átléphet a jelölőhöz a Szerkesztés menü Helyjelölő almenüjében található Ugrás jelölőre parancs használatával.

A jelölő törléséhez kattintson a Szerkesztés menü Helyjelölő almenüjének Jelölő eltávolítása parancsára. A dokumentum bezárásakor és újra megnyitásakor a jelölő automatikusan eltűnik.

Hasáb-, keret- és oldaltörések felvétele

A hasáb-, keret- és oldaltöréseket különleges töréskarakterek beszúrásával szabályozhatja.

  1. A Szöveg eszközzel helyezze el a beszúrási pontot arra a helyre, ahol töréspontot szeretne beszúrni.
  2. A Szöveg menüben kattintson a Töréskarakter beszúrása parancsra, majd válasszon egy törési lehetőséget.

Megjegyzés:

Töréspontot a számbillentyűzeten található Enter billentyű lenyomásával is beszúrhat a szövegbe. Hasábtörés beszúrásához nyomja le az Enter billentyűt; kerettörés beszúrásához nyomja le a Shift+Enter billentyűkombinációt; oldaltörés beszúrásához nyomja le a Ctrl+Enter (Windows), illetve a Command+Return (Mac OS) billentyűkombinációt.

Töréskarakter eltávolításához előbb a Szöveg menü Rejtett karakterek megjelenítése parancsára kattintva jelenítse meg a nem nyomtatandó karaktereket, majd jelölje ki és törölje a megfelelő töréskaraktert.

Megjegyzés:

Ha egy töréspontot a bekezdésbeállítások módosításával hoz létre (például a Beállítások megtartása párbeszédpanelen), a törés a megadott beállítást tartalmazó bekezdés elé kerül. Ha egy töréspontot különleges karakter beszúrásával hoz létre, a törés közvetlenül a különleges karakter után jelenik meg.

Töréspontok beállításai

A Szöveg menü Töréskarakter beszúrása pontja az alábbi beállításokat tartalmazza:

Hasábtörés 

Az aktuális szövegkeret következő hasábjába folyatja a szöveget. Ha a keret csak egy hasábot tartalmaz, a szöveg a szöveglánc következő keretébe kerül.

Kerettörés 

A szöveget a szöveglánc következő keretébe folyatja az aktuális szövegkeret hasábbeállításaitól függetlenül.

Oldaltörés 

A szöveget a következő olyan oldalra folyatja, amely egy, az aktuális szövegkerethez fűzött keretet tartalmaz.

Páratlan oldal törése 

A szöveget a következő olyan páratlan számú oldalra folyatja, amely egy, az aktuális szövegkerethez fűzött keretet tartalmaz.

Páros oldal törése 

A szöveget a következő olyan páros számú oldalra folyatja, amely egy, az aktuális szövegkerethez fűzött keretet tartalmaz.

Új bekezdés 

E beállítás hatására a program új bekezdést nyit (mint az Enter vagy a Return billentyű lenyomására).

Szándékos sortörés 

Sortörést vált ki a karakter beszúrásának a helyén; új sort kezd új bekezdés nélkül (a Shift+Enter vagy a Shift+Return billentyűk megnyomásával azonos). A szándékos sortörést lágy sortörésnek is hívják.

Tetszés szerinti sortörés 

Azt jelzi, hogy sortörés esetén hol kell megtörnie a sornyi szövegnek. A tetszés szerinti sortörés olyan, mint egy lágy elválasztójel, azzal a különbséggel, hogy a program nem szúr be elválasztójelet a sortörés helyén.

Hasonló törési beállítások a Beállítások megtartása és a Bekezdésstílus beállításai párbeszédpanelen is találhatók.

Feltételes szöveg használata

A feltételes szövegnek köszönhetően többféle verziót készíthet ugyanabból a dokumentumból. Miután létrehozta a feltételeket, azokat különféle szövegtartományokra vonatkoztathatja. Ezt követően a feltételek megjelenítésével, illetve elrejtésével különféle verziókat készíthet a dokumentumokról. Számítógépes útmutató létrehozásakor például külön feltételeket készíthet a Macintosh és a Windows operációs rendszer felhasználói számára. A használati utasítás Macintosh operációs rendszernek megfelelő verziójának nyomtatása előtt az összes olyan szöveg megjelenítheti, amelyre a „Mac” feltétel vonatkozik, az összes olyat pedig elrejtheti, amelyre a „Windows” feltétel vonatkozik. A használati utasítás Windows operációs rendszernek megfelelő verziójának nyomtatásához felcserélheti a feltételek állapotát.

iu_text_conditional_1
Conditional text shown

A. All conditions shown B. Conditional indicators 
iu_text_conditional_2
Conditional text hidden

A. “Mac” condition hidden B. Hidden condition symbols 

A feltételeket csak szövegre lehet vonatkoztatni. Rögzített objektumok is feltételessé alakíthatók, de csak a rögzített objektum jelölőjének kijelölésével. Táblázatcellákban szereplő szövegre is vonatkoztathatja a feltételeket, a táblázat celláira, oszlopaira és soraira azonban nem. Zárolt InCopy szövegekre nem vonatkoztathatja a feltételeket.

A feltételes szövegekkel való munkáról megtekinthet egy oktatóvideót is: www.adobe.com/go/lrvid4026_id.

A feltételes szöveget tartalmazó dokumentumok létrehozásakor követendő eljárás

Ha feltételes szöveget tartalmazó projektet készül létrehozni, vegye számba az anyag jellegét, és gondolja át, hogy a dokumentum beadását követően hány személy dolgozhat majd felváltva azon. Igyekezzen következetesen kezelni a feltételes szöveget, hogy egyszerűbben lehessen használni és könnyebben karban lehessen tartani a dokumentumot. A következő irányelveket tartsa szem előtt.

A verziók száma

Határozza meg, hogy hány verziója legyen a végleges projektnek. Ha például olyan útmutatót hoz létre, amely mind Windows, mind Macintosh platformon futó program működését ismerteti, akkor legalább két verziót: egy Windows, illetve egy Macintosh operációs rendszernek megfelelő verziót célszerű létrehozni. Ha azt szeretné, hogy az áttekintési folyamat során szerkesztői megjegyzésekkel is elláthassák a szöveget, akkor még több verziót érdemes létrehozni: egy megjegyzésekkel ellátott Macintosh verziót, egy megjegyzések nélküli Macintosh verziót, egy megjegyzésekkel ellátott Windows verziót és egy megjegyzések nélküli Windows verziót.

A sok feltételt tartalmazó dokumentumokhoz olyan feltétel-beállításokat is meghatározhat, amelyeknek a dokumentumra való alkalmazásával gyorsan készíthet különféle verziókat.

A szükséges feltételcímkék száma

Határozza meg, hogy hány feltételcímkére van szüksége a kívánt verziók előállításához. A dokumentum adott verziója a feltételcímkék egyedi készletével határozható meg. Egy végleges Windows útmutatót például egy megjelenített Windows feltételcímkével, valamint egy rejtett Macintosh feltételcímkével és egy rejtett Megjegyzések feltételcímkével határozhat meg. Ebben a példában azt kell majd eldöntenie, hogy külön feltételcímkét kíván-e használni a Windows, illetve a Macintosh operációs rendszerre vonatkozó megjegyzésekhez, vagy egyetlen feltételcímkét kíván-e használni mindkét operációs rendszerre vonatkozó megjegyzésekhez.

A tartalom felépítése

Mérje fel, hogy mennyi feltételt érdemes használni a dokumentumban, valamint gondolkodjon el azon, hogy hogyan lehet úgy összeállítani az anyagot, hogy azt utána ne legyen nehéz javítani és karban tartani. Elképzelhető például, hogy úgy is össze tud állítani egy könyvet, hogy annak csupán néhány dokumentumában kelljen feltételes szöveget használni. Úgy is dönthet, hogy külön fájlokat tart fenn egy adott fejezet verziói számára, és más-más könyvfájlt használ majd fel a könyv egyes verzióihoz.

Más esetekben, például többnyelvű dokumentumok esetén, a feltételek helyett érdemes lehet külön rétegeket létrehozni az egyes nyelvek számára, amelyeket azután tetszése szerint elrejthet, illetve megjeleníthet.

Címkézési stratégia

Határozhatja meg a feltételes szöveg legkisebb egységét. Más nyelvre fordítandó dokumentum esetén például célszerű egy kerek mondatnyi szöveget feltételes szöveggé alakítani. Mivel a szórendet gyakran módosítani kell a fordítás során, ezért egy mondatrész feltételes szöveggé alakítása nehezebbé teheti a fordítást.

A szóközök és az írásjelek feltételeinek következetlen alkalmazása felesleges szóközökhöz vagy helyesírási hibákhoz vezethet. Döntse el, hogy feltételes szöveggé kívánja-e alakítani a szóközöket és az írásjeleket. Ha a feltételes szöveg írásjellel kezdődik vagy végződik, az írásjelet is alakítsa feltételessé. Így könnyebb lesz majd olvasni a szöveget abban az esetben, ha egyszerre több verzió is meg van jelenítve.

A szótávolsággal kapcsolatos problémák (például nem feltételes szóközt követő feltételes szóköz) elkerülése érdekében egységesítse a feltételes szöveget követő szóközök kezelésének módját. (Pl. legyen az mindig feltételes vagy mindig nem feltételes).

A félreértések elkerülése érdekében határozza meg a feltételes szövegek megjelenítési sorrendjét, és következetesen ragaszkodjon ahhoz a teljes dokumentumban.

Tárgymutatók és kereszthivatkozások

Dokumentumok tárgymutatóinak készítésekor ügyeljen arra, hogy a feltételes szövegrészen belül vagy azon kívül helyezi-e el a tárgymutató-jelölőket. A rejtett feltételes szövegen belül található tárgymutató-jelölők nem szerepelnek a létrehozott tárgymutatóban.

A feltételes szövegre mutató kereszthivatkozások létrehozásakor ügyeljen arra, hogy a forrásszövegre a hivatkozottal azonos feltétel érvényesüljön. Ha például egy „Windows” bekezdéshez ad hozzá egy kereszthivatkozást, ám a szerkesztőpont egy „Mac” feltételben jelenik meg, akkor a „Mac” feltételnek megfelelő szövegek elrejtésekor a kereszthivatkozás nem lesz feloldva. A Hivatkozás panelen a „HT” jelzés lesz látható a kereszthivatkozás mellett.

Ha feltételes szöveget is tartalmazó bekezdésre mutató kereszthivatkozást hoz létre, majd módosítja az adott feltételnek megfelelő szöveg láthatósági beállítását, akkor frissítse a kereszthivatkozást.

Feltételek készítése

A program az aktuális dokumentumba menti a létrehozott feltételeket. Ha a feltétel létrehozása közben nincs megnyitva dokumentum, akkor az adott feltétel valamennyi létrehozásra kerülő dokumentumban szerepel majd.

Feltételjelzők (ilyen lehet például egy pirosan szedett hullámos aláhúzás) megadásával könnyen azonosíthatóvá alakíthatja a feltételes szövegrészeket.

A kezelt InCopy-fájlokban alkalmazhatja a meglévő feltételeket, újakat azonban nem hozhat létre, a meglévőket pedig nem törölheti. Az InCopy programban megjelenítheti, illetve elrejtheti a feltételes szövegrészeket, azonban a kezelt fájl lefoglalásának feloldásakor a változtatások nem tükröződnek az InDesign programban. A különálló InCopy-dokumentumokban ugyanúgy létrehozhat feltételeket, alkalmazhatja azokat, valamint módosíthatja azok láthatóságát, mint az InDesign programban.

  1. A Feltételes szöveg panel megjelenítéséhez kattintson az Ablak menü Szöveg és táblázatok elemére.
  2. Kattintson a Feltételes szöveg panel menüjének Új feltétel parancsára, majd adja meg a feltétel nevét.
  3. A Jelző csoportban adja meg annak a jelzőnek a megjelenését, amelynél a feltételt alkalmazni kívánja.

    Alapértelmezés szerint a jelzők (például a hullámos piros vonalak) csak a dokumentum megjelenítésekor láthatóak, a nyomtatásban és a kimenetnek szánt végleges változatban azonban nem. A Feltételes szöveg panelen található Jelzők menü beállításaival elrejtheti a jelzőket, illetve megadhatja, hogy azok a nyomtatásban és a kimenetnek szánt változatban is megjelenjenek. Ez utóbbit pl. áttekintéshez élszerű választani.

  4. Kattintson az OK gombra.

Feltételek alkalmazása szövegre

Adott szövegrészre több feltételt is alkalmazhat. Alapértelmezés szerint feltételjelzők azonosítják a feltételes szövegrészeket. Ha azonban el vannak rejtve a feltételek, akkor a Feltételes szöveg panelen állapíthatja meg, hogy mely feltételek vonatkoznak egy adott szövegrészre. Tömör pipa jelzi, ha a feltétel érvényesül az adott szövegnél. Halvány pipa jelzi, ha a feltétel csak a kijelölés egy részében érvényesül.

  1. Jelölje ki azt a szövegrészt, amelynél érvényesíteni kívánja a feltételt.
  2. A Klónozás forrása panelen (Ablakok > Szöveg és táblázatok > Feltételes szöveg) tegye az alábbiak valamelyikét:
    • Feltétel alkalmazásához kattintson a kívánt feltételre vagy a feltétel neve mellett található négyzetre.

    • Feltétel alkalmazásához és a szövegnél alkalmazott többi feltétel eltávolításához az Alt (Windows), illetve az Option (Mac OS) billentyűt nyomva tartva kattintson a kívánt feltételre.

    • Feltétel eltávolításához a feltétel neve mellett található négyzetre való kattintással törölje a jelet a négyzetből. Ha az összes feltételt szeretné eltávolítani a kijelölt szövegből, akkor kattintson a [Nem feltételes] gombra.

Megjegyzés:

Billentyűparancsokkal nem alkalmazhat feltételeket. A Gyors alkalmazás gombbal viszont alkalmazhat feltételeket.

Feltételek megjelenítése és elrejtése

Egy feltétel elrejtésekor az összes olyan szövegrészt elrejti a program, amelyre az adott feltétel vonatkozik. A feltételek elrejtésének hatására gyakran módosul a dokumentum, illetve könyv oldalszámozása. Az Intelligens szövegáttördelés funkcióval automatikusan beszúrhat és eltávolíthat oldalakat, amikor elrejti, illetve megjeleníti a feltételeket.

A program figyelmen kívül hagyja a dokumentum rejtett feltételes szövegrészeit. Így például nem nyomtatja és nem exportálja a rejtett szövegrészeket, a rejtett feltételes szövegrészben található tárgymutató-jelölőket nem veszi fel a generált tárgymutatóba, valamint kereséskor és helyesírás-ellenőrzéskor kihagyja a rejtett feltételes szövegrészeket.

Amikor elrejti valamelyik feltételt, egy rejtett feltételre utaló szimbólum  tárolja a rejtett szövegrészt . Ha olyan szöveget jelöl ki és próbál törölni, amely rejtett feltételes szimbólumot tartalmaz, az InCopy megerősítést kér a rejtett feltételes szöveg törlésére vonatkozóan. Rejtett feltételes szövegrészeket nem láthat el a egyéb feltételekkel, stílusokkal és formázással.

Ha egy szövegrésznél több feltétel is érvényesül, melyek közül legalább egy meg van jelenítve, akkor az adott szövegrész nem lesz rejtve.

  • Adott feltételek megjelenítéséhez, illetve elrejtéséhez kattintson a kívánt feltétel neve mellett található láthatósági négyzetre. A szemet jelképező ikon mutatja, ha látható a feltétel.
  • Az összes feltétel megjelenítéséhez, illetve elrejtéséhez válassza a Feltételes szöveg panel menüjének Az összes megjelenítése, illetve Az összes elrejtése parancsát.

Feltételkészletek használata

A feltételkészletekkel az összes feltétel láthatósági beállítása megadható, így pillanatok alatt különféle változatokat készíthet a dokumentumból. Vegyünk példaként egy olyan komplex dokumentumot, amelynél a platformra vonatkozó feltételként a Macintosh, a Windows XP, a Vista és az UNIX feltétel, a nyelvre vonatkozó feltételként az angol, a francia, a német és a spanyol feltétel, szerkesztői feltételként pedig a Szerkesztői áttekintés és a Belső megjegyzések nevű feltétel van megadva. A Vista verzió francia nyelvű változatának áttekintéséhez létrehozhat egy olyan készletet, amely csak a Vista, a francia és a Szerkesztői áttekintés feltételt jeleníti meg, a többit pedig elrejti.

Bár ehhez nem feltétlenül szükséges készleteket használni, a készletekkel pillanatok alatt és megbízható módon módosíthatja a különféle feltételek láthatósági beállítását.

  1. A kívánt módon lássa el feltételekkel a szöveget.
  2. Ha a Feltételes szöveg panelen nem látható a Beállítás menü, válassza a Feltételes szöveg panel menüjének Beállítások megjelenítése parancsát.
  3. A Feltételes szöveg panelen a kívánalmaknak megfelelően tegye láthatóvá vagy rejtse el a feltételeket.
  4. A Beállítás menüben kattintson az Új készlet létrehozása parancsra, adja meg a készlet nevét, majd kattintson az OK gombra.

    Az új készlet lesz az aktív készlet.

  5. Végezze el a következő műveletek valamelyikét:
    • A feltételkészlet dokumentumra való alkalmazásához válassza ki annak nevét a Beállítás menüben.

    • Feltételkészlet felülírásához kijelöléssel tegye aktívvá a kívánt feltételkészletet, majd módosítsa az egyes feltételek láthatósági beállítását. Egy pluszjel (+) lesz látható a feltételkészlet mellett. A felülírások eltávolításához jelölje ki újra a feltételkészletet. A feltételkészlet új láthatósági beállításokkal való frissítéséhez válassza a „[feltételkészlet] újradefiniálása” lehetőséget.

    • Feltételkészlet törléséhez jelölje ki a feltételkészlet, majd válassza a „[feltételkészlet] törlése” lehetőséget. Egy feltételkészlet törlésével a készletben szereplő feltételek nem törlődnek, és az alkalmazott feltételek sem törlődnek alkalmazási helyükről.

Feltételek kezelése

  1. Végezze el a következő műveletek valamelyikét:

    Feltétel törlése

    Jelöljön ki egy feltételt, majd kattintson a Feltételes szöveg panel alján látható Feltétel törlése ikonra. A törölt feltétel helyett adjon meg egy másikat, majd kattintson az OK gombra. A megadott feltétel az összes olyan szövegrészre vonatkozni fog, amelyre a törölt feltétel is vonatkozott.

    Több feltétel törléséhez szomszédos feltételeknél a Shift billentyűt nyomva tartva, nem szomszédos feltételeknél a Ctrl (Windows), illetve a Command (Mac OS) billentyű nyomva tartva kattintással jelölje ki a törölni kívántakat, majd kattintson a Feltétel törlése ikonra.

    Szövegre vonatkozó feltétel eltávolítása

    Egy feltételcímke szövegből való eltávolítása nem ugyanúgy működik, mint amikor egy címkét távolít el a szövegből. Amikor eltávolít egy címkét a szövegből, az a dokumentumban marad, hogy később újra lehessen alkalmazni.

    Szövegre vonatkozó feltétel eltávolításához jelölje ki a szöveget, majd a feltétel neve mellett található négyzetre való kattintással törölje a jelet a négyzetből. Ha az összes feltételt szeretné eltávolítani a kijelölt szövegből, akkor kattintson a [Nem feltételes] gombra.

    Feltételek betöltése (importálása)

    Csak a feltételek betöltéséhez válassza a Feltételes szöveg panel menüjének Feltételek betöltése parancsát, a feltételek és készletek betöltéséhez pedig a Feltételek és készletek betöltése parancsát. Jelölje ki azt az InDesign-dokumentumot, amelyből importálni kívánja a feltételeket, majd kattintson a Megnyitás gombra. A betöltött feltételek és készletek lecserélik az azokkal azonos nevű feltételeket és készleteket.

    Az InCopy-fájlokból nem tölthet be feltételeket az InDesign programba, az InDesign-fájlokból viszont mind az InDesign, mind az InCopy programba betöltheti azokat.

    A betöltött készletek figyelmen kívül hagyják a jelenleg a Feltételes szöveg panelen található feltételek láthatósági beállításait.

    Könyvben szereplő feltételek szinkronizálása

    Ha szeretne gondoskodni arról, hogy egy könyv valamennyi dokumentumában ugyanazok a feltételek érvényesüljenek, akkor a stílusforrás-dokumentumban hozza létre a feltételeket, a Szinkronizálási beállítások párbeszédpanelen válassza ki a feltételes szöveg beállításait, végül szinkronizálja a könyvet.

    Feltételjelzők megjelenítése és elrejtése

    A feltételjelzők megjelenítéséhez, illetve elrejtéséhez a Feltételes szöveg panel Jelzők menüjében válassza a Megjelenítés, illetve az Elrejtés lehetőséget. Ha egy verzió van megjelenítve, és szeretné megtekinteni, hogy hol vannak feltételes részek, akkor jelenítse meg a feltételjelzőket. Ha az elrendezés megtekintése közben zavarónak találja a feltételjelzőket, rejtse el azokat. Ha a nyomtatásban és a kimenetben is szeretné szerepeltetnie a feltételjelzőket, válassza a Megjelenítés és nyomtatás lehetőséget.

    Feltétel nevének módosítása

    A Feltételes szöveg panelen kattintson valamelyik feltételre, várjon picit, majd a feltétel nevére való kattintással jelölje azt ki. Adjon meg egy másik nevet.

    Feltételjelzők szerkesztése

    Kattintson duplán valamelyik feltételre a Feltételes szöveg panelen, vagy jelölje ki valamelyik feltételt, majd válassza a panel menüjének Feltétel beállítása parancsát. Adja meg a jelző beállításait, majd kattintson az OK gombra.

Feltételes szöveg keresése és módosítása

A Keresés/csere párbeszédpanelen keresheti meg az adott feltétellel (feltételekkel) ellátott szövegrészeket, valamint láthatja le azokat más feltétellel (feltételekkel).

  1. Jelenítse meg az összes olyan feltételes szöveget, amelyet bele kíván foglalni a keresésbe.

    A program nem keres a rejtett szövegekben.

  2. Kattintson a Szerkesztés menü Keresés/csere parancsára.
  3. Ha a Formátum keresése és a Formátum módosítása mező nem látható a párbeszédpanel alján, kattintson a További beállítások elemre.
  4. Kattintson a Formátum keresése mezőre a Formázási beállítások keresése párbeszédpanel megnyitásához. A Feltételek részben a [Bármilyen feltétel] lehetőség kiválasztásával kereshet olyan szöveget, amelynél legalább egy érvényesül a feltételek közül, a [Nem feltételes] lehetőség kiválasztásával kereshet olyat, amelynél egy feltétel sem érvényesül, illetve külön is kiválaszthatja, hogy mely feltétel(ek)re kívánja korlátozni a keresést. Kattintson az OK gombra.

    Ezzel a funkcióval pontosan a kijelölt feltételeknek megfelelő szövegrészek kereshetők meg. Ha például az 1., és a 2. feltételt jelölte ki, akkor a program sem azokat a szövegrészeket nem jeleníti meg találatként, amelyekre ezek közül csak az egyik feltétel vonatkozik, sem azokat, amelyekre e két feltétel mellett még másik is vonatkozik.

  5. Kattintson a Formátum módosítása mezőre a Formázási beállítások megváltoztatása párbeszédpanel megnyitásához. Adja meg a különféle formázási beállításokat (pl. egy feltételes vagy egy karakterstílust), majd kattintson az OK gombra.

    Ha a Formázási beállítások megváltoztatása párbeszédpanelen kijelöli a Feltételek részben szereplő feltételeket, akkor a [Bármilyen feltétel] nem módosítja a talált feltételes szöveget. Ennek a lehetőségnek akkor veheti hasznát, ha más formázást (pl. karakterstílust) szeretne alkalmazni. Ha az összes feltételt szeretné eltávolítani a talált szövegből, akkor válassza a [Nem feltételes] lehetőséget. Adott feltétel kijelölésekor adja meg, hogy az felülírja-e a talált szövegre vonatkozó feltételek valamelyikét, vagy azzal együtt érvényesüljön-e.

  6. Kattintson a Keresés gombra, majd cserélje le a feltételt a Módosítás, a Módosítás/keresés vagy a Mindet módosítja gomb használatával.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat