Create and modify shapes using Pen and shape tools and copy paths into After Effects from Illustrator and Photoshop.

You create a shape layer by drawing in the Composition panel with a shape tool or the Pen tool. You can then add shape attributes to existing shapes or create shapes within that shape layer. By default, if you draw in the Composition panel when a shape layer is selected, you create a shape within that shape layer, above the selected shapes or group of shapes. If you draw in the Composition panel using a shape tool or Pen tool when an image layer other than a shape layer is selected, you create a mask. For more information, see Create masks in After Effects.

Shortcuts for Shape tool is Q, and Pen Tool shortcut is G.

Heroimage

Note:

Before drawing in the Composition panel to create a shape layer, press F2 and deselect all layers.

Usually, a new shape has a fill and a stroke that correspond to the Fill and Stroke settings in the Tools panel at the time that the shape is drawn. You can use the same controls in the Tools panel to change these attributes for a selected shape after it has been drawn. Shapes created from text are created with fills and strokes that match the fills and strokes of the original text.

Convert Vector Art Footage to Shape

You can create a shape layer from a vector art footage layer, and then modify it. With the ability to bevel and extrude objects in After Effects, you can extrude the artwork, for example, extruded logos. For more information, see Extruding text and shape layers.

To convert a vector art footage layer to shape layer, choose Layer > CreateCreate Shapes from Vector Layer. A matching shape layer appears above the footage layer, and the footage layer is muted.

  • Not all features of Illustrator files are currently preserved. Examples include: opacity, images, and gradients.
  • Converted shapes ignore PAR overrides specified in the Interpret Footage dialog box.
  • Gradients and unsupported types may show as 50% gray shapes.
  • Files with thousands of paths may import slowly without feedback.
  • The menu command works on a single selected layer at a time.
  • If you import an Illustrator file as a composition (multiple layers), you cannot convert all those layers in one pass. However, you can import the file as footage, and then use the command to convert the single footage layer to shapes.

Create a shape dragging with shape tools

The shape tools are the Rectangle , Rounded Rectangle , Ellipse , Polygon , and Star tools.

Note:

To activate and cycle through the shape tools, press Q.

A polygon is a star without an Inner Radius or Inner Roundness property. So, the name of the shape created for a polygon or a star is the same: polystar.

You can create a mask by dragging with a shape tool on a selected layer in the Composition panel or Layer panel. You can create a shape by dragging with a shape tool on a selected shape layer in the Composition panel. If you drag with a shape tool in the Composition panel with no layer selected, you create a shape on a new shape layer.

Note:

To draw a mask on a shape layer, click the Tool Creates Mask button in the Tools panel with a shape tool active.

When you create a shape by dragging with a shape tool in the Composition panel, you create a parametric shape path. To instead create a Bezier shape path, press the Alt (Windows) or Option (Mac OS) key before you click to begin dragging. You can release the key before you complete the drag operation. All mask paths are Bezier paths. (See About shapes and shape layers.)

Dragging starts when you click in the Composition panel or Layer panel to begin drawing, and ends when you release the mouse button. Pressing modifier keys at different times during a single dragging operation achieves different results:

  • To reposition a shape or mask as you are drawing, hold the spacebar or the middle mouse button while dragging.

  • To scale a circle, ellipse, square, rounded square, rectangle, or rounded rectangle around its center while drawing, hold the Ctrl (Windows) or Command (Mac OS) key after you begin dragging. Don’t release the key until you have released the mouse button to finish drawing.

  • To cancel the drawing operation, press Esc.

Note:

Each shape tool retains the settings of the most recent drawing operation with that tool. For example, if you draw a star and modify the number of points to be 10, then the next star that you draw will also have 10 points. To reset settings for a tool and create a shape with the default settings, double-click the tool in the Tools panel. (See Create a shape or mask the size of the layer.)

Draw rectangles, rounded rectangles, squares, and rounded squares

  1. Select the Rectangle tool  or the Rounded Rectangle tool , and do one of the following:
    • To draw a rectangle or rounded rectangle, drag diagonally.
    • To draw a square or rounded square, Shift-drag diagonally.
Rectangle

2.  (Optional) If drawing a rounded rectangle or rounded square, do the following before releasing the mouse button:

  • To increase or decrease the corner roundness, press the Up arrow key or the Down arrow key, or roll the mousewheel forward or backward.
  • To set corner roundness to the minimum or maximum, press the Left arrow key or the Right arrow key.

3.  Finish drawing by releasing the mouse button. If drawing a square or rounded square, release the Shift key after releasing the mouse button.

Note:

Squares are created to be square according to the pixel aspect ratio of the composition. If the pixel aspect ratio of the composition is not 1, then squares appear square in the Composition panel only if the Toggle Pixel Aspect Ratio button is selected at the bottom of the Composition panel.

Draw ellipses and circles

  1. Select the Ellipse tool , and do one of the following:
    • To draw an ellipse, drag diagonally.
    • To draw a circle, Shift-drag diagonally.
  2. Release the mouse to finish drawing. If drawing a circle, release the Shift key after releasing the mouse button.
Circle

Note:

Circles are created to be circular according to the pixel aspect ratio of the composition. If the pixel aspect ratio of the composition is not 1, then circles appear circular in the Composition panel only if the Toggle Pixel Aspect Ratio button is selected at the bottom of the Composition panel.

Draw polygons and stars

  1. Select the Polygon tool  or the Star tool , and do one of the following:
    • Drag to scale and rotate the polygon or star as you draw it.
    • Shift-drag to scale the polygon or star as you draw it, preventing rotation.
Starploygon

2.  (Optional) Do the following before releasing the mouse button:

  • To add or remove points, press the Up arrow key or the Down arrow key, or roll the mouse wheel forward or backward.
  • To increase or decrease the outer roundness, press the Left arrow key or the Right arrow key.
  • To keep the inner radius of a star constant as you move the mouse to increase the outer radius, hold the Ctrl (Windows) or Command (Mac OS) key.
  • To increase or decrease the inner roundness of a star, press the Page Up key or the Page Down key.

3.  Release the mouse button to finish drawing. If Shift-dragging to prevent rotation, release the Shift key after releasing the mouse button.

Create a Bezier shape or mask using the Pen tool

You can create a Bezier mask using the Pen tool on a selected layer in the Composition panel or Layer panel. You can create a shape with a Bezier path using the Pen tool on a selected shape layer in the Composition panel. If you draw with the Pen tool in the Composition panel with no layer selected, you create a shape on a new shape layer.

Creating a RotoBezier path is similar to creating a manual Bezier path. The primary difference is that direction lines for vertices and curvature for path segments are automatically calculated.

Create a manual Bezier path using the Pen tool

  1. With the Pen tool selected and the RotoBezier option deselected in the Tools panel, click in the Composition panel where you want to place the first vertex.
  2. Click where you want to place the next vertex. To create a curved segment, drag the direction line handle to create the curve that you want.

    Note:

    To reposition a vertex after you’ve clicked to place it but before you’ve released the mouse button, hold the spacebar while dragging.

    The last vertex that you add appears as a solid square, indicating that it is selected. Previously added vertices become hollow, and deselected, as you add more vertices.

  3. Repeat step 2 until you are ready to complete the path.
  4. Complete the path by doing one of the following:
    • To close the path, place the pointer over the first vertex and, when a closed circle icon appears next to the pointer , click the vertex. You can also close a path by double-clicking the last vertex or choosing Layer > Mask And Shape Path > Closed.
    • To leave the path open, activate a different tool, or press F2 to deselect the path.

Draw straight manual Bezier path segments with the Pen tool

The simplest path that you can draw with the Pen tool is a straight line, made by clicking with the Pen tool to create two vertices. By continuing to click, you create a path made of straight-line segments connected by corner points.

  1. Place the Pen tool where you want the straight segment to begin, and click to place a vertex. (Do not drag.)
    Clicking with Pen tool creates straight segments
    Clicking with Pen tool creates straight segments.
  2. Click again where you want the segment to end. (Shift-click to constrain the angle between segments at the corner point to a whole multiple of 45°.)
  3. Continue clicking to set vertices for additional straight segments.

Draw curved manual Bezier path segments with the Pen tool

You create a curved path segment by dragging direction lines. The length and direction of the direction lines determine the shape of the curve.

Note:

Shift-drag to constrain the angle of the direction lines to whole multiples of 45°. Alt-drag (Windows) or Option-drag (Mac OS) to modify only the outgoing direction line.

1.  Place the Pen tool where you want the curve to begin, and hold the mouse button down. A vertex appears, and the Pen tool pointer changes to an arrowhead.

2.  Drag to modify the length and direction of both direction lines for a vertex, and then release the mouse button.

Drawing the first vertex in a curved path
Drawing the first vertex in a curved path

A. Placing the Pen tool B. Starting to drag (mouse button pressed) C. Dragging to extend direction lines 

3.  Place the Pen tool where you want the curved segment to end, and do one of the following:

  • To create a C-shaped curve, drag in the direction opposite from the direction that you dragged the previous direction line, and then release the mouse button.
Drawing the second vertex in a curved path
Drawing the second vertex in a curved path

A. Starting to drag B. Dragging away from previous direction line, creating a C curve C. Result after releasing mouse button 
  • To create an S-shaped curve, drag in the same direction as the previous direction line, and then release the mouse button.
Drawing an S curve
Drawing an S curve

A. Starting to drag B. Dragging in same direction as previous direction line, creating an S curve C. Result after releasing mouse button 

4.  Continue dragging the Pen tool from different locations to create a series of smooth curves.

Create a shape of the size of the layer

  1. Select the destination for the new shape:

    • To create a shape on an existing shape layer, select the shape layer.
    • To create a shape on a new shape layer with the dimensions of the composition, deselect all layers by pressing F2.
    • To replace a shape path, select the shape path (not the group) in the Composition panel or Timeline panel.
  2. In the Tools panel, double-click the Rectangle , Rounded Rectangle , Ellipse , Polygon , or Star tool.

Create shapes from text characters

Use Create Shapes From Text to extract the outlines for each character, create shapes from the outlines, and put the shapes on a new shape layer. You can then use these shapes as you would any other shapes.

Use Create Masks From Text to extract the outlines for each character, create masks from the outlines, and puts the masks on a new solid-color layer. You can then use these masks as you would any other masks.

Note:

Some font families, such as Webdings, include characters that are graphical images, rather than text. Converting text from these font families can be a good way to get started with simple graphical elements in shape layers.

create shape from text
  1. Select the text to convert to shapes:
    • To create shapes for all characters in a text layer, select the text layer in the Timeline panel or Composition panel.
    • To create shapes for specific characters, select the characters in the Composition panel.
  2. Do one of the following:
    • Choose Layer > Create Shapes From Text.
    • Right-click (Windows) or Control-click (Mac OS) the layer or text and choose Create Shapes From Text from the context menu.

  • The Video switch for the text layer is turned off.
  • The new shape layer is created at the top of the layer stacking order. The new layer contains one shape group for each selected character, plus fill and stroke properties that match the fills and strokes of the text.
  • For characters that consist of compound paths—such as i and e—multiple paths are created and combined with the Merge Paths path operation.
  • Effects, masks, layer styles, and keyframes and expressions for properties in the Transform property group of the text layer are copied to the new shape layer or solid-color layer.

Copy a path from Illustrator or Photoshop

copy a path from Illustrator or After Effects

You can copy a path from Illustrator or Photoshop and paste it into After Effects as a mask path or shape path.

To make the data copied from Illustrator compatible with After Effects, the AICB option must be selected in the Files & Clipboard section of the Adobe Illustrator Preferences dialog box.

For a path imported from Photoshop to be scaled correctly, the Photoshop document must have a resolution of 72 dpi. 72 dpi is the Resolution setting of documents created in Photoshop using a Film & Video preset.

You can also use a copied Illustrator or Photoshop path as an After Effects motion path. See Create a motion path from a mask, shape, or paint path for more information.

Path drawn in Adobe Illustrator (left) and pasted into After Effects as a mask (right)
Path drawn in Adobe Illustrator (left) and pasted into After Effects as a mask (right)
  1. In Illustrator or Photoshop, select an entire path, and then choose Edit > Copy.

  2. In After Effects, do one of the following to define a target for the paste operation:
    • To create a mask, select a layer.
    • To replace an existing mask path or shape path, select its Path property.

    Note:

    To paste a path as a shape path, you must select the Path property of an existing shape in a shape layer. This selection tells After Effects what the target of the paste operation is; if the target isn’t specified in this way, After Effects assumes that the target is the entire layer and therefore draws a new mask. If there is no Path property—perhaps because the shape layer is empty—then you can draw a placeholder path with the Pen tool and then paste the path from Illustrator into the placeholder path.

  3. Choose Edit > Paste. If you paste multiple paths into a shape path, the first path goes into the shape path, and the remaining paths are pasted into new mask paths.

Create a shape from a motionpath

You can copy position keyframes, anchor point keyframes, or an effect control point’s position keyframes and paste those keyframes into a selected mask path or shape path. When you create mask paths or shape paths from motion paths, make sure that you copy keyframes from a single Position property only—do not copy the keyframes of any other property.

Note:

Draw a motion path with Motion Sketch and then paste the path into a mask path or shape path.

Create a mask or shape from a motion path
The motion path of the spaceship copied to the background layer, and animated

Create a shape path from a motion path

  1. In the Timeline panel, click the name of the Position property or Anchor Point property from which you want to copy the motion path. (This selects all keyframes. To select only some of the keyframes of a motion path, Shift-click them.)
  2. Choose Edit > Copy.
  3. To create a shape layer, press F2 to deselect all layers, then click in the Composition panel with the Pen tool to create a single-point Bezier path.

  4. Press SS to reveal the Path property for the shape. Click the name of the Path property into which to paste the keyframes from the motion path.
  5. Choose Edit > Paste.

Create a mask path from a motion path

Duplicate a shape group while transforming

When a shape group is selected in group selection mode, you can duplicate the group while moving, rotating, or scaling it in the Composition panel.

Hold the Alt (Windows) or Option (Mac OS) key as you drag to transform a group.

The pointer changes to a duplication pointer ( or ) as you hold the key and place the pointer near the group transform box.