Managing layers

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. Planning and setup
    9. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. XMP metadata
  7. Working with text and graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, painting, and paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. How to taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Working with layers
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, keyframing, motion tracking, and keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels, masks, and mattes
  12. Adjusting color
    1. Color basics
    2. Use the Adobe Color Themes extension
    3. Color management
    4. Color Correction effects
  13. Effects and animation presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. Preview changes to 3D designs real time with the Real-Time Engine
    7. Add responsive design to your graphics 
  16. Views and previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Collaborate with Team Projects
    5. Share and manage changes with Team Project collaborators
    6. Creative Cloud Libraries in After Effects
    7. Plug-ins
    8. CINEMA 4D and Cineware
  19. Memory, storage, performance
    1. Memory and storage
    2. Improve performance
    3. Preferences
    4. GPU and GPU driver requirements for After Effects

Jeff Almasol provides a script on his redefinery website that renders and exports each of the selected layers separately. For example, use this script if layers represent different versions of an effect or different parts of an effect that you want to render as separate passes for flexibility in how they get composited.

View and change layer information

  • To rename a layer or property group, do one of the following:
    • Select the item in the Timeline panel, press Enter (Windows) or Return (Mac OS), and enter the new name.

    • Right-click (Windows) or Control-click (Mac OS) the item in the Timeline panel, choose Rename, and enter the new name.

  • To alternate between viewing the names of source footage items and the names of layers in the Timeline panel, click the Layer Name/Source Name column heading in the Timeline panel.
Note:

When the layer name and the source footage name are the same, square brackets appear around the layer name in the layer name view, like this: [layer name]

  • To show the name of the source footage file for a selected layer in the Info panel, press Ctrl+Alt+E (Windows) or Command+Option+E (Mac OS).
  • To see what footage item is the source for a layer, right-click (Windows) or Control-click (Mac OS) the layer in the Timeline panel and choose Reveal Layer Source In Project.

The source footage item is selected in the Project panel.

You can filter layers in the Timeline panel to show only layers with properties that match a search string or certain other characteristics. See Search and filter in the Timeline, Project, and Effects & Presets panels and Showing properties and groups in the Timeline panel (keyboard shortcuts).

Jeff Almasol provides a script on his redefinery website that automatically writes specified information about footage items or layers to the Comment fields for the respective items in the Project panel or Timeline panel.

Christopher Green provides a script (Selected_Layers_Renamer.jsx) on his website with which you can rename multiple layers selected in the Timeline panel. You can search and replace text in the names, append characters to the beginning or end of the names, trim a specified number of characters from the beginning or end of the names, or replace the names with numbers in a series.

Layer switches and columns in the Timeline panel

Many of characteristics of a layer are determined by its layer switches, which are arranged in the Timeline panel in columns. By default, the A/V Features column appears to the left of the layer name, and the Switches and Modes (Transfer Controls) columns appear to the right, but you can arrange columns in a different order. (See Columns.)

To show or hide columns in the Timeline panel, click the Layer Switches , Transfer Controls , or In/Out/Duration/Stretch button in the lower-left corner of the Timeline panel. Press Shift+F4 to show or hide the Parent column. Press F4 to toggle the Switches and Modes columns.

The results of some layer switch settings depend on the settings of composition switches, which are in the upper right of the layer outline in the Timeline panel.

Note:

Quickly change the state of a switch for multiple layers by clicking the switch for one layer and dragging up or down that column for the adjacent layers.

Jeff Almasol provides a script on his redefinery website that creates a panel with which you can save and restore the layer switch settings for all layers in a composition.

Switches in the A/V Features column

Video 

Toggles layer visuals on or off. (See Toggle visibility or influence of a layer or property group.)

Audio 

Toggles layer sounds on or off.

Solo 

Includes the current layer in previews and renders, ignoring layers without this switch set. (See Solo a layer.)

Lock 

Locks layer contents, preventing all changes. (See Lock or unlock a layer.)

Switches in the Switches column

Shy 

Hides the current layer when the Hide Shy Layers composition switch is selected. (See Show and hide layers in the Timeline panel.)

Collapse Transformations/Continuously Rasterize

Collapses transformations if the layer is a precomposition; continuously rasterizes if the layer is a shape layer, text layer, or layer with a vector graphics file (such as an Adobe Illustrator file) as the source footage. Selecting this switch for a vector layer causes After Effects to rerasterize the layer for each frame, which improves image quality, but also increases the time required for previewing and rendering. (See Render order and collapsing transformations and Continuously rasterize a layer containing vector graphics.)

Quality 

Toggles between Best and Draft options for layer quality for rendering, including rendering to the screen for previews. (See Layer image quality and subpixel positioning.)

Effect 

Select to render the layer with effects. The switch does not affect the setting for individual effects on the layer. (See Delete or disable effects and animation presets.)

Frame Blend 

Sets frame blending to one of three states: Frame Mix , Pixel Motion , or off. If the Enable Frame Blending composition switch is not selected, the frame blending setting of the layer is irrelevant. (See Frame blending.)

Motion Blur 

Toggles motion blur on or off for the layer. If the Enable Motion Blur composition switch is not selected, the motion blur setting of the layer is irrelevant. (See Motion blur.)

Adjustment Layer 

Identifies the layer as an adjustment layer. (See Adjustment layers.)

3D Layer 

Identifies the layer as a 3D layer. If the layer is a 3D layer with 3D sublayers—as is the case for a text layer with per-character 3D properties—the switch uses this icon: . (See 3D layers overview and resources.)

Toggle visibility or influence of a layer or property group

The Video (eyeball) switch for a layer controls whether the visual information for a layer is rendered for previews or final output. If the layer is an adjustment layer, the Video switch controls whether the effects on the layer are applied to the composite of the layers below it. If the layer is a camera or light, the Video switch controls whether the layer is on or off.

Several components of layers—such as paint strokes, path operations in shape layers, and text animators in text layers—each have their own Video switches. You can use the Video switch to toggle the visibility and influence of these items individually.

  • To turn off the visibility of a layer deselect the Video switch for the layer.
  • To select the Video switch for all layers, choose Layer > Switches > Show All Video.
  • To deselect the Video switch for all layers except the selected layers, choose Layer > Switches > Hide Other Video.

Solo a layer

You can isolate one or more layers for animating, previewing, or final output by soloing. Soloing excludes all other layers of the same type from being rendered—both for previews in the Composition panel and for final output. For example, if you solo a video layer, any lights and audio layers are unaffected, so they appear when you preview or render the composition. However, the other video layers do not appear.

  • To solo one or more layers, select the layers in the Timeline panel, and click the Solo icon to the left of the layer names.
  • To solo one layer and unsolo all other layers, Alt-click (Windows) or Option-click (Mac OS) the Solo icon to the left of the layer name.

The Video switch is dimmed for other layers when a layer is soloed, indicating that the other layers are not visible.

Lloyd Alvarez provides a script on his After Effects Scripts website with which you can tag layers and then select, shy, and solo layers according to their tags. The tags are appended to comments in the Comments column in the Timeline panel.

Lock or unlock a layer

The Lock switch prevents layers from being edited accidentally. When a layer is locked, you cannot select it in either the Composition or Timeline panels. If you try to select or modify a locked layer, the layer flashes in the Timeline panel.

When a layer is locked, the Lock icon appears in the A/V Features column, which appears by default to the left of the layer name in the Timeline panel.

  • To lock or unlock a layer, click the Lock switch for the layer in the Timeline panel.
  • To unlock all layers in the active composition, choose Layer > Switches > Unlock All Layers.

Color labels for layers, compositions, and footage items

You can use labels (colored boxes in the Label column) in the Project panel and Timeline panel to organize and manage compositions, footage items, and layers. By default, different label colors indicate different kinds of footage items, but you can assign label colors to indicate whatever categories you choose.

Note:

Rename label groups to help you to organize and categorize layers and footage items. To see label names in the Label column, widen the column to greater than the default width.

  • To select all layers with the same label color, select a layer with that label color and choose Edit > Label > Select Label Group.
  • To change the color of a label for one layer, click the label in the Timeline panel and choose a color.
  • To change the color of a label for all layers with that label color, select one of the layers belonging to the label group, choose Edit > Label > Select Label Group, and choose Edit > Label > [color name].
  • To change the names and default colors for labels, choose Edit > Preferences > Labels (Windows) or After Effects > Preferences > Labels (Mac OS).
  • To change the default associations of label colors with source types, choose Edit > Preferences > Labels (Windows) or After Effects > Preferences > Labels (Mac OS).
  • To disable the use of a layer’s label color for layer handles and motion paths, choose Edit > Preferences > Appearance (Windows) or After Effects > Preferences > Appearance (Mac OS), and deselect Use Label Colors For Layer Handles And Paths.
  • To disable the use of a layer, footage item, or composition’s label color in the tabs of corresponding panels, choose Edit > Preferences > Appearance (Windows) or After Effects > Preferences > Appearance (Mac OS), and deselect Use Label Colors For Related Tabs.
Note:

By default, the panel label colors do not respond to the Brightness control in the Appearance preferences. To make the Brightness control affect panel label colors, select the Affects Label Colors option in the Appearance preferences.

Show and hide layers in the Timeline panel

You can mark a layer as shy and then use the Hide Shy Layers composition switch at the top of the Timeline panel to hide all shy layers in the Timeline panel layer outline. Making layers shy is useful for making room in the Timeline panel to show the layers and layer properties that you want to adjust.

The icon in the Switches column indicates whether a layer is shy or not shy .

Shy layers are still rendered, both for previews and for final output. To exclude layers from previews or final output, use the Video switch or make the layer a guide layer.

  • To toggle a layer between shy and not shy, click the Shy switch for the layer, or select the layer in the Timeline panel and choose Layer > Switches > Shy.
  • To toggle between hiding and showing all shy layers, click to select or deselect the Hide Shy Layers composition switch at the top of the Timeline panel, or choose Hide Shy Layers from the Timeline panel menu.

You can also filter layers in the Timeline panel to show only layers with properties that match a search string or certain other characteristics. See Search and filter in the Timeline, Project, and Effects & Presets panels and Showing properties and groups in the Timeline panel (keyboard shortcuts).

Lloyd Alvarez provides a script on his After Effects Scripts website with which you can tag layers and then select, shy, and solo layers according to their tags. The tags are appended to comments in the Comments field in the Timeline panel.

Layer image quality and subpixel positioning

The quality setting of a layer determines how precisely it is rendered, as well as influencing the precision of other calculations involving the layer, such as motion tracking and the use of the layer as a control layer for a compound effect.

Duplicated or split layers retain the Quality setting of the original layer.

You can choose between three options for quality: Best, Draft, and Wireframe. When you select the Best option, you can choose between bilinear and bicubic sampling, which are described in the next section. 

To toggle between Best (bilinear sampling), Draft, and Best (bicubic sampling) quality of selected layers, click the Quality switch in the Timeline panel. To choose from all these options plus the Wireframe option, choose Layer > Quality:

Best

Displays and renders a layer using subpixel positioning, anti-aliasing, 3D shading, and complete calculation of any applied effects. Best requires the most time for rendering—both for previews and for final output.

Draft

Displays a layer so that you can see it, but only at rough quality. Draft quality displays and renders a layer without anti-aliasing and subpixel positioning, and some effects are not precisely calculated.

Wireframe

Displays a layer as a box, without layer contents. Layer wireframes are displayed and rendered faster than layers rendered with Best or Draft settings.

Bilinear and bicubic sampling

For layers with quality set to Best, you can choose between bicubic and bilinear sampling. This per-layer setting determines how pixels are sampled for transformations such as scaling.

The default keyboard shortcuts for setting the sampling method for selected layers are Alt+B (Windows) and Option+B (Mac OS) for Best/Bilinear and Alt+Shift+B (Windows) and Option+Shift+B (Mac OS) for Best/Bicubic.

Bicubic sampling is somewhat more processor-intensive than bilinear sampling, and bicubic sampling is not the highest-quality choice in all cases. It’s rather easy to see artifacts with bicubic sampling in some circumstances, such as ringing and overshoots at a hard transition from one color to another. Bicubic sampling tends to be the best option in cases where transitions from one color to another are more gradual, as is the case with nearly all real-world photographic images, but not necessarily for sharp-edged graphics. Bicubic sampling helps more for scaling up than it does for scaling down.

Note:

Textures in the ray-traced 3D renderer do not use bicubic sampling; they always use bilinear sampling. Transformations within effects also still use bilinear sampling, unless the effect specifically implements another method (as with a dedicated scaling plug-in effect or distortion effect).

Subpixel positioning

Property values (like Position and Anchor Point) in After Effects are not restricted to integer values; they can have fractional values, too. This allows for smooth animation, as a value is interpolated from one keyframe to another. For example, if a Position value goes from [0,0,0] at a keyframe at time 0 to a value of [0,0,80] at time 1 second in a 25-frames-per-second composition, then the value at frame 1 is [0,0,3.2].

After Effects calculates all spatial values, like Position and effect control points, to a precision of 1/65,536 of a pixel. This is called subpixel precision.

If the pixels of a layer aren't positioned directly on the pixel boundaries of the composition, a small amount of blur occurs—very similar to anti-aliasing. This blur is not a problem for an object in motion, because objects in motion have motion blur, but it can soften fine details in a static image. Also, if an image is moving slowly or at just the wrong speed, the image can appear to oscillate between sharpness and blurriness.

Because the default anchor point for a layer is the center of an object, odd-sized objects have non-integer anchor points and appear soft when positioned at integer values. To minimize blurriness and in-and-out of focus result, follow these guidelines:

  • Create graphics with odd or even dimensions, based on the dimensions of the composition. For example, if the composition is 640x480 pixels, create graphics with even dimensions (such as 100x100 pixels); if the composition is 99x99 pixels, create graphics with odd dimensions (such as 75x53 pixels).

  • Set the position information for graphics (including the hold position and final position keyframes) to integers and not fractional numbers.

Continuously rasterize a layer containing vector graphics

When you import vector graphics, After Effects automatically rasterizes them. However, if you want to scale a layer that contains vector graphics above 100%, then you need to continuously rasterize the layer to maintain image quality. You can continuously rasterize vector graphics in layers based on Illustrator, SWF, EPS, and PDF files. Continuously rasterizing causes After Effects to rasterize the file as needed based on the transformation for each frame. A continuously rasterized layer generally produces higher-quality results, but it may render more slowly.

Shape layers and text layers are always continuously rasterized.

When you apply an effect to a continuously rasterized layer, the results may differ from the results of applying the effect to a layer without continuous rasterization. This difference in results is because the default rendering order for the layer changes. The default rendering order for a layer without continuous rasterization is masks, followed by effects, and then transformations; whereas the default rendering order for a continuously rasterized layer is masks, followed by transformations, and then effects.

Whether or not you continuously rasterize, if you view and render a composition using Best Quality, After Effects anti-aliases (smooths) the vector graphics.

You cannot open or interact with a continuously rasterized layer in a Layer panel. A result of this limitation is that you can’t paint directly on a continuously rasterized layer. However, you can copy and paste paint strokes from other layers.

Image from imported Illustrator file with rasterized layer
Image from imported Illustrator file

A. Original B. Enlarged with Continuously Rasterize switch turned off C. Enlarged with Continuously Rasterize switch turned on 

  1. In the Timeline panel, click the layer’s Continuously Rasterize switch   , which is the same as the Collapse Transformations switch for precomposition layers.
Adobe logo

Sign in to your account