User Guide Cancel

Working with After Effects and other applications

  1. After Effects User Guide
  2. Beta releases
    1. Beta Program Overview
    2. After Effects Beta Home
    3. Features in Beta
      1. Properties panel (Beta)
      2. Selectable Track Matte Layers (Beta)
      3. Native H.264 Encoding (Beta)
  3. Getting started
    1. Get started with After Effects
    2. What's new in After Effects 
    3. Release Notes | After Effects
    4. After Effects system requirements
    5. Keyboard shortcuts in After Effects
    6. Supported File formats | After Effects
    7. Hardware recommendations
    8. After Effects for Apple silicon
    9. Planning and setup
    10. Setup and installation
  4. Workspaces
    1. General user interface items
    2. Get to know After Effects interface
    3. Workflows
    4. Workspaces, panels, and viewers
  5. Projects and compositions
    1. Projects
    2. Composition basics
    3. Precomposing, nesting, and pre-rendering
    4. View detailed performance information with the Composition Profiler
    5. CINEMA 4D Composition Renderer
  6. Importing footage
    1. Preparing and importing still images
    2. Importing from After Effects and Adobe Premiere Pro
    3. Importing and interpreting video and audio
    4. Preparing and importing 3D image files
    5. Importing and interpreting footage items
    6. Working with footage items
    7. Detect edit points using Scene Edit Detection
    8. XMP metadata
  7. Text and Graphics
    1. Text
      1. Formatting characters and the Character panel
      2. Text effects
      3. Creating and editing text layers
      4. Formatting paragraphs and the Paragraph panel
      5. Extruding text and shape layers
      6. Animating text
      7. Examples and resources for text animation
      8. Live Text Templates
    2. Motion Graphics
      1. Work with Motion Graphics templates in After Effects
      2. Use expressions to create drop-down lists in Motion Graphics templates
      3. Work with Essential Properties to create Motion Graphics templates
      4. Replace images and videos in Motion Graphics templates and Essential Properties
  8. Drawing, Painting, and Paths
    1. Overview of shape layers, paths, and vector graphics
    2. Paint tools: Brush, Clone Stamp, and Eraser
    3. Taper shape strokes
    4. Shape attributes, paint operations, and path operations for shape layers
    5. Use Offset Paths shape effect to alter shapes
    6. Creating shapes
    7. Create masks
    8. Remove objects from your videos with the Content-Aware Fill panel
    9. Roto Brush and Refine Matte
  9. Layers, Markers, and Camera
    1. Selecting and arranging layers
    2. Blending modes and layer styles
    3. 3D layers
    4. Layer properties
    5. Creating layers
    6. Managing layers
    7. Layer markers and composition markers
    8. Cameras, lights, and points of interest
  10. Animation, Keyframes, Motion Tracking, and Keying
    1. Animation
      1. Animation basics
      2. Animating with Puppet tools
      3. Managing and animating shape paths and masks
      4. Animating Sketch and Capture shapes using After Effects
      5. Assorted animation tools
      6. Work with Data-driven animation
    2. Keyframe
      1. Keyframe interpolation
      2. Setting, selecting, and deleting keyframes
      3. Editing, moving, and copying keyframes
    3. Motion tracking
      1. Tracking and stabilizing motion
      2. Face Tracking
      3. Mask Tracking
      4. Mask Reference
      5. Speed
      6. Time-stretching and time-remapping
      7. Timecode and time display units
    4. Keying
      1. Keying
      2. Keying effects
  11. Transparency and Compositing
    1. Compositing and transparency overview and resources
    2. Alpha channels and masks
  12. Adjusting color
    1. Color basics
    2. Color management
    3. Color Correction effects
  13. Effects and Animation Presets
    1. Effects and animation presets overview
    2. Effect list
    3. Simulation effects
    4. Stylize effects
    5. Audio effects
    6. Distort effects
    7. Perspective effects
    8. Channel effects
    9. Generate effects
    10. Transition effects
    11. The Rolling Shutter Repair effect
    12. Blur and Sharpen effects
    13. 3D Channel effects
    14. Utility effects
    15. Matte effects
    16. Noise and Grain effects
    17. Detail-preserving Upscale effect
    18. Obsolete effects
  14. Expressions and Automation
    1. Expression
      1. Expression basics
      2. Understanding the expression language
      3. Using expression controls
      4. Syntax differences between the JavaScript and Legacy ExtendScript expression engines
      5. Editing expressions
      6. Expression errors
      7. Using the Expressions editor
      8. Use expressions to edit and access text properties
      9. Expression language reference
      10. Expression examples
    2. Automation
      1. Automation
      2. Scripts
  15. Immersive video, VR, and 3D
    1. Construct VR environments in After Effects
    2. Apply immersive video effects
    3. Compositing tools for VR/360 videos
    4. Tracking 3D camera movement
    5. Work in 3D Design Space
    6. 3D Transform Gizmos
    7. Do more with 3D animation
    8. Preview changes to 3D designs real time with the Real-Time Engine
    9. Add responsive design to your graphics 
  16. Views and Previews
    1. Previewing
    2. Video preview with Mercury Transmit
    3. Modifying and using views
  17. Rendering and Exporting
    1. Basics of rendering and exporting
    2. Export an After Effects project as an Adobe Premiere Pro project
    3. Converting movies
    4. Multi-frame rendering
    5. Automated rendering and network rendering
    6. Rendering and exporting still images and still-image sequences
    7. Using the GoPro CineForm codec in After Effects
  18. Working with other applications
    1. Dynamic Link and After Effects
    2. Working with After Effects and other applications
    3. Sync Settings in After Effects
    4. Creative Cloud Libraries in After Effects
    5. Plug-ins
    6. CINEMA 4D and Cineware
  19. Collaboration: Frame.io, and Team Projects
    1. Collaboration in Premiere Pro and After Effects
    2. Frame.io
      1. Install and activate Frame.io
      2. Use Frame.io with Premiere Pro and After Effects
      3. Frequently asked questions
    3. Team Projects
      1. Get Started with Team Projects
      2. Create a Team Project
      3. Collaborate with Team Projects
  20. Memory, storage, performance
    1. Memory and storage
    2. How After Effects handles low memory issues while previewing    
    3. Improve performance
    4. Preferences
    5. GPU and GPU driver requirements for After Effects

Working with Adobe Bridge and After Effects

Use Adobe Bridge to run animation presets; run cross-product workflow automation scripts; view and manage files and folders; organize your files by assigning keywords, labels, and ratings to them; search for files and folders; and view, edit, and add metadata.

  • To open Adobe Bridge from After Effects, choose File > Browse In Bridge.
  • To reveal a file in Adobe Bridge, select a file in the Project panel and choose File > Reveal In Bridge.
  • To use Adobe Bridge to browse for animation presets, choose Animation > Browse Presets.

Adobe Bridge is part of the Creative Cloud suite of applications and can be downloaded and installed through Creative Cloud. See the help documentation and the Adobe Bridge CC product page for more information.

See this video to get an overview of Adobe Bridge CC.

Working with Photoshop and After Effects

If you use Photoshop to create still images, you can use After Effects to bring those still images together and make them move and change. In After Effects, you can animate an entire Photoshop image or any of its layers. You can even animate individual properties of Photoshop images, such as the properties of a layer style. If you use After Effects to create movies, you can use Photoshop to refine the individual frames of those movies.

Comparative advantages for specific tasks

The strengths of After Effects are in its animation and automation features. This means that After Effects excels at tasks that can be automated from one frame to another. For example, you can use the motion tracking features of After Effects to track the motion of a microphone boom, and then automatically apply that same motion to a stroke made with the Clone Stamp tool. In this manner, you can remove the microphone from every frame of a shot, without having to paint the microphone out by hand on each frame.

In contrast, Photoshop has excellent tools for painting and drawing.

Deciding which application to use for painting depends on the task. Paint strokes in Photoshop directly affect the pixels of the layer. Paint strokes in After Effects are elements of an effect, each of which can be turned on or off or modified at any time. If you want to have complete control of each paint stroke after you’ve applied it, or if you want to animate the paint strokes themselves, use the After Effects paint tools. If the purpose of applying a paint stroke is to permanently modify a still image, use the Photoshop paint tools. If you are applying several paint strokes by hand to get rid of dust, consider using the Photoshop paint tools.

The animation and video features in Photoshop include simple keyframe-based animation. After Effects uses a similar interface, though the breadth and flexibility of its animation features are far greater.

After Effects can also automatically create 3D layers to mimic the planes created by the Photoshop Vanishing Point feature.

Exchanging still images

After Effects can import and export still images in many formats, but you will usually want to use the native Photoshop PSD format when transferring individual frames or still image sequences between After Effects and Photoshop.

When importing or exporting a PSD file, After Effects can preserve individual layers, masks, layer styles, and most other attributes. When you import a PSD file into After Effects, you can choose whether to import it as a flattened image or as a composition with its layers separate and intact.

It is often a good idea to prepare a still image in Photoshop before importing it into After Effects. Examples of such preparation include correcting color, scaling, and cropping. It is often better for you to do something once to the source image in Photoshop than to have After Effects perform the same operation many times per second as it renders each frame for previews or final output.

By creating your new PSD document from the Photoshop New File dialog box with a Film & Video preset, you can start with a document that is set up correctly for a specific video output type. If you are already working in After Effects, you can create a new PSD document that matches your composition and project settings by choosing File > New > Adobe Photoshop File.

Exchanging movies

You can also exchange video files, such as QuickTime movies, between Photoshop and After Effects. When you open a movie in Photoshop, a video layer is created that refers to the source footage file. Video layers allow you to paint nondestructively on the movie’s frames, much as After Effects works with layers with movies as their sources. When you save a PSD file with a video layer, you save the edits that you made to the video layer, not edits to the source footage itself.

You can also render a movie directly from Photoshop. For example, you can create a QuickTime movie from Photoshop that can then be imported into After Effects.

Color

After Effects works internally with colors in an RGB (red, green, blue) color space. Though After Effects can convert CMYK images to RGB, you should do video and animation work in Photoshop in RGB.

If relevant for your final output, it is better to ensure that the colors in your image are broadcast-safe in Photoshop before you import the image into After Effects. A good way to do this is to assign the appropriate destination color space—for example, SDTV (Rec. 601)—to the document in Photoshop. After Effects performs color management according to color profiles embedded in documents, including imported PSD files.

Working with Animate CC and After Effects

If you use Adobe Animate (formerly called Flash Professional) to create video or animation, you can use After Effects to edit and refine the video. For example, from Adobe Animate, you can export animations and applications as QuickTime movies, .mp4, and other standard video formats. You can then use After Effects to edit and refine the video.

If you use After Effects to edit and composite video, you can then use Animate to publish that video.

Animate and After Effects use separate terms for some concepts that they share in common. The following table lists the differences between the terms used in the two applications:

After Effects

Animate

Composition

Movie Clip

Composition frame (Composition panel)

Stage

Project panel

Library panel

Project files

FLA files

Render and export a movie

Publish SWF file

Exporting QuickTime video from Animate

If you create animations or applications with Animate, you can export them as QuickTime movies using the File > Export > Export Movie command in Animate. For a Animate animation, you can optimize the video output for animation. For an Animate application, Animate renders video of the application as it runs, allowing the user to manipulate it. This lets you capture the branches or states of your application that you want to include in the video file.

Importing and publishing video in Animate

When you import a movie file into Animate, you can use various techniques, such as scripting or Animate components, to control the visual interface that surrounds your video. For example, you might include playback controls or other graphics. You can also add graphic layers on top of the movie for composite results.

Composite graphics, animation, and video

Animate and After Effects each include many capabilities that allow you to perform complex compositing of video and graphics. Which application you choose to use will depend on your personal preferences and the type of final output you want to create.

Animate is the more web-oriented of the two applications, with its small final file size. Animate also allows for run-time control of animation. After Effects is oriented toward video and film production, provides a wide range of visual effects, and is generally used to create video files as final output.

Both applications can be used to create original graphics and animation. Both use a timeline and offer scripting capabilities for controlling animation programmatically. After Effects includes a larger set of effects.

Both applications allow you to place graphics on separate layers for compositing. These layers can be turned on and off as needed. Both also allow you to apply effects to the contents of individual layers.

In Animate, composites do not affect the video content directly; they affect only the appearance of the video during playback in Flash Player. In contrast, when you composite with imported video in After Effects, the video file you export actually incorporates the composited graphics and effects.

Because all drawing and painting in After Effects is done on layers separate from any imported video, it is always non-destructive. Animate has both destructive and nondestructive drawing modes.

 

Importing SWF files into After Effects

Animate has a unique set of vector art tools that make it useful for a variety of drawing tasks not possible in After Effects or Adobe® Illustrator®. You can import SWF files into After Effects to composite them with other video or render them as video with additional creative effects. Interactive content and scripted animation are not retained. Animation defined by keyframes is retained.

Each SWF file imported into After Effects is flattened into a single continuously rasterized layer, with its alpha channel preserved. Continuous rasterization means that graphics stay sharp as they are scaled up. This import method allows you to use the root layer or object of your SWF files as a smoothly rendered element in After Effects, allowing the best capabilities of each tool to work together.

Importing FLA files into After Effects

You can import Animate FLA files into After Effects as a composition of layered .swf files. You can composite them with a video or render them as video with additional creative effects.

To use the functionality, ensure that you install Animate 19.0 on the same computer.

When you import an Animate document into After Effects, the individual layers are exported by Animate as .swf files, and those files are added to the composition. During import, choose a location for the imported files in the Import Preferences dialog.

If the Import Audio option is enabled, audio layers are exported by Animate as .wav files.

Note:

Only ActionScript 3.0 documents are supported. To convert an HTML5 Canvas or WebGL document to ActionScript 3.0, open the document in Animate and select File > Convert To > ActionScript 3.0.

Working with Adobe XD and After Effects

You can export layers and artboards from Adobe XD to your After Effects project. This functionality enhances assets transfer between XD and After Effects, with native mapping of layers, artboards, vectors, text and artwork. As an Adobe XD designer, you can send to After Effects groups of layers and define advanced micro-interactions or artboards to create complex and refined transitions and interactions. If After Effects is not installed on your machine, the After Effects option from XD menu is greyed out.

To export your design assets from XD to After Effects:

  1. In XD, select the layer or artboard you want to animate in After Effects.

  2. Select File > Export > After Effects. After Effects launch (if closed) or moves to foreground (if opened in background).

  3. In a new composition the layers and artboards are added to your After Effects project as native shapes, texts, assets and nested compositions.

Note:

Export to After Effects is supported only with After Effects CC 2018 and 2019 versions. If you have an older version installed, Export to After Effects option is disabled in XD. To enable this option, log into your Creative Cloud application and update After Effects to the latest version.

List of supported XD features

After Effects supports the following XD features:

  • Vector shapes
  • Paths
  • Text layers
  • Bitmaps
  • Masks
  • Groups
  • Artboards
  • Symbols
  • Boolean operations
  • Strokes
  • Fills
  • Shadows
  • Opacity
  • Object blur
  • Background blur and brightness
  • Gradients as images
  • Repeat grids

Working with Adobe Premiere Pro and After Effects

Adobe Premiere Pro is designed to capture, import, and edit movies. After Effects is designed to create motion graphics, apply visual effects, composite visual elements, perform color correction, and perform other post-production tasks for movies.

You can easily exchange projects, compositions, sequences, tracks, and layers between After Effects and Adobe Premiere Pro:

If you have Adobe Premiere Pro, you can do the following:

  • Use Adobe Dynamic Link to work with After Effects compositions in Adobe Premiere Pro. A dynamically linked composition appears as a clip in Adobe Premiere Pro.
  • Use Adobe Dynamic Link to work with Adobe Premiere Pro sequences in After Effects. A dynamically linked sequence appears as a footage item in After Effects.
  • Start After Effects from within Premiere Pro and create a new composition with settings that match the settings of your Premiere Pro project.
  • Select a set of clips in Adobe Premiere Pro and convert them to a composition in After Effects.

For information on using Dynamic Link with After Effects and Premiere Pro, see Dynamic Link and After Effects and Dynamic Link sections in Adobe Premiere Pro Help.

Working with Adobe Media Encoder and After Effects

You can use Adobe Media Encoder to export video from After Effects. Use Adobe Media Encoder to encode formats like H.264, MPEG-2, and WMV. Other formats, are available in Adobe Media Encoder, but not in After Effects. For example, the DNxHD format is available in Adobe Media Encoder, but not in After Effects.

You can add After Effects project files to a watch folder in Adobe Media encoder, and the composition is automatically added to the encoding queue Adobe Media Encoder. See the Import files with Watch folder section in Adobe Media Encoder for detailed information.

For details about using Adobe Media Encoder with After Effects, see The Adobe Media Encoder.

See this tutorial to learn how to export After Effects compositions using Adobe Media Encoder.

Edit in Adobe Audition

While working in After Effects, you can use the more comprehensive audio-editing capabilities of Adobe Audition to fine-tune your audio. You can use the Edit in Adobe Audition command to start Adobe Audition from within After Effects.

If you edit an audio-only file (for example, a WAV file) in Adobe Audition, you change the original file. If you edit a layer that contains both audio and video (for example, an AVI file), you edit a copy of the source audio file.

  1. Select the layer that contains the audio that you want to edit. The item must be of a type that is editable in Adobe Audition.

  2. Choose Edit > Edit In Adobe Audition to open the clip in Edit view in Adobe Audition.

  3. Edit the file, and then do one of the following:

    • If you’re editing an audio-only layer, choose File > Save to apply your edits to the original audio file. You can also choose File > Save As to apply your edits to a copy of the audio file. If you choose File > Save As, import the copy of the file into After Effects.

    • If you’re editing a layer that contains both audio and video, choose File > Save As. After you save the file, import it into After Effects. Then, add it to the composition, and mute the original audio in the audio-video clip by deselecting the Audio switch in the Timeline panel.

    Note:

    Any effects applied to audio in After Effects aren’t included in the copy that is sent to Adobe Audition.

Adobe logo

Sign in to your account