Curves adjustment

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Migrate presets, actions, and settings
    8. Get to know Photoshop
  3. Photoshop and Adobe services
    1. Photoshop and Adobe Stock
    2. Creative Cloud Libraries
    3. Creative Cloud Libraries in Photoshop
    4. Grid and guides
    5. Creating actions
    6. Undo and history
    7. Default keyboard shortcuts
    8. Touch capabilities and customizable workspaces
    9. Use the Touch Bar with Photoshop
    10. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export cloud documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. System requirements 1.x | Photoshop on the iPad
    23. System requirements 2.x | Photoshop on the iPad
    24. Edit your image size
    25. Livestream as you create in Photoshop on the iPad
    26. Correct imperfections with the Healing Brush
    27. Create brushes in Capture and use them in Photoshop
  5. Photoshop on the web
    1. Photoshop on the web | Common questions    
    2. Introduction to the workspace
    3. System requirements | Photoshop on the web
    4. Keyboard shortcuts | Photoshop on the web
    5. Supported file types | Photoshop on the web
    6. Open and work with cloud documents
    7. Collaborate with stakeholders
    8. Apply limited edits to your cloud documents
  6. Cloud documents
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Share access and edit your cloud documents
  7. Workspace
    1. Workspace basics
    2. Create documents
    3. Use the Touch Bar with Photoshop
    4. Microsoft Dial support in Photoshop
    5. Tool galleries
    6. Performance preferences
    7. Use tools
    8. Touch gestures
    9. Touch capabilities and customizable workspaces
    10. Technology previews
    11. Metadata and notes
    12. Quickly share your creations
    13. Place Photoshop images in other applications
    14. Preferences
    15. Default keyboard shortcuts
    16. Rulers
    17. Show or hide non-printing Extras
    18. Specify columns for an image
    19. Undo and history
    20. Panels and menus
    21. Place files
    22. Position elements with snapping
    23. Position with the Ruler tool
    24. Presets
    25. Customize keyboard shortcuts
    26. Grid and guides
  8. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Export files in Photoshop
    4. Device Preview
    5. Copy CSS from layers
    6. Slice web pages
    7. HTML options for slices
    8. Modify slice layout
    9. Work with web graphics
    10. Create web photo galleries
  9. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  10. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
    26. Layer
    27. Flattening
    28. Composite
    29. Background
  11. Selections
    1. Select and Mask workspace
    2. Make quick selections
    3. Get started with selections
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Select a color range in an image
    7. Adjust pixel selections
    8. Convert between paths and selection borders
    9. Channel basics
    10. Move, copy, and delete selected pixels
    11. Create a temporary quick mask
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
    16. Selection
    17. Bounding box
  12. Image adjustments
    1. Perspective warp
    2. Reduce camera shake blurring
    3. Healing brush examples
    4. Export color lookup tables
    5. Adjust image sharpness and blur
    6. Understand color adjustments
    7. Apply a Brightness/Contrast adjustment
    8. Adjust shadow and highlight detail
    9. Levels adjustment
    10. Adjust hue and saturation
    11. Adjust vibrance
    12. Adjust color saturation in image areas
    13. Make quick tonal adjustments
    14. Apply special color effects to images
    15. Enhance your image with color balance adjustments
    16. High dynamic range images
    17. View histograms and pixel values
    18. Match colors in your image
    19. How to crop and straighten photos
    20. Convert a color image to black and white
    21. Adjustment and fill layers
    22. Curves adjustment
    23. Blending modes
    24. Target images for press
    25. Adjust color and tone with Levels and Curves eyedroppers
    26. Adjust HDR exposure and toning
    27. Filter
    28. Blur
    29. Dodge or burn image areas
    30. Make selective color adjustments
    31. Replace object colors
  13. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. How to make non-destructive edits in Camera Raw
    10. Radial Filter in Camera Raw
    11. Manage Camera Raw settings
    12. Open, process, and save images in Camera Raw
    13. Repair images with the Enhanced Spot Removal tool in Camera Raw
    14. Rotate, crop, and adjust images
    15. Adjust color rendering in Camera Raw
    16. Feature summary | Adobe Camera Raw | 2018 releases
    17. New features summary
    18. Process versions in Camera Raw
    19. Make local adjustments in Camera Raw
  14. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  15. Image transformations
    1. Transform objects
    2. Adjust crop, rotation, and canvas size
    3. How to crop and straighten photos
    4. Create and edit panoramic images
    5. Warp images, shapes, and paths
    6. Vanishing Point
    7. Use the Liquify filter
    8. Content-aware scaling
    9. Transform images, shapes, and paths
    10. Warp
    11. Transform
    12. Panorama
  16. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Fill and stroke selections, layers, and paths
    14. Draw with the Pen tools
    15. Create patterns
    16. Generate a pattern using the Pattern Maker
    17. Manage paths
    18. Manage pattern libraries and presets
    19. Draw or paint with a graphics tablet
    20. Create textured brushes
    21. Add dynamic elements to brushes
    22. Gradient
    23. Paint stylized strokes with the Art History Brush
    24. Paint with a pattern
    25. Sync presets on multiple devices
  17. Text
    1. Work with OpenType SVG fonts
    2. Format characters
    3. Format paragraphs
    4. How to create type effects
    5. Edit text
    6. Line and character spacing
    7. Arabic and Hebrew type
    8. Fonts
    9. Troubleshoot fonts
    10. Asian type
    11. Create type
    12. Text Engine error using Type tool in Photoshop | Windows 8
    13. World-Ready composer for Asian Scripts
    14. How to add and edit text in Photoshop
  18. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  19. Filters and effects
    1. Use the Liquify filter
    2. Use the Blur Gallery
    3. Filter basics
    4. Filter effects reference
    5. Add Lighting Effects
    6. Use the Adaptive Wide Angle filter
    7. Use the Oil Paint filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  20. Saving and exporting
    1. Save files in graphics formats
    2. Save your files in Photoshop
    3. File formats
    4. Save and export video and animations
    5. Save PDF files
    6. Digimarc copyright protection
  21. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Duotones
    8. Print images to a commercial printing press
    9. Improve color prints from Photoshop
    10. Troubleshoot printing problems | Photoshop
  22. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  23. 3D and technical imaging
    1. Creative Cloud 3D Animation (Preview)
    2. Print 3D objects
    3. 3D painting
    4. 3D panel enhancements | Photoshop
    5. Essential 3D concepts and tools
    6. 3D rendering and saving
    7. Create 3D objects and animations
    8. Image stacks
    9. 3D workflow
    10. Measurement
    11. DICOM files
    12. Photoshop and MATLAB
    13. Count objects in an image
    14. Combine and convert 3D objects
    15. 3D texture editing
    16. Adjust HDR exposure and toning
    17. 3D panel settings
  24. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Work with color profiles
    5. Color-managing documents for online viewing
    6. Color-managing documents when printing
    7. Color-managing imported images
    8. Proofing colors

Curves overview

In the Curves adjustment, you adjust points throughout an image’s tonal range. Initially, the image’s tonality is represented as a straight diagonal line on a graph. When adjusting an RGB image, the upper-right area of the graph represents the highlights and the lower-left area represents the shadows. The horizontal axis of the graph represents the input levels (original image values) and the vertical axis represents the output levels (new adjusted values). As you add control points to the line and move them, the shape of the curve changes, reflecting your image adjustments. The steeper sections of the curve represent areas of higher contrast while flatter sections represent areas of lower contrast.

You can save Curves adjustment settings as presets. See Save adjustment settings and Reapply adjustment settings.

Note:

The Curves adjustment can also be applied to CMYK, LAB, or Grayscale images. For CMYK images, the graph displays percentages of ink/pigment. For LAB and Grayscale images, the graph displays light values.

Photoshop Curves option
Curves options in the Properties panel

A. On-image adjustment tool B. Sample in image to set black point. C. Sample in image to set gray point. D. Sample in image to set white point. E. Edit points to modify the curve. F. Draw to modify the curve. G. Curves presets menu H. Set black point.  I. Set gray point. J. Set white point. K. Show clipping. 

Adjust image color and tone with Curves

Moving a point in the top portion of the curve adjusts the highlights. Moving a point in the center of the curve adjusts the midtones, and moving a point in the bottom section of the curve adjusts the shadows. To darken highlights, move a point near the top of the curve downward. Moving a point either down or to the right maps the Input value to a lower Output value, and the image darkens. To lighten the shadows, move a point near the bottom of the curve upward. Moving a point either up or to the left maps a lower Input value to a higher Output value, and the image lightens.

  1. To apply a Curves adjustment, do one of the following:

    • Click the Curves icon  in the Adjustments panel.
    • Choose Layer > New Adjustment Layer > Curves. Click OK in the New Layer dialog box.
    Note:

    Choosing Image > Adjustments > Curves applies the adjustment directly to the image layer and discards image information.

  2. (Optional) To adjust the color balance, in the Properties panel, choose the channel you want to adjust from the menu to the left of the Auto button.

  3. In the Properties panel, do any of the following:

    • Click directly on the curve line and then drag the control point to adjust a tonal area.
    • Select the On-image adjustment tool and then drag in the area of the image you want to adjust.
    • Select the On-image adjustment tool and click the tonal areas in the image that you want to adjust. This places control points along the curve line.
    • Choose a preset from the Preset menu.

    Dragging a control point up or down lightens or darkens the tonal area you’re adjusting. Dragging a control point left or right increases or decreases the contrast. You can add up to 14 control points to the curve. To remove a control point, drag it off the graph. As you adjust the tonality, the graph continues displaying the original diagonal baseline and image histogram as references. These options can be turned off, see Set Curves Display Options.

  4. (Optional) Do any of the following to modify the adjustment:

    • Add more points directly to the curve to adjust different tonal areas.
    • Click the On-image adjustment tool in other areas of the image, and drag up or down.
    • Move the Set Black and White Point sliders or use the Eyedropper tools to specify the darkest and lightest values in the image.
    • Click a point on the curve, and enter values in the Input and Output text boxes.
    • Select the pencil icon and draw a new curve over the existing one. When you have finished, click the Smooth the Curve Values icon or to smooth the curve you drew. Clicking more than once continues to smooth the curve further.

    Points on the curve remain anchored until you move them. You can make an adjustment in one tonal area without affecting other areas.

Photoshop On-image adjustment tool
Clicking the On-image adjustment tool in the image adds control points to the curve. Moving the control points adjusts the tonality of the image.

Removing control points from a curve

To remove a control point, do any of the following:

  • Drag the control point off the graph.
  • Select the control point and press Delete.
  • Ctrl-click (Windows) or Command-click (Mac OS) the control point.

 

Set Curve display options

You can control the curve grid display using the Curve display options.

  1. Apply a Curves adjustment.

  2. In the Properties panel, choose Curves Display Options from the panel menu.

    Note:

    If you chose Image > Adjustments > Curves, expand the Curve Display Options in the Curves dialog box.

  3. In the Curves Display Options dialog box, select any of the following:

    Light (0-255)  Displays the intensity values for RGB images in a range from 0 to 255, with black (0) at the lower-left corner.
    Pigment/Ink %  Displays the percentages for CMYK images are displayed in a range from 0 to 100, with highlights (0%) at the lower-left corner.
    Simple Grid  Displays gridlines in 25% increments.
    Detailed Grid  Displays gridlines in 10% increments.
    Show Channel Overlays  Displays color channel curves superimposed on the composite curve.
    Histogram  Displays a histogram of the original image tonal values behind the graph.
    Baseline  Displays the original image color and tonality as a 45-degree angle line for reference,
    Intersection Line  Displays horizontal and vertical lines to help you align control points as your drag them relative to the histogram or grid.

    Note:

    To change the gridline increment, Alt-click (Windows) or Option-click (Mac OS) the grid.

Apply an Auto correction in Curves

  1. Click Auto in the Properties panel.

Auto applies an automatic color correction using the current default setting. To change the default setting, choose Auto Options from the Properties panel menu and set the options in the Auto Color Correction Options dialog box. You can apply an Auto Color, Auto Contrast, or Auto Tone correction to an image. For more information on these options, see Set Auto adjustment options.

Set black and white points using the black point and white point sliders

When applying a Curves adjustment, use the black and white sliders to quickly set the black and white points (pure black and pure white values) in the image.

  1. Drag the black and white point sliders to any point along the horizontal axis. Note that the Input value changes as your drag.

  2. To preview clipping as you adjust black and white points, do one of the following:

    • Hold down Alt (Windows) or Option (Mac OS).
    • Choose Show Clipping For Black/White Points from the panel menu.

Add contrast to the midtones of a photo with Curves

If the image uses the full tonal range, but needs midtone contrast, Click the Curves icon  in the Adjustments panel. Drag the curve into an S shape.

Photoshop Increasing slope in the curve
Increasing the slope in the middle of the curve increases contrast in the midtones.

Keyboard shortcuts: Curves

You can use these keyboard shortcuts for Curves:

  • To set a point on the curve for the selected color in each color component channel (but not in the composite channel), Shift+Ctrl-click (Windows) or Shift+Command-click (Mac OS) in the image.

  • To select multiple points, Shift-click points on the curve. Selected points are filled with black.

  • To deselect all points on the curve, click in the grid, or press Ctrl‑D (Windows) or Command-D (Mac OS).

  • To select the next higher point on the curve, press the plus key; to select the next lowest, press the minus key.

  • To move selected points on the curve, press the arrow keys.

  • (Curves dialog box) To set a point on the curve for the current channel, Ctrl-click (Windows) or Command-click (Mac OS) in the image.

Note:

If you’re instead using the Curves adjustment, simply click in the image with the On-image adjustment tool .

Adobe logo

Sign in to your account